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Welcome to TeachUcomp, Inc.’s Advanced Access
course. This class caps the Microsoft Access classes. This
class is designed to complete the user skill set for the
student who is already familiar with this program and its
use of tables, forms, and queries.

Access is an excellent program to learn, as the skills
that you learn within Access can save valuable time and
money for organizations by automating, organizing and
structuring their data processing capabilities.

This class will focus giving the student who possesses
the basic working foundation of the Access program’s
tables, forms, and queries knowledge of the reports,
macros, and advanced features required to complete the
creation of a functioning desktop database file.

Introduction and Overview
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CHAPTER 14-
Reports

14.1- Using the Report Wizard

14.2- Using Basic Reports

14.3- Creating a Report in Design View

14.4- Sorting and Grouping Data in Reports

14.5- Creating Calculated Fields
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Reports

14.1- Using the Report Wizard:

You use reports to further calculate and then display the results from a query. You can also use
them to calculate statistical results on tables or queries for summary reports. They are simply a more
concise and certainly more “printer-friendly” way of presenting the data you have calculated in your queries
to anyone who needs to view this information. They use fields, like forms do, and the report design view
shares much in common with the form design view. However reports typically have a query as their data
source, versus a table.

A simple way to create a basic report is to use the Report Wizard. You can start the Report Wizard
by clicking “Report Wizard” button in the “Reports” button group on the “Create” tab in the Ribbon. That will
launch the “Report Wizard.” Once the Report Wizard is launched, it will lead you through a step-by-step
program that prompts you to respond to the questions that it poses. You simply enter the answers and
make your desired selections in each screen and then click the “Next >” button to proceed to the next
screen. When you are done answering all of the questions on each screen in the wizard, click the “Finish”
button in the final screen to create a basic report.

In the first screen of the “Report Wizard,” you use the “Tables/Queries:” drop-down to select the
query or table that you want use as the basis of the report. Then select which fields from the selected query
or table to display in the report by selecting them from the “Available Fields:” list and clicking the “>” button
to move them to the “Selected Fields:” list. You can also move all fields into the “Selected Fields:” list by
clicking the “>>” button, instead. Click the “Next >” button after you have added all the fields you want to
display to the “Selected Fields:” list.

In the next screen, you may need to select by which field or table you want to view the report results.
Make your selection and click the “Next >” button to continue. If you did not base your report on multiple
tables or a query, this screen will not appear.

In the next screen, select any fields by which you want to group the data in your report and click the
“>” button to add the selected groups to the report. If you do add grouping, you can click the “Grouping
Options…” button to open another screen where you can select a “Grouping Interval” for any fields by which
you grouped the report. Then click the “OK” button to close this screen. Then click the “Next>” button to
continue.

In the next screen, select by which fields you want to sort the report data by using the drop-down
menus available. Then click the button to the right of each field to toggle it to display the desired sort order:
“Ascending” (A-Z, 1-9) or “Descending (Z-A, 9-1).

If you have a “number” or “currency” field available in your report, you can click the “Summary
Options…” button in this screen to launch the “Summary Options” dialog box. Here you can set any
summary options for the available fields by checking the checkbox under the function you want performed
on each field. To the right of that, select either the “Detail and Summary” or “Summary Only” option button
to select the type of report to create. You can also check the checkbox for “Calculate percent of total for
sums,” if you want that option for your report summary. When you are done, click “OK” to close the
“Summary Options” dialog box. Click “Next>” to continue.

Next, select the desired report layout by choosing the option button that corresponds to the type of
layout you want in the “Layout” section. In the “Orientation” section, click the option button that corresponds
to the page orientation you want. You can also check the checkbox to “Adjust the field width so all fields fit
on a page,” if you desire. Click “Next>” to continue.

In the final screen, type a title for your report in the text box at the top of the screen. Then select
either to “Preview the report” or “Modify the report’s design.” To view the report data, select the first option
and click “Finish” to create your new report.
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Reports

14.2- Creating Basic Reports:

You can create a very basic report that simply shows the results from a table or query. To create a
basic report, select the table or query you want to use as the basis for the report from the listing shown in
the Navigation Pane. Next, click the “Report” button in the “Reports” button group on the “Create” tab in the
Ribbon.

Access will automatically create a simple report you can use to display the selected information.
While it lacks style, its ease of use and simplicity of creation compensate for it. You can also modify the
report’s content and layout in design view after it has been created, if needed.

14.3- Creating a Report in Design View:

Once you have created a report, it will appear in the Navigation Pane. Here you can select it and
then press “Ctrl” + “Enter” on your keyboard to open the report in design view. In design view you can edit
the report to change the field placement, add or remove fields, or format the report objects.

In design view, you can change many of the same aspects of reports that you changed in your forms
when using design view. You can also create a report from scratch in design view in much the same way
that you created forms. To do this, click the “Report Design” button in the “Reports” group on the “Create”
tab in the Ribbon. That will create a new, blank report and display it in design view.

One of the first things that you will notice about report design view that is different than the form
design view is the number of sections within the report. By default, the report design view shows a “Page
Header” section, a “Detail” section, and a “Page Footer” section. It is important to note that in a report, the
particular section that you place the fields into can impact what data displays in the field. Just as with form
design view, you can start by clicking and dragging the fields from the “Field List” at the right side of the
design view and then dropping them into the desired section of the report design window.

To use a query as the report’s data source, since queries are not shown in the “Field List,” you must
set the “Data Source” property of the report. To show the “Property Sheet,” click the “Property Sheet” button
in the “Tools” group on the “Design” tab of the “Report Design Tools” contextual tab in the Ribbon.

Use the drop-down at the top of the “Property Sheet” pane that appears at the right side of the
application window to select “Report,” if needed. Then click the “Data” tab below the drop-down. Click into
the “Record Source” property field on the “Data” tab and then use the drop-down that appears at the right
end of the field to select the name of the query to use as the data source for the report.

After selecting the data source, click the “Add Existing Fields” button in the “Tools” button group on
the “Design” tab of the “Report Design Tools” contextual tab in the Ribbon to show the fields in the query in
the “Field List” pane. You can then drag and drop the fields from the field list into the desired section of the
report. Fields placed into the “Detail” section display their field information once for each record in the
associated data source. Fields placed into the “Page Header” or “Page Footer” areas repeat once per page.
Those sections are suitable for report labels and date/time stamps, but not data fields or calculated fields.

You can also add two more useful sections to the report: the “Report Header” and “Report Footer.”
To enable the display of the report header and report footer, right-click on the header of any displayed
section in the report design view and then select the “Report Header/Footer” button from the pop-up menu
that appears.

Fields placed into either the “Report Header” or the “Report Footer” sections display their field data
once at the very top of the report and once at the very bottom of the report. Oftentimes, you will find report
titles placed into the “Report Header” section. The “Report Footer” section is often where you will place
fields that calculate the “Grand Total” of data fields placed into the “Detail” section. You can also add many
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Reports

14.3- Creating a Report in Design View- (Cont’d.):

other header and footer combinations for the various groupings you create in your report, which will be
examined in a later lesson.

You also have many of the same controls used in form design available for use in report design
view, as well. They are shown in the “Controls” button group on the “Design” tab of the “Report Design
Tools” contextual tab within the Ribbon. You can use the buttons in this group to add labels, images, or
custom calculated fields.

Once you have designed the report, you can view the report results in “Print Preview” to view how
the report would look if you actually printed it. To view a report in print preview, click the “View” drop-down
button in the “Views” button group on the “Design” tab of the “Report Design tools” contextual tab in the
Ribbon and then choose the “Print Preview” command. When you are viewing a report in “Print Preview,”
you can view multiple or single pages of the report and also print the report by using the buttons shown on
the “Print Preview” tab in the Ribbon. To close the preview and return to report design view when you are
finished previewing your report, click the “Close Print Preview” button in the “Close Preview” button group
on the “Print Preview” tab in the Ribbon.

14.4- Sorting and Grouping Data in Reports:

You can create data groupings in reports to group selected fields by the unique values they contain.
You can then calculate the value of another field for each unique grouping created by the values within the
grouped field. This is how you create summary totals by group within a report.

For example, assume you created a sales report that showed detailed data of product sales by
employee. You could create a data grouping on the “EmployeeID” field to create a group for each unique
value found in the “EmployeeID” field. When you create a data grouping, you can add a “group header” and
a “group footer” section to the report. Data fields placed into a group header or group footer display once for
each unique group within the field. You could then add a calculated field to the group footer that totals the
value of all of the sales in the “Amount” field for each unique grouping found in the “EmployeeID” field.
Doing this shows the subtotals for each employee in the group footer. Providing subtotals by group is an
extremely useful feature of reports!

To create a grouping in your report, click the “Group & Sort” button in the “Grouping & Totals” button
group on the “Design” tab of the “Report Design Tools” contextual tab in the Ribbon. That shows the
“Group, Sort, and Total” pane at the bottom of the report design view. In this pane are two buttons: “Add a
group” and “Add a sort.”

To add a report grouping, click the “Add a group” button and then select name of the field by which
you wish to group the data from the pop-up menu that appears. That will add the primary grouping, of which
you can have several, into the “Group, Sort, and Total” pane. To then view all the available options you
have for the group, click the “More >” button to expand the group options. You will click each drop-down,
from left to right, and set the value for each until you have specified all of your settings.

You can click the drop-down arrow shown after the field name to select the sorting method used to
sort the values in the grouped field. Moving to the right, the next drop-down arrow lets you set the method
used to create the groups within the selected field. Normally, you group “by entire value.” This means the
values in the grouped field must match entirely to be included as part of the same group.

However, you can also create groups based on field values that share the first few initial characters
or values. For text fields, you can select either the “by first character” or “by first two characters” option to
create groups based on these criteria. To create groupings based on more than two initial characters, select
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Reports

14.4- Sorting and Grouping Data in Reports- (Cont’d.):

the “Custom:” option and enter the number of initial characters by which to create grouped values within the
grouped field. For date/time and number fields, select a group option or enter a custom group value.

To create totals for the groups as you create the groupings, click the next drop-down to choose what
totals to display for the groupings created. To NOT calculate any field values for each group, leave the
selection at the default value of “with no totals.” To add totals, click the drop-down arrow and select the field
to total from the “Total On” drop-down that appears within the drop-down menu. Next, use the “Type” drop-
down to select the function to perform on the field selected from the “Total On” drop-down.

Below that, check any of the four checkboxes to enable or disable each setting. To add a grand total
for the field, select the “Show Grand Total” checkbox. To show each group’s value as a percentage of the
grand total, check the “Show group subtotal as % of Grand Total” checkbox. To show the group subtotals in
the group header, check the “Show subtotal in group header” checkbox. To show the group subtotals in the
group footer, check the “Show subtotal in group footer” checkbox.

To set multiple totals on several fields, if needed, select another field from the “Total On” drop-down
and then repeat the process. When finished, click the drop-down arrow in the “Group, Sort, and Total” pane
again to set the totals in the report.

To add a title to the groups, click the “click to add” hyperlink to open the “Zoom” dialog box where
you can enter the title to apply to the group and then click the “OK” button. This adds the title as a “Label”
control into the header of the group.

You can click the next drop-down to select “with a header section” or “without a header section.” If
you added a group title, you must have a group header section. You may only chose the “without a header
section” option if you do not have any controls of any kind in the group header. Choosing this option with
controls in the section will delete the section and the related controls. Likewise, you can set the next drop-
down to “with a footer section” or “without a footer section.” Once again, you may only remove the group
footer as long as you do not have any controls in that section. If you add totals to the group in the group
footer, you will not want to remove the group footer, as that would delete the calculated fields that Access
adds to that section when you add group totals.

The last drop-down lets you choose how the data records shown within each group should appear
when printed. You can select the default of “do not keep group together on one page” to ignore grouping
and ignore where the page breaks occur when you run out of printable area on a page. You can select the
“keep whole group together on one page” option to try to print all of the records in each group on one page.
You can select the “keep header and first record together on one page” option to start printing the grouped
data on a report page only if Access can fit both the group header and at least one detail record on the
same page.

You can then create additional groupings, if desired, by clicking the next “Add a group” button below
your current group and then repeating this entire process. Note, however, that the secondary groups should
logically be secondary groups within the larger, primary group. If using multiple groups, you can change the
order in which the grouping is applied by selecting the group whose order you want to change, and then
clicking the small “Move up” and “Move down” arrow buttons shown at the right end of the group. To delete
a group, click the “X” at the right end of the group. If you have controls in the group header or group footer,
these controls will be deleted along with the header or footer. Access will warn you if this is the case before
allowing you to delete the group.

The process of creating a group is the same process used to sort report data. As you have just seen
when creating a group, you can choose how to sort the values within the group. However, for some detailed
reports, you may not have any groupings. Regardless of whether or not you have created groups, you can
still sort the report using any available field.
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Reports

14.5- Creating Calculated Fields:

To modify reports in Access, open them in design view. In design view, you can add controls to the
report in the same way you add controls to a form. However, the controls in a report are typically read-only
and are not used to change data, but to display data, instead. One of the most useful types of controls is the
calculated text box control. These types of fields are created when you add totals to a group in a report.
While you can create many of the calculated fields you need while creating groups, you can also create
them yourself. A calculated field is a text box control that displays the result of a calculation you create,
instead of a field value.

To create a calculated field, open the report in design view and insert a text box control into the
report. Most often, calculated fields are added to either a group footer or to a report footer, depending on
whether you want to perform the calculation for each group or over all the records in a report.

Next, select the text box control you inserted and view its properties in the Property Sheet. You can
click the “Property Sheet” button in the “Tools” group on the “Design” tab of the “Report Design Tools”
contextual tab in the Ribbon to display the Property Sheet, if needed.

In the Property Sheet, select the “Data” tab, click into the “Control Source” property field and then
click the “Expression Builder” button […] which appears at the right end of the “Control Source” property
field. This will then launch the “Expression Builder” dialog box. This dialog box is used to create functions
and formulas.

Either type the expression (formula) to calculate into the box at the top of the “Expression Builder”
dialog box or select individual elements provided in the three sections at the bottom of the dialog box to
create the formula. When you are done creating your formula, click “OK” to set the field’s formula.

A very important consideration when creating a calculated field is where it will be placed in the
report. A calculated field may display different results depending upon the section of the report into which it
is inserted.

For example, if you had a calculated field that totaled a “Sales” field, the formula in the calculated
field would be: =SUM([Sales]). If you place this field into the “Report Footer,” it shows the total value of that
field for all records as a grand total. If you place it into a “group” footer, it shows the total of that field for all
the records in the group. If placed into the “Page Footer,” it causes an error, as calculated fields cannot be
evaluated on a per page basis.

In addition, if you place the calculated field into a “group” footer, you then have the ability to set the
function as a “running sum.” To do this, select the field and then click the “Data” tab in the Property Sheet.
You can then click into the “Running Sum” property field and use the drop-down that appears at the right
end to set the value to not calculate (which is the default), to calculate per grouping, or to calculate over all
the records. This is a great way of displaying a running totals over groups, if desired.

14.4- Sorting and Grouping Data in Reports- (Cont'd.):

To sort a report, click the “Add a sort” button in the “Group, Sort, and Total” pane. You can set the
same options for a sorted field that you can with a grouped field. However, you will most commonly only
need to set the two options initially shown when the sort is created. These options let you select the field by
which to sort and choose the sort order.

As with groups, you can re-order sorting that is applied or delete the sorting applied by using the
“Move up,” “Move down,” and “Delete” buttons at the right end of the sort field. When you are finished
creating groups and sorting, click the “X” button in the upper-right corner of the “Group, Sort, and Total”
pane to close it.
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ACTIONS-
Reports

USING THE REPORT WIZARD:

1. Click the “Report Wizard” button in the “Reports” group on the “Create” tab in the Ribbon.
2. Use the “Tables/Queries:” drop-down menu to select the query or table that you want use as the basis of 

the report.
3. Select which fields from the selected query or table to display in the report by selecting them from the 

“Available Fields:” list and then clicking the “>” button to move them to the “Selected Fields:” list.
4. To move all fields into the “Selected Fields:” list, click the “>>” button.
5. Click “Next >” when you have added all the fields that you want to display to the “Selected Fields:” list.
6. In the next screen, you may need to select by which field or table you wish to view the report results. 

Make your selection and click “Next >” to continue. If you did not base your report on multiple tables or a 
query, then move to the next step.

7. Select any fields by which you want to group the data in your report, and click the “>” button to add the 
selected groups to the report.

8. If you do add grouping, you can click the “Grouping Options…” button to open another screen where 
you can select a “Grouping Interval” for any fields by which you grouped the report. Then click “OK” to 
close this screen.

9. Click “Next>” to continue.
10. In the next screen, select by which fields you wish to sort the report data by using the drop-down menus 

available.
11. Then click the button to the right of each field to toggle it to display the desired sorting order: 

“Ascending” (A-Z, 1-9) or “Descending (Z-A, 9-1).
12. If you have a “number” or “currency” field available in your report, you can click the “Summary 

Options…” button in this screen to launch the “Summary Options” dialog box.
13. In this dialog box you can set any summary options for the available fields by checking the checkbox 

under the function that you want performed on each field.
14. To the right of that, select either the “Detail and Summary” or “Summary Only” option button to choose 

the type of report to create.
15. You can also check the checkbox for “Calculate percent of total for sums” if you want that option for your 

report summary.
16. When you are done, click “OK” to close the “Summary Options” dialog box.
17. Click “Next>” to continue.
18. Next, choose the desired report layout by selecting the option button in the “Layout” section that 

corresponds to the type of layout you want.
19. In the “Orientation” section, click the option button that corresponds to the page orientation you want.
20. You can also check the checkbox to “Adjust the field width so all fields fit on a page,” if you desire.
21. Click “Next>” to continue.
22. In the final screen, type a title for your report in the text box at the top of the screen.
23. Then select either to “Preview the report” or “Modify the report’s design.”
24. To view the report data, select the first option and click “Finish” to create your new report.Sam
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ACTIONS-
Reports

CREATING AND MODIFYING REPORTS IN DESIGN VIEW:

1. To open a pre-existing report in Design View, select the name of the report from the listing shown in 
the Navigation Pane and then press “Ctrl” + “Enter” on your keyboard.

2. To create a report from scratch in design view, click the “Report Design” button in the “Reports” 
group on the “Create” tab in the Ribbon to create a new, blank report in design view.

3. By default, the report design view shows a “Page Header” section, a “Detail” section, and a “Page 
Footer” section.

4. To set a data source for a blank report in design view, click the “Property Sheet” button in the 
“Tools” group on the “Design” tab of the “Report Design Tools” contextual tab in the Ribbon.

5. Use the drop-down at the top of the “Property Sheet” window to select “Report,” if needed.
6. Then click the “Data” tab.
7. Use the drop-down in the “Record Source” property field to select the name of the query to use as the 

data source for the report.
8. To show the available fields in the selected data source, click the “Add Existing Fields” button in the 

“Tools” button group.
9. Click and drag fields from the “Field List” at the right side of the design view and then drop them into the 

desired section of the report design window. 
10. Fields placed into the “Detail” section display their field information once for each record in the 

associated data source.
11. Fields placed into the “Page Header” or “Page Footer” areas repeat once per page.
12. To enable the display of the report header or footer, right-click on the header of any displayed 

section in the report design view and then select the “Report Header/Footer” button from the pop-up 
menu that appears.

13. Fields placed into either the “Report Header” or the “Report Footer” sections will display their field 
information once at the very top of the report and once at the very bottom of a report.

14. The controls you can add to a report are shown in the “Controls” button group on the “Design” tab of the 
“Report Design Tools” contextual tab within the Ribbon.

15. To view a report in print preview, click the “View” drop-down button in the “Views” button group on the 
“Design” tab of the “Report Design tools” contextual tab in the Ribbon and then choose the “Print 
Preview” command.

16. When you are viewing a report in “Print Preview,” you can view multiple or single pages of the report 
and also print the report by using the buttons shown on the “Print Preview” tab in the Ribbon.

17. To close the preview and return to report design view when you are finished previewing your 
report, click the “Close Print Preview” button in the “Close Preview” button group on the “Print Preview” 
tab in the Ribbon.

18. To save your changes when you are done making modifications to your report, click the “Save” 
button in the Quick Access toolbar.

CREATING BASIC REPORTS:

1. Select the table or query that you want to use as the basis for the report from the listing shown in the 
Navigation Pane.

2. Click the “Report” button in the “Reports” group on the “Create” tab in the Ribbon.
3. Access will automatically create a simple report that you can use to display the selected information. 

You can modify the report’s content and layout in design view after it has been created, if needed.
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ACTIONS-
Reports

SORTING AND GROUPING DATA IN A REPORT:

1. Open the report to which you want to add sorting or data grouping in design view by selecting the name 
of the report from the Navigation Pane and then pressing “Ctrl” + “Enter” on your keyboard.

2. To group  or sort data in the report, click the “Group & Sort” button in the “Grouping & Totals” group 
on the “Design” tab of the “Report Design Tools” contextual tab within the Ribbon. Doing that will show 
the “Group, Sort, and Total” pane at the bottom of the report design view. In this section are two buttons: 
“Add a group” and “Add a sort.”

3. To add a group, click the “Add a group” button and then select name of the field by which you want to 
group the data from the pop-up menu that appears. That will add the primary grouping, of which you can 
have several, into the “Group, Sort, and Total” pane.

4. To view all of the available options that you have for the group, click the “More >” button to expand 
the group options. You will click each drop-down, from left to right, and set the value for each until you 
have specified all the settings.

5. To select the sorting method used to sort the values in the grouped field, click the next drop-down 
arrow after the field name and choose a sort order.

6. To set how to create the groups within the selected field, click the next drop-down arrow to the right.
7. To group the values in the grouped field by their entire value, select the “by entire value” option.
8. To create groups based on field values that share the first few initial characters or values, select 

a group option or enter a custom group value. This changes based on the data type of the selected field.
9. For text fields, select either the “by first character,” “by first two characters,” or “Custom:” option. If 

needed, enter the number of initial characters by which to create group values within the grouped field.
10. For date/time and number fields, select a group option or enter a custom grouping value.
11. To create totals for the groups as you create the groupings, click the next drop-down to choose 

what totals to display for the groupings created.
12. To NOT add any totals to the group, leave the selection at the default value of “with no totals.”
13. To add totals, click the drop-down arrow and select the field to total from the “Total On” drop-down that 

appears within the drop-down menu.
14. Use the “Type” drop-down to select the function to perform on the field selected in the “Total On” drop-

down.
15. To add a grand total for the field, select the “Show Grand Total” checkbox.
16. To show each group’s value as a percentage of the grand total, check the “Show group subtotal as % of 

Grand Total” checkbox.
17. To show the group subtotals in the group header, check the “Show subtotal in group header” checkbox.
18. To show the group subtotals in the group footer, check the “Show subtotal in group footer” checkbox.
19. You can set many totals on several fields, if needed, by selecting another field from the “Total On” drop-

down and then repeating the process.
20. To set the totals in the report when finished, click the drop-down arrow in the “Group, Sort, and 

Total” pane again.
21. To add a group title, click the “click to add” hyperlink to open the “Zoom” dialog box and enter the 

group title to apply.
22. Click the “OK” button in the “Zoom” dialog box to add the title as a “Label” control into the group header.
23. To add or remove a group header, click the next drop-down to select “with a header section” or 

“without a header section.” If you added a group title, you must have a group header section. You may 
only chose the “without a header section” option if you do not have any controls in the group header. 
Choosing this option with controls in the section deletes the section and its related controls.

(Cont'd.)
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ACTIONS-
Reports

SORTING AND GROUPING DATA IN A REPORT- (CONT’D.):

24. To add or remove a group footer, set the next drop-down to “with a footer section,” or “without a footer 
section.” Once again, you may only remove the group footer as long as you do not have any controls in 
that section. If you add totals to the group footer, then do not remove the group footer, as that 
deletes the calculated fields Access adds to that section when you add group totals.

25. To choose how data records are shown within each group when printed, select a choice from the 
next drop-down.

26. To ignore grouping and ignore where the page breaks occur when you run out of printable area 
on a page, select the default of “do not keep group together on one page”.

27. To try to print all of the records in each group on one page, select the “keep whole group together 
on one page” option.

28. To start printing the grouped data on a report page only if Access can fit both the group header 
and at least one detail record on the same page, select “keep header and first record together on one 
page.”

29. To create additional groupings, if desired, click the next “Add a group” button below your current 
group and then repeat the entire process. Note that secondary groups should logically be secondary 
groupings within the larger, primary group.

30. To change the order in which grouping is applied if using multiple groups, select the group whose 
order you want to change and then click the small “Move up” and “Move down” arrow buttons that 
appear at the right end of the grouping.

31. To delete a group, click the “X” at the right end of the group listing. If you have controls in the group 
header or group footer, these controls will be deleted along with the header or footer. Access will 
warn you if this is the case before allowing you to delete the group.

32. To add sorting to a report, click the “Add a sort” button in the “Group, Sort, and Total” pane.
33. You can set any additional options for a sorted field in the same way that you can with a grouped field. 

However, you will most commonly only need to set the two options that are initially shown when the sort 
is created. That lets you select the field by which to sort and the method used to sort the field’s values.

34. To re-order the sorting that is applied or delete the sorting, use the “Move up,” “Move down,” and 
“Delete” buttons shown at the right end of the sort.

35. To close the “Group, Sort, and Total” pane when you are finished creating groups and sorting, 
click the “X” button in the upper-right corner of the “Group, Sort, and Total” pane.
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ACTIONS-
Reports

CREATING CALCULATED FIELDS:

1. Open the report to which you want to add a calculated field in design view by selecting the name of the 
report from the Navigation Pane and then pressing “Ctrl” + “Enter” on your keyboard.

2. Decide into which section you want to place the calculated field, depending on what totals you want the 
field to show. Most often, calculated fields are added to either a group footer or to a report footer, 
depending on whether you want to perform the calculation for each group or over all the records in a 
report Insert a regular text box control into the report.

3. Select the text box control you inserted and view its properties in the Property Sheet. You can click the 
“Property Sheet” button in the “Tools” group on the “Design” tab of the “Report Design Tools” contextual 
tab in the Ribbon to display the Property Sheet, if needed.

4. In the Property Sheet, select the “Data” tab, click into the “Control Source” property field and then click 
the “Expression Builder” button […] which appears at the right end of the “Control Source” property field.

5. This will then launch the “Expression Builder” dialog box, which is used to create functions and 
formulas.

6. Either type the expression (formula) to calculate into the box at the top of the “Expression Builder” dialog 
box or select individual elements provided in the three sections at the bottom of the dialog box to create 
the formula.

7. When you are done creating your formula, click “OK” to set the field’s formula.
8. Another important consideration when creating a calculated field that performs a calculation on the field 

data in the report is where it will be placed in the report. A calculated field may display different results 
depending upon which section of the report you insert it into.

9. For example, if you had a calculated field that totaled a “Sales” field, the formula in the calculated field 
would be: =SUM([Sales]). If you place this field into the “Report Footer,” it shows the total value of that 
field for all records as a grand total. If you place it into a “group” footer, it shows the total of that field for 
all the records in the group. If placed into the “Page Footer,” it causes an error, as calculated fields 
cannot be evaluated on a per page basis.

10. To create a “running sum” field on a “SUM” field that is placed into a “group” footer, select the 
field and select the “Data” tab in the Property Sheet.

11. Click into the “Running Sum” property field and use the drop-down that appears at the right end to set 
the value to not calculate (which is the default), to calculate per grouping, or to calculate over all the 
records.
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EXERCISES-
Reports

Purpose:

1. To be able to create basic reports on your data.

Exercises:

1. Open your Access application.
2. Open the “test” database you completed from the Exercise at the end of the last chapter in the

“Intermediate” manual.
3. Click the “Create” tab in the Ribbon.
4. Click the “Query Design” button in the “Queries” group.
5. In the “Show Table” dialog box, select all of the tables shown and then click the “Add” button.
6. Click “Close” in the “Show Table” dialog box.
7. Create the following query and save it as “qrySalesByEmployee.” Then close the query.

8. Click the “Report Wizard” button in the “Reports” group on the “Create” tab in the Ribbon.
9. Use the “Tables/Queries” drop-down to select “qrySalesByEmployee.”
10. Click the “>>” button to move all of the “Available Fields:” into the “Selected Fields:” list.
11. Click the “Next >” button to continue.
12. Select “EmployeeID,” and click the “>” button to group by the “EmployeeID” field.
13. Select “CompanyName” and click the “>” button to group by the “CompanyName” field.
14. Click the “Next >” button to continue.
15. Use the “1” drop-down to sort by “LastName.”
16. Use the “2” drop-down to sort by “FirstName.”
17. Click the “Summary Options…” button.
18. Click the check box for “Sum” and then click the “OK” button in the “Summary Options” dialog box.
19. Click the “Next >” button to continue.
20. Select the “Outline” option button in the “Layout” section and then click the “Landscape” option in the

“Orientations” section.
(Cont'd.)
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EXERCISES-
Reports

Exercises- (Cont'd.):

21. Click the “Next >” button to continue.
22. Type “Sales By Employee” into the “What title do you want for your report?” field.
23. Click the “Finish” button to close the report and open it in print preview to see the data.
24. Click the “Close Print Preview” button in the “Close Preview” group on the “Print Preview” tab in the

Ribbon.
25. In the design view, in the “EmployeeID Header” section, change the “EmployeeID” label text so that it

reads “Employee:.”
26. Select the “EmployeeID” field in the “EmployeeID Header” section.
27. Change the field’s value to “=[FirstName] & " " & [LastName]” by either changing the field’s value directly

in the section or by changing the “Control Source” property field on the “Data” tab in the “Property
Sheet” pane with the field selected.

28. In the “CompanyName Header” section, delete both the “LastName” and the “FirstName” labels.
29. In the “Detail” section, delete the both the “LastName” and “FirstName” fields.
30. Select the “SaleAmount” field in the “Detail” section along with the “=SUM([Sale Amount])” fields in the

“CompanyName Footer,” “EmployeeID Footer,” and the “Report Footer.”
31. With those fields still selected, click the “Format” tab in the “Property Sheet.”
32. Click into the “Format” property field on the “Format” tab in the “Property Sheet” pane and then select

“Currency” from the drop-down menu that appears.
33. Click “Save” in the Quick Access toolbar to save the report.
34. Click the “View” drop-down button in the “Views” button group on the “Design” tab of the “Report Design

Tools” contextual tab in the Ribbon and then choose the “Print Preview” command from the drop-down
menu to preview the report in print preview and see your changes applied.

35. Close the report and the database.
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