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Welcome to TeachUcomp, Inc.’s Intermediate Access

course. This class continues build on the base knowledge

gained within the Introductory Access course. This class is

designed to give the student that possesses a basic

knowledge of this program an enhanced skills base in

Access. This class introduces and explains advanced

query types, forms, and reports to students who are

already familiar with creating and using tables and queries

in Access.

Access is an excellent program to learn, as the skills

that you learn within Access can save valuable time and

money for organizations by automating, organizing and

structuring their data processing capabilities.

Access is a multi-featured database program in which

one creates powerful relational desktop databases or web-

based apps that store and manipulate data. It is a very

useful program and has many features that can automate

and simplify job tasks. Whether you want it to create

charts, reports, data entry forms, or data sources; Access

can assist you in accomplishing these tasks quickly and

easily.

Introduction and Overview
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Advanced Query Types

9.1- Make Table Queries:

Have you ever run a query and wished that you could save the result set of the query as a

permanent table? In Access, that is exactly what the “Make Table” queries do. A “Make Table” query

creates a new table as the output of a query, instead of simply displaying a query result set. This new

permanent table can be useful in a variety of ways: you could use it as a basis for other queries; it could

serve to backup important data; or it could show selected information from multiple underlying tables in a

single table which you could then export to Microsoft Excel for spreadsheet-style analysis. Since the basis

of the make table query is a standard ‘select’ query-type, you can restrict the columns and rows that are

displayed in the new table by picking just the fields you wish to view and applying query criteria.

The fields that comprise the new table created from the make table query’s result set retain the data

type and field size properties that were assigned to the original fields. However, other properties that you

may have set for the base table’s fields will not be inherited by the new fields. So, you may need to re-enter

validation rules, and other properties in the new table, if needed.

To create a make table query, first create a standard query in design view. Select only the fields that

you want to include in your new table, and use criteria to restrict the rows selected, if needed. Then click the

“Make Table” button in the “Query Type” group of the “Design” tab in the “Query Tools” contextual tab in the

Ribbon to change the query type.

In the “Make Table” dialog box that appears, you can type a name for the new table that will be

created when you run the query. You can also select whether to place the new table into the current

database, or into another database by selecting the desired option button. If you select “Another

Database:,” then you will have to click the “Browse…” button and use the dialog box that appears to select

the database file into which you want to place the new table. When you have selected where to place the

new table, click “OK” in the “Make Table” dialog box.

Once you are ready, you can run the query to create a new table. When you run a “Make Table”

query that was based on a “Select” query, Access will delete the “Select” query. So be sure to save a copy

before running the “Make Table” query. A dialog box will remind you of this if you forget.

Next, you will see a dialog box appear that confirms how many rows you are about to paste into a

new table. Click the “Yes” button in the dialog box to paste the selected rows and fields into a new table.

9.2- Update Queries:

If you want to make large-scale updates to the data in your Access tables based on a specified

criteria, you can create “Update” queries to update selected field values based on whether or not the record

matches a specified criteria. For example, if you needed to update area codes in a phone number field

based on whether or not the phone number contained a specified exchange, you could accomplish that with

an update query.

Unlike the ‘select’ queries that we have created so far, when creating update queries all that you

need to enter into the QBE grid are the actual fields that you wish to update and the fields that are needed

for criteria purposes.

If you do not want to update all of the records in the selected table when you run an update query,

then you must specify criteria by which to update the records. That way, when you run the update query

you will apply the specified updates to only those selected records that match the given criteria.

To create an update query, first create a new query in design view. Then click the “Update” button in

the “Query Type” group of the “Design” tab in the “Query Tools” contextual tab. When you do this, the layout

of the QBE grid will change slightly. You will now see a new row appear in the QBE grid named “Update

To:.” You then add only the fields from the selected table that you need to update and any fields needed forSa
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Advanced Query Types

9.2- Update Queries (cont.):

criteria purposes, and place them into the QBE grid. After that, you enter the value to which you want to

update the desired field into the “Update to:” row of the QBE grid, under the field which you wish to update.

Next, you apply the criteria by which you wish to select the records to be updated into the other field

or fields, as needed. You can then run the query to begin the update.

When you run the query, you will see a dialog box appear that tells you how many rows you are

about to update. If this number is correct, click “Yes” to continue to update the selected records. If this looks

incorrect, you can click “No” to abandon the update and double-check your criteria. Be extremely careful

when you make an update to your tables, as they can only be reversed by another “update” query, or by

hand. You cannot “undo” the effects of an update query after it has been run.

9.3- Append Queries:

You can use append queries as a way of “copying and pasting” records from one table to another

table, based on whether or not the records match a specified criteria. You can only append data from table

fields to other table fields that share the same (or a compatible) “data type.” So, for example, you may

append a “number” field into another “number” field. However, you cannot append a “number” field into a

“text” field. The more similar the two fields are, the easier it will be for you to append the data.

If the fields have the same field name, the data is automatically selected to be appended into the

field with the same name in the destination table. However, as long as the fields have common “Field Sizes”

so you don’t lose appended data, and share the same data types, you can easily specify to which fields the

copied data will be appended, even if they don’t share a common name. You can specify into which fields in

the destination table the fields from which you are appending will be placed when you create the append

query in design view.

To append only selected records from the original table into the destination table, you must use

selection criteria in the appropriate fields of the QBE grid when you are creating this query. That way, only

the records that meet the specified criteria will be appended to the destination table.

To create an append query, first create a query in design view. Then click the “Append” button in the

“Query Type” group of the “Design” tab in the “Query Tools” contextual tab in the Ribbon. Doing this will

launch the “Append” dialog box where you can select the name of the table into which you want to append

the data from the “Table Name:” drop-down. You can also select whether to append the new data into a

table in the current database, or another database by selecting the desired option button. If you select

“Another Database:,” then you will have to click the “Browse…” button and use the dialog box that appears

to select the database file which contains the table into which you will append the data. When you have

selected the table into which to append the data, click “OK” in the “Append” dialog box.

You can then add the fields into the QBE grid that you wish to append into the table that you just

selected. Next, click into the “Append to:” row in the QBE grid and select the field in the destination table

into which you wish to append the selected field’s data from the drop-down menu of available field choices.

In the “Criteria:” row, enter the criteria by which you wish to filter the records which are appended.

After you have selected the fields to append and into which fields they should be appended, you can

run the query to append the data. You will see a dialog box appear, telling you how many rows you are

about to append. If this is correct, click “Yes” to continue to append the selected records. If this looks

incorrect, you can click “No” to abandon the appending and double-check your criteria.

Sa
mple

- f
or

 ev
alu

ati
on

 pu
rp

os
es

 on
ly!



8Intermediate Access©TeachUcomp, Inc.

Advanced Query Types

9.4- Delete Queries:

You can use a delete query to delete records in a table based on specified criteria. Deleting

unnecessary records will speed up the performance of queries, reduce redundancies, and make for more

smoothly operating databases.

When you run a delete query, you are deleting records that match a specified criteria. You do not

delete field information only, you actually erase the entire record from the table. In order to not delete all of

the records in your table, you must carefully select which records to delete by using query criteria.

To create a delete query, start by creating a query in query design view. Then add the table that

contains the records to delete into the query design view. Next, click the “Delete” button in the “Query Type”

group of the “Design” tab in the “Query Tools” contextual tab in the Ribbon.

Next, add the fields to the QBE grid that you need to use for criteria purposes and place the criteria

by which you wish to select the records to delete into the “Criteria:” row. You can then run the query. You

will see a dialog box appear, telling you how many rows you are about to delete from the selected table. If

this is correct, click “Yes” to continue. If this looks incorrect, you can click “No” to abandon the record

deletion and double-check your criteria.

9.5- Crosstab Queries:

You can create crosstab queries to answer questions about how field data within a single table

relates to each other. Crosstab queries display one table field down the left side of the result table, and

another table field across the top of the table. In the intersecting cells, you will see data about how the two

fields are related via a third field. For example, if you had a table that showed the salesperson, the products

sold, and the number of each sold, you could create a crosstab query that sums the total amounts sold of

each product for each salesperson.

When you create a crosstab query, it is important to remember that the crosstab must be created

from a single table or query. Many times, these types of queries are based on other queries that you may

have created, as a single base table in your relational database rarely has the necessary data for

meaningful crosstab analysis. Crosstab queries display their answers in a spreadsheet-like format and, as

such, the result set of a crosstab query is not updateable.

Access gives you the “Crosstab Query Wizard” to assist you in creating crosstab queries. You can

run this wizard by clicking the “Query Wizard” button in the “Queries” group (“Other” group in 2007) on the

“Create” tab in the Ribbon. In the “New Query” dialog box that appears, select the “Crosstab Query Wizard”

and then click “OK.”

In the “Crosstab Query Wizard,” the first screen prompts you to select the table or query that will

serve as the basis of the crosstab query. You can select the desired table or query in this screen, and then

click the “Next >” button to continue. The second screen will prompt you to select up to three fields that you

want to display as the row headings at the left side of the crosstab query’s result set. Move the desired

fields from the “Available Fields:” list to the “Selected Fields:” list using the “>” button. Then click “Next >” to

continue. The next screen asks you to select which field you want for the column headings at the top of the

crosstab result set. Select the desired field and click “Next >” to continue. On the next screen, you select

what number you want shown in the intersecting cells of the column and row headings. In the “Fields:” list,

select the desired field to calculate and then select which function to perform on that field from the

“Functions:” list. If you wish to show a row summary, you can check the “Yes, include row sums” checkbox.

Then click “Next >” to continue. In the last screen you can type a name for the crosstab into the field

provided, and then click “Finish” to view the result set of the crosstab query.Sa
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Advanced Query Types

9.6- The Find Duplicates Query:

You can use the “Find Duplicates” query to find duplicate records within a table. To create a find

duplicates query, click the “Query Wizard” button in the “Queries” group (“Other” group in 2007) on the

“Create” tab in the Ribbon. In the “New Query” dialog box, select the “Find Duplicates Query Wizard” and

then click “OK.”

The first screen of the “Find Duplicates Query Wizard” allows you to select the table within which

you wish to find duplicate records. Make your selection and then click “Next >” to continue. In the second

screen, you select by which fields you wish to examine the records to look for duplicates. You click on the

fields within which you wish to look for duplicate information in the “Available fields:” list, and then click the

“>” button to move them into the “Duplicate-value fields:” list. You cannot have more than 10 fields listed in

the “Duplicate-value fields:” list. When you have added the necessary fields, click “Next >” to continue. In

the third screen you can select any other additional fields you would like to display in addition to the ones

within which you will be searching for duplicate values. You can click on the names of the fields you wish to

view in the “Available fields:” list, and click the “>” button to move them into the “Additional query fields:” list.

Then click “Next >” to continue to the last screen. In the last screen, you can type a name for the query into

the text box available, and then click “Finish” to view the duplicates in a query result set.

Note that this is not the recommended process for removing duplicate records from a table. This

query simply informs you of which records are duplicated in the selected table. While it is possible to delete

the displayed records from the find duplicates query result set, you can also remove duplicates using the

function of the primary key in a table.

If you want to remove duplicates from a table in Access, you can right-click on the table from which

you wish to remove duplicates in the Navigation Pane, and then choose “Copy” from the pop-up menu that

appears. Then right-click into the table list in the Navigation Pane, and choose “Paste” from the pop-up

menu that appears. Doing that will cause the “Paste Table As” dialog box to appear. In this dialog box, type

in a name of the copy of the table that you are about to make and select the “Structure Only” option in the

“Paste Options” section of the dialog box. Then click “OK.”

Next, open the copy of the table structure that you made in table design view. If there are any

primary key field assignments made, remove them by selecting the field or fields by which the primary key is

assigned, and then clicking the “Primary Key” button in the “Tools” group on the “Design” tab of the “Table

Tools” contextual tab in the Ribbon. Then select the combination of fields by which you wish to determine if

there are duplicates in the original table, and click the “Primary Key” button again to assign the unique

combination of values produced by the selected fields as the new “Primary Key.” Remember that the

purpose of a primary key is to eliminate duplicate values within a table. So, once that is done, click the

“Save” button in the Quick Access toolbar to save the structural changes you made.

At that point, create an “Append Query” to append the records from the original table that contains

the duplicate records into the new table structure. When you run the append query, any records which

contain a combined duplicate value in the primary key fields will not be appended into the copy of the table.

You should see an error message that says that a certain number of rows were not appended due to table

key violations. Those are the duplicate records, so you may append the records that were not removed into

the copy that you created. Then the copy of the original table should contain duplicate-free records.
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Advanced Query Types

9.7- The Find Unmatched Query:

In a relational database, you aren’t supposed to have records in a “child,” or related, table which

have no reference to a related record in a “parent” table. For example, in a “Sales” table that contains a

“CustomerID” field, any reference placed into the “CustomerID” field should correspond to a valid

“CustomerID” in the “Customers” table.

However, this isn’t always the case. If properly constructed from the beginning, enforcing referential

integrity on your Access tables will ensure that you do not have unmatched records. But if you are creating

a new Access database from data that was not stored in a relational database that had referential integrity

checks, then you may have unmatched field references within your tables. Using the “Find Unmatched”

query finds such records in a “child” table field that do not contain any valid reference to a record in the

parent table. Such records are said to be “orphaned.” You can then re-create the necessary reference in the

records shown, maintaining data validity.

To create a find unmatched query, click the “Query Wizard” button in the “Queries” group (“Other”

group in 2007) on the “Create” tab in the Ribbon. Select the “Find Unmatched Query Wizard” in the “New

Query” dialog box, and click “OK” to launch the “Find Unmatched Query Wizard.”

In the first screen, select the name of the table or query that may contain unmatched, or “orphaned”

records. Then click “Next >” to continue to screen two. In the second screen, select the name of the “parent”

table that contains the records that should contain the matching values for the records in the first table

selected. Then click “Next >” to continue. In the third screen, you must select the names of the two fields in

each table by which the two tables should be joined. Then click the “<=>” button to link the two fields for the

duration of the query to find unmatched records. Then click “Next >” to continue to the next screen. Here,

you can select any additional fields you wish to display in the query results from the “Available fields:” list,

and click the “>” button to move them into the “Selected fields:” list. Then click “Next >” to continue to the

last screen where you can type a name for the query into the text box provided. Click “Finish” to then

display the records from the first table that contain no matching records in the second table.
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ACTIONS-

Advanced Query Types
CREATING A MAKE-TABLE QUERY:

1. Open the database.

2. Click the “Query Design” button in the “Queries” group (“Other” group in 2007) on the “Create” tab in the 

Ribbon.

3. Select the desired tables or queries to add from the “Show Table” dialog box.

4. Click “Add” to add the selected tables or queries to the new query.

5. Click “Close” in the “Show Table” dialog box, when finished.

6. Add the fields that you need into the QBE grid.

7. Click into the “Criteria” row under the appropriate fields.

8. Enter the desired criteria under the appropriate field(s).

9. Click the “Make Table” button in the “Query Type” group on the “Design” tab in the “Query Tools” 

contextual tab in the Ribbon to open the “Make Table” dialog box.

10. Type a name for the new table that will be created into the “Table Name:” text box.

11. Click “OK.”

12. Run the query when you are ready.

13. Select “Yes” at the prompt to create the new table.

CREATING AN UPDATE QUERY:

1. Open the database.

2. Click the “Query Design” button in the “Queries” group (“Other” group in 2007) on the “Create” tab in the 

Ribbon.

3. Select the desired tables or queries to add from the “Show Table” dialog box.

4. Select the desired tables or queries to add to the update query from the “Show Table” dialog box.

5. Click “Add” to add the selected tables or queries to the new query.

6. Click “Close” in the “Show Table” dialog box.

7. Click the “Update” button in the “Query Type” group on the “Design” tab in the “Query Tools” contextual 

tab in the Ribbon.

8. Add the fields that you want to update as well as any field needed for criteria purposes into the QBE 

grid.

9. Click into the “Update to:” row under the field(s) that you wish to update.

10. Type in the value or expression (formula) to which you wish to update the field’s value.

11. Add the necessary criteria by which to apply the update into the “Criteria:” row, under the appropriate 

fields.

12. Run the query.

13. Select “Yes” at the dialog box prompt to update the selected records.
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ACTIONS-

Advanced Query Types
CREATING AN APPEND QUERY:

1. Open the database.

2. Click the “Query Design” button in the “Queries” group (“Other” group in 2007) on the “Create” tab in the 

Ribbon.

3. Select the desired tables or queries to add from the “Show Table” dialog box.

4. Click “Add” to add the selected table or query.

5. Click “Close” in the “Show Table” dialog box.

6. Click the “Append” button in the “Query Type” group on the “Design” tab in the “Query Tools” contextual 

tab in the Ribbon to open the “Append” dialog box.

7. Select the name of the table to which you want to append the data from the “Table Name:” drop-down.

8. Click “OK.”

9. Place the fields from which you wish to append data into the QBE grid.

10. Click into the “Append to:” row under any unmatched field if necessary, and select the name of the 

matching field from the table into which the data will be appended from the drop-down list.

11. Click into the “Criteria:” row under any fields by which you want to restrict the records that are appended 

and enter any necessary criteria.

12. Run the query.

13. Select “Yes” at the dialog box prompt to append the data into the destination table.

CREATING A DELETE QUERY:

1. Open the database.

2. Click the “Query Design” button in the “Queries” group (“Other” group in 2007) on the “Create” tab in the 

Ribbon.

3. Select the desired tables or queries to add from the “Show Table” dialog box.

4. Click “Add” to add the selected table or query.

5. Click “Close” in the “Show Table” dialog box.

6. Click the “Delete” button in the “Query Type” group on the “Design” tab in the “Query Tools” contextual 

tab in the Ribbon.

7. Place the fields necessary for the query criteria into the QBE grid.

8. Click into the “Criteria:” row under the appropriate fields, and enter the necessary criteria.

9. Run the query.

10. Select “Yes” at the prompt.
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ACTIONS-

Advanced Query Types
RUNNING THE CROSSTAB QUERY WIZARD:

1. Open the database.

2. Click the “Query Wizard” button in the “Queries” group (“Other” group in 2007) on the “Create” tab in the 

Ribbon.

3. Select “Crosstab Query Wizard” in the “New Query” dialog box.

4. Click “OK.”

5. Select the desired table or query from which to create the crosstab query.

6. Click the “Next >” button.

7. Select the fields (up to 3) that you want to use to provide values for the row headings (at the left).

8. Click the “Next >” button.

9. Select the field that you would like to provide vales for the column headings (at the top).

10. Click the “Next >” button.

11. Select the field you want to calculate at the intersection of the column and row headings and select the 

function to perform on that field.

12. Click the “Next >” button.

13. Enter a name for the crosstab query, and click the “Finish” button.

RUNNING THE FIND DUPLICATES QUERY WIZARD:

1. Open the database.

2. Click the “Query Wizard” button in the “Queries” group (“Other” group in 2007) on the “Create” tab in the 

Ribbon.

3. Select the “Find Duplicates Query Wizard” in the “New Query” dialog box.

4. Click “OK.”

5. Select the name of the desired table or query in which you wish to search for duplicate records.

6. Click the “Next >” button.

7. Select the fields (up to 10) within which you wish to search for duplicate values.

8. Click the “Next >” button.

9. Select any other fields that you want to display in the query result set.

10. Click the “Next >” button.

11. Enter a name for your cross-tab query, and click the “Finish” button.
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ACTIONS-

Advanced Query Types
RUNNING THE FIND UNMATCHED QUERY WIZARD:

1. Open the database.

2. Click the “Query Wizard” button in the “Queries” group (“Other” group in 2007) on the “Create” tab in the 

Ribbon.

3. Select the “Find Unmatched Query Wizard” in the “New Query” dialog box.

4. Click “OK.”

5. Select the desired table which contains the field within which you want to search for unmatched records.

6. Click the “Next >” button.

7. Select the related table which contains the field within which you wish to search for values missing from 

the first table.

8. Click the “Next >” button.

9. Select the field to match from the fields listed in the table at the left side of this screen.

10. Select the matching field from the fields listed in the table at the right side of this screen.

11. Click the “<=>” button to link the two selected fields in the table for the duration of the query.

12. Click the “Next >” button.

13. Select any additional fields that you want to display in the query result set, and click the “>” button to 

add them to the list of fields at the right side of this tab.

14. Click the “Next >” button.

15. Enter a name for your new query, and click the “Finish” button.
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EXERCISES-

Advanced Query Types
Purpose:

1. To be able to create some advanced types of queries.

Exercises:

1. Open your Access application.

2. Open the “test” database you completed from the Exercise at the end of the last chapter in the

“Introductory” manual.

3. Click the “Query Wizard” button in the “Queries” group (“Other” group in 2007) on the “Create” tab in

the Ribbon.

4. Select the “Find Duplicates Query Wizard” in the “New Query” dialog box.

5. Click “OK.”

6. Select “Table: Customers,” and click “Next >.”

7. Click “City,” and click the “>” arrow to add it to the “Duplicate-value fields:” list.

8. Click “Next >” to continue.

9. Click “CompanyName,” and click the “>” arrow to add it to the “Additional query fields:” list.

10. Click “Next >” to continue.

11. Click “Finish.”

12. Close the query result set.

13. Close the database.
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CHAPTER 10-

Creating Forms

10.1- Forms Overview

10.2- The Form Wizard

10.3- Creating Forms

10.4- Using Forms

10.5- Form and Report Layout View

10.6- Form and Report Design View

10.7- Viewing the Ruler and Grid

10.8- The “Snap to Grid” Feature

10.9- Creating a Form in Design View
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Creating Forms

10.1- Forms Overview:

Forms can have different functions within an Access database. You can use forms to create

Navigation Forms in Access, where users can click buttons that perform different actions- such as opening

other forms and reports. However, Access forms are primarily used as data entry forms that allow users to

edit and enter table data. When performing data entry with forms, users enter information into form fields

that are associated with data fields in a linked table. The data is then stored in the tables, just as if you had

entered the data into the datasheet view of the table. Using data entry forms in your database simplifies and

streamlines data entry, and provides more security for the table data than allowing a user to do data entry

directly in the table in datasheet view.

10.2- The Form Wizard:

A simple way to create basic data entry forms is to use the “Form Wizard” provided by Access. If

using Access 2013 or 2010, you can start the “Form Wizard” by clicking the “Form Wizard” button located

on the “Create” tab in the “Forms” group within the Ribbon. If using Access 2007, you can start the “Form

Wizard” by clicking the “More Forms” button in the “Forms” group on the “Create” tab in the Ribbon and then

selecting the “Form Wizard” command from the button’s drop-down menu to launch the “Form Wizard”

dialog box.

In the first screen of the “Form Wizard” dialog box, select the name of the table or query upon which

you would like to base this form from the “Tables/Queries:” drop-down provided. Below that, use the buttons

available to move the fields that you want to add to the form from the “Available Fields:” list into the

“Selected Fields:” list. When you are finished, click the “Next >” button to continue.

Continue answering the questions posed to you in each screen of the “Form Wizard,” and then click

the “Next >” button to continue. Once you have completed all of the screens and named your new form,

click the “Finish” button at the end of the “Form Wizard” to create a basic data entry form.

10.3- Creating Forms:

There are several ways to create a basic data entry form using the buttons in the “Forms” button

group on the “Create” tab in the Ribbon. Starting in Access 2010, some form choices have been moved to

the “More Forms” drop-down button. To create a form using this method, first select the name of the table or

query in the Navigation Pane for which you want to create an associated data entry form. Then click the

type of form to create from the buttons listed in the “Forms” button group on the “Create” tab in the Ribbon.

Access will instantly create a form of the specified type for the selected table or query.

Let’s examine some of the more popular form style choices. You can select a desired table or query

from the Navigation Pane and then click the “Form” button to create a standard data entry form. In Access

2013, this creates a “Split Form” by default. In Access 2010:2007, it creates a form that displays one record

at a time from the underlying data source.

You can click the “Split Form” button to create a split form that shows the current record at the top of

the form and an accompanying datasheet view of the underlying data source at the bottom of the form.

You can click the “Multiple Items” button to create a form that displays multiple records in the form,

with each record displayed in its own row. Note that starting in Access 2010, the “Split Form” and Multiple

Items” form buttons have been moved to the drop-down menu that appears when you click the “More

Forms” drop-down button.Sa
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Creating Forms

10.5- Form and Report Layout View:

Once you have created a form, you can edit it. You can change the placement of the fields within the

form, add or remove fields from the form, or add color to the form objects or background. In order to perform

many of these tasks, you will need to switch to either the “Layout View” or the “Design View” of the form.

To do this, right-click the form that you want to edit in design or layout view from the forms listed in

the Navigation Pane. Select either the “Design View” or the “Layout View” choice in the pop-up menu that

appears to open the selected form in design view or layout view. The major difference between the two

views is that in “Layout View,” you will see the actual data from the underlying data source while editing the

form. In “Design View,” you will not see any data from the underlying data source, but you do have more

options for editing the properties of the form objects than is available in “Layout View.” In either view you

can select the objects placed into the form and apply general formatting. You can also adjust the size or

placement of selected form elements, called “controls,” in either view.

10.4- Using Forms:

Once you have created a data entry form, you can use it to edit, create, and navigate table records.

Navigating within a data entry form is exactly like navigating through records in the datasheet of a table.

You can use the “Tab” key on your keyboard to move through the data fields. You also have the same

“record navigation” buttons in the lower left corner of the data entry form that you have in the datasheet view

of a table. You can also use these to move through the records in the table. You can also add a new record

into the table through the form by clicking the “New Record” button in the lower left corner of the data entry

form. You just need to remember that a data entry form is simply a “face” for your database tables.

10.6- Form and Report Design View:

While Access may seem very complex with its multiple object types and the various views of each, it

does actually use the same type of “Design View” and “Layout View” for both its forms and its reports. This

helps to simplify the design process for these types of objects. To access the form and report design view,

you right-click on the name of the form or report you want to modify from the listing shown in the Navigation

Pane, and then select the “Design View” command in the pop-up menu that appears. You could also create

a new form in design view by clicking the “Form Design” button in the “Forms” group on the “Create” tab

within the Ribbon. This creates a new, blank form that you can modify as you desire in design view.

10.7- Viewing the Ruler and Grid:

When you edit forms and reports, you are often editing the objects inside of the forms and reports

known as controls. Notice that in form or report design view there is a gridline displayed that you can use

to place and align the form and report controls. There is also a ruler which you can use for measurements.

They can both be turned on and off by clicking either the “Ruler” or “Grid” buttons. In Access 2013:2010,

these button are located on the “Size/Space” drop-down button within the “Sizing & Ordering” group on the

“Arrange” tab in the “Form Design Tools” or “Report Design Tools” contextual tab in the Ribbon. In Access

2007, these button are located in the “Show/Hide” section of the “Arrange” tab in the “Form Design Tools” or

“Report Design Tools” contextual tab in the Ribbon. Each time you click one of these buttons you will toggle

the display of the grid or ruler on or off in the design view of the form.Sa
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Creating Forms

10.8- The “Snap To Grid” Feature:

When you place controls onto a form or report in design view, you can either enable or disable the

“snap to grid” feature. When enabled, this feature forces the controls to align themselves with the underlying

grid on the form or report. If disabled, you have a greater flexibility in placing controls on the form or report,

but may find it more difficult to align the controls. Once again, this is a “toggle” command. So you perform

the same action to both enable and disable this feature. You can do this by clicking the “Snap to Grid”

button. In Access 2013:2010, this button is located on the “Size/Space” drop-down button within the “Sizing

& Ordering” group on the “Arrange” tab in the “Form Design Tools” contextual tab in the Ribbon. In Access

2007, this button is located in the “Control Layout” group on the “Arrange” tab of the “Form Design Tools”

contextual tab within the Ribbon.

10.9- Creating a Form in Design View:

Most forms are connected to an underlying table or query from which they display and/or update the

table data. In form design view, you can access the list of fields available to the form and simply drag and

drop them onto your form to quickly add data controls to the form for data entry or display.

To view the field list available for a form, just open the selected form in design view and click the

“Add Existing Fields” button in the “Tools” group on the “Design” tab of the “Form Design Tools” contextual

tab within the Ribbon. Either way, this will show the “Field List” in a pane at the right side of the form design

view. If you have associated a data source with the form, then the available fields will be shown in the

“Fields available for this view:” section of the “Field List” pane.

If there is no underlying data source associated with the form, then click the “Show all tables”

hyperlink to display all of the available tables within this pane. Then click the small plus sign next to the

name of the table that you would like to associated with the form to view its fields in the “Field List.” Then

click and drag the desired fields from the table into your form. This also associates the selected table with

the form.

Notice that when you add a field from the “Field List” into your form, you are actually adding two

controls at once. The control at the left side is a text label that displays the name of the data field. The

control at the right is the actual data field where the underlying data will display.

In the next chapter, you will examine the ways that you can manipulate the form controls in more

detail. It is also worth noting that while you can add controls using the “Field List,” many more types of

controls are available for use in the “Controls” group on the “Design” tab of the “Form Design Tools”

contextual tab within the Ribbon. You can use the buttons in this group to add many types of form controls

into your form to create a more advanced form design. You will also examine these controls in greater detail

in the next chapter.
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ACTIONS-

Creating Forms
USING THE FORM WIZARD:

1. If using Access 2013 or 2010, click the “Form Wizard” button located on the “Create” tab in the “Forms” 

group within the Ribbon. If using Access 2007, click the “More Forms” button in the “Forms” group on 

the “Create” tab in the Ribbon and then select the “Form Wizard” command from the button’s drop-down 

menu to launch the “Form Wizard” dialog box.

2. In the first screen, you can select the drop-down list under “Tables/Queries:” to select a table or query 

upon which to base the form.

3. Move the fields that you want to display in the form from the “Available Fields:” list to the “Selected 

Fields:” list by selecting the name of the field to use and clicking the “>” button to move them.

4. Click “Next>” when you have added all the fields that you want to display to the “Selected Fields:” list.

5. In the next screen, select the layout for your form by selecting the option button that corresponds to the 

type of form layout you desire. Then click “Next>” to continue.

6. Select the desired form style by selecting the option button that corresponds to the type of style that you 

prefer. Then click “Next>” to continue.

7. In the last screen you can type a name for your form into the box provided, and select to either “Open 

the form to view or enter information” or “Modify the form’s design.”

8. Click “Finish” to create your form.

CREATING FORMS:

1. Select the name of the form or query in the Navigation Pane for which you want to create an associated 

data entry form.

2. Click on the type of form that you want to create from the buttons listed in the “Forms” button group on 

the “Create” tab in the Ribbon. Note that starting in Access 2010, some of the buttons have been moved 

to the drop-down menu that appears when you click the “More Forms” drop-down button.

3. You can click the “Form” button to create a standard data entry form that displays one record at a time 

from the underlying data source.

4. You can click the “Split Form” button to create a split form that shows the current record at the top of the 

form and an accompanying datasheet view of the underlying data source at the bottom of the form.

5. You can click the “Multiple Items” button to create a form that displays multiple records in the form, with 

each record displayed in its own row within the form.

USING A DATA ENTRY FORM:

1. Double-click the name of the form to open from the list of forms displayed in the Navigation Pane.

2. You can navigate through the records in the form using the record navigation buttons located in the 

lower left corner of the data entry form.

3. You can click the “First Record” button to view the first record in the form.

4. You can click the “Previous Record” button to view the previous record in the form.

5. You can click the “Next Record” button to view the next record in the form.

6. You can click the “Last Record” button to view the last record in the form.

7. You can click the “New Record” button to create a new blank record at the end of the form.
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ACTIONS-

Creating Forms
NAVIGATING FORM FIELDS:

1. Double-click the name of the form to open from the list of forms displayed in the Navigation Pane.

2. You can click into a field to enter data. As long as the field isn’t “read-only” you should be able to edit 

the data in the field.

3. Press “Tab” on your keyboard to move to the next field, based on the tab order of the form controls.

4. Press “Shift”+“Tab” to move to the previous field, based on the tab order of the form controls.

5. Press “Enter” to move to the next field, based on the tab order of the form controls.

ADDING A NEW RECORD IN A DATA ENTRY FORM:

1. Double-click the name of the form to open from the list of forms displayed in the Navigation Pane.

2. Click the “New Record” button in the lower left corner of the form to move to the empty record at the end 

of the associated table.

3. Move through the fields in the form, entering information as needed into each one.

4. When you are done entering new records, click the “X” in the upper right corner to close the form.

EDITING RECORDS IN A FORM:

1. Double-click the name of the form to open from the list of forms displayed in the Navigation Pane.

2. Navigate to the record that you want to edit, and click into the field that you want to change.

3. Make your changes to the selected field.

OPENING A FORM IN DESIGN VIEW:

1. Open the database that contains the form that you want to edit in design view.

2. Right-click the name of the specific form to edit from the list of forms in the Navigation Pane.

3. Select the “Design View” command in the pop-up menu that appears to open the form in design view.

OPENING A FORM IN LAYOUT VIEW:

1. Open the database that contains the form that you want to edit in layout view.

2. Right-click the name of the specific form to edit from the list of forms in the Navigation Pane.

3. Select the “Layout View” command in the pop-up menu that appears to open the form in layout view.
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ACTIONS-

Creating Forms

CREATING FORMS IN DESIGN VIEW:

1. Open the database that contains the form that you want to edit in design view.

2. Right-click the name of the specific form to edit from the list of forms in the Navigation Pane.

3. Select the “Design View” command in the pop-up menu that appears to open the form in design view.

4. To remove a control from a form, click on any form control to select it and then press the “Delete” key on 

your keyboard.

5. To view the field list available for a form, just open the selected form in design view and click the “Add 

Existing Fields” button in the “Tools” group on the “Design” tab of the “Form Design Tools” contextual 

tab within the Ribbon. The “Field List” will appear in a pane at the right side of the form design view.

6. If you have associated a data source with the form, then the available fields will be shown in the “Fields 

available for this view:” section of the “Field List” pane.

7. If there is no underlying data source associated with the form, then click the “Show all tables” hyperlink 

to display all of the available tables within this pane.

8. Then you can click the small plus sign next to the name of the table that you would like to associated 

with the form to view its fields in the “Field List.”

9. Then just click and drag the desired fields from the table into your form. This also associates the 

selected table with the form.

ENABLING AND DISABLING THE “SNAP TO GRID” FEATURE IN DESIGN VIEW:

1. Open the database that contains the form that you want to edit in design view.

2. Right-click the name of the specific form to edit from the list of forms in the Navigation Pane.

3. Select the “Design View” command in the pop-up menu that appears to open the form in design view.

4. Click the “Snap to Grid” button. In Access 2013:2010, this button is located on the “Size/Space” drop-

down button within the “Sizing & Ordering” group on the “Arrange” tab in the “Form Design Tools” or 

“Report Design Tools” contextual tab in the Ribbon.

5. In Access 2007, this button is located in the “Control Layout” group on the “Arrange” tab of the “Form 

Design Tools” or “Report Design Tools” contextual tab within the Ribbon.

SHOWING AND HIDING THE RULER AND THE GRID IN DESIGN VIEW:

1. Open the database that contains the form that you want to edit in design view.

2. Right-click the name of the specific form to edit from the list of forms in the Navigation Pane.

3. Select the “Design View” command in the pop-up menu that appears to open the form in design view.

4. Click either the “Ruler” or “Grid” button to toggle their visibility.

5. In Access 2013:2010, these button are located on the “Size/Space” drop-down button within the “Sizing 

& Ordering” group on the “Arrange” tab in the “Form Design Tools” or “Report Design Tools” contextual 

tab in the Ribbon.

6. In Access 2007, these button are located in the “Show/Hide” section of the “Arrange” tab in the “Form 

Design Tools” or “Report Design Tools” contextual tab in the Ribbon.

7. Each time you click one of these buttons you will toggle the display of the grid or ruler on or off in the 

design view of the form.
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EXERCISES-

Creating Forms
Purpose:

1. To be able to create a basic form for your database.

Exercises:

1. Open your Access application.

2. Open the “test” database you completed from the Exercise at the end of the previous chapter.

3. If using Access 2013:2010, click the “Form Wizard” button located on the “Create” tab in the “Forms”

group within the Ribbon. If using Access 2007, click the “More Forms” button in the “Forms” group

on the “Create” tab in the Ribbon and then select the “Form Wizard” command from the button’s

drop-down menu to launch the “Form Wizard” dialog box.

4. In the first screen of the “Form Wizard,” use the “Tables/Queries” drop-down to select “Table:

Customers.”

5. Click the “>>” arrow button to move all of the fields shown in the “Available fields:” list into the

“Selected Fields:” list.

6. Click the “Next >” button.

7. Select “Justified.”

8. Click the “Next >” button.

9. If using Access 2007, select “Windows Vista” and then click the “Next >” button.

10. Enter “frmCustomers” into the “What title do you want for your form?” text box.

11. Select the “Open the form to view or enter information.” option button

12. Click “Finish.”

13. View the information in the form, and then close the form when you are finished.

14. Close the database.
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11.1- Selecting Controls

11.2- Deleting Controls

11.3- Moving and Resizing Controls

11.4- Sizing Controls to Fit

11.5- Nudging Controls

11.6- Aligning, Spacing, and Sizing Controls

11.7- Formatting Controls

11.8- Viewing Control Properties

CHAPTER 11-

Form & Report Controls
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11.1- Selecting Controls:

When you are placing controls into forms and reports in “Design View,” you will often need to select,

move, align and space the controls. In this lesson, you will look at the ways that you can accomplish these

tasks. Before you can perform any of these tasks, however, you will need to be able to select the controls

that you’ve placed on the form.

To select a control, simply click the control. It will appear with a thick, orange border with eight small

squares around its perimeter. To select multiple controls, you will need to click the first control that you want

to select, hold down the “Shift” key on your keyboard, and then click on any other controls that you would

like to select as well. When you are finished selecting the controls, release the “Shift” key.

Another way to select controls is to click and drag your mouse, starting in the blank area of the form.

As you click and drag you will see a selection area appear. Any form or report controls that you touch with

the selection area are included for selection once you release your mouse button.

To de-select controls that you have selected, simply click into the blank area of the form. If you have

multiple controls selected, and simply want to de-select a single selected control, then you can hold down

the “Shift” key on your keyboard and then click the control that you want to de-select to remove from the

group of selected controls.

If using “Layout View,” you can use the click method of selection for the form and report controls,

however, you cannot lasso them with a selection marquee. When selected, you will not see any of the small

squares that appear around the orange border of the controls, like you do in “Design View.” This is normal.

Note that you can still move, align, and resize the selected controls in much the same way in either view,

regardless of the minor superficial difference in the appearance of selected controls between the two views.

Form & Report Controls

11.2- Deleting Controls:

Once you have taken the initial step of selecting the controls, you can then delete, copy, move,

align, and space them as needed within your form or report. To delete selected controls, just press the

“Delete” key on your keyboard. Note that if you delete a form field that you inserted into your form through

the “Field List,” deleting the field will also delete the associated label control too. Also note that the opposite

is not true. You can delete the label control in a paired field control without deleting the associated field.

11.3- Moving and Resizing Controls:

You can move and resize selected controls in a form or report that is displayed in design view. You

may want to do this if the controls aren’t large enough to display the field data, or if they are not placed into

the desired area in the form. When you select controls, you will notice that seven small orange squares and

one large gray or brown square appear around the orange border of the selected controls. To resize a

selected control, move your mouse pointer over the handle that represents the direction in which you want

to resize the control until your mouse pointer turns into a small two-headed black arrow. When it does this,

click and drag to resize the selected control or controls. Note that if you are using “Layout View,” you can

simply place your mouse pointer anywhere over the orange border until you see the double-pointed black

arrow, and then click and drag to resize the selected control or controls.

You can also move selected controls. This will allow you to pick up a control or a group of selected

controls and place them into another part of the form. To do this in “Design View,” move your mouse pointer

over the border of the selected control, but not where there is a resizing square, until the mouse pointer

turns into a small four-pointed arrow. Click and drag on the border when your mouse pointer looks like thatSa
mple

- f
or

 ev
alu

ati
on

 pu
rp

os
es

 on
ly!



26Intermediate Access©TeachUcomp, Inc.

11.3- Moving and Resizing Controls (cont.):

to move the selected control or controls. When you release the left mouse button, you will drop the control

or controls to wherever the mouse pointer is placed. In “Layout View,” you simply place the mouse pointer

directly over the center of a selected control until you see the four-pointed arrow appear. Then click and

drag to move only the selected control or controls into the desired position within the form or report.

When you add controls to a form or report from the “Field List,” they will appear as a “paired” control:

one “label” control, and one “text box” control. This means that in addition to the actual data field, there will

also be a paired label with the field’s name in it. If you move one control in the paired set in “Design View,”

you move the other as well. Sometimes, however, you want to move one control without moving the other

while in “Design View.” The “handle” that you use to move a single part of a paired control is the large gray

or brown square that appears in the upper left corner of the control when the control is selected. If you place

your mouse pointer over this large handle, until it turns into the four-pointed arrow, you can click and drag at

that point in time to move the individual control independently of its paired control partner. Then just release

the mouse button to place it into a new position. Note that in “Layout View,” the paired control effect is

nullified. You always move only the selected control or controls when you reposition them within the form.

Form & Report Controls

11.4- Sizing Controls to Fit:

You can also size controls to vertically fit their font display size in “Design View.” You may do this if

you increase the size of the font used to display the data in a control and then wish to resize the control

vertically without having to align it to the next available gridline. To size a control to fit, simply select the

control to size and then click the “To Fit” button (“Size To Fit” button in Access 2007). In Access 2013:2010,

this button is located on the “Size/Space” drop-down in the “Sizing & Ordering” group on the “Arrange” tab

on the “Form Design Tools” contextual tab within the Ribbon. In Access 2007, this button is located in the

“Size” group on the “Arrange” tab of the “Form Design Tools” contextual tab within the Ribbon.

11.5- Nudging Controls:

You may also “nudge” selected controls to move them just a little bit, freeing them from the

restrictions of the “Snap to Grid” feature. This can give you extra precision in their placement on the form or

report. To do this, simply select the control(s) to nudge, hold down the “Ctrl” key on your keyboard, and then

press the “Arrow keys” on your keyboard to “nudge” the controls up, down, left or right one pixel at a time.

11.6- Aligning, Spacing, and Sizing Controls:

In most forms you have controls that you want to align in columns or rows within your form. You may

want to break the form or report up into different sections and align a smaller group of controls within a

certain section. Either way, you can align selected controls easily in a form or report.

In “Design View,” you select the controls to align, and click the desired alignment to apply from the

alignment buttons available. In Access 2013:2010, these buttons are located on the “Align” drop-down

button in the “Sizing & Ordering” group on the “Arrange” tab in the “Form Design Tools” contextual tab

within the Ribbon. In Access 2007, these buttons are located in the “Control Alignment” group on the

“Arrange” tab of the “Form Design Tools” contextual tab in the Ribbon.

To set the spacing between selected controls, you must click the desired spacing option button from

the group of options that are available. In Access 2013:2010, these buttons are available in the “Spacing”Sa
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Form & Report Controls

11.7- Formatting Controls:

In “Design View,” you can format the appearance of selected controls in your forms and reports. In

both “Design View” and “Layout View” in Access 2013:2010, you can select controls, and then apply

formatting found in the “Font,” “Number,” “Background,” and “Control Formatting” groups on the “Format”

tab in the “Form Design Tools” contextual tab within the Ribbon. You can also select themed formatting for

your form by choosing from the buttons shown in the “Themes” group on the “Design” tab in the “Form

Design Tools” contextual tab within the Ribbon.

In Access 2007, you can use the formatting buttons available in the “Font” and “Controls” groups on

the “Design” tab of the “Form Design Tools” contextual tab within the Ribbon. You can also apply automatic

formatting to a form using the “AutoFormat” button in the “AutoFormat” group on the “Arrange” tab in the

“Form Design Tools” contextual tab within the Ribbon. When using the “Layout View,” you will have the

same formatting options, however, they are in slightly different locations. You can use the buttons available

in the “Font,” “Formatting,” “Controls,” and “AutoFormat” groups on the “Format” tab of the “Form Layout

Tools” contextual tab in the Ribbon.

To apply formatting to your form or report controls in either view, first select the desired control or

controls to format. Then click the necessary buttons in button groups listed to achieve your desired

appearance.

11.8- Viewing Control Properties:

Each control you select has many individual properties whose values you can set within the

“Property Sheet.” To view the properties for a selected control, select the desired control in the form or

report and then click the “Property Sheet” button in the “Tools” group on the “Design” tab of the “Form

Design Tools” contextual tab while using “Design View” to show the “Property Sheet” if needed. Each time

you click this button, you turn the display of the “Property Sheet” on or off. When its display is enabled, you

will see all of the properties of the selected control listed on one of the tabs shown in this pane. They are

broken down into major property groups on each of the following tabs: “Format,” which contains properties

relating to the appearance of the control; “Data,” which contains properties relating to the data values stored

in the control (if any); “Event,” which contains properties relating to programming events which you shall

examine when using macros; “Other,” which lists any miscellaneous properties; or “All,” which lists all of the

properties available in alphabetical order. You can click into the desired property field and then change the

settings for the selected control, as desired.

11.6- Aligning, Spacing, and Sizing Controls (cont.):

section of the “Size/Space” drop-down button’s menu in the “Sizing & Ordering” group on the “Arrange” tab

in the “Form Design Tools” contextual tab within the Ribbon. In Access 2007, these are located in the

“Position” group on the “Arrange” tab of the “Form Design Tools” contextual tab in the Ribbon.

You can set the size of multiple selected controls to match the height of the tallest or shortest control

or the width of the widest or narrowest control. To do this, select the desired controls in the form or report. If

using Access 2013:2010, you then choose the desired sizing option from the choices available in the “Size”

section of the “Size/Space” drop-down button’s menu of choices in the “Sizing & Ordering” group on the

“Arrange” tab in the “Form Design Tools” contextual tab within the Ribbon. If using Access 2007, you then

click the desired sizing option button in the “Size” group on the “Arrange” tab of the “Form Design Tools”

contextual tab in the Ribbon.
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ACTIONS-

Form & Report Controls
SELECTING MULTIPLE CONTROLS:

1. To select a control, simply click the control.

2. To select multiple controls, you will need to click the first control that you want to select, hold down the 

“Shift” key on your keyboard, and then click on any other controls that you would like to select as well. 

When you are finished selecting the controls, release the “Shift” key.

3. Another way to select controls is to click and drag your mouse, starting in the blank area of the form. As 

you click and drag you will see a selection area appear. Any form or report controls that you touch with 

the selection area are included for selection once you release your mouse button.

4. To de-select controls that you have selected, simply click into the blank area of the form. If you have 

multiple controls selected, and simply want to de-select a single selected control, then you can hold 

down the “Shift” key on your keyboard and then click the control that you want to de-select to remove 

from the group of selected controls.

5. If using “Layout View,” you can use the click method of selection for the form and report controls, 

however, you cannot lasso them with a selection marquee. When selected, you will not see any of the 

small squares that appear around the orange border of the controls, like you do in “Design View.” This is 

normal. Note that you can still move, align, and resize the selected controls in much the same way in 

either view, regardless of the minor superficial difference in the appearance of selected controls 

between the two views.

DELETING CONTROLS:

1. To delete selected controls, just press the “Delete” key on your keyboard.

2. If you delete a form field that you inserted into your form through the “Field List,” deleting the field will 

also delete the associated label control too. Contrarily, also note that you can delete the label control in 

a paired field control without deleting the associated field.

MOVING AND RESIZING CONTROLS:

1. To resize a selected control in “Design View,” move your mouse pointer over the handle that represents 

the direction in which you want to resize the control until your mouse pointer turns into a small two-

headed black arrow. When it does this, click and drag to resize the selected control or controls.

2. If you are using “Layout View,” you can simply place your mouse pointer anywhere over the orange 

border until you see the double-pointed black arrow. Then click and drag to resize the selected control.

3. To move selected controls in “Design View,” move your mouse pointer over the border of the selected 

control, but not where there is a resizing square, until the mouse pointer turns into a small four-pointed 

arrow. Click and drag on the border when your mouse pointer looks like that to move the selected 

control or controls. 

4. To move selected controls in “Layout View,” you simply place the mouse pointer directly over the center 

of a selected control until you see the four-pointed arrow appear. Then click and drag to move only the 

selected control or controls into the desired position within the form or report.

5. To move a single part of a paired control in “Design View,” click and drag one part of the control using 

the large gray or brown square that appears in the upper left corner of the control when the control is 

selected. Note that in “Layout View,” the paired control effect is nullified. You always move only the 

selected control or controls when you reposition them within the form.Sa
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ACTIONS-

Form & Report Controls
SIZING CONTROLS TO FIT:

1. To size a control to fit, simply select the control to size and then click the “To Fit” button (“Size To Fit” 

button in Access 2007).

2. In Access 2013:2010, this button is located on the “Size/Space” drop-down in the “Sizing & Ordering” 

group on the “Arrange” tab on the “Form Design Tools” contextual tab within the Ribbon.

3. In Access 2007, this button is located in the “Size” group on the “Arrange” tab of the “Form Design 

Tools” contextual tab within the Ribbon.

NUDGING SELECTED CONTROLS:

1. Select the control or controls to nudge, hold down the “Ctrl” key on your keyboard, and then press the

“Arrow keys” on your keyboard to “nudge” the controls up, down, left or right one pixel at a time.

ALIGNING, SPACING, AND SIZING SELECTED CONTROLS:

1. To align controls in “Design View,” select the controls to align and click the desired alignment to apply

from the alignment buttons available.

2. In Access 2013:2010, these buttons are located on the “Align” drop-down button in the “Sizing &

Ordering” group on the “Arrange” tab in the “Form Design Tools” contextual tab within the Ribbon.

3. In Access 2007, these buttons are located in the “Control Alignment” group on the “Arrange” tab of the

“Form Design Tools” contextual tab in the Ribbon.

4. To set the spacing between selected controls, click the desired spacing option button from the group of

options available.

5. In Access 2013:2010, these buttons are available in the “Spacing” section of the “Size/Space” drop-

down button’s menu in the “Sizing & Ordering” group on the “Arrange” tab in the “Form Design Tools”

contextual tab within the Ribbon.

6. In Access 2007, these are located in the “Position” group on the “Arrange” tab of the “Form Design

Tools” contextual tab in the Ribbon.

7. You can set the size of multiple selected controls to match the height of the tallest or shortest control or

the width of the widest or narrowest control. To do this, select the desired controls in the form or report.

8. If using Access 2013:2010, choose the desired sizing option from the choices available in the “Size”

section of the “Size/Space” drop-down button’s menu of choices in the “Sizing & Ordering” group on the

“Arrange” tab in the “Form Design Tools” contextual tab within the Ribbon.

9. If using Access 2007, you then click the desired sizing option button in the “Size” group on the “Arrange”

tab of the “Form Design Tools” contextual tab in the Ribbon.
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ACTIONS-

Form & Report Controls
FORMATTING SELECTED CONTROLS:

1. In “Design View,” you can format the appearance of selected controls in your forms and reports. In both

“Design View” and “Layout View” in Access 2013:2010, you can select controls, and then apply

formatting found in the “Font,” “Number,” “Background,” and “Control Formatting” groups on the

“Format” tab in the “Form Design Tools” contextual tab within the Ribbon. You can also select themed

formatting for your form by choosing from the buttons shown in the “Themes” group on the “Design” tab

in the “Form Design Tools” contextual tab within the Ribbon.

2. In Access 2007, you can use the formatting buttons available in the “Font” and “Controls” groups on the

“Design” tab of the “Form Design Tools” contextual tab within the Ribbon. You can also apply automatic

formatting to a form using the “AutoFormat” button in the “AutoFormat” group on the “Arrange” tab in the

“Form Design Tools” contextual tab within the Ribbon. When using the “Layout View,” you will have the

same formatting options, however, they are in slightly different locations. You can use the buttons

available in the “Font,” “Formatting,” “Controls,” and “AutoFormat” groups on the “Format” tab of the

“Form Layout Tools” contextual tab in the Ribbon.

3. To apply formatting to your form or report controls in either view, first select the desired control or

controls to format. Then click the necessary buttons in button groups listed to achieve your desired

appearance.

VIEWING CONTROL PROPERTIES:

1. To view the properties for a selected control, first select the desired control in the form or report.

2. Next, either click the “Property Sheet” button in the “Tools” group on the “Design” tab of the “Form

Design Tools” contextual tab if using “Design View,” or click the “Property Sheet” button in the “Tools”

group on the “Arrange” tab of the “Form Layout Tools” contextual tab if using “Layout View.”

3. Each time you click the button, you turn the display of the “Property Sheet” on or off. When its display is

enabled, you will see the “Property Sheet” appear in a pane at the right side of the form window. They

are separated into major property groups on each of the following tabs: “Format,” which contains

properties relating to the appearance of the control; “Data,” which contains properties relating to the

data values stored in the control (if any); “Event,” which contains properties relating to programming

events which you shall examine when using macros; “Other,” which lists any miscellaneous properties;

or “All,” which lists all of the properties available in alphabetical order.

4. Click into the property field that you want to change and set the new value for the selected control.
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EXERCISES-

Form & Report Controls
Purpose:

1. To be able to manipulate controls in a form or report

Exercises:

1. Open your Access application.

2. Open the “test” database you completed from the Exercise at the end of the previous chapter.

3. Right-click on the “frmCustomers” form in the Navigation Pane and then choose the “Design View”

command to open the selected form in “Design View.”

4. Rearrange the form fields until it resembles the following images for Access 2013:2010 or 2007.

5. Click “Save” in the Quick Access toolbar to save your design changes.

6. Close the “frmCustomers” form.

7. Close the database.

Access 2013:2010

Access 2007
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CHAPTER 12-

Using Controls

12.1- The Controls Group

12.2- Adding Label Controls

12.3- Adding Logos and Image Controls

12.4- Adding Line and Rectangle Controls

12.5- Adding Combo Box Controls

12.6- Adding List Box Controls

12.7- Setting Tab Order
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Using Controls

12.1- The Controls Group:

Access gives you a button group that you can use to easily place controls of different types into your

forms and reports quickly and easily when they are opened in “Design View.” This button group is the

“Controls” group on the “Design” tab of the “Form Design Tools” contextual tab within the Ribbon. To add

any type of control from this group, simply click the button that corresponds to the type of control you would

like to insert. Place your mouse pointer into the location in the form at which you wish to place the control

and then click and drag with the mouse pointer over the area in the form or report where you want to place

the control. When you release your mouse button, the control will be inserted into the selected location and

any additional information that you need to enter for the control will be prompted by the appropriate control’s

wizard, if available.

In this lesson, you will examine adding sophisticated controls to forms or reports in Design View. To

make this process easier, ensure that the “Use Control Wizards” button in the “Controls” group on the

“Design” tab of the “Form Design Tools” contextual tab within the Ribbon is activated. It will appear

highlighted if it is activated. Note that in Access 2013:2010, this button appears in a separate section when

you click the “More” drop-down button in the lower right corner of the control group. When this button is

enabled, it ensures that when you create a control in your form or report, the associated “wizard” will

automatically launch, assisting you in creating the selected type of control. This simplifies setting the

properties of the control that you select.

12.2- Adding Label Controls:

Label controls add text descriptions to the forms and reports that you create. A label displays the

text that you enter into it in “Design View” as a “read-only” label that appears for your users when viewing

the form in “Form View.” The user does not interact with the label control. If you need an interactive text

control, use the “Text Box” control, instead.

To create a label control in a form or report, first open the form or report in design view. Next, click

the “Label” button in the “Controls” group on the “Design” tab of the “Form Design Tools” contextual tab in

the Ribbon. Then click and drag over the area in the form or report that you want the label to cover. There is

no “wizard” associated with adding labels. So, when you release the mouse button, the label control will

insert itself into the form. At that point, simply type the text that you want the label to display. When you

have finished adding text to the label, click into the blank area in the form to set the label’s text. Note that if

you do not add text immediately after creating the label, the label will be removed from the form when you

de-select it.

After creating the label, if you wish to later edit the text within the label, click it once to select it. Then

place your mouse pointer over the actual text displayed in the selected label and click it once again to place

the insertion point into the label. Then edit the text as needed. Once again, click off of the label into the

blank area of the form to set your text changes when you are finished editing the label’s text.
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Using Controls

12.3- Adding Logos and Image Controls:

The “Logo” control and the “Image” control both insert a selected image into your form. The only

difference between the two controls is that the “Logo” is automatically resized and then placed into the

“Form Header” section within the form. When you use the “Image” control, you choose the size and

placement of the selected image within the form.

To add a logo to your form, just click the “Logo” button. In Access 2013:2010, this button is located

in the “Header/Footer” group on the “Design” tab of the “Form Design Tools” contextual tab within the

Ribbon. In Access 2007 this button is located in the “Controls” group on the “Design” tab of the “Form

Design Tools” contextual tab within the Ribbon.

After you have clicked the “Logo” button, Access will open the “Insert Picture” dialog box which you

can use to locate the image file that you want to use as the logo within the form. Select the image file and

then click the “OK” button in the “Insert Picture” dialog box to automatically insert the logo into the “Form

Header” section of your current form.

To insert an image into the form and also choose the size and placement of the image, click the

“Image” button in the “Controls” group on the “Design” tab of the “Form Design Tools” contextual tab within

the Ribbon. Next, click and drag over the area in the form or report over which you want to place the image.

When you release the mouse button, the control will insert itself into the form and also launch the “Insert

Picture” dialog box. Use the “Insert Picture” dialog box to locate the image file that you want to insert. Select

the image file and then click the “OK” button in the “Insert Picture” dialog box to insert the selected picture

into the frame that you created.

12.4- Adding Line and Rectangle Controls:

You can use the “Line” and “Rectangle” controls to add separation to the different parts of your

forms and reports. These can serve to break up the forms and reports that you create into different

“sections,” if you would like.

To add a line or a rectangle, open the form or report in design view. Then click either the “Line” or

“Rectangle” buttons in the “Controls” group on the “Design” tab of the “Form Design Tools” contextual tab in

the Ribbon. Next, click and drag from one point to another point within the form or report over which you

want to place the line or rectangle. The selected shape will appear when you release your mouse button.

There is no “wizard” associated with adding either lines or rectangles.

12.5- Adding Combo Box Controls:

Combo box controls allow you to create drop-down menus from which your users can select a

choice in order to create an entry within a field. The choices available in the combo box menu can come

from a table or query, or you can type your own list of values from which the users can select. These

controls can reduce the amount of data entry error in a field by limiting the range of data entry choices. If

you created a “lookup” field within your Access tables, you will notice that these types of fields are

automatically displayed in the forms as combo box controls when you add them from the “Field List.”

To add a combo box control to a form, open the form or report in design view. Next, click the

“Combo Box” button in the “Controls” group on the “Design” tab of the “Form Design Tools” contextual tab in

the Ribbon. Then click and drag over the area within the form where you want to place the combo box.

As long as you have the “Use Control Wizards” button selected in the “Controls” group on the

“Design” tab of the “Form Design Tools” contextual tab in the Ribbon when you create the combo box

control, a “Combo Box” wizard will appear to guide you through the rest of the process of creating theSa
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Using Controls

12.5- Adding Combo Box Controls (cont.):

combo box control. Simply answer the questions posed to you by the wizard for each screen, and click

“Next >” until you are done. Then click “Finish” to create the desired combo box control within the form.

Combo boxes are almost always exclusively used by forms and not by reports, as reports are read-only and

you often will use the combo box to update values in the underlying data source.

12.6- Adding List Box Controls:

List box controls are very much like combo box controls, as they also allow you to create a list of

choices from which your users can select to fill-in a field’s value. The difference between a combo box and

a list box is that the combo box only displays the choices when a user clicks the drop-down arrow in the

combo box. In a list box, the choices are shown constantly and whichever choice in the list is highlighted is

the value selected. As such, list boxes tend to take up a bit more space in the form than combo boxes.

To insert a list box control, open the form in design view and then click the “List Box” button in the

“Controls” group on the “Design” tab of the “Form Design Tools” contextual tab in the Ribbon. Then click

and drag over the area within the form where you want to place the list box. As long as you have the “Use

Control Wizards” button selected in the “Controls” group on the “Design” tab of the “Form Design Tools”

contextual tab in the Ribbon when you create the list box control, a “List Box” wizard will launch to assist

you in creating the list box control. Simply answer the questions posed to you by the wizard for each screen,

and click “Next >” until you are done. Then click “Finish” to create the list box control in the form.

12.7- Setting Tab Order:

When a user opens a form in Access, they can move from field to field within the form by pressing

the “Tab” key on their keyboard. The order in which the cursor will cycle through the available controls

within the form is called the “tab order.” If the tab order isn’t set properly within a form, when a user presses

the “Tab” key the focus may appear at a random control within the form. This is extremely aggravating to

the users. You can set the tab order of a form to increase the ease of data entry within the form. You can

either set the tab order automatically or manually.

To set the tab order automatically, open the form in design view and then click the “Tab Order”

button. In Access 2013:2010, this button is located in the “Tools” group on the “Design” tab in the “Form

Design Tools” contextual tab within the Ribbon. In Access 2007 this button is located in the “Control Layout”

group on the “Arrange” tab of the “Form Design Tools” contextual tab within the Ribbon. This will launch the

“Tab Order” dialog box. Here you can click the “Auto Order” button to automatically set the “Tab Order” of

the controls within the selected section of the form.

To set the tab order manually, click and drag the gray row selector buttons at the left of the names of

the controls displayed in the “Custom Order:” section into the desired tab order. When the focus of the

controls is set to the correct order, click “OK” to set your custom tab order.
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ACTIONS-

Using Controls

ADDING A LABEL CONTROL:

1. To create a label control in a form or report, first open the form or report in design view.

2. Next, click the “Label” button in the “Controls” group on the “Design” tab of the “Form Design Tools” 

contextual tab in the Ribbon.

3. Then click and drag over the area in the form or report that you want the label to cover.

4. When you release the mouse button, the label control will insert itself into the form. At that point, simply 

type the text that you want the label to display.

5. When you have finished adding text to the label, click into the blank area in the form to set the label’s 

text.

6. After creating the label, if you wish to later edit the text within the label, click it once to select it.

7. Then place your mouse pointer over the actual text displayed in the selected label and click it once 

again to place the insertion point into the label.

8. Edit the text as needed.

9. Click off of the label into the blank area of the form to set your text changes when you are finished 

editing the label’s text.

ADDING A LOGO OR IMAGE CONTROL:

1. To add a logo to your form, just click the “Logo” button. In Access 2013:2010 this button is located in the 

“Header/Footer” group on the “Design” tab of the “Form Design Tools” contextual tab within the Ribbon. 

In Access 2007 this button is located in the “Controls” group on the “Design” tab of the “Form Design 

Tools” contextual tab within the Ribbon.

2. Doing that will open the “Insert Picture” dialog box, which you can use to locate the image file that you 

want to use as the logo within the form. Select the image file and then click the “OK” button in the “Insert 

Picture” dialog box to automatically insert the logo into the “Form Header” section of your current form.

3. To insert an image into the form and also choose the size and placement of the image, click the “Image” 

button in the “Controls” group on the “Design” tab of the “Form Design Tools” contextual tab within the 

Ribbon.

4. Next, click and drag over the area in the form or report over which you want to place the image. When 

you release the mouse button, the control will insert itself into the form and also launch the “Insert 

Picture” dialog box.

5. Use the “Insert Picture” dialog box to locate the image file that you want to insert. Select the image file 

and then click the “OK” button in the “Insert Picture” dialog box to insert the selected picture into the 

frame that you created.

ADDING A LINE OR RECTANGLE CONTROL:

1. To add a line or a rectangle, open the form or report in design view.

2. Then click either the “Line” or “Rectangle” buttons in the “Controls” group on the “Design” tab of the 

“Form Design Tools” contextual tab in the Ribbon, as desired.

3. Next, click and drag from one point to another point within the form or report over which you want to 

place the line or rectangle. The selected shape will appear when you release your mouse button.
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ACTIONS-

Using Controls
ADDING A COMBO BOX CONTROL:

1. To add a combo box control to a form, open the form or report in design view.

2. Next, click the “Combo Box” button in the “Controls” group on the “Design” tab of the “Form Design 

Tools” contextual tab in the Ribbon.

3. Then click and drag over the area within the form where you want to place the combo box.

4. As long as you have the “Use Control Wizards” button selected in the “Controls” group on the “Design” 

tab of the “Form Design Tools” contextual tab in the Ribbon when you create the combo box control, a 

“Combo Box” wizard will appear to guide you through the rest of the process of creating the combo box 

control. Note that in Access 2013:2010, this button appears in a separate section when you click the 

“More” drop-down button in the lower right corner of the control group.

5. Simply answer the questions posed to you by the wizard for each screen, and click “Next >” until you are 

done.

6. Then click “Finish” to create the desired combo box control within the form.

ADDING A LIST BOX CONTROL:

1. To insert a list box control, open the form in design view and then click the “List Box” button in the 

“Controls” group on the “Design” tab of the “Form Design Tools” contextual tab in the Ribbon.

2. Then click and drag over the area within the form where you want to place the list box.

3. As long as you have the “Use Control Wizards” button selected in the “Controls” group on the “Design” 

tab of the “Form Design Tools” contextual tab in the Ribbon when you create the list box control, a “List 

Box” wizard will launch to assist you in creating the list box control. Note that in Access 2013:2010, this 

button appears in a separate section when you click the “More” drop-down button in the lower right 

corner of the control group.

4. Simply answer the questions posed to you by the wizard for each screen, and click “Next >” until you are 

done.

5. Then click “Finish” to create the list box control in the form.

SETTING TAB ORDER:

1. To set the tab order automatically, open the form in design view and then click the “Tab Order” button. In 

Access 2013:2010, this button is located in the “Tools” group on the “Design” tab in the “Form Design 

Tools” contextual tab within the Ribbon. In Access 2007 this button is located in the “Control Layout” 

group on the “Arrange” tab of the “Form Design Tools” contextual tab within the Ribbon.

2. In the “Tab Order” dialog box, click the “Auto Order” button to automatically set the “Tab Order” of the 

controls within the selected section of the form.

3. To set the tab order manually, click and drag the gray row selector buttons at the left of the names of the 

controls displayed in the “Custom Order:” section into the desired tab order.

4. When the focus of the controls is set to the correct order, click “OK” to set your custom tab order.
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EXERCISES-

Using Controls

Purpose:

1. To be able to add basic controls to a form to enhance its function and visual appeal.

Exercises:

1. Open your Access application.

2. Open the “test” database you completed from the Exercise at the end of the previous chapter.

3. Right-click on the “frmCustomers” form in the Navigation Pane and then choose the “Design View”

command to open the selected form in “Design View.”

4. Click the “Label” control in the “Controls” group on the “Design” tab of the “Form Design Tools”

contextual tab in the Ribbon.

5. Click and drag a label in the upper right corner of the “Detail” area within the form.

6. Type the following into the text label: “Please enter the customer information here. Use the

navigation buttons in the lower left corner of the screen to navigate through the record set.”

7. Click into the main body of the form to de-select the label control.

8. Click on the “CustomerID” field, and press “Delete” on your keyboard.

9. Make sure that the “Use Control Wizards” button in the “Controls” group on the “Design” tab of the

“Form Design Tools” contextual tab in the Ribbon is activated. Note that in Access 2013:2010, this

button appears in a separate section when you click the “More” drop-down button in the lower right

corner of the control group.

10. Click the “Combo Box” control button in the “Controls” group on the “Design” tab of the “Form Design

Tools” contextual tab in the Ribbon, and then click and drag over the area where the “CustomerID”

field used to be.

11. When you release the mouse button, the “Combo Box Wizard” should automatically appear.

12. Select the “Find a record on my form based on the value I selected in my combo box.”

13. Click “Next >.”

14. Click “CustomerID” and click the “>” button to move it to the “Selected Fields:” area.

15. Click “CompanyName” and click the “>” button to move it to the “Selected Fields:” area.

16. Click “Next >.”

17. Click “Next >.”

18. Type “Select a company:” as the label.

19. Click “Finish.”

20. Arrange the fields in the form as shown in the picture below.

21. Click “Save” in the Quick Access toolbar and close the form and database when you are finished.
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CHAPTER 13-

Subforms

13.1- Creating Subforms

13.2- Using the Subform/Subreport Control
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Subforms

13.1- Creating Subforms:

If you want to use a single form to display information from two or more related tables in your

database, using subforms is the way to accomplish that goal. With subforms, you can view the data from

one table (the “parent” table) and any related data from a related table (a “child” table) in an embedded

subform within the original form. This can be an excellent way to create one main form that allows the user

to edit information in multiple, related tables. In forms that use subforms, the main (outer) form displays

table data that represents the “one” side of a “1-to-many” join. The linked subform will display table data that

shows the “many” side of the relationship between the two tables.

You can display data in the subform in either “form” view, displaying one record at a time, or

“datasheet” view, which shows multiple records at a time. Using the “Datasheet” view of the subform is

common. You can add multiple subforms to a main form, and can also add subforms within other subforms.

When you create subforms, you start by creating two separate forms: one for each table. You can

then drag the icon of the subform from the Navigation Pane into the main form when it is displayed in design

view just as if it were a form control. It is often better to create the subform first, as you can then set the

display properties for it, and decide how large it will be. This way, you can leave appropriate space in the

main form for the embedded subform when you then design that.

After you have dragged the subform onto the main form in design view you will see it displayed as

an embedded subform control. You can change the properties of the subform by selecting the subform just

as if it were a control in the main form. If you double-click the selected subform, you can edit its properties in

the “Property Sheet” panel, as well. You can also simply edit either form in the form design view to make

changes to the forms there, as well.

13.2- Using the Subform/Subreport Control:

Another way to create a subform is to use the “Subform/Subreport” control that appears in the

“Controls” group on the “Design” tab of the “Form Design Tools” contextual tab within the Ribbon. To use

this tool, simply open the form into which you want to insert a subform in “Design View.” Then click the

“Subform/Subreport” button in the “Controls” group. Next, click and drag over the area in the form where

you want the subform to appear.

Assuming that the “Use Control Wizards” button in the “Controls” group of the “Design” tab in the

“Form Design Tools” contextual tab is selected, then the “SubForm Wizard” dialog box will appear. In this

dialog box, you select the form, table or query that will serve as the basis for the subform. Answer each

question posed to you in each screen and click the “Next >” button to continue through the screens in the

wizard. When you are finished, just click the “Finish” button to insert the subform into your main form.
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ACTIONS-

Subforms
INSERTING A SUBFORM INTO A MAIN FORM:

1. Create two forms: one for the table that represents the “one” side of the relationship, and one that 

represents the “many” side of the relationship.

2. Open the main form (the “one” side of the relationship) in design view. Change the size of the design 

window until you can also see the contents of the database container as well as the main form.

3. Click and drag the icon of the subform from the database container into the main form and drop it in the 

location in the main form where you’d like it to appear.

4. Set any linking options between the data in the two forms, if necessary.

INSERTING A SUBFORM CONTROL:

1. Open the form into which you want to insert a subform in “Design View.”

2. Then click the “Subform/Subreport” button in the “Controls” group.

3. Next, click and drag over the area in the form where you want the subform to appear.

4. Assuming that the “Use Control Wizards” button in the “Controls” group of the “Design” tab in the “Form 

Design Tools” contextual tab is selected, then the “SubForm Wizard” dialog box will appear.

5. In this dialog box, you select the form, table or query that will serve as the basis for the subform.

6. Answer each question posed to you in each screen and click the “Next >” button to continue through the 

screens in the wizard.

7. When you are finished, just click the “Finish” button to insert the subform into your main form.
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EXERCISES-

Subforms
Purpose:

1. To be able to add a subform to a main form.

Exercises:

1. Open your Access application.

2. Open the “test” database you completed from the Exercise at the end of the previous chapter.

3. Select the “Sales” table in the Navigation Pane.

4. Click the “More Forms” drop-down button in the “Forms” group on the “Create” tab in the Ribbon.

Select the “Datasheet” command from the button’s drop-down menu.

5. Click “Save” in the Quick Access toolbar and name the form “subfrmSales” and then click “OK.”

6. Close the “subfrmSales” subform

7. Right-click the “frmCustomers” form in the Navigation Pane, and select the “Design View” command.

8. Extend the “Detail” area within the form to accommodate the subform that you are about to insert.

You can do this by placing your mouse pointer over the bottom of the section, and then clicking and

dragging downward when the mouse pointer changes into a vertical arrow intersected by a line.

9. Click and drag the “subfrmSales” subform out of the Navigation Pane, and drop it into the “Detail”

area of the “frmCustomers” form.

10. Move and resize the “subfrmSales” subform control in the “frmCustomers” form until it resembles the

picture below. Then save and close the form and the database.
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Access Keyboard Shortcuts

Category: General Shortcuts

Command Key

Open a database Ctrl + O

Create a new database Ctrl + N

Exit Access Alt + F4

Print Ctrl + P

Open “Page Setup” from “Print Preview” S

Cancel “Print Preview” or “Layout Preview” C or Esc

Save Ctrl + S or Shift + F12

Open “Save As” dialog box F12

Open a combo box (drop-down box) Alt + Down Arrow or 

F4

Refresh a lookup field F9

Move down one line in combo or list box Down Arrow

Move down one page in combo or list box Page Down

Move up one line in combo or list box Up Arrow

Move up one page in combo or list box Page Up

Exit the combo or list box Tab

Open “Find” from Datasheet or Form View Ctrl + F

Open “Replace” from Datasheet or Form 

View

Ctrl + H

Switch between Edit Mode and Navigation 

Mode in a datasheet

F2

Exit Navigation Mode in a form or report Esc

Show/Hide Property Sheet in Design View Alt + Enter or F4

Cycle between panes in Design View F6

Open “Choose Builder” or Visual Basic 

Editor in Form and Report Design View

F7

Switch between Visual Basic Editor and 

Form or Report Design View windows

Shift + F7 or Alt + F11

Copy Ctrl + C

Cut Ctrl + X

Paste Ctrl + V

Move selected form or report 

control right

Right Arrow or Ctrl + 

Right Arrow

Move selected form or report 

control left

Left Arrow or Ctrl + Left 

Arrow

Move selected form or report 

control up

Up Arrow or Ctrl + Up 

Arrow

Move selected form or report 

control down

Down Arrow or Ctrl + 

Down Arrow

Increase height of control Shift + Down Arrow

Reduce height of control Shift + Up Arrow

Increase width of control Shift + Right Arrow

Decrease width of control Shift + Left Arrow

Show/Hide Navigation Pane F11

Cycle between open windows Ctrl + F6

Close the active window Ctrl + W

Switch focus of controls Tab

“Next” button in wizards Alt + N

“Back” button in wizards Alt + B

“Finish” button in wizards Alt + F

Display hyperlink address F2

Check Spelling F7

Open “Zoom” when performing 

data entry in small fields

Shift + F2

Switch forward to next object 

view, if available

Ctrl + , (comma)

Switch back to previous object 

view, if available

Ctrl + . (period)

Category: Using the Navigation Pane

Command Key

Rename selected Navigation 

Pane object

F2

Open (Run) selected Navigation 

Pane object

Enter

Design selected Navigation Pane 

object

Ctrl + Enter
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Access Keyboard Shortcuts

Category: Using Menus

Command Key

Show pop-up menu Shift + F10

Show access keys in Ribbon Alt or F10

Show application menu Alt + Spacebar

Close menus Alt

Category: Using Windows and Dialog Boxes

Command Key

Switch to next open application Alt + Tab

Switch to previous application Alt + Shift + Tab

Shown Windows “Start” Menu Ctrl + Esc

Close active window in database Ctrl + W

Switch to next open database window Ctrl + F6

Switch to previous open database window Ctrl + Shift + F6

Switch to next tab in dialog box Ctrl + Tab

Switch to previous tab in dialog box Ctrl + Shift + Tab

Move to next option or option group Tab

Move to previous option or option group Shift + Tab

Perform selected button action or toggle 

status of selected checkbox

Spacebar

Close dialog box Alt + F4

Show/Hide the Field List Pane Alt + F8

Send selected Navigation Pane object as 

an email message

Alt + F + E

Category: Working with Text and Data

Command Key

Extend text selection one character right Shift + Right Arrow

Extend text selection one word right Ctrl + Shift + Right 

Arrow

Extend text selection one character left Shift + Left Arrow

Extend text selection one word left Ctrl + Shift + Left 

Arrow

Undo typing Ctrl +Z or Alt + 

Backspace

Undo changes to field, then undo 

changes to record

Esc once to undo field, 

Esc twice to undo record

Insert current date Ctrl + ; (semicolon)

Insert current time Ctrl + : (colon)

Insert default field value Ctrl + Alt + Spacebar

Insert previous record’s field 

value

Ctrl + ‘ (apostrophe)

Add new record Ctrl + + (plus sign)

Delete current record Ctrl + - (minus sign)

Save changes to current record Shift + Enter

Switch between options in a 

checkbox or option box

Spacebar

Insert a new line Ctrl + Enter

Recalculate fields F9

Requery underlying data Shift + F9
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