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Welcome to Teachucomp, Inc.’s Intermediate Excel

course. This class expands the student’s knowledge of

Microsoft Excel, one of the most popular worksheet

programs available today. This class is designed to give

the student a firm working knowledge of this program

Excel is an excellent program to learn, as the skills

that you learn in Excel apply to many other programs as

well, especially Access. It is the recommended starting

point for learning database programs.

Excel is a multi-featured worksheet program in which

you can create powerful worksheets that can

manipulate numbers for you. It is a very powerful

program, and has many advanced features that can

automate and simplify your work. Whether you want it to

create charts , worksheets, or data sources, Excel can

assist you in accomplishing your tasks quickly and

easily.

This class will focus on giving the student enhanced

skills in the Excel program. You will learn how to create

and format your own charts, create 3D Formulas, use

Paste Special, and link cells for instant updating of data.

Introduction and Overview
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CHAPTER 12-

3D Formulas

12.1- Creating 3D Formulas

12.2- 3D Formula Syntax

12.3- Creating 3D Range References
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3D Formulas

12.1- Creating 3D Formulas:

It is helpful to be able to create a single formula that calculates data gathered from multiple

worksheets. These types of formulas are called 3D formulas. They calculate information from multiple

worksheets and show the result in a selected formula cell.

When you use 3D formulas, you must also expand your knowledge of formula syntax. You will be

using additional punctuation marks when you write these formulas in order to tell Excel specifically which

cells from which worksheet you will be using. The additional punctuation marks you will need to know are:

1. !- used to separate the sheet name from the cell reference.

2. $- used to denote an absolute value.

3. :- used to separate sheet names in ranged 3D formulas.

4. ,- used to separate individual sheet/cell references from each other.

12.2- 3D Formula Syntax:

The best way to learn how a 3D formula works is to look at some examples. Here are three

examples of 3D formulas. The first is a simple 3D formula, the latter two are ranged 3D formulas:

1. =Sheet1!B2+Sheet2!B2+Sheet3!B2

2. =SUM(Sheet1:Sheet3!B2)

Or

3. =SUM(Sheet1!B2,Sheet2!B2,Sheet3!B2)

All three of these formulas will display the same answer. You can use any syntax that you like. The

change in the syntax from what you previously learned is that now you are inserting the name of the

particular worksheet in the workbook, followed by an exclamation point, and then the cell reference.

12.3- Creating 3D Range References:

In example #2 above, you can see a 3D cell range reference used to create a formula. A 3D cell

range is one cell range that spans several sheets deep. In example #2, the range is cell B2, but it is cell B2

in all of the worksheets from “Sheet1” through “Sheet3.”

When referencing 3D ranges in formulas, you use the colon (:) to separate the names of the first and

last sheets in the range, followed by a single cell range reference. The cell reference given is then used as

the selected cell range through all of the worksheets listed. So in the above example, you are adding cell B2

from Sheet1, Sheet2 and Sheet3.

In 3D ranges, the given cell range cannot change from one sheet to another. Otherwise it is just

another 3D formula, and you should use one of the other two alternate syntaxes available.Sam
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ACTIONS-

3D Formulas
ADDITIONAL PUNCTUATION USED IN 3D FORMULAS:

! used to separate the sheet name from the cell references.

$ used to denote an absolute value.

: used to separate sheet names in ranged 3D formulas.

, used to separate individual sheet/cell references from each other.

CREATING A SIMPLE 3D FORMULA:

1. Select the cell into which you want to enter the 3D formula, and type an equal sign to begin. (=)

2. Type the name of the worksheet (found on the worksheet tab) of the first page from which you want to 

select a cell range, followed by an exclamation point (!).

3. Enter the cell range address from the sheet that you want to enter into the formula, followed by the 

mathematical operator you need.

4. Select the next sheet from which you want to select a cell range, followed by an exclamation point (!).

5. Enter the cell range address from this sheet that you want to enter into the formula, followed by the 

mathematical operator you need.

6. Repeat steps 5 and 6 until you have entered all of the cell ranges from all of the worksheets that you 

want to use in the 3D formula.

7. Press “Enter” on your keyboard to finish the formula.

CREATING A 3D-RANGE FORMULA:

1. Select the cell into which you want to enter the 3D formula.

2. Type an equal sign to begin the formula, followed by the function name that you want to calculate a 3D 

cell range for, and an open parenthesis [(].

3. Type in the name of the worksheet (on the worksheet tab) of the first page, a colon (:), and then the last 

work sheet name followed by an exclamation point (!).

4. Enter a cell range reference for the selected sheets into the formula.

5. Type a closed parenthesis [)].

6. Press “Enter” on your keyboard.

CREATING A RANGED 3D FORMULA:

1. Select the cell where you want to enter your ranged 3D formula. Then type an equal sign (=), followed 

by the function name that you want to use, then followed by an open parenthesis [(].

2. Type the name of the sheet (found on the worksheet tab) that contains the cell range that you want to 

include in the function, followed by an exclamation point (!).

3. Enter the cell range to select from the sheet (separated by a colon [:], if it is a cell range), and then 

followed by a comma (,) to separate this sheet/cell reference from the next sheet/cell reference.

4. Repeat steps 3 and 4 for the other sheet/cell references needed for your ranged 3D formula. Do not

enter a comma (,) after the last sheet/cell reference, but instead close the ranged 3D formula with the 

closed parenthesis [)].

5. Press “Enter” on your keyboard to finish the formula.
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EXERCISES-

3D Formulas
Purpose:

1. To be able to create 3D formulas in a worksheet.

Exercises:

1. Open your Excel application.

2. If using Excel 2007, click the Microsoft Office button and then click the “New” command. If using

Excel 2010, click the “File” tab in the Ribbon, and then click the “New” command.

3. Double-click the “Blank Workbook” icon to create a new workbook.

4. On “Sheet1,” enter the following data into the location shown:

5. Copy the range of A2:B6, and paste it to the same range of cells in “Sheet2.”

6. On “Sheet2,” edit cell B2 to read “Q2 Sales:.”

7. Select cell B2, and type “Q2 Sales.”

8. Click on the “Sheet3” tab.

9. Click into cell A1, and type “Total Sales:.”

10. In cell A2, type “=SUM(Sheet1:Sheet2!B3:B6).” Exit the cell to finish the formula.

11. Click the “Save” button within the Quick Access toolbar to open the “Save As” dialog box.

12. Use the “Save As” dialog box to save the file to the “Documents” folder on your computer, and name 

the file “Inter- Sample.”

13. Click the “x” in the upper right corner of the application window to exit the program

Sam
ple

- fo
r e

va
lua

tio
n p

urp
os

es
 on

ly.



9Intermediate Excel©TeachUcomp, Inc.

CHAPTER 13-

Named Ranges

13.1- Naming Ranges

13.2- Creating Names from Headings

13.3- Moving to a Named Range

13.4- Using Named Ranges in Formulas

13.5- Naming 3D Ranges

13.6- Managing Named Ranges
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Named Ranges

13.1- Naming Ranges:

Instead of always having to type a cell range into formulas you can use range names, but only if you

first name a particular range of cells. This can be helpful if you have a worksheet that contains data of the

same type in the same place. For instance, if the cell range F2:F10 always contained totals of the regional

sales for your company, you could select that range and name it “regional_sales”. Then you can move

quickly to that named range, or use it as a substitute for cell range references in ranged formulas.

To name a range, first select the cell range that you want to name. Then click into the “Name Box” in

the formula bar. Type the name for the range, and then press the “Enter” key on your keyboard to set the

range name. Remember that there are no spaces allowed in range names, so use the underscore character

instead (_), if needed. Also, range names must be unique within their defined scope- which is typically the

whole workbook, by default. Once you have created the named range, then any time in the future when you

select that specific cell range, the range name will appear in the name box within the formula bar.

Alternately, you can create a named range by first selecting the cell range that you want to name,

and then clicking the “Define Name” button in the “Defined Names” group on the “Formulas” tab in the

Ribbon. Doing this will open the “New Name” dialog box, where you can define the named range that you

selected. You enter the range name into the “Name:” text box. A neat feature of this method is that you can

then use the “Scope:” drop-down to select where you want the definition of the named range to function.

When you use the name box to create a named range, it defines it with a default “workbook” scope. You

can limit this scope by selecting a single worksheet from this drop-down, if desired. You can then enter a

comment, if desired, into the “Comment:” text box. Next, assuming that you selected your cell range first,

you should see the cell reference shown in the “Refers to:” text box. You can, however, change this

reference if necessary. Once you have the correct information entered, click the “OK” button to create the

named range.

It is also extremely important to note that when you create named ranges, you are making a specific

reference to particular cells on a particular sheet. The reference that is created when you make a named

range is an absolute reference, meaning that you cannot copy and paste a formula that contains a range

name and expect it to adjust to its new location. Instead, the formula will always refer back to its original

cells (the ones defined by the range name) no matter where you copy or paste the formula in the workbook.

13.2- Creating Names from Headings:

You can use the column and row headings in a table or list within a worksheet to name a range of

cells. If you use this method of creating named ranges, then start by selecting the cell range- including any

titles that you want to use as the names for the ranges that will be created. Next, click the “Create from

Selection” button in the “Defined Names” group on the “Formulas” tab in the Ribbon. In the “Create Names

from Selection” dialog box that appears, check the checkboxes that indicate where in your selection the

range names are located. Usually, this dialog box will not need to be changed, as it looks for text values at

the perimeter of your selection from which it can create range names. When the correct location of the cells

that you want to use for the named ranges is checked in the “Create Names from Selection” dialog box,

finish the process by clicking the “OK” button to create them.Sam
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Named Ranges

13.3- Moving to a Named Range:

A quick way to select the cells in any named ranges that you have on your worksheet is to move to

the named range. Once you have named the ranges on your worksheet, they are contained in the drop-

down list that appears when you click the “Name Box” drop-down within the Formula Bar.

Click the drop-down arrow next to the “Name Box” to view the available ranges and select the name

of the range that you want to select from the list. The range will appear selected in the worksheet and the

name will appear in the “Name Box” in the formula bar.

13.4- Using Named Ranges in Formulas:

You can use named ranges instead of cell range addresses in formulas. One way to do this is to

simply type the named range instead of the specific cell range when creating the formulas by hand. Another

way to use named ranges in formulas is to begin creating the formula using whichever method that you

prefer. When you need to insert the reference to the named range, just click the “Use in Formula” drop-

down button in the “Defined Names” group on the “Formulas” tab in the Ribbon. Just select the name of the

range that you want to use in the formula to insert it. Then finish your formula as you normally would.

You can also change your existing formulas, inserting the named ranges into the formulas that

already exist in your worksheet. To do this, first create the named range that is an exact substitute for a pre-

existing cell range reference in one of your formulas. Then, select the formula cell that contains the cell

range reference that you want to replace with a named range. Next, click the “Define Name” drop-down

button in the “Defined Names” group on the “Formulas” tab in the Ribbon. Select the “Apply Names…”

command from that button’s drop-down menu of choices to open the “Apply Names” dialog box. In this

dialog box, click on the name or names of the named ranges shown in order to substitute the named

ranges. Often, this is already done when you open the “Apply Names” dialog box. Once you have selected

the correct named range to use for the substitution, click the “OK” button to apply them.

13.5- Naming 3D Ranges:

You can also give names to 3D ranges. As we learned in the previous chapter, a 3D range is one

cell range that spans through multiple worksheets. As long as the cell range reference is the same for all of

the different worksheets in the group that you select, you can give it a name. Then it, too, can be used in

your formulas in place of the typical 3D cell range references.

To do this, click the “Define Name” button in the “Defined Names” group on the “Formulas” tab in the

Ribbon. That will open the “New Name” dialog box. In the “Name:” text box, enter the name that you want to

give to your 3D range. Remember that there are no spaces allowed in range names. Ensure that the

“Scope:” drop-down is set to “workbook.”

Next, in the “Refers to:” text box, click the “Collapse Dialog” button at the right end of the text box.

Click the sheet name tab of the first sheet in the 3D cell range. Hold down the “Shift” key on your keyboard,

and then click the sheet name tab of the last worksheet that you want to include in the 3D range.

Once the worksheet group has been selected, you next click and drag over the cells in the

worksheet that you want to use as the cell reference for the 3D range. Next, click the “Expand Dialog”

button at the right end of the “Refers To:” text box again to expand the dialog box. In the “New Name” dialog

box, click the “OK” button when you are finished to create the 3D named range.

Note that you will not be able to select this range name from the “Name Box.” Remember that when

you select a range name from the “Name Box,” it highlights the cells in the selected range. It would be
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Named Ranges

13.5- Naming 3D Ranges (cont.):

impossible to show all of the cells from the multiple sheets in a single window so you cannot access it

through the “Name Box.” You may, however, use it as a substitute for 3D range references in your 3D

formulas.

13.6- Deleting Named Ranges:

If you no longer require a named range that you have created, you can delete it from the list of

named ranges in the workbook. To see the list of named ranges that are available, click the “Name

Manager” button in the “Defined Names” group on the “Formulas” tab in the Ribbon. Select the named

range that you want to delete from the list of named ranges shown in the dialog box. Next, click the “Delete”

button to delete the named range. Click “OK” in the confirmation message box that appears to finish

deleting the selected range name. You can then click the “Close” button in the “Name Manager” dialog box.
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ACTIONS-

Named Ranges
NAMING RANGES:

1. Select the cell range that you want to name.

2. Click into the “Name Box” in the formula bar and type the name for the range

3. Press the “Enter” key on your keyboard to set the range name.

OR

1. Select the cell range that you want to name, and then click the “Define Name” button in the “Defined 

Names” group on the “Formulas” tab in the Ribbon.

2. In the “New Name” dialog box, enter a range name into the “Name:” text box.

3. Then use the “Scope:” drop-down to select where you want the definition of the named range to 

function. When you use the name box to create a named range, it defines it with a default “workbook” 

scope. You can limit this scope by selecting a single worksheet from this drop-down, if desired.

4. You can then enter a comment, if desired, into the “Comment:” text box.

5. Next, assuming that you selected you cell range first, you should see the cell reference shown in the 

“Refers to:” text box. You can, however, change this reference if necessary.

6. Once you have the correct information entered, click the “OK” button to create the named range.

CREATING RANGE NAMES FROM HEADINGS:

1. Select the cell range- including any titles that you want to use as the names for the ranges that will be 

created.

2. Next, click the “Create from Selection” button in the “Defined Names” group on the “Formulas” tab in the 

Ribbon.

3. In the “Create Names from Selection” dialog box that appears, check the checkboxes that indicate 

where in your selection the range names are located. Usually, this dialog box will not need to be 

changed, as it looks for text values at the perimeter of your selection from which it can create range 

names.

4. When the correct location of the cells that you want to use for the named ranges is checked in the 

“Create Names from Selection” dialog box, finish the process by clicking the “OK” button to create the 

named range.

MOVING TO A NAMED RANGE:

1. Click the drop-down arrow next to the “Name Box” in the Formula Bar in order to view the available 

ranges.

2. Select the name of the range to which you want to move from the list shown.

3. The range will appear selected in the worksheet, and the name will appear in the “Name Box” in the 

formula bar.Sam
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ACTIONS-

Named Ranges
USING NAMED RANGES IN FORMULAS:

1. Type the named range, instead of the specific cell range, when creating the formulas by hand.

OR

1. Start by creating the formula using whichever method that you prefer.

2. When you need to insert the reference to the named range into your formula, just click the “Use in 

Formula” drop-down button in the “Defined Names” group on the “Formulas” tab in the Ribbon.

3. Select the name of the range that you want to use in the formula to insert it.

4. Then finish your formula as you normally would.

OR

1. You can also change your existing formulas, inserting the named ranges into the formulas that already 

exist in your worksheet. To do this, first create the named range that is an exact substitute for a pre-

existing cell range reference in one of your formulas. 

2. Select the formula cell that contains the cell range reference that you want to replace with a named 

range.

3. Click the “Define Name” drop-down button in the “Defined Names” group on the “Formulas” tab in the 

Ribbon. Select the “Apply Names…” command from that button’s drop-down menu of choices to open 

the “Apply Names” dialog box.

4. In this dialog box, click on the name or names of the named ranges shown in order to substitute the 

named ranges. Often, this is already done when you open the “Apply Names” dialog box.

5. Once you have selected the correct named range to use for the substitution, click the “OK” button to 

apply them.

NAMING 3D RANGES:

1. Click the “Define Name” button in the “Defined Names” group on the “Formulas” tab in the Ribbon.

2. In the “New Name” dialog box, click into the “Name:” text box and enter the name that you want to give

to your 3D range.

3. Ensure that the “Scope:” drop-down is set to “workbook.”

4. Next, in the “Refers to:” text box, click the “Collapse Dialog” button at the right end of the text box.

5. Click the sheet name tab of the first sheet in the 3D cell range. Hold down the “Shift” key on your

keyboard, and then click the sheet name tab of the last worksheet that you want to include in the 3D

range. Once the worksheet group has been selected, you next click and drag over the cells in the

worksheet that you want to use as the cell reference for the 3D range.

6. Next, click the “Expand Dialog” button at the right end of the “Refers To:” text box again to expand the

dialog box. In the “New Name” dialog box, click the “OK” button when you are finished to create the 3D

named range.Sam
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ACTIONS-

Named Ranges
DELETING NAMED RANGES:

1. If you no longer require a named range that you have created, you can delete it from the list of named 

ranges in the workbook.

2. To see the list of named ranges that are available, click the “Name Manager” button in the “Defined 

Names” group on the “Formulas” tab in the Ribbon.

3. Select the named range that you want to delete from the list of named ranges shown in the dialog box.

4. Next, click the “Delete” button to delete the named range.

5. Click “OK” in the confirmation message box that appears to finish deleting the selected range name.

6. You can then click the “Close” button in the “Name Manager” dialog box.
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EXERCISES-

Named Ranges
Purpose:

1. To be able to create named ranges and use them in formulas.

Exercises:

1. Open up the “Inter- Sample” file in your “Documents” folder.

2. Select “Sheet1.”

3. Click the “Define Name” button in the “Defined Names” group on the “Formulas” tab in the Ribbon. 

This will open the “New Name” dialog box.

4. Enter “SalesRange” into the “Name:” text box.

5. Select “workbook” from the “Scope:” drop-down.

6. Click the “Expand/Collapse Dialog Box” button at the right end of the “Refers to:” box to collapse the 

dialog box.

7. Hold down the “Shift” key on your keyboard, and then click the worksheet tab for “Sheet2.”

8. Select the range of cells from B3:B6.

9. Click the “Expand/Collapse Dialog Box” button at the right end of the “Refers to:” box to expand the 

dialog box. The range reference shown in the “Refers to:” text box should read: 

“='Sheet1:Sheet2'!$B$3:$B$6.”

10. Click the “OK” button in the “New Name” dialog box.

11. Select “Sheet3.”

12. Select cell A2 in “Sheet3.”

13. Click and drag over the cell range reference of “Sheet1:Sheet2!B3:B6” shown in the Formula Bar.

14. Click the “Use in Formula” button in the “Defined Name” group on the “Formulas” tab in the Ribbon. 

Select “SalesRange” from the drop-down menu. That should paste the name into the formula shown 

in the Formula Bar.

15. Press the “Enter” key on your keyboard to set the formula.

16. Click the “Save” button in the Quick Access Toolbar to save your changes.

17. Click the “X” button in the upper right corner of the application window to exit.
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CHAPTER 14-

Conditional Formatting and Cell Styles

14.1- Conditional Formatting

14.2- Finding Cells with Conditional Formatting

14.3- Clearing Conditional Formatting

14.4- Using Table and Cell Styles
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Conditional Formatting and Cell Styles

14.1- Conditional Formatting:

With conditional formatting, you set criteria for cells that change the appearance of the cell

depending on whether or not the cell’s value meets the criteria specified. For example, if you wanted to

have a worksheet cell appear with a red fill color only if it contained a negative number, you could do that

with conditional formatting. Conditional formatting can be applied to all cells, but can be especially helpful in

formula cells as a way to visually indicate the cell’s value- which may change when data entry occurs.

You can make use of several of the preset conditional formats that are provided in Excel, or you can

create your own rules and formatting to apply. To apply conditional formatting, first select the cells in the

worksheet to which you wish to apply conditional formatting. Then click the “Conditional Formatting” button

in the “Styles” group on the “Home” tab in the Ribbon.

If you want to apply one of the default formats using the values from your cell selections as the

upper and lower bounds, then simply roll down to the conditional formatting style that you wish to use in the

second section of the drop-down menu that appears. From the side menu that appears, you can then

choose which of the specific variations of the style you wish to apply. Just click the style that you want in

order to apply it to the selection.

You can also create your own custom rules, and then decide what type of formatting to apply when a

selected cell meets the criteria that you have specified. To do this, you can select one of the rule choices

shown in the first section of the drop-down menu: “Highlight Cell Rules” or “Top/Bottom Rules.” From the

side menu, you then select the type of values that you want to highlight. This will open a dialog box where

you enter the criteria, which when met, will apply the formatting that you then choose.

Note that you can create multiple rules for selected cells. However, if you wish to do this, then you

may want to begin by selecting the cells to which you want to apply multiple rules, first. Then you can click

the “Conditional Formatting” button in the “Styles” group on the “Home” tab in the Ribbon. From the drop-

down menu that appears, you can then choose the “Manage Rules…” command in order to open the

“Conditional Formatting Rules Manager” dialog box. Assuming that you want to only view rules for the

selected cells, then choose the “Current Selection” choice from the “Show formatting rules for:” drop-down

at the top of this dialog box. Otherwise, you can choose a whole worksheet, or even the entire workbook,

from this drop-down. Any rules for the selection made from this drop-down are then listed in the rules area

below that. If there are no rules created yet, then this area will not show anything.

To create a new rule for the selected area, click the “New Rule…” button at the top of the

“Conditional Formatting Rules Manager” dialog box. In the “New Formatting Rule” dialog box, select what

type of rule to create by choosing a rule type from the types shown in the “Select a Rule Type:” list. Then

enter the evaluation criteria into the area at the bottom of this window. Once you have finished setting the

formatting that you want to use, click the “OK” button to return to the “Conditional Formatting Rules

Manager” dialog box.

If you want to add other rules to the selection, just repeat the process. New rules will be added to the

list shown, under the previous rule. Note that if you have multiple rules applied, they will be enforced in the

order shown, from top to bottom, within this dialog box. Note that for any rule, you can check the “Stop If

True” checkbox at the right end of the rule to end the sequence of rule processing if the cell value meets the

criteria specified by the selected rule.

You can edit a rule that has been applied by selecting the rule to modify from the list, and then

clicking the “Edit Rule…” button at the top of the “Conditional Formatting Rules Manager” dialog box. This

will re-open the rule in the “Edit Formatting Rule” window, where you can change the criteria or formatting.

If you want to delete a rule from the list shown in the “Conditional Formatting Rules Manager” dialog

box, start by clicking on the rule that you wish to remove. Then click the “Delete Rule” button at the top of

the “Conditional Formatting Rules Manager” dialog box.
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Conditional Formatting and Cell Styles

14.1- Conditional Formatting (cont.):

Note that you can also alter the order in which the rules are enforced in this dialog box. To change

the order of the rules, click on the rule whose order you wish to change, and then click either the “Move Up”

or “Move Down” buttons to change the order in which the rule will be enforced. Remember that the rules are

enforced from top to bottom in this list.

Once you have finished creating your rules, you can click the “OK” button to apply the conditional

formatting rules to your selection and close the “Conditional Formatting Rules Manager” dialog box.

14.2- Finding Cells with Conditional Formatting:

Often, if a cell that has a conditional formatting rule applied doesn’t meet the criteria specified, the

cell will not appear to be any different from any other cell. This can be a problem when trying to edit or

modify conditional formatting for selected cells. If you want to find the cells that contain conditional

formatting within your worksheet or workbook, Excel makes it easy to do so. First, click into a cell that

doesn’t contain conditional formatting within your worksheet. Then click the “Find & Select” button in the

“Editing” group on the “Home” tab in the Ribbon. From the drop-down that appears, select “Conditional

Formatting” to move the active cell to the first cell that it encounters that contains conditional formatting.

14.3- Clearing Conditional Formatting:

You can easily clear all conditional formatting from selected cells, or from the entire worksheet. If

you want to only remove conditional formatting from selected cells, then you will first need to select those

cells in your worksheet. Then click the “Conditional Formatting” button in the “Styles” group on the “Home”

tab in the Ribbon. Roll your mouse pointer down to the “Clear Rules” command in the drop-down menu that

appears. From the side menu that appears, you can select from which object you wish to remove the

conditional formatting. If you want to remove the conditional formatting from only the selected cells, then

choose the “Clear Rule from Selected Cells” command. To clear all conditional formatting from the entire

sheet, select the “Clear Rule from Entire Sheet” command.

14.4- Using Table and Cell Styles:

You can apply predefined formatting to tables, or selected cells, within your worksheets. This can

quickly and easily improve the appearance and functionality of your worksheet data. You can use the

“Format as Table” function to quickly format selected cells and also convert them into a table. You can also

apply this to any existing tables that you have created in your worksheet. If you simply want to apply

formatting without converting the selected cells into a table, then use the “Cell styles” command, instead.

To do either task, first select the cells to which you want to apply a predesigned format. Then click

either the “Format as Table” or “Cell styles” drop-down buttons in the “Styles” group on the “Home” tab in

the Ribbon, depending upon which type of formatting you want to apply. From the drop-down menus that

appear, select the appearance to apply to the selected cells or cell in your worksheet.

If you select the “Format as Table” button, then after you have selected your desired style, you will

see the “Format As Table” dialog box appear. This will convert the selected cells into a table, or “list,” as

they were previously called in Excel 2003. If your selected table has headers (meaning selected cells that

contains labels at the top of columns) then check the “My table has headers” checkbox. Then just click the

“OK” button to apply the selected formatting to the cells and simultaneously convert them into a table.
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ACTIONS-

Conditional Formatting and Cell Styles

APPLYING CONDITIONAL FORMATTING:

1. To apply one of the default formats using the values from your cell selections as the upper and lower

bounds, then simply roll down to the conditional formatting style that you wish to use in the second

section of the drop-down menu that appears. From the side menu that appears, choose which of the

specific variations of the style you wish to apply. Click the style that you want in order to apply it.

2. You can also create your own custom rules, and then decide what type of formatting to apply when a

selected cell meets the criteria that you have specified. To do this, you can select one of the rule

choices shown in the first section of the drop-down menu: “Highlight Cell Rules” or “Top/Bottom Rules.”

From the side menu, you then select the type of values that you want to highlight. This will open a dialog

box where you enter the criteria, which when met, will apply the formatting that you then choose.

3. If you want to create multiple rules for selected cells, begin by selecting the cells to which you want to

apply multiple rules, first. Then you can click the “Conditional Formatting” button in the “Styles” group on

the “Home” tab in the Ribbon. From the drop-down menu that appears, you can then choose the

“Manage Rules…” command in order to open the “Conditional Formatting Rules Manager” dialog box.

4. If you want to only view rules for the selected cells, then choose the “Current Selection” choice from the

“Show formatting rules for:” drop-down at the top of this dialog box. Otherwise, you can choose a whole

worksheet, or even the entire workbook, from this drop-down. Any rules for the selection made from this

drop-down are then listed in the rules area below that. If there are no rules created yet, then this area

will not show anything.

5. To create a new rule for the selected area, click the “New Rule…” button at the top of the “Conditional

Formatting Rules Manager” dialog box. In the “New Formatting Rule” dialog box, select what type of rule

to create by choosing a rule type from the types shown in the “Select a Rule Type:” list. Then enter the

evaluation criteria into the area at the bottom of this window. Once you have finished setting the

formatting that you want to use, click the “OK” button to return to “Conditional Formatting Rules

Manager” dialog box.

6. If you want to add other rules to the selection, just repeat step 5 above. New rules will be added to the

list shown, under the previous rule. Note that if you have multiple rules applied, they will be enforced in

the order shown, from top to bottom, within this dialog box. Note that for any rule, you can check the

“Stop If True” checkbox at the right end of the rule to end the sequence of rule processing if the cell

value meets the criteria specified by the selected rule.

7. You can edit a rule that has been applied by selecting the rule to modify from the list, and then clicking

the “Edit Rule…” button at the top of the “Conditional Formatting Rules Manager” dialog box. This will

re-open the rule in the “Edit Formatting Rule” window, where you can change the criteria or formatting.

8. If you want to delete a rule from the list shown in the “Conditional Formatting Rules Manager” dialog

box, start by clicking on the rule that you wish to remove. Then click the “Delete Rule” button at the top

of the “Conditional Formatting Rules Manager” dialog box.

9. Note that you can also alter the order in which the rules are enforced in this dialog box. To change the

order of the rules, click on the rule whose order you wish to change, and then click either the “Move Up”

or “Move Down” buttons to change the order in which the rule will be enforced. Remember that the rules

are enforced from top to bottom in this list.

10. Once you have finished creating your rules, you can click the “OK” button to apply the conditional

formatting rules to your selection and close the “Conditional Formatting Rules Manager” dialog box.
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ACTIONS-

Conditional Formatting and Cell Styles

FINDING CONDITIONAL FORMATTING:

1. First, click into a cell that doesn’t contain conditional formatting within your worksheet.

2. Then click the “Find & Select” button in the “Editing” group on the “Home” tab in the Ribbon.

3. From the drop-down that appears, select “Conditional Formatting” to move the active cell to the first cell

that it encounters that contains conditional formatting.

CLEARING CONDITIONAL FORMATTING:

1. You can easily clear all conditional formatting from selected cells, or from the entire worksheet. If you

want to only remove conditional formatting from selected cells, then you will first need to select those

cells in your worksheet.

2. Click the “Conditional Formatting” button in the “Styles” group on the “Home” tab in the Ribbon. Roll

your mouse pointer down to the “Clear Rules” command in the drop-down menu that appears. From the

side menu that appears, you can select from which object you wish to remove the conditional formatting.

3. If you want to remove the conditional formatting from only the selected cells, then choose the “Clear

Rule from Selected Cells” command.

4. To clear all conditional formatting from the entire sheet, select the “Clear Rule from Entire Sheet”

command.

AUTOMATICALLY FORMATING A TABLE OR SELECTED CELLS:

1. First select the cells to which you want to apply a predesigned format. Then click either the “Format as

Table” or “Cell styles” drop-down buttons in the “Styles” group on the “home” tab in the Ribbon,

depending upon which type of formatting you want to apply. From the drop-down menus that appear,

select the appearance to apply to the selected cells or cell in your worksheet.

2. If you select the “Format as Table” button, then after you have selected your desired style, you will see

the “Format As Table” dialog box appear. If your selected table has headers then check the “My table

has headers” checkbox. Then just click the “OK” button to apply the selected formatting to the cells and

convert them into a table.
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EXERCISES-

Conditional Formatting and Cell Styles

Purpose:

1. To be able to apply conditional formatting.

Exercises:

1. Open your Excel application.

2. Open up the “Inter- Sample” file in your “Documents” folder.

3. Select “Sheet1.”

4. Select the cell range of B3:B6.

5. Click the “Conditional Formatting” button in the “Styles” group on the “Home” tab in the Ribbon.

6. Roll your mouse pointer down to the “Color Scales” command.

7. Choose the “Green-Yellow-Red Color Scale” choice from the side menu to shade the results by the

default upper and lower values.

8. If necessary, select cell range B3:B6 again.

9. Click the “Conditional Formatting” button in the “Styles” group on the “Home” tab in the Ribbon.

10. Roll your mouse pointer down to the “Clear Rules” command.

11. Choose the “Clear Rules from Selected Cells” choice from the side menu to remove the conditional

formatting from the selected cells.

12. Click the “Save” button in the Quick Access Toolbar to save your changes.

13. Click the “X” button in the upper right corner of the application window to exit.
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15.1- Using Paste Special

15.2- Pasting Linked Formulas

CHAPTER 15-

Paste Special
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15.1- Using Paste Special:

Paste Special is a tool that Excel provides to you that allows you to cut or copy information, and then

paste only certain elements of the original selection to a new location. For example, you could copy a cell

and then select to paste its value, or format only. You can also copy and paste values from cells and

perform mathematical operations as you paste the values to new cell locations: adding, subtracting, or

multiplying them with the value(s) that already existed in the destination cell(s).

By default in Excel, information is exclusive to individual worksheets. This means that if you copy

data from one worksheet and paste it to another worksheet, any changes that you make to the original data

will not be automatically reflected in the worksheet to which you had pasted a copy of the data. Paste

Special fixes this by allowing you to paste a link between the two cells so that when the original data is

changed in the original worksheet, the new value will be passed to the linked cell in the second worksheet

the next time it is opened. Using this feature also allows you to paste linked data cells between two

completely separate workbooks.

To use the Paste Special function, you begin by copying a cell as usual. Then select the destination

cell. Now, however, instead of directly clicking the “Paste” button, you will click the “Paste” button’s drop-

down menu. At the top of the drop-down menu that appears, you can see different options that you have for

selecting what elements of the copied element you want to paste to the new location. You could also just

click the “Paste Special…” command at the bottom of the drop-down menu to launch the “Paste Special”

dialog box.

In the “Paste Special” dialog box you select the option button that represents what aspect of the

copied element you wish to paste in the “Paste” section at the top of this dialog box. Note that if you select

the “Values” option, you can then also choose a mathematical operation from the “Operation” section to

perform between the value that you are pasting, and the value that currently exists in the cell to which you

are pasting. Once you have made your selections, click the “OK” button to paste your special content.

Paste Special

When you invoke the “Paste Special” dialog

box, you have several options as to what elements

of the copied cells you wish to paste. Let’s take a

moment to examine what options are available

when using the “Paste Special” dialog box.

In the “Paste” section at the top of the dialog

box you can select “All” to paste everything that you

copied. This is the same thing as simply choosing

“Paste” from the “Paste” button’s drop-down menu.

You can select “Formulas” to paste the formula only.

This is also the default behavior of a formula when

you normally copy and paste, so it is also rare to

choose this option. Selecting “Values” copies the

current values displayed in the cell or cells that you

copied. This is useful for copying and pasting the

displayed values from formula cells. Also, you

sometimes want to paste the value of one cell that

you have copied onto the value displayed in another

cell, performing a selected mathematical operation between the two values. If you select the “Values” option

and select a destination cell into which to paste the copied value that has a pre-existing value in it, you can

then select a mathematical operation to perform with the two values in the “Operation” section. You can

choose “None” to overwrite the destination cell’s value with the copied value. You can also select “Add,”
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15.1- Using Paste Special (cont.):

“Subtract,” “Multiply,” or “Divide” to perform those calculations on the two values, as well.

Back in the “Paste” section at the top, you can also select to paste the “Formats” of the copied cells.

This pastes only the formatting of the copied cells and will perform the same function that the “Format

Painter” button performs. You can select “Comments” to copy cell comments from one cell to a new cell.

You can select “Validation” to copy the cell validation rules from one cell to another cell.

You can select “All using Source theme” to paste all of the cell contents in the document theme

formatting that is applied to the copied cells. If you select “All except borders,” you will paste all of the

copied cell contents and formatting, except for the borders. If you select “Column widths,” you will paste the

copied cell’s column width onto the selected cell’s column. You can also select “Formulas and number

formats” to paste only the cell formulas and the number formatting. You can also select “Values and number

formats” to paste only the cell values and the number formatting to the destination cells. Starting in Excel

2010, you can select “All merging conditional formats” to copy conditional formatting and merge it with

existing conditional formatting in the destination cell or cells.

You can check the “Skip Blanks” checkbox to not replace cell data in the destination cells where

there were blank values in the copied cells. Checking the “Transpose” checkbox will switch the data in the

columns to data that will now display across the rows, and vice versa. Once again, after selecting your

options, you would click “OK” to paste the copied data elements.

Paste Special

15.2- Pasting Linked Formulas:

You can select to paste a link between two cells so that when the value in the copied cell is

changed, the value displayed in the linked cell reflects the change. This is very handy when using the result

of a formula as the basis for other formulas in linked workbooks or worksheets. For example, if you had a

worksheet that totaled sales per month on one worksheet, and another worksheet in the same workbook

that totaled the monthly sales per quarter, you could copy and link the totals from the first worksheet into the

second worksheet. That way, any changes made to the data in the first worksheet would be automatically

reflected in the second sheet!

To copy a link between cells, first copy the cell that you want to link into another worksheet or

workbook, and then select the destination cell to link. Then click the “Paste” button’s drop-down menu in the

“Clipboard” group on the “Home” tab of the Ribbon to display the drop-down menu of choices. Select the

“Paste Link” command to paste the link back to the original cell that you copied. If you are using the “Paste

Special” dialog box, you can also click the “Paste Link” button that appears in the lower left corner of the

dialog box to paste a link to the original cell that you copied. If you examine the contents of the linked cell,

you will see that it is actually a formula. The formula simply states that the cell’s value is to be equal to the

value displayed in the cell address shown. The cell address is the address of the cell that was copied.

If you use this feature to paste links between data in separate workbooks you should exercise care

not to rename or move those workbooks. Doing so will break any links in the formula references created by

the “Paste Link” button, forcing you to delete the links and recreate them again or edit the formula

references within each linked cell. As long as you do not move or rename the workbooks, you should be

able to change the value in the cell which you copied in one workbook and save your changes. Then the

next time that you open the workbook that contains the linked cells, you will see a small dialog box appear

telling you that the workbook contains links to data in other workbooks which has changed. It then asks if

you want to update the values in the linked cells to reflect the changes. Click the “Update” button to update

the data in the linked worksheet, and be sure to save the changes made in this workbook as well.
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ACTIONS-

Paste Special
USING PASTE SPECIAL:

1. Begin by copying a cell, as usual.

2. Select the destination cell to which you want to paste the copied content.

3. Click the “Paste” button’s drop-down menu in the “Clipboard” group on the “Home” tab in the Ribbon. At 

the top of the drop-down menu that appears, you can see options that you have for selecting what 

elements of the copied element you want to paste. You could also just click the “Paste Special…” 

command at the bottom of the drop-down menu to open the “Paste Special” dialog box.

4. In the “Paste Special” dialog box you select the option button that represents what aspect of the copied 

element you wish to paste in the “Paste” section at the top of this dialog box. Note that if you select the 

“Values” option, you can then also choose a mathematical operation from the “Operation” section to 

perform between the value that you are pasting, and the value that currently exists in the cell to which 

you are pasting.

5. Once you have made your selections, click the “OK” button to paste your special content.

PASTING LINKED CELL DATA:

1. Begin by copying a cell, as usual.

2. Select the destination cell to which you want to link the copied content.

3. Click the “Paste” button’s drop-down menu in the “Clipboard” group on the “Home” tab in the Ribbon.

4. Select the “Paste Link” command to paste the link back to the original cell that you copied. If you are 

using the “Paste Special” dialog box, you can also click the “Paste Link” button that appears in the lower 

left corner of the dialog box to paste a link to the original cell that you copied.
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EXERCISES-

Paste Special
Purpose:

1. To be able to use features of the paste special function.

Exercises:

1. Open the “Inter- Sample” file in your “Documents” folder.

2. Select the “Sheet1” worksheet.

3. Select the cells from A2:B6.

4. Click the “Copy” button in the “Clipboard” group on the “Home” tab in the Ribbon.

5. Select the “Sheet3” worksheet.

6. Select cell A4.

7. Click the “Paste” button in the “Clipboard” group on the “Home” tab in the Ribbon.

8. Expand the width of column B on “Sheet3.” Then edit the contents of cell B4 to read: “Q1-Q2 

Sales:.”

9. Select the “Sheet2” worksheet.

10. Select the cells from B3:B6.

11. Click the “Copy” button in the “Clipboard” group on the “Home” tab in the Ribbon.

12. Select the “Sheet3” worksheet.

13. Select cell B5.

14. Click the drop-down button below the “Paste” button in the “Clipboard” group on the “Home” tab in 

the Ribbon. Select the “Paste Special…” command from the button’s drop-down menu.

15. In the “Paste Special” dialog box, select the “Values” option in the “Paste” section at the top of the 

dialog box. Then select the “Add” option button in the “Operation” section at the bottom of the dialog 

box.

16. Click the “OK” button when you are finished.

17. Click the “Save” button in the Quick Access Toolbar to save your changes.

18. Click the “X” button in the upper right corner of the application window to exit.
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16.1- Sharing Workbooks

16.2- Highlighting Changes

16.3- Reviewing Changes

16.4- Using Comments

16.5- Compare and Merge Workbooks

CHAPTER 16-

Sharing Workbooks
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Sharing Workbooks

16.1- Sharing Workbooks:

You can share a workbook to allow multiple users on a network to access the workbook and make

changes simultaneously. All you need to do is create the workbook, set it to be a shared workbook, and

then place it on a shared network folder that the editing users can access. There are, however, a few

pointers that you should be aware of before you share a workbook.

After sharing a workbook, you will not be able to insert or change any of the following objects or

settings until you have stopped sharing the workbook: merged cells, conditional formatting, data validation,

charts, pictures, objects, drawing objects, hyperlinks, scenarios, outlines, subtotals, data tables, PivotTable

reports, workbook and worksheet protection, and macros. Therefore, insert or apply these things prior to

sharing the workbook, if needed. Also, all users who will be editing the workbook must have Excel 97 or

later to be able to make changes.

To share a workbook, first open the workbook that you wish to share. Then click the “Share

Workbook” button in the “Changes” group on the “Review” tab to launch the “Share Workbook” dialog box.

In this dialog box, click the “Editing” tab, and check the “Allow changes by more than one user at the same

time. This also allows workbook merging.” checkbox. Next, click the “Advanced” tab to set additional

sharing options. In the “Track Changes” section, you can select the option button for “Keep change history

for:” and type a number (in days) to track any changes to the workbook. If you don’t want to track changes,

then select the “Don’t keep change history” option. In the “Update changes” section, you can select the

“When file is saved” option button to update the workbook’s changes every time that it is saved. You could

also select the “Automatically every:” option button, and then enter a number (in minutes) that it should save

the changes automatically. If you select this option, you can also specify to “Save my changes and see

others’ changes” or “Just see other users’ changes” by clicking either option button.

Sometimes, when two users edit the same cell at the same time a conflict will arise when Excel goes

to save the workbook. In the “Conflicting changes between users” section, you can set how to resolve those

conflicts. You can select either the option button for “Ask me which changes win” or “The changes being

saved win.” In the “Include in personal view” section, you can include what to include in your custom view of

the shared workbook. By default, the view includes any filter or print settings you make, or you can use the

original printer and filter settings. In the future, when you open the shared workbook, it will display using the

settings of your custom view, so that each user can have their own view of the data. You can check the

“Print settings” and “Filter settings” checkboxes to include those in the default view.

When you finish specifying share options, click “OK” in the “Share Workbook” dialog box. If you have

already saved the workbook, a message box will appear telling you that you must resave the workbook.

Click “OK” to continue. In the “Save As” dialog box that appears, select the shared network location to

which you want to save the shared workbook. Once you have done this, the other users may go edit and

review the shared workbook. When two users try to save changes that affect the same cell, Excel will

display the “Resolve Conflicts” dialog box for one of the two users. In this dialog box you will be able to read

information about each change and the conflicting change made by others. To keep your changes and

move to the next conflicting change, click “Accept Mine.” To accept the other user’s changes, click “Accept

Others.” You can also click “Accept All Mine” or “Accept All Others” to accept all of your changes over the

other users, or to accept all of the other users changes over yours. Note that this will only occur if you

selected to “Ask me which changes win” in the “Conflicting changes between users” section of the “Share

Workbooks” dialog box.

When you want to stop sharing a shared workbook, make sure that all the other users have saved

and closed their copies of the shared workbook, first. Then click the “Share Workbook” button in the

“Changes” group on the “Review” tab to launch the “Share Workbook” dialog box. On the “Editing” tab,

uncheck the “Allow changes by more than one user at the same time” checkbox. Then click “OK.”
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Sharing Workbooks

16.2- Highlighting Changes:

You have a few options for reviewing the changes that have been made to a workbook. You can

elect to show and track changes in a workbook and even list the changes made in a separate worksheet

named “History.” You can then use the “History” tab to review the changes that were made and then choose

to accept or reject the changes individually. In the “History” sheet you will see the name of the person who

made the change, what type of change was made, when it was made, what cells were affected, and what

data was added or deleted. If you don’t want to see this information in a separate sheet, you can also elect

to have it display in the changed worksheet directly. You can use this when several people have made

editing changes to a shared workbook, or after you have sent out a workbook for review and then want to

merge the input and commentary into one copy.

To review the changes made in a shared workbook, click the “Track Changes” button in the

“Changes” group on the “Review” tab. Then click the “Highlight Changes…” command in the button’s drop-

down menu to open the “Highlight Changes” dialog box.

In the “Highlight Changes” dialog box you can set the display of editing changes. You can check the

“Track changes while editing. This also shares your workbook.” checkbox to enable changes to be tracked

as you edit the workbook. In the “Highlight which changes” section, you decide what types of changes to

highlight. By default, some types of changes aren’t tracked. However, in this section you can choose when,

for whom, and for what cells to highlight changes. Use the “When:” checkbox and drop-down to select for

what duration of time to highlight the changes. You only can highlight changes from as far back as you have

set to track changes when you created the shared workbook. So, for example, if you set the shared

workbook to track change history for 30 days, you won’t be able to see or highlight any changes made from

before 30 days ago. Use the “Who:” checkbox and drop-down to select from whom to highlight changes.

You can even use the “Where:” checkbox and drop-down to select a cell range to highlight changes within.

You can check the “Highlight changes on screen” checkbox to show the changes made in the cells

that were changed. Changed cells display a small triangle in their upper left corners. When you hold your

mouse pointer over them in the worksheet, the information about the change appears in a small pop-up text

box. You can also check the “List changes on a new sheet” checkbox to list the changes in a new

worksheet named “History.” You can then review the changes in either place. Just click the “OK” button to

highlight changes in the selected location.

16.3- Reviewing Changes:

After viewing the changes that have been made, you can then elect to either accept or reject the

changes to the shared workbooks. To do this, click the “Track Changes” button in the “Changes” group on

the “Review” tab. Then click the “Accept/Reject Changes…” command in the button’s drop-down menu to

open the “Select Changes to Accept or Reject” dialog box. In this dialog box, use the “When:,” “Who:,” and

“Where:” checkboxes and drop-down menus to filter for the changes that you want to review. Once you

have made your desired selections, click “OK” to begin reviewing the selected changes.

Next, each selected change will appear. It will show who made the change, when they made the

change, and what they changed in the “Accept or Reject Changes” dialog box. At the bottom of the dialog

box click “Accept,” to accept the change shown; “Reject,” to reject the change shown; “Accept All,” to accept

all changes made; or “Reject All” to reject all changes made. Note that if there were multiple changes made

to a cell, you may have to select which change to keep in the dialog box before pressing one of the buttons

available. When you are finished, the dialog box will close automatically. You can leave anytime before

then, if needed, by simply clicking the “Close” button to exit.
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Sharing Workbooks

16.4- Using Comments:

You can use the buttons in the “Comments” group on the “Review” tab in the Ribbon to manage

comments in worksheet cells and also review changes to a shared workbook. You can also manipulate “ink”

annotations from users of tablet PCs using the buttons in this group during the review process.

You can add a comment to a cell for other people who use that workbook to read. For example, you

could include a cell comment to a formula cell that explains its function, or you could add a cell comment

that gives tips on what data should be entered into the cell. Often you use comments when making changes

to a shared workbook so that others can be informed as to what you changed and why you changed it.

Cell comments are little text boxes associated with particular cells. When someone moves their

mouse pointer over a cell that contains a comment, the comment text box will pop up: revealing the

comments for that cell. Cells with commentary attached to them display as normal within the workbook, but

contain a small red triangle in the upper right corner of the cell to indicate that they have a comment

associated with them. When you make a change to a shared workbook and then highlight the changes, you

will see the changes also listed as cell comments, but using a different color.

You can easily insert a new comment into a cell by clicking on the cell into which you want to place

the comment, and then clicking the “New Comment” button in the “Comments” group on the “Review” tab in

the Ribbon. You may also right-click on a cell and then choose the “Insert Comment” command from the

pop-up menu that appears in order to insert a new comment, as well.

The comment will appear as a text box attached to the cell. It will display the default user name

associated with the Office installation associated with the comment. You simply type your comment into the

text box. When you are finished typing your cell comment, click back into the worksheet cells to “set” the

comment. After that, you will see the comment appear in your worksheet when you simply hold your mouse

pointer over the cell that contains the comment.

If you want to edit cell comments at a later point, you start by selecting the cell with the comment

that you want to edit. Next, either click the “Edit Comment” button in the “Comments” group on the “Review”

tab in the Ribbon, or right-click the comment cell and select the “Edit Comment” command from the pop-up

menu. This will make the comment appear in its editing mode, where you can change the comment as you

wish. Once again, when you are finished editing the content, just click back into the worksheet cells to “set”

the comment.

To delete a comment from a cell, you start by selecting the cell with the comment that you want to

delete. Next, click the “Delete” button in the “Comments” group on the “Review” tab in the Ribbon, or right-

click the cell with the comment that you want to delete and select the “Delete Comment” command from the

pop-up menu that appears.

Comments can be easily viewed by moving the mouse pointer over the cell with the comment that

you wish to display. The comment will pop-up so you can read it. However, if you have many comments in a

workbook, you may want to start at a certain comment and read through all of the comments available. You

can do this by clicking either the “Previous” or “Next” buttons in the “Comments” group on the “Review” tab

in the Ribbon to move from comment to comment in the workbook until you reach the end of the workbook.

Once you have reached the end of the comments in a workbook, it will ask you if you want to start reviewing

from the beginning of the workbook. Just click the “OK” button to continue reviewing the comments from the

beginning of the workbook, or click the “Cancel” button to stop reviewing the comments. Then just click into

a non-commented cell in the worksheet to hide the display of the comment again.

You can also change the display of a comment so that when you roll your mouse pointer off the cell

that contains the comment, the comment will still be visible. To do this, click on the cell that has the

comment that you want to constantly display, and then click the “Show/Hide Comment” button in the

“Comments” group on the “Review” tab in the Ribbon. You also click this button to hide the comment
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16.4- Using Comments (cont.):

when you want to hide the display again it by clicking on the cell with the displayed comment, and then

clicking the “Show/Hide Comment” button again.

Likewise, you can also toggle the display of all of the comments in your workbook between

constantly showing and only showing when selected. To do this, just click anywhere into the worksheet and

then click the “Show All Comments” button in the “Comments” group on the “Review” tab in the Ribbon to

constantly display all the workbook’s comments. If the comments overlap each other, you can move to the

hidden comment by clicking and dragging the comment by its border in order to reposition the display of the

comment. To hide all the comments again once you’ve shown them, just click the “Show All Comments”

button again to hide the constant display of comments in the workbook.

You can print the comments in a worksheet in one of two ways. You can either print them off on a

separate sheet that lists all of the comments in a workbook, or you can print them as they are displayed on

screen. If you choose the latter option, then you must set the comments that you want to print in the

worksheet to constantly “show.” Then click the “Page Setup” dialog box button in the lower right corner of

the “Page Setup” group on the “Page Layout” tab of the Ribbon in order to open the “Page Setup” dialog

box. In the “Page Setup” dialog box, click the “Sheet” tab. Use the “Comments:” drop-down to select how to

print cell comments: “(None),” which won’t print comments; “At end of sheet,” which prints them at the end

of the sheet on a separate piece of paper; or “As displayed on sheet,” which prints them as they are

displayed on the sheet. Click “OK” to set your printing preference for the comments and then print the sheet

to view the comments in the printout using the method that you specified.

Sharing Workbooks

16.5- Compare and Merge Workbooks:

If you have created or received copies of a shared workbook into which different users have made

different changes, you can take those workbook files and merge the changes together into a single

workbook. There are a few requirements that the files must meet before you can merge them together.

First, all merged workbooks must be copies of the original shared workbook. They must all have different

files names, but must all be located in the same folder. They cannot have passwords applied to them. They

must also have change tracking in effect since the copies were created and they must have been tracking

the change history. Also note that if you merge multiple copies, changes in the last workbook copy that you

merge will replace any conflicting changes in the workbook into which you are merging.

To merge shared workbooks, make sure that you have all of the copies to be merged located in the

same folder with different file names. Next, you will need to add a button to the Quick Access toolbar for this

function, which does not appear in the Ribbon. To do this, click the “Customize Quick Access Toolbar”

button at the right end of the Quick Access toolbar. Then select the “More commands…” choice from the

button’s drop-down menu. In the “Customize” category of the “Excel Options” window that appears, select

the “All commands” choice from the “Choose commands from:” drop-down menu. Then scroll through the

list of commands until you find the “Compare and Merge Workbooks…” command. Click it to select it, and

then click the “Add >>” button to move it to the list at the right. Then click the “OK” button to finish.

Next, click the “Compare and Merge Workbooks” button in the Quick Access toolbar. You can save

the workbook, if prompted. That will then launch the “Select Files to Merge into Current Workbook” dialog

box. Here you can select the copies of the workbook to merge into the open copy, or original shared

workbook. Note that if you do select more than one copy in this dialog box, the order in which they appear

will be the order in which they are merged into the open workbook. When you have finished selecting the

file or files to merge into the open workbook, click “OK.”
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ACTIONS-

Sharing Workbooks
SHARING WORKBOOKS:

1. Open the workbook that you wish to share.

2. Click the “Share Workbook” button in the “Changes” group on the “Review” tab to launch the “Share 

Workbook” dialog box.

3. In this dialog box, click the “Editing” tab, and check the “Allow changes by more than one user at the 

same time. This also allows workbook merging.” checkbox.

4. Next, click the “Advanced” tab to set additional sharing options. In the “Track Changes” section, you can 

select the option button for “Keep change history for:” and type a number (in days) to track any changes 

to the workbook. If you don’t want to track changes, then select the “Don’t keep change history” option.

5. In the “Update changes” section, you can select the “When file is saved” option button to update the 

workbook’s changes every time that it is saved. You could also select the “Automatically every:” option 

button, and then enter a number (in minutes) that it should save the changes automatically. If you select 

this option, you can also specify to “Save my changes and see others’ changes” or “Just see other 

users’ changes” by clicking either option button.

6. In the “Conflicting changes between users” section, you can set how to resolve conflicts. You can select 

either the option button for “Ask me which changes win” or “The changes being saved win.”

7. In the “Include in personal view” section, you can include what to include in your custom view of the 

shared workbook. By default, the view includes any filter or print settings you make, or you can use the 

original printer and filter settings. In the future, when you open the shared workbook, it will display using 

the settings of your custom view, so that each user can have their own view of the data. You can check 

the “Print settings” and “Filter settings” checkboxes to include those in the default view.

8. When you finish specifying share options, click “OK” in the “Share Workbook” dialog box. If you have 

already saved the workbook, a message box will appear telling you that you must resave the workbook. 

Click “OK” to continue. In the “Save As” dialog box that appears, select the shared network location to 

which you want to save the shared workbook.

RESOLVING CONFLICTS TO A SHARED WORKBOOK:

1. When two users try to save changes that affect the same cell, Excel will display the “Resolve Conflicts” 

dialog box for one of the two users.

2. In this dialog box you will be able to read information about each change and the conflicting change 

made by others.

3. To keep your changes and move to the next conflicting change, click “Accept Mine.”

4. To accept the other user’s changes, click “Accept Others.”

5. You can also click “Accept All Mine” or “Accept All Others” to accept all of your changes over the other 

users, or to accept all of the other users changes over yours.

TO STOP SHARING A SHARED WORKBOOK:

1. Make sure that all the other users have saved and closed their copies of the shared workbook, first.

2. Click the “Share Workbook” button in the “Changes” group on the “Review” tab to launch the “Share 

Workbook” dialog box.

3. In the “Share Workbook” dialog box, uncheck the “Allow changes by more than one user at the same 

time” checkbox.

4. Click “OK” to stop sharing the workbook.
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ACTIONS-

Sharing Workbooks

HIGHLIGHTING CHANGES IN A SHARED WORKBOOK:

1. Click the “Track Changes” button in the “Changes” group on the “Review” tab. Then click the 

“Accept/Reject Changes…” command in the button’s drop-down menu to open the “Highlight Changes” 

dialog box.

2. In the “Highlight Changes” dialog box you can set the display of editing changes. You can check the 

“Track changes while editing. This also shares your workbook.” checkbox to enable changes to be 

tracked as you edit the workbook.

3. In the “Highlight which changes” section, you decide what types of changes to highlight. In this section, 

use the “When:” checkbox and drop-down to select for what duration of time to highlight the changes. 

Then use the “Who:” checkbox and drop-down to select from whom to highlight changes. You can also 

use the “Where:” checkbox and drop-down to select a cell range to highlight changes within.

4. You can check the “Highlight changes on screen” checkbox to show the changes made in the cells that 

were changed. Changed cells display a small triangle in their upper left corners. When you hold your 

mouse pointer over them, the information about the change appears in a small pop-up text box.

5. You can also check the “List changes on a new sheet” checkbox to list the changes in a new worksheet 

named “History.” You can then review the changes in either place.

6. When you are finished, click the “OK” button to highlight changes in the selected location.

ACCEPTING OR REJECTING SHARED WORKBOOK CHANGES:

1. Click the “Track Changes” button in the “Changes” group on the “Review” tab. Then click the 

“Accept/Reject Changes…” command in the button’s drop-down menu to open the “Select Changes to 

Accept or Reject” dialog box.

2. In this dialog box, use the “When:,” “Who:,” and “Where:” checkboxes and drop-down menus to filter for 

the changes that you want to review.

3. Once you have made your desired selections, click “OK” to begin reviewing the selected changes.

4. Next, each selected change will appear. It will show who made the change, when they made the 

change, and what they changed in the “Accept or Reject Changes” dialog box.

5. At the bottom of the dialog box click “Accept,” to accept the change shown; “Reject,” to reject the 

change shown; “Accept All,” to accept all changes made; or “Reject All” to reject all changes made.

6. Note that if there were multiple changes made to a cell, you may have to select which change to keep in 

the dialog box before pressing one of the buttons available. When you are finished, the dialog box will 

close automatically.

7. You can leave anytime before finishing, if needed, by simply clicking the “Close” button to exit.

USING COMMENTS:

1. You can insert a new comment into a cell by clicking on the cell into which you want to place the 

comment, and then clicking the “New Comment” button in the “Comments” group on the “Review” tab in 

the Ribbon. You may also right-click on a cell and then choose the “Insert Comment” command from the 

pop-up menu that appears in order to insert a new comment, as well.

2. The comment will appear as a text box attached to the cell. It will display the default user name 

associated with the Office installation associated with the comment.

(cont.)
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ACTIONS-

Sharing Workbooks
USING COMMENTS (CONT.):

3. You simply type your comment into the text box. When you are finished typing your cell comment, click 

back into the worksheet cells to “set” the comment.

4. After that, you will see the comment appear in your worksheet when you simply hold your mouse pointer 

over the cell that contains the comment.

5. If you want to edit cell comments at a later point, you start by selecting the cell with the comment that 

you want to edit.

6. Next, either click the “Edit Comment” button in the “Comments” group on the “Review” tab in the Ribbon, 

or right-click the comment cell and select the “Edit Comment” command from the pop-up menu.

7. This will make the comment appear in its editing mode, where you can change the comment as you 

wish. Once again, when you are finished editing the content, just click back into the worksheet cells to 

“set” the comment.

8. To delete a comment from a cell, you start by selecting the cell with the comment that you want to 

delete.

9. Next, click the “Delete” button in the “Comments” group on the “Review” tab in the Ribbon, or right-click 

the cell with the comment that you want to delete and select the “Delete Comment” command from the 

pop-up menu that appears.

10. You can read through all of the comments available by clicking either the “Previous” or “Next” buttons in 

the “Comments” group on the “Review” tab in the Ribbon to move from comment to comment in the 

workbook until you reach the end of the workbook. Once you have reached the end of the comments in 

a workbook, it will ask you if you want to start reviewing from the beginning of the workbook. Just click 

the “OK” button to continue reviewing the comments from the beginning of the workbook, or click the 

“Cancel” button to stop reviewing the comments. Then just click into a non-commented cell in the 

worksheet to hide the display of the currently selected comment again.

11. You can also change the display of a comment so that when you roll your mouse pointer off the cell that 

contains the comment, the comment will still be visible. To do this, click on the cell that has the 

comment that you want to constantly display, and then click the “Show/Hide Comment” button in the 

“Comments” group on the “Review” tab in the Ribbon. You also click this button to hide the comment 

when you want to hide the display again it by clicking on the cell with the displayed comment, and then 

clicking the “Show/Hide Comment” button again.

12. Likewise, you can also toggle the display of all of the comments in your workbook between constantly 

showing and only showing when selected. To do this, just click anywhere into the worksheet and then 

click the “Show All Comments” button in the “Comments” group on the “Review” tab in the Ribbon to 

constantly display all the workbook’s comments.

13. If the comments overlap each other, you can move to the hidden comment by clicking and dragging the 

comment by its border in order to reposition the display of the comment.

14. To hide all the comments again once you’ve shown them, just click the “Show All Comments” button 

again to hide the constant display of comments in the workbook.

15. You can print the comments in a worksheet in one of two ways. You can either print them off on a 

separate sheet that lists all of the comments in a workbook, or you can print them as they are displayed 

on screen. If you choose the latter option, then you must set the comments that you want to print in the 

worksheet to constantly “show.”

16. Then click the “Page Setup” dialog box button in the lower right corner of the “Page Setup” group on the 

“Page Layout” tab of the Ribbon in order to open the “Page Setup” dialog box.

(cont.)
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ACTIONS-

Sharing Workbooks
USING COMMENTS (CONT.):

17. In the “Page Setup” dialog box, click the “Sheet” tab.

18. Use the “Comments:” drop-down to select how to print cell comments: “(None),” which won’t print 

comments; “At end of sheet,” which prints them at the end of the sheet on a separate piece of paper; or 

“As displayed on sheet,” which prints them as they are displayed on the sheet.

19. Click “OK” to set your printing preference for the comments and then print the sheet to view the 

comments in the printout using the method that you specified.

COMPARE AND MERGE WORKBOOKS:

1. If you have created or received copies of a shared workbook into which different users have made 

different changes, you can take those workbook files and merge the changes together into a single 

workbook. There are a few requirements that the files must meet before you can merge them together. 

First, all merged workbooks must be copies of the original shared workbook. They must all have 

different files names, but must all be located in the same folder. They cannot have passwords applied to 

them. They must also have change tracking in effect since the copies were created and they must have 

been tracking the change history. Also note that if you merge multiple copies, changes in the last 

workbook copy that you merge will replace any conflicting changes in the workbook into which you are 

merging.

2. Next, you will need to add a button to the Quick Access toolbar for this function, which does not appear 

in the Ribbon.

3. To do this, click the “Customize Quick Access Toolbar” button at the right end of the Quick Access 

toolbar. Then select the “More commands…” choice from the button’s drop-down menu.

4. In the “Customize” category of the “Excel Options” window that appears, select the “All commands” 

choice from the “Choose commands from:” drop-down menu.

5. Then scroll through the list of commands until you find the “Compare and Merge Workbooks…” 

command. Click it to select it, and then click the “Add >>” button to move it to the list at the right.

6. Then click the “OK” button to finish.

7. Next, click the “Compare and Merge Workbooks” button in the Quick Access toolbar. You can save the 

workbook, if prompted.

8. That will then launch the “Select Files to Merge into Current Workbook” dialog box. Here you can select 

the copies of the workbook to merge into the open copy, or original shared workbook. Note that if you do 

select more than one copy in this dialog box, the order in which they appear will be the order in which 

they are merged into the open workbook.

9. When you have finished selecting the file or files to merge into the open workbook, click “OK.”
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EXERCISES-

Sharing Workbooks
Purpose:

1. To be able to insert and manage cell comments.

Exercises:

1. Open the “Inter- Sample” workbook.

2. Select “Sheet3.”

3. Select cell B4.

4. Click the “New Comment” button in the “Comments” group on the “Review” tab in the Ribbon.

5. Type a comment that reads, “Table values below are static values created from a paste special

function. They are not formulas.”

6. Click into cell A1 to set the comment in B4.

7. Roll your mouse pointer over cell B4 to watch the comment appear. Roll your mouse pointer away

from cell B4 to hide the comment again.

8. Select cell B4.

9. Click the “Show/Hide Comment” button in the “Comments” group on the “Review” tab in the Ribbon.

10. Click once on the border of the displayed comment to select it.

11. Move your mouse pointer over one of the small white resizing circles that surround the border until

your mouse pointer changes into a two-pointed arrow.

12. Click and drag at that point to change the size of the comment. Release the mouse button when it is

the size that you prefer.

13. Click the “Show/Hide Comment” button in the “Comments” group on the “Review” tab in the Ribbon.

The display of the comment should return to its normal function.

14. Click the “Save” button in the Quick Access Toolbar to save your changes.

15. Click the “X” button in the upper right corner of the application window to exit.

Sam
ple

- fo
r e

va
lua

tio
n p

urp
os

es
 on

ly.



38Intermediate Excel©TeachUcomp, Inc.

17.1- Auditing Worksheets

17.2- Tracing Precedent and Dependent Cells

17.3- Tracing Errors

17.4- Error Checking

17.5- Using the Watch Window

17.6- Cell Validation

CHAPTER 17-

Auditing Worksheets
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17.1- Auditing Worksheets:

Auditing Worksheets refers to the process of discovering which cells involved in cell formulas are

dependent upon which other cells in order to function. For example, you might have a formula at the bottom

of a column that adds up the numbers above it. That formula is “dependent” on those cells to function, so

you call it a “dependent cell” in regards to the cells above it. The cells above the formula cell would be

called the “precedent” cells. These are the cells which contain the values used to perform the calculation.

When you discuss auditing worksheets it is just a “fancy” way of discussing which cells come first, what

cells are dependent on those cells, and so on and so forth.

In Excel, you can use the buttons available in the “Formula Auditing” group on the “Formulas” tab in

the Ribbon to trace the precedent and dependent cells of a selected formula cell. This allows you to easily

see what cells the selected formula cell uses in its calculations. This also enables you to see what other

formula cells then use the value derived by the selected formula cell in their calculations.

Auditing Worksheets

17.2- Tracing Precedent and Dependent Cells:

You can select any formula cell or any cell used by a formula cell, and then trace arrows that point to

either the precedent or dependent cells from the selected cell. When you do this, Excel draws blue arrows

either from the selected cell to its dependent cells, or from the precedent cells to the selected cell-

depending on which button you choose from the buttons available in the “Formula Auditing” group on the

“Formulas” tab in the Ribbon.

If the precedent or dependent cells are on another worksheet, then a black arrow that points to a

worksheet icon will be displayed versus displaying a blue arrow. You can double-click on the black arrow to

view the “Go to” dialog box, which should point to the worksheet reference. You can then click on the

reference and click “OK” to jump to the referenced cell in the other worksheet.

To view the precedent cells from a selected formula cell, first select the formula cell. Next, click the

“Trace Precedents” button in the “Formula Auditing” group on the “Formulas” tab in the Ribbon. This will

cause Excel to trace arrows back to the precedent cells that are referenced by the formula in the selected

cell. In some cases, these cells may also be formulas. In that case, you can continue to click the “Trace

Precedents” button in order to view multiple levels of precedent cells. In this way, you can work backward to

discover which cells are referenced by the formula to perform its calculations. This is handy for determining

which cells may be causing errors or inaccuracies in your worksheet formula calculations.

Tracing dependent cells is the same procedure in reverse. You simply click on a cell from which you

want to trace the dependent cells, and then click the “Trace Dependents” button in the “Formula Auditing”

group on the “Formulas” tab in the Ribbon. Excel will draw arrows to any cells that need the value

calculated by the selected cell in order to function. You can click the “Trace Dependents” button as many

times as needed in order to trace multiple levels of dependency from the selected cell, if necessary.

To remove all of the auditing arrows that Excel draws in a worksheet, first select the worksheet from

which you want to remove the auditing arrows. Next, click the “Remove Arrows” button in the “Formula

Auditing” group on the “Formulas” tab in the Ribbon. This will remove all arrows from the selected

worksheet. It is important to note that you must clear the traced arrows in each individual worksheet

separately

If you only wish to remove the last level of precedent or dependent arrows that were drawn in a

worksheet, you can click the drop-down button to the right of the “Remove Arrows” button, and then select

either the “Remove Precedent Arrows” or “Remove Dependent Arrows” commands from the button’s drop-

down menu to remove the last level of precedent and dependent arrows that were traced.
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Auditing Worksheets

17.3- Tracing Errors:

Another feature of auditing worksheets is that it allows you to trace arrows back to the cells that are

being referenced by a selected formula if the formula that you create displays an error. To do this, first

select the formula cell with the error displayed in it. Next, click the “Error Checking” drop-down button in the

“Formula Auditing” group on the “Formulas” tab in the Ribbon, and then select the “Trace Error” command

to draw arrows to the cells that cause the error. Invalid or inaccurate cell referencing is often a common

cause of formula errors. Using this tool will show you the cells that are being referenced. You can then fix

the cell references, if that turns out to be the reason why the formula won’t function.

17.4- Error Checking:

You can use the “Error Checking” button in the “Formula Auditing” group on the “Formulas” tab in

the Ribbon to trace and correct formula errors in your worksheets. To do this, just click the “Error Checking”

button in the “Formula Auditing” group on the “Formulas” tab in the Ribbon while selecting a worksheet that

contains formula errors. You’ll then show the first formula error encountered in the worksheet in the “Error

Checking” dialog box.

You can click the “Help on this error” button to launch the associated help page for this error topic in

a separate window. You can read the information, and close the window when you are finished. You can

then click the “Resume” button in the “Error Checking” dialog box to resume error checking the sheet. If you

click the “Show Calculation Steps…” button in the “Error Checking” dialog box, it then launches the

“Evaluate Formula” dialog box. Note that you can also launch this dialog box independently of the “Error

Checking” dialog box. You can separately launch this dialog box by clicking the “Evaluate Formula” button

in the “Formula Auditing” group on the “Formulas” tab in the Ribbon.

In the “Evaluate Formula” dialog box, you can click the “Evaluate” button to evaluate the underlined

reference displayed in the formula. If you have nested functions in the formula, you can step through each

calculation to view when the error occurs. You can click the “Restart” button to restart the calculations

again, if needed. If the underlined reference that is being evaluated is a reference to another formula, you

can click the “Step In” button to view that function in this window and evaluate its value. You can then click

the “Step Out” button to step back out of that formula and into the original formula to continue evaluating the

first formula. When you are finished, click “Close” to return to the “Error Checking” dialog box.

You can click the “Ignore Error” button to skip the error displayed in the formula and continue to the

next formula error. However, once you choose to ignore an error, you will no longer be able to recheck it

using the “Error Checking” feature! This acts much like telling the “Spell Checker” feature to ignore a

misspelled word: it will no longer regard the error cell as being an error, even though the formula still won’t

function. You can click the “Options…” button in the lower left corner of this dialog box to fix this. Click the

“Reset Ignored Errors” button in the “Options” dialog box and then click “OK” to reset ignored errors.

You can click the “Edit in Formula Bar” button in the “Error Checking” dialog box to display the

formula in the Formula Bar, where you can edit it to fix the mistake. Once you feel that you have corrected

the problem, click the green arrow at the left end of the formula bar to “set” the formula. Then click

“Resume” in the “Error Checking” dialog box to resume error checking.

You can also just click the “Previous” and “Next” buttons at the bottom of the “Error Checking” dialog

box to move through the malfunctioning formulas in your worksheet without “ignoring” them. When you

finish viewing all of the errors in your formula cells, you will see a small dialog box that appears and tells

you that the error check is complete. Click “OK” to finish your error checking.
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Auditing Worksheets

17.5- Using the Watch Window:

You can watch the value of a cell to note when it changes, even if the cell isn’t viewable on screen at

the time it changes. To watch the value of a cell, click the “Watch Window” button in the “Formula Auditing”

group on the “Formulas” tab in the Ribbon. That will open the “Watch Window” dialog box.

In this dialog box, click the “Add Watch…” button at the top of the dialog box to set a cell to watch in

this window. Then, with the “Add Watch” dialog box open, click and drag over the adjacent cells in the sheet

that you want to watch. If the cells are non-adjacent, you can hold down “Ctrl” on your keyboard and click on

non-adjacent cells to select them. Once you have made your cell selections, click “Add” to return to the

“Watch Window.” The cell references that you added will be listed individually in this window pane. Then as

you change cells in your worksheet, you can see the values change in the watch window. This can be

useful for checking how data entry will affect cell values in a formula that you can’t see when you are

performing the data entry. To delete an entry from the “Watch Window,” click on the reference in the “Watch

Window” that you want to delete. Then click the “Delete Watch” button at the top of the “Watch Window” to

delete the selected reference. When you are finished with the “Watch Window,” close it by clicking the “X” in

the upper right corner of the “Watch Window.”

17.6- Cell Validation:

You can use cell validation to restrict data entry in selected cells to a limited range of values. To use

cell validation, first select the cell or cell range upon which you wish to place data entry restrictions. Then

click the “Data Validation” button shown in the “Data Tools” group on the “Data” tab in the Ribbon. In the

“Data Validation” dialog box that opens there are three tabs: “Settings,” “Input Message,” and “Error Alert.”

You click the “Settings” tab to set the range of allowable values for the selected cell or cells. You use

the “Allow:” drop-down to select a restriction criteria. You can select “Whole Number” or “Decimal” to restrict

the cell entry to values within a specified limit. Next, you would use the “Data:” drop-down to select a

comparison criteria. You then specify the value or values within which data entry will be allowed.

You can select the “List” choice from the “Allow:” drop-down on the “Settings” tab to restrict data

entry in the selected cells to a list of cell values shown in the worksheet. Next, you would click the “Collapse

Dialog” button at the right end of the “Source:” text box to collapse the “Data Validation” dialog box to a

single line. Then click and drag over the cells that you want to use as the list of values from which the user

can select. The list you select must be on the same worksheet as the cell to which you are applying the cell

validation. Click the “Expand Dialog” button at the right end of the text box to expand the dialog box again.

To the right of the “Data Validation” dialog box, you can check the “In-cell dropdown” to set the cell’s data

entry method to be a drop-down list from which the user can select a displayed choice.

You can select “Date” or “Time” from the “Allow:” drop-down to restrict data entry in the selected cell

or cells to a range of dates or times. Then use the “Data:” drop-down to select a comparison operator for

your criteria. Use the “Start Date:” or “Start Time:” and (if needed) the “End Date:” or “End Time:” text boxes

to set the date or time range by which you wish to restrict data entry.

You can select “Text Length” from the “Allow:” drop-down to restrict the length of text entries in cells.

Once again, you would use the “Data:” drop-down to select a comparison operator and then use the

“Minimum:” and/or the “Maximum:” text boxes to set the upper and lower limits of the text for data entry.

You can select “Custom” from the “Allow:” drop-down to enter a logical formula or select a logical

formula cell in the “Formula:” text box. A logical formula has to evaluate to either “True” or “False.” This

indicates whether or not to allow data entry in the cell.
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Auditing Worksheets

17.6- Cell Validation (cont.):

After selecting what data to allow on the “Settings” tab, note that you can check or uncheck the

“Ignore blank” checkbox for most selections. To allow null (empty) cells as being a valid entry, then check

this box. To disallow blank cells as valid entries, clear the check box. Note that if you have a reference to a

range with a blank cell in it for the allowed values of the cell, then checking the “Ignore blank” checkbox will

allow any cell value to be entered into the cell as valid data.

Next, click the “Input Message” tab in the “Data Validation” dialog box. Here you can set an option

message to display when the cell is selected for data entry. You have to check the “Show input message

when cell is selected” checkbox. Then you can type a title for the message box that will appear when the

user selects this cell into the “Title:” text box. Type the message that you want the user to see into the “Input

message:” text box. When the user click onto this cell in the worksheet they will see a cell comment appear

next to the cell. They can click and drag the message box to a different location in the worksheet if they find

it to be in the way when they select the cell for data entry.

You can click the “Error Alert” tab to set how Excel will respond to invalid data entry in the cell. Make

sure that the “Show error alert after invalid data is entered” checkbox is checked in order to enable this

feature. Then use the “Style:” drop-down to set the icon that will appear in the error dialog box. You will see

the icon shown below the “Style:” drop-down. Type the title for the error message box into the “Title:” text

box. Then type the text of your error message into the “Error Message:” text box.

Once you have set the data validation that you want to the currently selected cells in the worksheet,

click “OK” to apply the data validation. When you apply data validation on cells that have pre-existing

values, the existing values will not be checked against the new cell validation rules. So, you can have data

that breaks the validation rules that you have applied. If you want to check to see if there are any cells with

invalid data entries, click the “Data Validation” drop-down button on the “Data Tools” group on the “Data”

tab in the Ribbon. Then select the “Circle Invalid Data” command from the drop-down button’s menu of

choices. Doing this will circle the invalid entries with a red circle in the worksheet. You can then edit the

values of the circled cells. To remove the red circles around the invalid data, you can click the “Data

Validation” drop-down button on the “Data Tools” group on the “Data” tab in the Ribbon. Then select the

“Clear Validation Circles” command from the drop-down button’s menu of choices to remove them.

If you want to edit the restrictions placed on a cell through cell validation, select the cell that you

want to edit and click the “Data Validation” button shown in the “Data Tools” group on the “Data” tab in the

Ribbon. This will launch the “Data Validation” dialog box again, where you can change the settings as

desired. If you change one cell of several cells that have the same cell validation rule applied, you can

check the “Apply these changes to all other cells with the same settings” checkbox at the bottom of the

“Settings” tab in the “Data Validation” dialog box and then click “OK” to apply the change not only to the

selected cell, but also to all other cells in the worksheet that had the same data validation settings applied.

To clear cell validation after applying it to a cell or cells in a worksheet, select the cell or cells from

which you want to remove the cell validation. Then click the “Data Validation” button shown in the “Data

Tools” group on the “Data” tab in the Ribbon. Click the “Clear All” button in the lower left corner of the “Data

Validation” dialog box to remove all cell validation settings from the selected cells.Sam
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ACTIONS-

Auditing Worksheets
TRACING PRECEDENT AND DEPENDENT CELLS:

1. To view the precedent cells from a selected formula cell, first select the formula cell.

2. Next, click the “Trace Precedents” button in the “Formula Auditing” group on the “Formulas” tab in the 

Ribbon. This will cause Excel to trace arrows back to the precedent cells that are referenced by the 

formula in the selected cell. In some cases, these cells may also be formulas. In that case, you can 

continue to click the “Trace Precedents” button in order to view multiple levels of precedent cells.

3. Tracing dependent cells is the same procedure in reverse. You simply click on a cell from which you 

want to trace the dependent cells, and then click the “Trace Dependents” button in the “Formula 

Auditing” group on the “Formulas” tab in the Ribbon. Excel will draw arrows to any cells that need the 

value calculated by the selected cell in order to function. You can click the “Trace Dependents” button 

as many times as needed in order to trace multiple levels of dependency from the selected cell.

4. If the precedent or dependent cells are on another worksheet, then a black arrow that points to a 

worksheet icon will be displayed versus displaying a normal blue arrow. You can double-click on the 

black arrow to view the “Go to” dialog box, which should point to the worksheet reference. You can then 

click on the reference and click “OK” to jump to the referenced cell in the other worksheet.

5. To remove all of the auditing arrows that Excel draws in a worksheet, first select the worksheet from 

which you want to remove the auditing arrows. Next, click the “Remove Arrows” button in the “Formula 

Auditing” group on the “Formulas” tab in the Ribbon. This will remove all arrows from the selected 

worksheet. It is important to note that you must clear the traced arrows in each individual worksheet 

separately

6. If you only wish to remove the last level of precedent or dependent arrows that were drawn in a 

worksheet, you can click the drop-down button to the right of the “Remove Arrows” button, and then 

select either the “Remove Precedent Arrows” or “Remove Dependent Arrows” commands from the 

button’s drop-down menu to remove the last level of precedent and dependent arrows that were traced. 

TRACING FORMULA ERRORS:

1. Select the formula cell with the error displayed in it.

2. Click the “Error Checking” drop-down button in the “Formula Auditing” group on the “Formulas” tab in 

the Ribbon, and then select the “Trace Error” command to draw arrows to the cells that cause the error.

ERROR CHECKING A WORKSHEET:

1. Click the “Error Checking” button in the “Formula Auditing” group on the “Formulas” tab in the Ribbon.

2. In the “Error Checking” dialog box you’ll see the first formula error displayed.

3. You can click the “Help on this error” button to view the associated help file for the error topic. You can 

click the “Resume” button in the “Error Checking” dialog box to resume error checking, when finished.

4. If you click the “Show Calculation Steps…” button, it launches the “Evaluate Formula” dialog box. You 

can also launch this dialog box by clicking the “Evaluate Formula” button in the “Formula Auditing” 

group on the “Formulas” tab in the Ribbon.

5. In the “Evaluate Formula” dialog box, you can click the “Evaluate” to evaluate the underlined reference 

in the formula displayed. You can click the “Restart” button to restart the calculations again, if needed.

(cont.)
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ACTIONS-

Auditing Worksheets
ERROR CHECKING A WORKSHEET:

6. If the underlined reference being evaluated is a reference to another formula, you can click the “Step In” 

button to view that function evaluate its value. You can then click the “Step Out” button to step back out 

of that formula and into the original formula to continue evaluating the first formula.

7. When you are finished evaluating the formula, click “Close” to return to the “Error Checking” dialog box.

8. You can click the “Ignore Error” button to ignore the error displayed in the formula and continue to the 

next formula error. 

9. You can click the “Edit in Formula Bar” button in the “Error Checking” dialog box to display the formula 

in the Formula Bar, where you can edit it to fix the mistake. Once you feel that you have corrected the 

problem, click the check mark at the left end of the formula bar to “set” the formula. Then click “Resume” 

in the “Error Checking” dialog box to resume error checking.

10. You can also just click the “Previous” and “Next” buttons at the bottom of the “Error Checking” dialog 

box to move through the malfunctioning formulas in your worksheet without “ignoring” them.

11. When you finish viewing all of the errors in your formula cells, you will see a small dialog box that 

appears, telling you that the error check is complete. Click “OK” to finish your error checking.

USING THE WATCH WINDOW:

1. Click the “Watch Window” button in the “Formula Auditing” group on the “Formulas” tab in the Ribbon. 

That will open the “Watch Window” dialog box.

2. In this dialog box, click the “Add Watch…” button at the top of the dialog box to set a cell to watch in this 

window. Then, with the “Add Watch” dialog box open, click and drag over the adjacent cells in the sheet 

that you want to watch. If the cells are non-adjacent, you can hold down “Ctrl” on your keyboard and 

click on non-adjacent cells to select them.

3. Once you have made your cell selections, click “Add” to return to the “Watch Window.” The cell 

references that you added will be listed individually in this window pane.

4. To delete an entry from the “Watch Window,” click on the reference in the “Watch Window” that you 

want to delete.

5. Then click the “Delete Watch” button at the top of the “Watch Window” to delete the selected reference.

6. When you are finished with the “Watch Window,” close it by clicking the “X” in the upper right corner of 

the “Watch Window.”

APPLYING CELL VALIDATION:

1. Select the cell or cell range upon which you wish to place data entry restrictions.

2. Click the “Data Validation” button shown in the “Data Tools” group on the “Data” tab in the Ribbon. In 

the “Data Validation” dialog box that opens there are three tabs: “Settings,” “Input Message,” and “Error 

Alert.”

3. Click the “Settings” tab to set the range of allowable values for the selected cell or cells. You use the 

“Allow:” drop-down to select a restriction criteria. You can select “Whole Number” or “Decimal” to restrict 

the cell entry to values within a specified limit. Next, you would use the “Data:” drop-down to select a 

comparison criteria. You then specify the value or values within which data entry will be allowed.

(cont.)
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ACTIONS-

Auditing Worksheets

APPLYING CELL VALIDATION (CONT.):

4. You can select the “List” choice from the “Allow:” drop-down on the “Settings” tab to restrict data entry in 

the selected cells to a list of cell values shown in the worksheet. Next, you would click the “Collapse 

Dialog” button at the right end of the “Source:” text box to collapse the “Data Validation” dialog box to a 

single line. Then click and drag over the cells that you want to use as the list of values from which the 

user can select. The list you select must be on the same worksheet as the cell to which you are applying 

the cell validation. Click the “Expand Dialog” button at the right end of the text box to expand the dialog 

box again. To the right of the “Data Validation” dialog box, you can check the “In-cell dropdown” to set 

the cell’s data entry method to be a drop-down list from which the user can select a displayed choice.

5. You can select “Date” or “Time” from the “Allow:” drop-down to restrict data entry in the selected cell or 

cells to a range of dates or times. Then use the “Data:” drop-down to select a comparison operator for 

your criteria. Use the “Start Date:” or “Start Time:” and (if needed) the “End Date:” or “End Time:” text 

boxes to set the date or time range by which you wish to restrict data entry.

6. You can select “Text Length” from the “Allow:” drop-down to restrict the length of text entries in cells. 

Once again, you would use the “Data:” drop-down to select a comparison operator and then use the 

“Minimum:” and/or the “Maximum:” text boxes to set the upper and lower limits of the text for data entry.

7. You can select “Custom” from the “Allow:” drop-down to enter a logical formula or select a logical 

formula cell in the “Formula:” text box. A logical formula has to evaluate to either “True” or “False.” This 

indicates whether or not to allow data entry in the cell.

8. After selecting what data to allow on the “Settings” tab, note that you can check or uncheck the “Ignore 

blank” checkbox for most selections. To allow null (empty) cells as being a valid entry, then check this 

box. To disallow blank cells as valid entries, clear the check box. Note that if you have a reference to a 

range with a blank cell in it for the allowed values of the cell, then checking the “Ignore blank” checkbox 

will allow any cell value to be entered into the cell as valid data.

9. Next, click the “Input Message” tab in the “Data Validation” dialog box. Here you can set an option 

message to display when the cell is selected for data entry. You have to check the “Show input 

message when cell is selected” checkbox. Then you can type a title for the message box that will 

appear when the user selects this cell into the “Title:” text box. Type the message that you want the user 

to see into the “Input message:” text box. When the user click onto this cell in the worksheet they will 

see a cell comment appear next to the cell. They can click and drag the message box to a different 

location in the worksheet if they find it to be in the way when they select the cell for data entry.

10. You can click the “Error Alert” tab to set how Excel will respond to invalid data entry in the cell. Make 

sure that the “Show error alert after invalid data is entered” checkbox is checked in order to enable this 

feature. Then use the “Style:” drop-down to set the icon that will appear in the error dialog box. You will 

see the icon shown below the “Style:” drop-down. Type the title for the error message box into the 

“Title:” text box. Then type the text of your error message into the “Error Message:” text box.

11. Once you have set the data validation that you want to the currently selected cells in the worksheet, 

click “OK” to apply the data validation.

12. When you apply data validation on cells that have pre-existing values, the existing values will not be 

checked against the new cell validation rules. So, you can have data that breaks the validation rules that 

you have applied. If you want to check to see if there are any cells with invalid data entries, click the 

“Data Validation” drop-down button on the “Data Tools” group on the “Data” tab in the Ribbon. Then 

select the “Circle Invalid Data” command from the drop-down button’s menu of choices. This will circle 

the invalid entries with a red circle in the worksheet. You can then edit the values of the circled cells.

(cont.)
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ACTIONS-

Auditing Worksheets

APPLYING CELL VALIDATION (CONT.):

13. To remove the red circles around the invalid data, you can click the “Data Validation” drop-down button 

on the “Data Tools” group on the “Data” tab in the Ribbon. Then select the “Clear Validation Circles” 

command from the drop-down button’s menu of choices to remove them.

14. If you want to edit the restrictions placed on a cell through cell validation, select the cell that you want to 

edit and click the “Data Validation” button shown in the “Data Tools” group on the “Data” tab in the 

Ribbon. This will launch the “Data Validation” dialog box again, where you can change the settings as 

desired. If you change one cell of several cells that have the same cell validation rule applied, you can 

check the “Apply these changes to all other cells with the same settings” checkbox at the bottom of the 

“Settings” tab in the “Data Validation” dialog box and then click “OK” to apply the change not only to the 

selected cell, but also to all other cells in the worksheet that had the same data validation settings 

applied.

15. To clear cell validation after applying it to a cell or cells in a worksheet, select the cell or cells from which 

you want to remove the cell validation. Then click the “Data Validation” button shown in the “Data Tools” 

group on the “Data” tab in the Ribbon. Click the “Clear All” button in the lower left corner of the “Data 

Validation” dialog box to remove all cell validation settings from the selected cells.
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EXERCISES-

Auditing Worksheets
Purpose:

1. Displaying precedent and dependent cell arrows.

2. Removing auditing arrows.

Exercises:

1. Open the “Inter- Sample” workbook.

2. Select “Sheet1.”

3. Select cell B3.

4. Click the “Trace Dependents” button in the “Formula Auditing” group on the “Formulas” tab in the

Ribbon.

5. Double-click on the black arrow that appears. You will open the “Go To” dialog box. Select the cell

reference shown in the dialog box, and then click the “OK” button.

6. Select the “Sheet1” worksheet again.

7. Click the “Remove Arrows” button in the “Formula Auditing” group on the “Formulas” tab in the

Ribbon.

8. Click the “Save” button in the Quick Access Toolbar to save your changes.

9. Click the “X” button in the upper right corner of the application window to exit.
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CHAPTER 18-

Outlining Worksheets

18.1- Using Outlines

18.2- Applying and Removing Outlines
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Outlining Worksheets

18.1- Using Outlines:

Outlining a worksheet adds an additional organizational quality to a long or wide worksheet. Outlines

group worksheet data into different levels based on column and row headings. Lower level data is

associated with the headings in the rows or columns. To apply an outline, though, you must have a

structured worksheet that would benefit from outlining. Usually, large worksheets that have column and row

headings, detail data, and totals or subtotals can benefit from outlining.

Once applied, the outline can be expanded to view any pertinent detail data. They can also be

collapsed to hide the detail data, but still show totals. This makes outlining larger, organized worksheets an

excellent idea as it will minimize the scrolling that you have to do to access the data that you want to see.

You can also see labels and totals that normally would be difficult to see simultaneously because of their

distance of separation within the columns and rows of the worksheet.

When an outlined section is expanded, you can see all of the data in that section. Also, a minus (-)

sign will appear above the section. If you click the minus sign, the section will collapse, hiding the detail

data. The minus sign will also turn into a plus sign (+) indicating that there is detail data being hidden.

Clicking the plus sign will expand the section again. You may also click the small “1” and “2” numbers at the

left end or top of the outline section to view the first level or second level of details data. It is also possible to

have multiple levels of outlining in the same section.

18.2- Applying and Removing Outlines:

You can apply an outline to a selected range of cells by first selecting the cell range to which you

want to apply an outline and then clicking the “Group” button in the “Outline” group on the “Data” tab in the

Ribbon. This will launch the “Group” dialog box where you select whether to group the rows or columns of

your cell selection. Then click the “OK” button to apply an outline to the columns or rows.

To remove an outline, just select the cell range to which you applied the outline and then click the

“Ungroup” button in the “Outline” group on the “Data” tab in the Ribbon. This will launch the “Ungroup”

dialog box from which you will select whether to ungroup the rows or columns of your selection. Then click

the “OK” button to remove the outlining from the selection’s columns or rows.

You can also apply an auto outline to an entire worksheet. Just select any cell in the worksheet area

and then click the drop-down “Group” button in the “Outline” group on the “Data” tab in the Ribbon. Select

the “Auto Outline” command from the drop-down menu of choices. The worksheet will be automatically

outlined depending on the logical structure that you have applied to the worksheet’s creation. It is quick and

easy to outline an entire worksheet this way.

To remove an auto outline that you have applied, just click the drop-down “Ungroup” button in the

“Outline” group on the “Data” tab in the Ribbon. Then select the “Clear Outline” command from the button’s

drop-down menu. This will remove any outlining from your worksheet.
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ACTIONS-

Outlining Worksheets

COLLAPSING AND EXPANDING AN OUTLINE:

1. To collapse an outline, click the minus sign (-) in the gray outline border over the columns or next to the 

rows that you want to collapse.

2. To expand an outline, click the plus sign (+) in the gray outline border over the columns or next to the 

rows that you want to expand.

3. You may also click the small “1” and “2” numbers at the left end or top of the outlined section to view the 

first level or second level of detail data.

APPLYING AND REMOVING OUTLINES:

1. You can apply an outline to a selected range of cells by first selecting the cell range to which you want 

to apply an outline and then clicking the “Group” button in the “Outline” group on the “Data” tab in the 

Ribbon. This will launch the “Group” dialog box where you select whether to group the rows or columns 

of your cell selection. Then click the “OK” button to group the selected columns or rows.

2. To remove an outline, just select the cell range to which you applied the outline and then click the 

“Ungroup” button in the “Outline” group on the “Data” tab in the Ribbon. This will launch the “Ungroup” 

dialog box from which you will select whether to ungroup the rows or columns of your selection. Then 

click the “OK” button to remove the outlining from the selection’s columns or rows.

3. You can also apply an auto outline to an entire worksheet. Just select any cell in the worksheet area 

and then click the drop-down “Group” button in the “Outline” group on the “Data” tab in the Ribbon. 

Select the “Auto Outline” command from the drop-down menu of choices. The worksheet will be 

automatically outlined depending on the logical structure that you have applied to the worksheet’s 

creation. It is quick and easy to outline an entire worksheet this way.

4. To remove an auto outline that you have applied, just click the drop-down “Ungroup” button in the 

“Outline” group on the “Data” tab in the Ribbon. Then select the “Clear Outline” command from the 

button’s drop-down menu. This will remove any outlining from your worksheet.
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EXERCISES-

Outlining Worksheets
Purpose:

1. To apply and remove an outline.

Exercises:

1. Open the “Inter- Sample” workbook.

2. Click the “Sheet3” worksheet.

3. Click into cell B9 in the worksheet.

4. Double-click the “AutoSum” button in the “Function Library” group on the “Formulas” tab in the

Ribbon.

5. Click the drop-down arrow below the “Group” button in the “Outline” group on the “Data” tab in the

Ribbon. Select the “Auto Outline” command from the button’s drop-down menu.

6. Click the small minus sign (-) that appears at the left edge of the screen to collapse the detail data.

7. Click the small plus sign (+) that appears at the left edge of the screen to expand the detail data.

8. Click the drop-down arrow below the “Ungroup” button in the “Outline” group on the “Data” tab in the

Ribbon. Select the “Clear Outline” command from the button’s drop-down menu.

9. Click the “Save” button in the Quick Access Toolbar to save your changes.

10. Click the “X” button in the upper right corner of the application window to exit.
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CHAPTER 19-

Consolidating Worksheets

19.1- Consolidating Data
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Consolidating Worksheets

19.1- Consolidating Data:

Consolidating data refers to making a worksheet that adds, subtracts, or performs some other

mathematical operation on information gathered from multiple other worksheets. For example, if you had a

workbook that had quarterly accounting balances on four separate worksheets, you could create a single

consolidated worksheet that adds the data from the four separate worksheets into a single annual

worksheet. You can consolidate data from up to 255 different sources. You can even create links to the

original source data from the consolidated sheet that will allow it to be updated when information in one of

the original worksheets changes. When used in this way, consolidating worksheets become akin to

performing a very large paste special.

Before you perform a consolidation, be sure that you have opened all of the workbooks that contain

data that you want to consolidate. You will need to make references to the cells that contain the data

needed for the consolidation, and the references are much easier to create when the workbooks are

opened.

Next, you must select the destination cell for the results first. This is the cell that will be used as the

upper left corner of the final, consolidated data. Once you have this cell selected, you can click the

“Consolidate” button in the “Data Tools” group on the “Data” tab in the Ribbon. This will open the

“Consolidate” dialog box.

In the “Consolidate” dialog box, you use the “Function:” drop-down to select the mathematical

operation you want to perform on the consolidated data.

Next, you need to enter references to the cells in the worksheets that you want to consolidate into

the “All references:” list. You use the “Reference:” text box to add the individual worksheet references to the

“All references:” list. To do this, click the “Expand/Collapse Dialog Box” button at the right end of the

“Reference:” text box to collapse the entire “Consolidate” dialog box down to only the “Reference:” line.

Then simply click on the worksheet that contains the first cell range that you want to consolidate. In this

worksheet, you then click and drag over the cells that you want to use as the first reference in your

consolidation. Then click the “Expand/Collapse Dialog Box” button at the right end of the “Reference:” text

box to expand the “Consolidate” dialog box back into view. To add the reference that you just made into the

“All references:” list, click the “Add” button to the right of the “All references:” list to add the reference

currently shown in the “Reference:” text box into the list. Then repeat the whole process of selecting cell

references until you have added all of the cell references needed by the consolidation into the “All

references:” list.

Next, you need to determine how to consolidate the information in the cell references. The

references can either be consolidated by category or by position. When you create a worksheet that is

consolidated by category, the row and/or column headings used in each reference become the categories

by which Excel will consolidate the data in the final consolidated worksheet. For example, if you are

consolidating multiple worksheets that have the exact same heading (“Quarter 1,” “Quarter 2,” etc…), then

you will probably want to consolidate by category. This allows Excel to use the headings to consolidate the

data, even if they aren’t in the same place within each worksheet from which you are consolidating!

Also note that when you consolidate by category it is imperative that you select the row and column

headings in addition to the data that you want to consolidate from each worksheet reference, so that Excel

can consolidate the data based on matching the category names. Note that you must check either or both

checkboxes for the “Top row” and/or “Left column” in the “Use label in” section in the lower left corner of the

“Consolidate” dialog box, based upon where the labels are in the cell references that you selected. Excel

will consolidate the data using the labels that are in the position that you indicate. This is a must when you

consolidate by category.

You can also choose to consolidate worksheet data by its position in the reference. In this case,
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Consolidating Worksheets

19.1- Consolidating Data (cont.):

Excel doesn’t care what the titles of the rows or columns are. They shouldn’t even be selected in your

references when consolidating by position. All that Excel needs to know when consolidating by position is

where the data is in the worksheet reference. If consolidating by position, you must use worksheets that

have the data that you want to consolidate in the exact same position in each referenced worksheet in order

for this to work properly and have the resultant consolidated data have any worthwhile meaning. When

using this method Excel simply performs consolidation of the data based on its physical location (cell

addresses) within the worksheet references that you select. Note that in order to consolidate by position,

you simply do not check anything in the “Use labels in” section of the “Consolidate” dialog box.

Finally, you must decide whether or not to check the checkbox for “Create links to source data.” This

checkbox, if checked, will create a link back to the original data sources in the final consolidated data,

updating the consolidation when the original data changes. If you choose this method, your resultant

consolidated data will contain actual references back to the source data cells. These inserted columns or

rows contain a reference to the original data. Excel then outlines and hides these references, so that the

consolidated data appears like a normal outlined worksheet. You can click the plus and minus signs on the

consolidated worksheet to view the detail data it received from the original worksheet references.

Note that if you do not check the “Create links to source data” checkbox, then Excel will simply insert

the consolidated data values into the destination area. However, if values in one of the original data source

changes, it will not update the consolidated data.

Once you are ready to perform the consolidation, just click the “OK” button in the “Consolidate”

dialog box.
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ACTIONS-

Consolidating Worksheets
CONSOLIDATING DATA:

1. Before you perform a consolidation, be sure that you have opened all of the workbooks that contain data 

that you want to consolidate.

2. Next, you must select the destination cell for the results first. This is the cell that will be used as the 

upper left corner of the final, consolidated data.

3. Once you have this cell selected, you can click the “Consolidate” button in the “Data Tools” group on the 

“Data” tab in the Ribbon. This will open the “Consolidate” dialog box.

4. In the “Consolidate” dialog box, you use the “Function:” drop-down to select the mathematical operation 

you want to perform on the consolidated data.

5. Next, you need to enter references to the cells in the worksheets that you want to consolidate into the 

“All references:” list. You use the “Reference:” text box to add the individual worksheet references to the 

“All references:” list.

6. To do this, click the “Expand/Collapse Dialog Box” button at the right end of the “Reference:” text box to 

collapse the entire “Consolidate” dialog box down to only the “Reference:” line.

7. Then simply click on the worksheet that contains the first cell range that you want to consolidate. In this 

worksheet, you then click and drag over the cells that you want to use as the first reference in your 

consolidation. Then click the “Expand/Collapse Dialog Box” button at the right end of the “Reference:” 

text box to expand the “Consolidate” dialog box back into view.

8. To add the reference that you just made into the “All references:” list, click the “Add” button to the right 

of the “All references:” list to add the reference currently shown in the “Reference:” text box into the list.

9. Then repeat steps 6 through 8 until you have added all of the cell references needed by the 

consolidation into the “All references:” list.

10. If consolidating by category, be sure to select the row and column headings in addition to the data that 

you want to consolidate from each worksheet reference, so that Excel can consolidate the data based 

on matching the category names. Note that you must check either or both checkboxes for the “Top row” 

and/or “Left column” in the “Use label in” section in the lower left corner of the “Consolidate” dialog box, 

based upon where the labels are in the cell references that you selected. Excel will consolidate the data 

using the labels that are in the position that you indicate. This is a must when you consolidate by 

category. 

11. If consolidating by position, you must use worksheets that have the data that you want to consolidate in 

the exact same position in each referenced worksheet in order for this to work properly. Also, you do not 

need to select the column or row labels in the individual references. When using this method Excel 

simply performs consolidation of the data based on its physical location (cell addresses) within the 

worksheet references that you select. Note that in order to consolidate by position, you simply do not 

check anything in the “Use labels in” section of the “Consolidate” dialog box. 

12. Finally, you must decide whether or not to check the checkbox for “Create links to source data.” This 

checkbox, if checked, will create a link back to the original data sources in the final consolidated data, 

updating the consolidation when the original data changes.

13. Note that if you do not check the “Create links to source data” checkbox, then Excel will simply insert the 

consolidated data values into the destination area. However, if values in one of the original data source 

changes, it will not update the consolidated data.

14. Once you are ready to perform the consolidation, just click the “OK” button in the “Consolidate” dialog 

box.
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EXERCISES-

Consolidating Worksheets
Purpose:

1. Consolidate worksheets by category.

Exercises:

1. Open the “Inter- Sample” workbook.

2. Select the “Sheet3” worksheet.

3. Click cell A12.

4. Click the “Consolidate” button in the “Data Tools” group on the “Data” tab in the Ribbon. This will

open the “Consolidate” dialog box.

5. From the “Function:” drop-down, select “Sum.”

6. Click into the “Reference” text box, and then click the red, white and blue “Collapse/Expand Dialog

Box” button at the right end of the “Reference” text box.

7. Click the “Sheet1” sheet, and select cells A3:B6.

8. Click the red, white and blue “Collapse/Expand Dialog Box” button at the right end of the

“Reference” text box to expand the “Consolidate” dialog box.

9. Click the “Add” button to add the selected reference to the “All references:” list.

10. Click the red, white and blue “Collapse/Expand Dialog Box” button at the right end of the

“Reference” text box to collapse the “Consolidate” dialog box again.

11. Click the “Sheet2” sheet, and select cells A3:B6.

12. Click the red, white and blue “Collapse/Expand Dialog Box” button at the right end of the

“Reference” text box to expand the “Consolidate” dialog box.

13. Click the “Add” button to add the selected reference to the “All references:” list.

14. Click the check box for “Left Column” in the “Use labels in” section.

15. Remove the checkbox from “Create links to data source,” if one is present.

16. Click the “OK” button.

17. Click the “Save” button in the Quick Access Toolbar to save your changes.

18. Click the “X” button in the upper right corner of the application window to exit.
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CHAPTER 20-

Creating Worksheet Charts

20.1- Creating Charts

20.2- Selecting Charts and Chart Elements

20.3- Moving and Resizing Charts

20.4- Changing the Chart Type

20.5- Changing the Data Range

20.6- Switching Column and Row Data

20.7- Choosing a Chart Layout

20.8- Choosing a Chart Style

20.9- Printing Charts

20.10- Deleting Charts
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Creating Worksheet Charts

20.1- Creating Charts:

Excel allows you to create charts from the data stored in a worksheet. This is useful for times when

you wish to create visual representations of the worksheet data for meeting, presentations or reports. To

insert a chart, first select the cell range that contains the data that will be used in the chart- including the row

and column labels. This allows the selected data to automatically be used in the chart, saving you the step

of having to select it later. Then click the “Insert” tab in the Ribbon. In the “Charts” button group, you can

see various type of charts that you can insert. To insert a chart based on the selected data, click on the

button that represents the general chart type that you want to use, and then click on the specific subtype to

use in the button’s drop-down menu. Alternately, you can click the “Create Chart” button in the lower right

corner of the “Charts” group to open the “Insert Chart” dialog box. Here you can select a major chart type

from the listing shown at the left side of the dialog box, and then select the specific subtype to use by

clicking on the desired subtype in the list at the right side of the dialog box. To then insert a chart of the

selected type, you can click the “OK” button. Using either method will insert a basic chart of the selected

subtype as an embedded chart object in the current worksheet.

The next thing that you should immediately notice is that when you have a chart object selected, you

will see a new contextual tab appear in the Ribbon. This is the “Chart Tools” tab, and it consists of three

separate tabs: “Design,” “Layout,” and “Format.” You will use the buttons that are in the various groups on

all three tabs within the “Chart Tools” contextual tab to make changes to the selected chart objects.

20.2- Selecting Charts and Chart Elements:

When you insert a new chart into a worksheet, the entire chart area will appear selected. You will

also see the “Chart Tools” contextual tabs appear in the Ribbon. First, you should become familiar with

selecting chart elements. Note that a chart is not simply a single object, but rather is a complex object that is

comprised of many other smaller, selectable objects. You should be aware of exactly what element in the

chart is selected before you begin any procedure, such as formatting or moving the chart itself or the

objects within the chart.

One way to select objects is by using your mouse. You can click on the individual elements within

the chart in order to select them. Note that in order to select the entire chart, you should click into the “Chart

Area.” That is the blank area that surrounds most of the actual elements of the chart. When the “Chart Area”

is selected you can then perform functions that affect the entire chart, such as moving the chart or

formatting the background of the chart. Inside of the chart area is the “Plot Area.” This is the area inside of

the “Chart Area,” where the actual graphic representation of your data is located. Inside of the “Plot Area,”

you can click on the graphic to select a series from your chart. You can then click on an individual point in a

series to select an individual point. Note that other chart elements, such as chart titles, data labels, and the

legend are all independently selectable. So, in summary, you should be aware of exactly what element

within the chart is selected before you perform an operation or function. Otherwise, you could inadvertently

make mistakes such as moving elements within the chart when you meant to move the entire chart, or

formatting the entire chart background when you meant to format only a single data series.

Another way to select a chart or many of the elements of a chart is by using the “Chart Elements”

drop-down in the “Current Selection” group on the “Layout” tab of the “Chart Tools” contextual tab in the

Ribbon. Use this drop-down to select the major elements within your chart. However, not all chart elements

are shown in the drop-down list. However, you can also click on chart elements with your mouse and then

inspect the value shown in the “Current Selection” drop-down to see exactly what you have selected within

your chart. This make a great double-check to ensure that you have the correct chart elements selected

before you begin a procedure.
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Creating Worksheet Charts

20.4- Changing the Chart Type:

After creating your chart, you can change the fundamental chart type, or choose a different sub-type

of the same general chart type that you initially selected. Either way, be aware that when you change the

chart type, you may lose some custom formatting that you have applied to the chart or you may need to

reposition custom elements that you have added to the chart area.

To change your chart type, simply select the chart or one of the chart elements. Next, click the

“Change Chart Type” button in the “Type” group on the “Design” tab of the “Chart Tools” contextual tab in

the Ribbon. In the “Change Chart Type” dialog box that appears, you can select the type of chart that you

want to use from the various chart types shown in the pane at the left side of the dialog box. When you do

that, the different sub-types of the selected chart type will appear in the scrolling list at the right side of the

dialog box. Click on the specific chart sub-type that you want to apply. Then click the “OK” button at the

bottom of this dialog box to change the selected chart type.

20.3- Moving and Resizing Charts:

When you insert a new chart into a worksheet, it will appear as an embedded chart object within the

worksheet. When a chart is embedded within a worksheet, you can move it around within the worksheet

and also resize it to the desired size. Before you do this, however, you will need to ensure that you have the

“Chart Area” selected. To select the “Chart Area,” you can either click into the blank area of the chart object

to select the entire chart or you can select the “Chart Area” choice from the “Chart Elements” drop-down in

the “Current Selection” group on the “Layout” tab of the “Chart Tools” contextual tab in the Ribbon.

To move the chart, just click and drag inside the “Chart Area” within the chart. The mouse pointer

will appear as a four-pointed arrow while the chart is being moved. You will also see the an outline of where

the chart will be placed when you release your mouse pointer. When the outline appears in the desired

location, release the mouse button to drop the chart into its new location within the worksheet.

To resize the chart, place your mouse pointer over one of the dotted resizing areas that appear at

the four corners and the four sides of the chart inside of the light blue border. When you are in the correct

position, you will see your mouse pointer become a double-pointed arrow. At that point, click and drag to

resize the chart area to your desired width and height.

Also, you may want the selected chart to appear as the only object in its own worksheet. You may

also want to move the chart to a different worksheet, but still have it remain as an embedded object within a

different worksheet. You can accomplish either task by selecting the chart area, and then clicking the “Move

Chart” button in the “Location” group on the “Design” tab of the “Chart Tools” contextual tab in the Ribbon.

Doing this will open the “Move Chart” dialog box. Here you can decide where to place your chart.

First, select either the option button for “New sheet:” or “Object in:,” as desired. If you choose “New

sheet:,” then type the name for the new worksheet into the text box to the right of the option button. This

option places the chart as the only object in its own worksheet. This maximizes the amount of space

available for plotting charted data. If you select the “Object in:” option, then use the drop-down to the right of

that option button to select the name of the worksheet into which you want to embed the selected chart

object. Once you have made your choice in this dialog box, click the “OK” button to move the chart.
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Creating Worksheet Charts

20.5- Changing the Data Range:

You can switch the range of data cells that are being used by a chart. If you accidentally selected

the wrong range of cells when you created the chart, or if you later want to switch the data that is being

shown in a chart that you have already created, it can be helpful to note that you can switch the data shown

in a chart without having to create a new chart object.

To change the data that is being plotted by a chart, select the chart or a chart element. Then click

the “Select Data” button in the “Data” group on the “Design” tab in the “Chart Tools” contextual tab within

the Ribbon. Doing that will open the “Select Data Source” dialog box. You use this dialog box to select

which cells in your worksheet contain the data and labels that you want to plot in your chart.

In the “Chart data range:” text box, you will see a range reference to the cells that have been

selected for the data. To change the data range, click the “Collapse/Expand Dialog Box” button at the right

end of the “Chart data range:” text box to collapse the “Select Data Source” dialog box. Now you should be

able to view the selected cells within the worksheet, which appear in the worksheet with a blinking marquee

encircling them. To select a new data range, just click and drag over the cells in the worksheet that contain

the new data that you want to show within the chart. Then click the “Collapse/Expand Dialog Box” button

again to show the “Select Data Source” dialog box. You can then just click the “OK” button to chart the

newly selected data using the same chart.

You can also use the “Select Data Source” dialog box to edit and modify the legend entries and axis

labels used by the chart. To do this, open the “Select Data Source” dialog box again by clicking the “Select

Data” button in the “Data” group on the “Design” tab in the “Chart Tools” contextual tab within the Ribbon.

In the “Source Data” dialog box, you will see the “Legend Entries (Series)” section and the

“Horizontal (Category) Axis Labels” section at the bottom of the dialog box. Also note that you can switch

the column and row data from your selection by clicking the “Switch Column/Row” button to switch what

data is being shown where within the chart.

In the “Legend Entries (Series)” section, you can click the “Add” button to add another series to your

chart. In the “Edit Series” dialog box that appears, you can click into the “Series name:” text box and then

click the worksheet cell that contains the value that you want to use as the label for the series. Alternately,

you can just type a name for the series directly into the text box provided. You then click into the “Series

values:” text box, and then click and drag over the cells in the worksheet that contain the values that you

want to display in the series. If needed, you can use the “Collapse/Expand Dialog Box” buttons to assist you

in selecting the cells. Once you have added the necessary cell references, just click the “OK” button to add

the series to the list shown in the “Legend Entries (Series)” list.

Also, you can edit a selected series in this list to change its title or the cells referenced by the series.

To do this, just select the series in the “Legend Entries (Series)” list that you want to change, and then click

the “Edit” button in the “Legend Entries (Series)” list. As when adding a new series, the “Edit Series” dialog

box appears. You can change the cell references shown in either the “Series name:” or “Series values:” text

boxes, just as you would if creating a new series. Once again, when finished, click the “OK” button to

change the series and return to the “Legend Entries (Series)” list in the “Select Data Source” dialog box.

To delete a series shown in the “Legend Entries (Series)” list in the “Select Data Source” dialog box,

just click on the name of the series within the list that you want to remove. Then click the “Remove” button

in this section to remove the series from being plotted within the chart. Note that this will not delete or

otherwise affect the cells used by the series, it simply removes them from the data that is being charted.

If you wish to change the order in which the series are plotted within the chart, start by selecting the

series whose position you wish to change from the “Legend Entries (Series)” list in the “Select Data Source”

dialog box. Then you can click the small “Move Up” and “Move Down” arrows in the “Legend Entries

(Series)” to change the order of the selected series within the series list.
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Creating Worksheet Charts

20.6- Switching Column and Row Data:

While it is possible to switch the charted display of the series and the categories by using the “Select

Data Source” dialog box, note that you can also just click the “Switch Row/Column” button in the “Data”

group on the “Design” tab on the “Chart Tools” contextual tab within the Ribbon to switch the charting of the

selected values between the column values and the row values. Each time you click this button, Excel will

toggle the data series being charted to the data contained either in the rows or the columns in the cell range

that you selected as the source data for your chart.

20.5- Changing the Data Range (cont.):

In the “Horizontal (Category) Axis Labels” section of the “Select Data Source” dialog box, you can

change which cells are used for the axis labels within your chart. To do this, just click the “Edit” button in the

“Horizontal (Category) Axis Labels” section in order to open the “Axis Labels” dialog box. Here you can

select the cell range that is shown in the “Axis label range:” text box, if needed and then click and drag over

the cells in your worksheet that contain the axis labels. Use the “Collapse/Expand Dialog Box” button, if

needed. Once you have selected these cells, just click the “OK” button to return to the “Select Data Source”

dialog box.

If you wish to set how the chart interprets hidden and empty cells that appear in your data range

selection, you can click the “Hidden and Empty Cells” button in the lower left corner of the “Select Data

Source” dialog box. In the “Hidden and Empty Cell Settings” dialog box that appears, you can choose the

display of empty cells by selecting the desired option from the “Show empty cells as:” section. You can

show them as “Gaps” in a line, “Zero” value points in a line, or you can “Connect data points with line.” Once

you have set your choice, you can check or uncheck the “Show data in hidden columns or rows” checkbox,

as desired. This defaults to being unchecked, which hides the display of data in hidden rows and columns

from your chart. You can check it if you wish to display that information within the chart. Once you have set

your choices for the display of hidden and empty cells, just click the “OK” button to return to the “Select Data

Source” dialog box. Once you have finished using the “Select Data Source” dialog box, just click the “OK”

button to apply your changes to your chart data.

20.7- Choosing a Chart Layout:

You can use one of the preset chart layouts to quickly and easily create a chart that contains the

chart elements that you want to show, including standard chart objects such as the legend, data labels, and

a chart title. To apply or change a chart layout, simply select a chart or an element within the chart, first.

Then click on the chart layout that you wish to apply to the selected chart from the list shown in the “Chart

Layouts” group on the “Design” tab of the “Chart Tools” contextual tab in the Ribbon.

20.8- Choosing a Chart Style:

You can use the chart styles that are available to quickly and easily apply a themed style to your

chart and its elements. To apply or change a chart style, simply select a chart or an element within the

chart, first. Then click on the chart style that you wish to apply to the selected chart from the list shown in

the “Chart Styles” group on the “Design” tab of the “Chart Tools” contextual tab in the Ribbon.
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Creating Worksheet Charts

20.9- Printing Charts:

To print a chart that is embedded in a worksheet without printing the rest of the worksheet, select the

chart or one of the elements of the chart, first. To print an embedded chart in a worksheet along with the

accompanying worksheet information, just click into one of the worksheet cells first. To print a chart that is

on its own page, just select the worksheet containing the chart.

Once you have made your selection, just print the chart as you normally would using the “Print”

command.

20.10- Deleting Charts:

To delete an embedded chart from a worksheet you must first select the chart area. You can do this

by selecting “Chart Area” from the “Chart Elements” drop-down menu in the “Current Selection” group on

the “Layout” tab in the “Chart Tools” contextual tab in the Ribbon. Next, press the “Delete” key on your

keyboard to delete the chart object from the worksheet.

If you have placed the chart on its own worksheet in the workbook, then you should delete the

worksheet that contains the chart in order to remove it from the workbook entirely. You can right-click on the

worksheet tab that contains the chart, and then choose the “Delete” command from the pop-up menu that

appears. In the confirmation message box that then opens, click the “Delete” button to permanently remove

the worksheet chart.
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ACTIONS-

Creating Worksheet Charts
CREATING A CHART WITH THE CHART WIZARD:

1. Select the cell range that contains the data that will be used in the chart- including the row and column 

labels. This allows the selected data to automatically be used in the chart, saving you the step of having 

to select it later.

2. Click the “Insert” tab in the Ribbon. In the “Charts” button group, you can see various type of charts that 

you can insert. To insert a chart based on the selected data, click on the button that represents the 

general chart type that you want to use, and then click on the specific subtype to use in the button’s 

drop-down menu.

3. Alternately, you can click the “Create Chart” button in the lower right corner of the “Charts” group to 

open the “Insert Chart” dialog box. Here you can select a major chart type from the listing shown at the 

left side of the dialog box, and then select the specific subtype to use by clicking on the desired subtype 

in the list at the right side of the dialog box. To then insert a chart of the selected type, you can click the 

“OK” button. Using either method will insert a basic chart of the selected subtype as an embedded chart 

object in the current worksheet.

4. The next thing that you should immediately notice is that when you have a chart object selected, you will 

see a new contextual tab appear in the Ribbon. This is the “Chart Tools” tab, and it consists of three 

separate tabs: “Design,” “Layout,” and “Format.” You will use the buttons that are in the various groups 

on all three tabs within the “Chart Tools” contextual tab to make changes to the selected chart objects.

SELECTING CHARTS AND CHART ELEMENTS:

1. One way to select chart objects is by using your mouse. You can click on the individual elements within 

the chart in order to select them. Note that in order to select the entire chart, you should click into the 

“Chart Area.” That is the blank area that surrounds most of the actual elements of the chart.

2. Another way to select a chart or many of the elements of a chart is by using the “Chart Elements” drop-

down in the “Current Selection” group on the “Layout” tab of the “Chart Tools” contextual tab in the 

Ribbon.

3. You can also click on chart elements with your mouse and then inspect the value shown in the “Current 

Selection” drop-down to see exactly what you have selected within your chart. This make a great 

double-check to ensure that you have the correct chart elements selected before you begin a 

procedure.

MOVING AND RESIZING CHARTS:

1. Select the “Chart Area,” you can either click into the blank area of the chart object to select the entire 

chart or you can select the “Chart Area” choice from the “Chart Elements” drop-down in the “Current 

Selection” group on the “Layout” tab of the “Chart Tools” contextual tab in the Ribbon.

2. To move the chart, just click and drag inside the “Chart Area” within the chart. The mouse pointer will 

appear as a four-pointed arrow while the chart is being moved. You will also see the an outline of where 

the chart will be placed when you release your mouse pointer. When the outline appears in the desired 

location, release the mouse button to drop the chart into its new location within the worksheet.

(cont.)
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ACTIONS-

Creating Worksheet Charts
MOVING AND RESIZING CHARTS (CONT.):

3. To resize the chart, place your mouse pointer over one of the dotted resizing areas that appear at the 

four corners and the four sides of the chart inside of the light blue border. When you are in the correct 

position, you will see your mouse pointer become a double-pointed arrow. At that point, click and drag to 

resize the chart area to your desired width and height.

4. If you want the selected chart to appear as the only object in its own worksheet, or if you want to move 

the chart to a different worksheet but still have it remain as an embedded chart, you can perform either 

task by selecting the chart area, and then clicking the “Move Chart” button in the “Location” group on the 

“Design” tab of the “Chart Tools” contextual tab in the Ribbon.

5. In the “Move Chart” dialog box that appears, select either the option button for “New sheet:” or “Object 

in:.” If you choose “New sheet:,” then type the name for the new worksheet into the text box to the right 

of the option button. If you select the “Object in:” option, then use the drop-down to the right of that 

option to select the name of the worksheet into which you want to embed the selected chart object.

6. Once you have made your choice in this dialog box, click the “OK” button to move the chart.

CHANGING THE CHART TYPE:

1. Select the chart or one of the chart elements.

2. Next, click the “Change Chart Type” button in the “Type” group on the “Design” tab of the “Chart Tools” 

contextual tab in the Ribbon.

3. In the “Change Chart Type” dialog box that appears, you can select the type of chart that you want to 

use from the various chart types shown in the pane at the left side of the dialog box. When you do that, 

the different sub-types of the selected chart type will appear in the scrolling list at the right side of the 

dialog box. Click on the specific chart sub-type that you want to apply.

4. Then click the “OK” button at the bottom of this dialog box to change the selected chart type.

CHANGING THE DATA RANGE:

1. To change the data that is being plotted by a chart, select the chart or a chart element. Then click the 

“Select Data” button in the “Data” group on the “Design” tab in the “Chart Tools” contextual tab within 

the Ribbon.

2. In the “Select Data Source” dialog box, you will see a range reference to the cells that have been 

selected for the data in the “Chart data range:” text box.

3. To change the data range, click the “Collapse/Expand Dialog Box” button at the right end of the “Chart 

data range:” text box to collapse the “Select Data Source” dialog box. You should be able to view the 

selected cells within the worksheet, which appear with a blinking marquee encircling them.

4. To select a new data range, just click and drag over the cells in the worksheet that contain the new data 

that you want to show within the chart.

5. Then click the “Collapse/Expand Dialog Box” button again to show the “Select Data Source” dialog box.

6. You can then just click the “OK” button to chart the newly selected data using the same chart.

7. To use the “Select Data Source” dialog box to edit and modify the legend entries and axis labels used 

by the chart, open the “Select Data Source” dialog box again by clicking the “Select Data” button in the 

“Data” group on the “Design” tab in the “Chart Tools” contextual tab within the Ribbon.

(cont.)
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ACTIONS-

Creating Worksheet Charts
CHANGING THE DATA RANGE (CONT.):

8. In the “Source Data” dialog box, you will see the “Legend Entries (Series)” section and the “Horizontal 

(Category) Axis Labels” section at the bottom of the dialog box. Note that you can switch the column 

and row data from your selection by clicking the “Switch Column/Row” button to switch what data is 

being shown where within the chart.

9. In the “Legend Entries (Series)” section, you can click the “Add” button to add another series to your 

chart. In the “Edit Series” dialog box that appears, you can click into the “Series name:” text box and 

then click the worksheet cell that contains the value that you want to use as the label for the series. 

Alternately, you can just type a name for the series directly into the text box provided. You then click into 

the “Series values:” text box, and then click and drag over the cells in the worksheet that contain the 

values that you want to display in the series. If needed, you can use the “Collapse/Expand Dialog Box” 

buttons to assist you in selecting the cells. Once you have added the necessary cell references, just 

click the “OK” button to add the series to the list shown in the “Legend Entries (Series)” list.

10. You can edit a selected series in this list to change its title or the cells referenced by the series. To do 

this, just select the series in the “Legend Entries (Series)” list that you want to change, and then click the 

“Edit” button in the “Legend Entries (Series)” list. As when adding a new series, the “Edit Series” dialog 

box appears. You can change the cell references shown in either the “Series name:” or “Series values:” 

text boxes, just as you would if creating a new series. When finished, click the “OK” button to change 

the series and return to the “Legend Entries (Series)” list in the “Select Data Source” dialog box.

11. To delete a series shown in the “Legend Entries (Series)” list in the “Select Data Source” dialog box, just 

click on the name of the series within the list that you want to remove. Then click the “Remove” button in 

this section to remove the series from being plotted within the chart. Note that this will not delete or 

otherwise affect the cells used by the series, it simply removes them from the data that is being charted.

12. If you wish to change the order in which the series are plotted within the chart, start by selecting the 

series whose position you wish to change from the “Legend Entries (Series)” list in the “Select Data 

Source” dialog box. Then you can click the small “Move Up” and “Move Down” arrows in the “Legend 

Entries (Series)” to change the order of the selected series within the series list.

13. In the “Horizontal (Category) Axis Labels” section of the “Select Data Source” dialog box, you can 

change which cells are used for the axis labels within your chart. To do this, just click the “Edit” button in 

the “Horizontal (Category) Axis Labels” section in order to open the “Axis Labels” dialog box. Here you 

can select the cell range that is shown in the “Axis label range:” text box, if needed and then click and 

drag over the cells in your worksheet that contain the axis labels. Use the “Collapse/Expand Dialog Box” 

button, if needed. Once you have selected these cells, just click the “OK” button to return to the “Select 

Data Source” dialog box.

14. If you wish to set how the chart interprets hidden and empty cells that appear in your data range 

selection, you can click the “Hidden and Empty Cells” button in the lower left corner of the “Select Data 

Source” dialog box. In the “Hidden and Empty Cell Settings” dialog box that appears, you can choose 

the display of empty cells by selecting the desired option from the “Show empty cells as:” section. You 

can show them as “Gaps” in a line, “Zero” value points in a line, or you can “Connect data points with 

line.” Once you have set your choice, you can check or uncheck the “Show data in hidden columns or 

rows” checkbox, as desired. This defaults to being unchecked, which hides the display of data in hidden 

rows and columns from your chart. You can check it if you wish to show that information within the chart.

15. Once you have set your choices for the display of hidden and empty cells, just click the “OK” button to 

return to the “Select Data Source” dialog box. Once you have finished using the “Select Data Source” 

dialog box, just click the “OK” button to apply your changes to your chart data.
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ACTIONS-

Creating Worksheet Charts
SWITCHING COLUMN AND ROW DATA:

1. To switch the charted display of the series and the categories in your selected chart, note that you can 

just click the “Switch Row/Column” button in the “Data” group on the “Design” tab on the “Chart Tools” 

contextual tab within the Ribbon to switch the charting of the selected values between the column 

values and the row values. Each time you click this button, Excel will toggle the data series being 

charted to the data contained either in the rows or the columns in the cell range that you selected as the 

source data for your chart.

CHOOSING A CHART LAYOUT:

1. To apply or change a chart layout, simply select a chart or an element within the chart, first.

2. Then click on the chart layout that you wish to apply to the selected chart from the list shown in the 

“Chart Layouts” group on the “Design” tab of the “Chart Tools” contextual tab in the Ribbon.

CHOOSING A CHART STYLE:

1. To apply or change a chart style, simply select a chart or an element within the chart, first.

2. Then click on the chart style that you wish to apply to the selected chart from the list shown in the “Chart 

Styles” group on the “Design” tab of the “Chart Tools” contextual tab in the Ribbon.

PRINTING CHARTS:

1. To print a chart that is embedded in a worksheet without printing the rest of the worksheet, select the 

chart or one of the elements of the chart, first.

2. To print an embedded chart in a worksheet along with the accompanying worksheet information, just 

click into one of the worksheet cells first.

3. To print a chart that is on its own page, just select the worksheet containing the chart.

4. Once you have made your selection, just print the chart as you normally would using the “Print” 

command.

DELETING CHARTS:

1. To delete an embedded chart from a worksheet you must first select the chart area. You can do this by 

selecting “Chart Area” from the “Chart Elements” drop-down menu in the “Current Selection” group on 

the “Layout” tab in the “Chart Tools” contextual tab in the Ribbon.

2. Next, press the “Delete” key on your keyboard to delete the chart object from the worksheet.

3. If you have placed the chart on its own worksheet in the workbook, then you should delete the 

worksheet that contains the chart in order to remove it from the workbook entirely. You can right-click on 

the worksheet tab that contains the chart, and then choose the “Delete” command from the pop-up 

menu that appears. In the confirmation message box that then opens, click the “Delete” button to 

permanently remove the worksheet chart.
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EXERCISES-

Creating Worksheet Charts
Purpose:

1. To be able to chart data shown in a worksheet.

Exercises:

1. Open the “Inter- Sample” workbook.

2. Select the “Sheet1” sheet.

3. Select the range of cells A2:B6.

4. Click the “Pie” button in the “Charts” group on the “Insert” tab in the Ribbon.

5. Select the “Pie” chart sub-type from the button’s drop-down menu to insert a standard pie chart.

6. Move the embedded chart so that its upper left corner covers cell D2.

7. Click the “Save” button in the Quick Access Toolbar to save your changes.

8. Click the “X” button in the upper right corner of the application window to close Excel.
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CHAPTER 21-

Editing and Formatting Charts

21.1- Formatting Chart Objects

21.2- Inserting Objects into a Chart

21.3- Changing Chart Labels

21.4- Changing Axes Display

21.5- Changing the Chart Background

21.6- Applying Chart Analysis Lines

21.7- Naming Charts

21.8- Applying Shape Styles to Chart Elements

21.9- Applying WordArt Styles to Chart Elements

21.10- Saving Custom Chart Templates
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Creating Worksheet Charts

21.1- Formatting Chart Objects:

You can change the formatting of all of your chart objects by simply selecting which object you want

to format, first. To select a chart object, you can either choose the name of the object that you want to select

from the “Chart Elements” drop-down in the “Current Selection” group on the “Layout” tab in the “Chart

Tools” contextual tab within the Ribbon, or you can simply click on them directly in the chart in order to

select them. Next, you can click the “Format Selection” button located drop-down in the “Current Selection”

group on the “Layout” tab in the “Chart Tools” contextual tab in the Ribbon.

When you do this, a “Format (object name)” dialog box will appear. The title of the dialog box, as

well as the categories that appear within the dialog box will change depending on which object you have

selected. Click a category shown at the left side of this dialog box in order to see your formatting options for

that category displayed at the right side of the dialog box. You can then change any formatting properties

shown in the right side of the dialog box. Note that the changes that you make in this dialog box are applied

to the selected chart object as soon as you make them. When you are done making your formatting

changes, click the “Close” button in the lower right corner of the dialog close the dialog box.

Note that if you began your formatting by applying a chart style, you can reset your chart’s formatting

back to the default style to remove any custom formatting that you have applied. To do this, just click the

“Reset to Match Style” button in the “Current Selection” group on the “Layout” tab in the “Chart Tools”

contextual tab in the Ribbon. When you click this button, the chart’s formatting will revert back to the default

chart style that was last applied- removing any custom formatting that you have applied.

21.2- Inserting Objects into a Chart:

You can add pictures, shapes and text boxes to a selected chart in order to place additional

information into your Excel charts. For example, if you wanted to add your company’s logo to the chart area,

or if you want to add more text to the chart, you can do so by using the buttons that are available in the

“Insert” group on the “Layout” tab of the “Chart Tools” contextual tab in the Ribbon.

To insert a picture that you have saved your computer into your chart, first select the chart area.

Next, click the “Picture” button in the “Insert” group on the “Layout” tab of the “Chart Tools” contextual tab in

the Ribbon. When you do that, the “Insert Picture” dialog box will appear. Use this dialog box to locate the

picture that you want to insert. Then select the image to insert and click the “Insert” button in this dialog box.

To insert a drawn shape into your chart area, first select the chart and then click the “Shapes” button

in the “Insert” group on the “Layout” tab of the “Chart Tools” contextual tab in the Ribbon. Next, select the

shape to draw from the drop-down list that appears. You can then simply double-click with your mouse at

the position within the chart at which you want to insert the type of shape that you selected.

If you want to add a text box into which you can enter additional text for your chart, then click the

“Text Box” button in the “Insert” group on the “Layout” tab of the “Chart Tools” contextual tab in the Ribbon.

Then click and drag over the area within the chart where you want to place the text box. You will then need

to enter the additional text that you want to have appear within the text box.

21.3- Changing Chart Labels:

You can change the appearance of the labels that are used in your chart by using the buttons that

are shown in the “Labels” group on the “Layout” tab of the “Chart Tools” contextual tab in the Ribbon. The

buttons that are shown in this group include the “Chart Title,” “Axis Titles,” “Legend,” “Data Labels,” and the
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Creating Worksheet Charts

21.3- Changing Chart Labels (cont.):

“Data Table” button. You can click on any one of these buttons to display a drop-down menu that shows

your placement and visibility options for the selected label object. You can click on the selection that you

want to make in order to apply it to the selected label type.

Also note that at the bottom of the drop-down menus, there is a general options that says “More

(object name) Options…” that you can select in order to open the “Format (object name)” dialog box. You

can change the settings in this dialog box to make additional adjustments to the label’s appearance within

the chart. When you have finished making your changes, just click the “Close” button in this dialog box.

21.4- Changing Axes Display:

You can change the display of the axes in your two-dimensional chart types, such as the column

and bar chart types. The buttons in the “Axes” group on the “Layout” tab in the “Chart Tools” contextual tab

in the Ribbon allow you to set the placement, labeling, and gridline appearance of the axes of the chart.

First, select the chart or an element in the chart whose axes you wish to format.

Next, you can click either the “Axes” or “Gridlines” buttons, depending upon what you want to format.

Then select which axis or axis gridlines you want to format by rolling over your desired choice in the drop-

down menu. You can then apply a selected formatting to the selected axis from the side menus that appear.

Using the “Axes” button you can change the positioning and labeling of the selected axis. Using the

“Gridlines” button you can change the appearance and labeling of the gridlines that appear on each axis.

Also note that, like the buttons in the “Labels” group, you can select the “More (object name)

Options…” choice in the drop-down menus that appear to open the “Format (object name)” dialog box. Here

you can set additional formatting options for the selected axis or axis gridlines. Once you have finished

making your custom formatting changes, you can then click the “Close” button to close this dialog box.

21.5- Changing the Chart Background:

You can change the display of the background of your chart using the buttons that are available in

the “Background” group on the “Layout” tab in the “Chart Tools” contextual tab within the Ribbon. The

buttons that are available within this group are “Plot Area,” “Chart Wall,” “Chart Floor,” and “3-D Rotation.”

Depending upon the chart type that you selected you may have only some of these buttons available. For

example, if you selected a 2-D chart style then the “3-D Rotation” button will be unavailable.

To use one of these buttons, click on the button that corresponds to the element of the chart

background that you want to format. Then select whether or not you want to hide the selected element, or

display the element with the default fill color applied in the chart. Note that these buttons also contain the

“More (object name) Options…” command at the bottom of each button’s drop-down menu. You can select

this command to open the “Format (object name)” dialog box. In this dialog box, you can change the

appearance of the selected element as desired using the categories and options shown. Once you have

finished applying your desired formatting changes, you can click the “Close” button to close the dialog box.Sam
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Creating Worksheet Charts

21.6- Applying Chart Analysis Lines:

If you select a chart type that makes uses of analysis lines, such as a “Line” or “Scatter” chart type,

then you can use the buttons that are available in the “Analysis” group on the “Layout” tab of the “Chart

Tools” contextual tab within the Ribbon to add lines that extend and enhance the information shown within

the selected chart. You can add normal trendlines and projected trendlines, error bars, up/down bars, and

drop lines to your data markers. The buttons included in this group are “Trendline,” “Lines,” “Up/Down Bars,”

and “Error Bars.”

To add one of these types of lines to your selected chart, just click the button that corresponds to the

type of line that you want to add and then select your desired choice of analysis line from the drop-down

menu that appears. For all of the buttons with the exception of the “Lines” button, you can also choose the

“More (object name) Options…” command at the bottom of the drop-down menu in order to open the

“Format (object name)” dialog box. You can then use the categories at the left side and their corresponding

options at the right side of the dialog box to set whatever formatting options you want to apply to the

analysis lines. Note that if you choose this option for applying some types of analysis lines, you may need to

select for which series in your chart you wish to add the analysis line in the “Add (object name)” dialog box

that appears. Then you can format the desired analysis line for the selected series, as desired.

21.7- Naming Charts:

You can click into the “Chart Name:” text box in the “Properties” group on the “Layout” tab of the

“Chart Tools” contextual tab within the Ribbon to type a name for your currently selected chart object. This

allows you to more easily refer to the chart if you have multiple charts in your workbook. This also assists in

giving the chart a name for use in VBA (Visual Basic for Applications) coding, if that is needed.

21.8- Applying Shape Styles to Chart Elements:

You can select any chart element within a chart and then apply formatting changes to the shape of

the selected chart element by using the preset object styles listed in the “Shape Styles” list in the “Shape

Styles” group on the “Format” tab of the “Chart Tools” contextual tab within the Ribbon. To do this, simply

select the chart element whose shape you wish to change, and then click on the desired preset shape style

in the list to apply it to the selected chart element.

To apply your own custom formatting, you can use the “Shape Fill,” “Shape Outline,” and “Shape

Effects” buttons to the selected chart element. If you want to customize the appearance of the inner fill effect

applied to your currently selected chart element, then click the “Shape Fill” button. In the drop-down menu

that appears, you can select a fill color, a picture, a gradient, or a texture to apply to the selected object.

If you want to customize the appearance of the formatting of the outline, border, or line that you have

selected in your chart, then click the “Shape Outline” button. In the drop-down menu that appears, you can

then select a color for the selected line. You can also roll your mouse pointer down to the “Weight,”

“Dashes,” or “Arrows” commands and then select a desired choice from the side menu that appears. Also

note that many of the side menus have a “More (object name)…” command available at the bottom of the

menu of choices. You can always select this command to open the “Format (object name)” dialog box,

where you can customize the appearance of the selected object down to the last detail. If you do open this

dialog box to make custom changes, just click the “Close” button to close it when you are finished.

You can also apply a custom effect to your selected chart element by clicking the “Shape Effects”

button and then rolling down to the general effect category that you want to apply in the drop-down menu
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Creating Worksheet Charts

21.8- Applying Shape Styles to Chart Elements (cont.):

that appears. You can then select the desired variant to apply in the side menu of category choices shown.

21.9- Applying WordArt Styles to Chart Elements:

You can select any chart element that contains text and apply preset WordArt formatting styles to it

in order to quickly format the appearance of the text within the selected chart element. To do this, first select

the chart element that contains text which you want to format. Then click on the desired WordArt style that

you wish to apply in the “WordArt Styles” list in the “WordArt Styles” group on the “Format” tab in the “Chart

Tools” contextual tab within the Ribbon.

If you wish to apply your own custom formatting to a selected text-containing chart element, you may

use the “Text Fill,” “Text Outline” and “Text Effects” buttons in the “WordArt Styles” group to apply your own

custom formatting to the selected text. If you click the “Text Fill” button, you will have the option of filling the

text in the shape with a selected color, a picture, a gradient, or a texture. You can use the “Text Outline”

button to select the color, weight, arrow, and dash style of the outline of the text within the selected chart

element. You can then use the “Text Effects” button to select an effect to apply to the text within the

selected chart element. Just roll your mouse pointer down to the category of effect that you want to apply to

the text, and then select a specific variant of that stylistic category from the side menu of choices that

appears.

21.10- Saving Custom Chart Templates:

Once you have a created a chart that you have formatted in the manner that you like, you can save

the chart as a custom chart template. Doing that will save any chart modifications that you have made as a

chart template. In the future, you can apply the custom chart template to other charts that you create. That

saves time by allowing you to apply a saved chart format without having to reformat each newly created

chart from scratch each time.

To save a customized chart as a template, just select the chart that you wish to save. Next, click the

“Save As Template” button in the “Type” group on the “Design” tab of the “Chart Tools” contextual tab within

the Ribbon. In the “Save Chart Template” dialog box that appears, type a name for the template into the

“File name:” text box. Do not change the location to which the file will be saved. Then click the “Save”

button to finish saving your chart template.

In the future, you can apply the saved custom chart template to any chart that you create. To do this,

select the chart to which you want to apply the custom chart template. Then click the “Change Chart Type”

button in the “Type” group on the “Design” tab of the “Chart Tools” contextual tab within the Ribbon. This

will open the “Change Chart Type” dialog box. Click the “Templates” category from the list at the left side of

this dialog box and then select the desired template to apply from the list of saved templates that appears at

the right side of the dialog box. Then click the “OK” button to apply the template to the selected chart.

When you want to delete the custom chart type that you have created, you can also do that by using

the “Change Chart Type” dialog box. In the “Change Chart Type” dialog box, click the “Manage

Templates…” button in the lower left corner of the dialog box. Doing this causes Windows to open the folder

where the template files are located on your computer. In the window that appears, select the name of the

chart template file that you created and now wish to delete from the list shown. Then press the “Delete” key

on your keyboard to delete the file. You can then close the window when you are finished. Then click the

“Close” button in the upper right corner of the “Change Chart Type” dialog box to close it.
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Editing and Formatting Charts
FORMATTING CHART OBJECTS:

1. Select the name of the chart object that you want to format from the “Chart Elements” drop-down in the 

“Current Selection” group on the “Layout” tab in the “Chart Tools” contextual tab in the Ribbon, or click 

on the chart object directly in the chart in order to select it.

2. Click the “Format Selection” button located drop-down in the “Current Selection” group on the “Layout” 

tab in the “Chart Tools” contextual tab in the Ribbon.

3. When you do this, a “Format (object name)” dialog box will appear. The title of the dialog box, as well as 

the categories that appear within the dialog box will change depending on which object you have 

selected.

4. Click a category shown at the left side of this dialog box in order to see your formatting options for that 

category displayed at the right side of the dialog box. You can then change any formatting properties 

shown in the right side of the dialog box. Note that the changes that you make in this dialog box are 

applied to the selected chart object as soon as you make them.

5. When you are done making your formatting changes, click the “Close” button in the lower right corner of 

the dialog close the dialog box.

6. You can reset your chart’s formatting back to the default style by clicking the “Reset to Match Style” 

button in the “Current Selection” group on the “Layout” tab in the “Chart Tools” contextual tab in the 

Ribbon.

INSERTING OBJECTS INTO A CHART:

1. You can add pictures, shapes and text boxes to a selected chart by using the buttons that are available 

in the “Insert” group on the “Layout” tab of the “Chart Tools” contextual tab in the Ribbon.

2. To insert a picture that you have saved your computer into your chart, first select the chart area.

3. Next, click the “Picture” button in the “Insert” group on the “Layout” tab of the “Chart Tools” contextual 

tab in the Ribbon. When you do that, the “Insert Picture” dialog box will appear. Use this dialog box to 

locate the picture that you want to insert.

4. Select the image to insert and click the “Insert” button in the “Insert Picture” dialog box.

5. To insert a drawn shape into your chart area, first select the chart and then click the “Shapes” button in 

the “Insert” group on the “Layout” tab of the “Chart Tools” contextual tab in the Ribbon.

6. Next, select the shape to draw from the drop-down list that appears. You can then simply double-click 

with your mouse at the position within the chart at which you want to insert the selected shape.

7. If you want to add a text box into which you can enter additional text for your chart, then click the “Text 

Box” button in the “Insert” group on the “Layout” tab of the “Chart Tools” contextual tab in the Ribbon.

8. Then click and drag over the area within the chart where you want to place the text box. You will then 

need to enter the additional text that you want to have appear within the text box.

Sam
ple

- fo
r e

va
lua

tio
n p

urp
os

es
 on

ly.



74Intermediate Excel©TeachUcomp, Inc.

ACTIONS-

Editing and Formatting Charts
CHANGING CHART LABELS:

1. You can change the appearance of the labels that are used in your chart by using the buttons that are 

shown in the “Labels” group on the “Layout” tab of the “Chart Tools” contextual tab in the Ribbon. The 

buttons that are shown in this group include the “Chart Title,” “Axis Titles,” “Legend,” “Data Labels,” and 

the “Data Table” button.

2. You can click on any one of these buttons to display a drop-down menu that shows your placement and 

visibility options for the selected label object.

3. You can click on the selection that you want to make in order to apply it to the selected label type.

4. Also note that at the bottom of the drop-down menus, there is a general options that says “More (object 

name) Options…” that you can select in order to open the “Format (object name)” dialog box.

5. You can change the settings in this dialog box to make additional adjustments to the label’s appearance 

within the chart.

6. When you have finished making your changes, just click the “Close” button in this dialog box.

CHANGING AXES DISPLAY:

1. The buttons in the “Axes” group on the “Layout” tab in the “Chart Tools” contextual tab in the Ribbon 

allow you to set the placement, labeling, and gridline appearance of the axes of the chart. To change 

the axes display, first select the chart or an element in the chart whose axes you wish to format. Using 

the “Axes” button you can change the positioning and labeling of the selected axis. Using the “Gridlines” 

button you can change the appearance and labeling of the gridlines that appear on each axis.

2. Next, you can click either the “Axes” or “Gridlines” buttons, depending upon what you want to format.

3. Then select which axis or axis gridlines you want to format by rolling over your desired choice in the 

drop-down menu.

4. You can then apply a selected formatting to the selected axis from the side menus that appear.

5. Also note that, like the buttons in the “Labels” group, you can select the “More (object name) Options…” 

choice in the drop-down menus that appear to open the “Format (object name)” dialog box.

6. Here you can set additional formatting options for the selected axis or axis gridlines.

7. Once you have finished making your custom formatting changes, you can then click the “Close” button 

to close this dialog box.

CHANGING THE CHART BACKGROUND:

1. You can change the display of the background of your chart using the buttons that are available in the 

“Background” group on the “Layout” tab in the “Chart Tools” contextual tab within the Ribbon. The 

buttons that are available within this group are “Plot Area,” “Chart Wall,” “Chart Floor,” and “3-D 

Rotation.” Depending upon the chart type that you selected you may have only some of these buttons 

available.

2. To use one of these buttons, click on the button that corresponds to the element of the chart background 

that you want to format.

3. Then select whether or not you want to hide the selected element, or display the element with the 

default fill color applied in the chart.

(cont.)
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ACTIONS-

Editing and Formatting Charts
CHANGING THE CHART BACKGROUND (CONT.):

4. Note that these buttons also contain the “More (object name) Options…” command at the bottom of 

each button’s drop-down menu. You can select this command to open the “Format (object name)” dialog 

box.

5. In this dialog box, you can change the appearance of the selected element as desired using the 

categories and options shown.

6. Once you have finished applying your desired formatting changes, you can click the “Close” button to 

close the dialog box.

APPLYING CHART ANALYSIS LINES:

1. If you select a chart type that makes uses of analysis lines, such as a “Line” or “Scatter” chart type, then 

you can use the buttons that are available in the “Analysis” group on the “Layout” tab of the “Chart 

Tools” contextual tab within the Ribbon to add lines that extend and enhance the information shown 

within the selected chart. You can add normal trendlines and projected trendlines, error bars, up/down 

bars, and drop lines to your data markers. The buttons included in this group are “Trendline,” “Lines,” 

“Up/Down Bars,” and “Error Bars.”

2. To add one of these types of lines to your selected chart, just click the button that corresponds to the 

type of line that you want to add and then select your desired choice of analysis line from the drop-down 

menu that appears.

3. For all of the buttons with the exception of the “Lines” button, you can also choose the “More (object 

name) Options…” command at the bottom of the drop-down menu in order to open the “Format (object 

name)” dialog box.

4. You can then use the categories at the left side and their corresponding options at the right side of the 

dialog box to set whatever formatting options you want to apply to the analysis lines. Note that if you 

choose this option for applying some types of analysis lines, you may need to select for which series in 

your chart you wish to add the analysis line in the “Add (object name)” dialog box that appears. Then 

you can format the desired analysis line for the selected series, as desired.

NAMING CHARTS:

1. You can click into the “Chart Name:” text box in the “Properties” group on the “Layout” tab of the “Chart 

Tools” contextual tab within the Ribbon to type a name for your currently selected chart.

APPLYING SHAPE STYLES TO CHART ELEMENTS:

1. You can select any chart element within a chart and then apply formatting changes to the shape of the 

selected chart element by using the preset object styles listed in the “Shape Styles” list in the “Shape 

Styles” group on the “Format” tab of the “Chart Tools” contextual tab within the Ribbon. To do this, 

simply select the chart element whose shape you wish to change, and then click on the desired preset 

shape style in the list to apply it to the selected chart element.

(cont.)
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ACTIONS-

Editing and Formatting Charts
APPLYING SHAPE STYLES TO CHART ELEMENTS (CONT.):

2. To apply your own custom formatting, you can use the “Shape Fill,” “Shape Outline,” and “Shape 

Effects” buttons to the selected chart element.

3. If you want to customize the appearance of the inner fill effect applied to your currently selected chart 

element, then click the “Shape Fill” button. In the drop-down menu that appears, you can select a fill 

color, a picture, a gradient, or a texture to apply to the selected object.

4. If you want to customize the appearance of the formatting of the outline, border, or line that you have 

selected in your chart, then click the “Shape Outline” button.

5. In the drop-down menu that appears, you can then select a color for the selected line. You can also roll 

your mouse pointer down to the “Weight,” “Dashes,” or “Arrows” commands and then select a desired 

choice from the side menu that appears.

6. Also note that many of the side menus have a “More (object name)…” command available at the bottom 

of the menu of choices. You can always select this command to open the “Format (object name)” dialog 

box, where you can customize the appearance of the selected object down to the last detail.

7. If you do open this dialog box to make custom changes, just click the “Close” button to close it when you 

are finished.

8. You can also apply a custom effect to your selected chart element by clicking the “Shape Effects” button 

and then rolling down to the general effect category that you want to apply in the drop-down menu that 

appears. You can then select the desired variant to apply in the side menu of category choices shown.

APPLYING WORDART STYLES TO CHART ELEMENTS:

1. Select the chart element that contains text which you want to format. Then click on the desired WordArt 

style that you wish to apply in the “WordArt Styles” list in the “WordArt Styles” group on the “Format” tab 

in the “Chart Tools” contextual tab within the Ribbon.

2. If you wish to apply your own custom formatting to a selected text-containing chart element, you may 

use the “Text Fill,” “Text Outline” and “Text Effects” buttons in the “WordArt Styles” group to apply your 

own custom formatting to the selected text.

3. If you click the “Text Fill” button, you will have the option of filling the text in the shape with a selected 

color, a picture, a gradient, or a texture.

4. You can use the “Text Outline” button to select the color, weight, arrow, and dash style of the outline of 

the text within the selected chart element.

5. You can then use the “Text Effects” button to select an effect to apply to the text within the selected 

chart element. Just roll your mouse pointer down to the category of effect that you want to apply to the 

text, and then select a specific variant of that stylistic category from the side menu of choices that 

appears.

Sam
ple

- fo
r e

va
lua

tio
n p

urp
os

es
 on

ly.



77Intermediate Excel©TeachUcomp, Inc.

ACTIONS-

Editing and Formatting Charts
SAVING CUSTOM CHART TEMPLATES:

1. Select the chart that you wish to save.

2. Next, click the “Save As Template” button in the “Type” group on the “Design” tab of the “Chart Tools” 

contextual tab within the Ribbon.

3. In the “Save Chart Template” dialog box that appears, type a name for the template into the “File name:” 

text box. Do not change the location to which the file will be saved. Then click the “Save” button to finish 

saving your chart template.

4. In the future, you can apply the saved custom chart template to any chart that you create. To do this, 

select the chart to which you want to apply the custom chart template.

5. Then click the “Change Chart Type” button in the “Type” group on the “Design” tab of the “Chart Tools” 

contextual tab within the Ribbon. This will open the “Change Chart Type” dialog box.

6. Click the “Templates” category from the list at the left side of this dialog box and then select the desired 

template to apply from the list of saved templates that appears at the right side of the dialog box.

7. Then click the “OK” button to apply the template to the selected chart.

8. When you want to delete the custom chart type that you have created, you can also do that by using the 

“Change Chart Type” dialog box.

9. In the “Change Chart Type” dialog box, click the “Manage Templates…” button in the lower left corner of 

the dialog box. Doing this causes Windows to open the folder where the template files are located on 

your computer.

10. In the window that appears, select the name of the chart template file that you created and now wish to 

delete from the list shown. Then press the “Delete” key on your keyboard to delete the file.

11. You can then close the window when you are finished.

12. Then click the “Close” button in the upper right corner of the “Change Chart Type” dialog box to close it.
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EXERCISES-

Editing and Formatting Charts
Purpose:

1. To be able to make formatting and layout modifications to a chart.

Exercises:

1. Open the “Inter- Sample” workbook.

2. Click the “Sheet1” sheet.

3. Click on the embedded pie chart on “Sheet1” that was created in the exercise from the last chapter.

4. Click the “Layout” tab in the “Chart Tools” contextual tab within the Ribbon.

5. Click the “Text Box” button in the “Insert” group.

6. Click and drag a small text box area in the lower left corner of the pie chart.

7. Type “Created by (your name).” into the text box.

8. Click on the “Legend” in the chart in order to select it.

9. Click the “Format” tab in the “Chart Tools” contextual tab within the Ribbon.

10. Click on “Colored Outline- Aqua, Accent 5” in the “Shape Styles” list to apply it to the legend.

11. Use the “Current selection” drop-down in the “Current Selection” group to choose “Series “Q1

Sales:”” from the drop-down.

12. Click the “Shape Effects” button in the “Shape Styles” group.

13. Roll your mouse pointer down to the “Shadow” category in the button’s drop-down menu.

14. Select the “Offset Diagonal Bottom Right” shadow in the “Outer” subcategory in the side menu that

appears to apply that shadow style to the pie.

15. Use the “Current selection” drop-down in the “Current Selection” group to choose “Chart Title” from

the drop-down.

16. Select the “Fill- White, Drop Shadow” WordArt style shown in the “WordArt Styles” group to apply

the selected style to the chart title.

17. Click the “Save” button in the Quick Access Toolbar to save your changes.

18. Click the “X” button in the upper right corner of the application window to exit.
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CHAPTER 22-

PivotTables

22.1- Creating PivotTables and PivotCharts

22.2- Manipulating a PivotTable

22.3- Changing Calculated Value Fields

22.4- Applying PivotTable Styles

22.5- Creating a PivotChart

22.6- Setting PivotTable Options

22.7- Sorting and Filtering PivotTable Data
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PivotTables

22.1- Creating Pivot Tables and PivotCharts:

You can use the PivotTable feature of Excel to access some of the most powerful data-analysis that

Excel can provide. PivotTables allow you to organize massive amounts of data in more coherent and

meaningful ways to extract from the data exactly what you want to know. Probably the most helpful feature

of PivotTables is the ability that they have to be reorganized quickly and easily to change what information

they are displaying and calculating. When you create a PivotTable, you are comparing information in your

worksheet and then calculating intersecting values of your choosing. In addition to the PivotTables, you can

also create PivotCharts, which use the data from PivotTables but display it in a graphic format.

The best way to learn how to use PivotTables is to actually create one with which you can

experiment and practice. Excel makes it easy to create a PivotTable from your data. To create a PivotTable,

first select the worksheet that contains the data from which you want to create a PivotTable. Next, click the

“Insert” tab in the Ribbon. Click the “PivotTable” drop-down button in the “Tables” group and choose either

the “PivotTable” or “PivotChart” command, as desired.

Either way, next you will see the “Create PivotTable” dialog box appear. Here you must select the

source of data for the PivotTable. Your choices are: “Select a table or range,” which pulls the data from your

Excel worksheet, or “Use an external data source,” which allows you to use data from a query or an open

database connection.

Below that area, you have to select whether you want to place the PivotTable or PivotChart into a

new worksheet or an existing worksheet. If you click the “Existing Worksheet” choice, then you’ll have to

click into the “Location:” text box and then click into the worksheet to select the cell that will become the

upper left corner of the PivotTable or PivotChart. When you are finished, click “OK” to create your new

PivotTable or PivotChart.

Next you will see the “PivotTable Field List” task pane appear at the side of your workbook window.

If you elected to create a PivotChart, you will see the “PivotChart Filter Pane” appear. In the “PivotTable

Field List” pane, you will see the information from your data source. Now you have to click the checkbox

next to each field in the “Choose fields to add to report:” section that you want to add to the PivotTable. As

you check each field, Excel will add it into one of the four quadrants shown in the “Drag fields between

areas below:” section at the bottom of the task pane. For PivotTables, these fields are “Report Filter,”

“Column Labels,” “Row Labels,” and “Values.” For PivotCharts these fields are “Report Filter,” “Legend

Fields (Series),” “Axis Fields (Categories),” or “Values.” At that point, you can click and drag the fields

shown from one quadrant to another, based on what function or layout you want the PivotTable to show.

Note fields that are placed into the “Values” section are calculated using the SUM function, by default.

22.2- Manipulating a PivotTable:

Now you will see the ways that you can alter a PivotTable to change what data is displayed and

calculated within the PivotTable. As was seen in the last lesson, you can check and uncheck the fields

shown in the “Choose fields to add to report:” list within the “PivotTable Field List” task pane to show or hide

their display in the PivotTable. Once the fields have been added to any one of the four quadrants shown at

the bottom of the task pane, you may click and drag the fields shown in these areas from one quadrant to

another in order to rearrange the display of the data, if needed.

When working with the fields in your PivotTable, note that if you click into a worksheet cell outside of

the PivotTable area, the PivotTable will become de-selected and the “PivotTable Field List” will be hidden.

You can simply click back into a cell within the PivotTable to reactivate the PivotTable and display the

“PivotTable Field List” again.

You can also filter what information is displayed within each of the columns and rows. Notice that
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PivotTables

22.2- Manipulating a PivotTable (cont.):

each time that you add fields to the PivotTable, the field will appear with a small drop-down arrow to the

right of the field name within the actual PivotTable. You can click this drop-down arrow to show a menu

listing all of the unique values within that column or row. Values that are checked will display in the

PivotTable and values that are unchecked will be hidden from the PivotTable. You can check and uncheck

the values in each column or row, as needed, to display just the data that you want to see. When you are

finished checking and unchecking value items in the drop-down menu, click “OK” at the bottom to set your

filter choices. Note that you can select the “(Select All)” option at the top of the manual filter list in order to

select all values in the field for display once again.

You can also make use of the buttons shown in the “Options” and “Design” tabs of the “PivotTable

Tools” contextual tab within the Ribbon to change the appearance of your PivotTable data. The “Expand

Entire Field” and “Collapse Entire Field” buttons in the “Active Field” group on the “Options” tab can be used

to collapse and expand the detail data for any selected field in an outlined group. In this same group, you

can click the “Field Settings” button to open a dialog box where you can change the settings of the currently

selected field within the PivotTable.

Also, if you need to enable the display of the “Field List” for any reason, you can click the “Field List”

button in the “Show/Hide” group on the “Options” tab in order to show and hide the “PivotTable Field List” in

the program.

22.3- Changing Calculated Value Fields:

When you add a field into the “Values” section of the “PivotTable Field List” task pane, the

information in the field is added together using the Sum function. You can change the function used, if you

wish. There are also several other features of value fields that you can alter, if desired.

To change the properties of your value fields, click the small drop-down arrow to the right of the field

name displayed in the “Values” section of the “PivotTable Field List.” Select the “Value Field Settings…”

command from the pop-up menu that appears. Doing this will open the “Value Field Settings” dialog box.

The “Source Name:” field shows the original field name from which the value field derives its data.

You can type a name for the field to display in the PivotTable into the “Custom Name:” text box. On the

“Summarize by” tab, click on the name of the function by which you wish to summarize the source field

selected. You can click the “Number Format” button in the lower left corner of this dialog box to open a

simplified version of the “Format Cells” dialog box which you can use to set the appearance of the numeric

formatting used by the numbers in the selected PivotTable value field. Then you can click the “OK” button to

return to the “Value Field Settings” dialog box.

You can click the “Show values as” tab in the “Value Field Settings” dialog box, to select how you

want to show the data from the field. You can select another summarization option from the “Show values

as:” drop-down. You can compare the values listed in the rows or columns as a percentage of the column,

row, or field total. You can also choose to show the number as the difference of another field. If you select a

comparison option that requires you to select another field against which you wish to compare the value,

you can select that field’s name from the “Base field:” list and then select the value against which to

compare from that field from the “Base item:” list. Once you have set the options that you want for your

value field, click the “OK” button to set the appearance of the value field.
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PivotTables

22.4- Applying PivotTable Styles:

You can use PivotTable styles to apply preset formatting to your PivotTables in Excel. To do this,

just click into any cell within your PivotTable. Then click on the desired style that you want to apply in the

listing of PivotTable styles shown in the “PivotTable Styles” group on the “Design” tab of the “PivotTable

Tools” contextual tab within the Ribbon.

You can modify the settings of the preset PivotTable styles by checking the desired checkboxes in

the “PivotTable Style Options” group on the “Design” tab of the “PivotTable Tools” contextual tab within the

Ribbon. Doing this will allow you to select the areas within the PivotTable to which special formatting is

applied. You can select to apply special formatting to the “Row Headers” and “Column Headers” by

checking those checkboxes. You can also apply banding to the row or columns within the PivotTable by

checking the “Banded Rows” or “Banded Columns” checkboxes.

22.5- Creating a PivotChart:

A PivotChart shows the data from an associated PivotTable in a graphic format. You can easily

create a PivotChart from the data that is displayed in your PivotTable after you have created the PivotTable

if you didn’t create one when you initially created the PivotTable.

To create a PivotChart to accompany your PivotTable, click into the PivotTable that you want to view

as a PivotChart. Then click the “PivotChart” button in the “Tools” group on the “Options” tab of the

“PivotTable Tools” contextual tab within the Ribbon.

When you do this, Excel will open the “Insert Chart” dialog box. Here you will select the chart type

and specific subtype that you want to use to represent the data from your PivotTable. Then click the “OK”

button to insert the selected chart into the worksheet. You can click the drop-down arrows in the “PivotTable

Field List” to filter what data is shown within the PivotChart, just like you can do with the PivotTable. Also

note that changes that you make to one object will be reflected in the other, as the PivotTable is just the

data source for the PivotChart.

22.6- Setting PivotTable Options:

If you wish to view and edit your general PivotTable options, you can do so by clicking “Options”

button in the “PivotTable” group on the “Options” tab in the “PivotTable Tools” contextual tab within the

Ribbon. Doing this will open the “PivotTable Options” dialog box where you can set several properties that

control the appearance and behavior of the selected PivotTable.

At the top of this dialog box, you can type a name for the PivotTable into the “Name:” text box.

Below that, you have several tabs that represent the various PivotTable option categories.

In the “Layout & Format” tab, you can check or uncheck the options shown in order to set the

appearance of the PivotTable data. You can click the “Totals & Filters” tab to change the display of totals

and subtotals in the PivotTable and also set the general filtering and sorting behaviors you have available.

On the “Display” tab, you can set options that determine the appearance of the PivotTable in the worksheet.

You can click the “Printing” tab to set the appearance of the PivotTable when printed. Finally, on the “Data”

tab, you can set options that control the relationship that is shared between the PivotTable and its source

data in the worksheet. After setting or removing any additional options that you want your PivotTable to

posses in these tabs, click the “OK” button to set the options for the selected PivotTable.
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PivotTables

22.7- Sorting and Filtering PivotTable Data:

You can sort and filter the data by using the drop-down fields that you have added to the PivotTable.

If you click the drop-down arrow next to a selected data field, you will see a pop-up menu that shows you

the sorting and filtering options that you have available.

You can select the “Sort A to Z” command to sort the field data in ascending order. You can choose

the “Sort Z to A” to sort the field data in descending order. You can also select the “More Sort Options…”

command in order to show the “Sort” dialog box. Here you can set any more advanced sorting options that

you wish, and then click the “OK” button to apply them to your field data.

You can also apply filtering to a data field in order to include or exclude data records from display

within the PivotTable. To manually select which field values to display, simply check or uncheck the values

listed in the field’s drop-down listing. You can also select either the “Label Filters” or “Value Filters”

commands in order to display a side menu of comparison choices. You can then select the desired

comparison operator from the side menu to display a “Value Filter” dialog box. Here you can enter the value

or values needed in order to filter the field’s data.

If, after applying a filter, you want to show all of the field’s values again, you can click the field’s

drop-down arrow button and then select either the “(Select All)” checkbox or select the “Clear Filter”

command from the drop-down menu.
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ACTIONS-

PivotTables
CREATING PIVOTTABLES OR PIVOTCHARTS:

1. To create a PivotTable, first select the worksheet that contains the data from which you want to create a 

PivotTable.

2. Next, click the “Insert” tab in the Ribbon. Click the “PivotTable” drop-down button in the “Tables” group 

and choose either the “PivotTable” or “PivotChart” command, as desired.

3. Either way, next you will see the “Create PivotTable” dialog box appear. Here you must select the 

source of data for the PivotTable. Your choices are: “Select a table or range,” which pulls the data from 

your Excel worksheet, or “Use an external data source,” which allows you to use data from a query or 

an open database connection.

4. Below that area, you have to select whether you want to place the PivotTable or PivotChart into a new 

worksheet or an existing worksheet. If you click the “Existing Worksheet” choice, then you’ll have to click 

into the “Location:” text box and then click into the worksheet to select the cell that will become the 

upper left corner of the PivotTable or PivotChart. When you are finished, click “OK” to create your new 

PivotTable or PivotChart.

5. Next you will see the “PivotTable Field List” task pane appear at the side of your workbook window. If 

you elected to create a PivotChart, you will see the “PivotChart Filter Pane” appear. In the “PivotTable 

Field List” pane, you will see the information from your data source. Now you have to click the checkbox 

next to each field in the “Choose fields to add to report:” section that you want to add to the PivotTable.

6. As you check each field, Excel will add it into one of the four quadrants shown in the “Drag fields 

between areas below:” section at the bottom of the task pane. For PivotTables, these fields are “Report 

Filter,” “Column Labels,” “Row Labels,” and “Values.” For PivotCharts these fields are “Report Filter,” 

“Legend Fields (Series),” “Axis Fields (Categories),” or “Values.”

7. At that point, you can click and drag the fields shown from one quadrant to another, based on what 

function or layout you want the PivotTable to show. Note fields that are placed into the “Values” section 

are calculated using the SUM function, by default.

MANIPULATING A PIVOTTABLE:

1. You can check and uncheck the fields shown in the “Choose fields to add to report:” list within the 

“PivotTable Field List” task pane to show or hide their display within the PivotTable.

2. Once the fields have been added to any one of the four quadrants shown at the bottom of the task pane, 

you may click and drag the fields shown in these areas from one quadrant to another in order to 

rearrange the display of the data, if needed.

3. When working with the fields in your PivotTable, note that if you click into a worksheet cell outside of the 

PivotTable area, the PivotTable will become de-selected and the “PivotTable Field List” will be hidden. 

You can simply click back into a cell within the PivotTable to reactivate the PivotTable and display the 

“PivotTable Field List” again.

4. You can click the small drop-down arrow to the right of any field name within the actual PivotTable to 

show a menu listing all of the unique values within that column or row. Values that are checked will 

display in the PivotTable and values that are unchecked will be hidden from the PivotTable. You can 

check and uncheck the values in each column or row, as needed, to display just the data that you want 

to see. When you are finished checking and unchecking value items in the drop-down menu, click “OK” 

at the bottom to set your filter choices. Note that you can select the “(Select All)” option at the top of the 

manual filter list in order to select all values in the field for display once again.

(cont.)
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ACTIONS-

PivotTables
MANIPULATING A PIVOTTABLE (CONT.):

5. You can also make use of the buttons shown in the “Options” and “Design” tabs of the “PivotTable 

Tools” contextual tab within the Ribbon to change the appearance of your PivotTable data. The “Expand 

Entire Field” and “Collapse Entire Field” buttons in the “Active Field” group on the “Options” tab can be 

used to collapse and expand the detail data for any selected field in an outlined group.

6. In this same group, you can click the “Field Settings” button to open a dialog box where you can change 

the settings of the currently selected field within the PivotTable.

7. Also, if you need to enable the display of the “Field List” for any reason, you can click the “Field List” 

button in the “Show/Hide” group on the “Options” tab in order to show and hide the “PivotTable Field 

List” in the program.

CHANGING CALCULATED VALUE FIELDS:

1. To change the properties of your value fields, click the small drop-down arrow to the right of the field 

name displayed in the “Values” section of the “PivotTable Field List.”

2. Select the “Value Field Settings…” command from the pop-up menu that appears. Doing this will open 

the “Value Field Settings” dialog box.

3. The “Source Name:” field shows the original field name from which the value field derives its data.

4. You can type a name for the field to display in the PivotTable into the “Custom Name:” text box.

5. On the “Summarize by” tab, click on the name of the function by which you wish to summarize the 

source field selected.

6. You can click the “Number Format” button in the lower left corner of this dialog box to open a simplified 

version of the “Format Cells” dialog box which you can use to set the appearance of the numeric 

formatting used by the numbers in the selected PivotTable value field. Then you can click the “OK” 

button to return to the “Value Field Settings” dialog box.

7. You can click the “Show values as” tab in the “Value Field Settings” dialog box, to select how you want 

to show the data from the field.

8. You can select another summarization option from the “Show values as:” drop-down. You can compare 

the values listed in the rows or columns as a percentage of the column, row, or field total. You can also 

choose to show the number as the difference of another field. If you select a comparison option that 

requires you to select another field against which you wish to compare the value, you can select that 

field’s name from the “Base field:” list and then select the value against which to compare from that field 

from the “Base item:” list.

9. Once you have set the options that you want for your value field, click the “OK” button to set the 

appearance of the value field.

APPLYING PIVOTTABLE STYLES:

1. Click into any cell within your PivotTable and then click on the desired style that you want to apply in the 

listing of PivotTable styles shown in the “PivotTable Styles” group on the “Design” tab of the “PivotTable 

Tools” contextual tab within the Ribbon.

2. You can modify the settings of the preset PivotTable styles by checking the desired checkboxes in the 

“PivotTable Style Options” group on the “Design” tab of the “PivotTable Tools” contextual tab within the 

Ribbon.
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ACTIONS-

PivotTables
CREATING A PIVOTCHART:

1. To create a PivotChart to accompany your PivotTable, click into the PivotTable that you want to view as 

a PivotChart.

2. Then click the “PivotChart” button in the “Tools” group on the “Options” tab of the “PivotTable Tools” 

contextual tab within the Ribbon.

3. When you do this, Excel will open the “Insert Chart” dialog box. Here you will select the chart type and 

specific subtype that you want to use to represent the data from your PivotTable. Then click the “OK” 

button to insert the selected chart into the worksheet.

4. You can click the drop-down arrows in the “PivotTable Field List” to filter what data is shown within the 

PivotChart, just like you can do with the PivotTable.

5. Also note that changes that you make to one object will be reflected in the other, as the PivotTable is 

just the data source for the PivotChart.

SETTING PIVOTTABLE OPTIONS:

1. If you wish to view and edit your general PivotTable options, you can do so by clicking “Options” button 

in the “PivotTable” group on the “Options” tab in the “PivotTable Tools” contextual tab within the Ribbon.

2. In the “PivotTable Options” dialog box, you can type a name for the PivotTable into the “Name:” text 

box.

3. On the “Layout & Format” tab, you can check or uncheck the options shown in order to set the 

appearance of the PivotTable data.

4. You can click the “Totals & Filters” tab to change the display of totals and subtotals in the PivotTable 

and also set the general filtering and sorting behaviors you have available.

5. On the “Display” tab, you can set options that determine the appearance of the PivotTable in the 

worksheet.

6. You can click the “Printing” tab to set the appearance of the PivotTable when printed.

7. Finally, on the “Data” tab, you can set options that control the relationship that is shared between the 

PivotTable and its source data in the worksheet.

8. After setting or removing any additional options that you want your PivotTable to posses in these tabs, 

click the “OK” button to set the options for the selected PivotTable.

SORTING AND FILTERING PIVOTTABLE DATA:

1. If you click the drop-down arrow next to a selected data field within the PivotTable, you will see a pop-up 

menu that shows you the sorting and filtering options that you have available.

2. You can select the “Sort A to Z” command to sort the field data in ascending order.

3. You can choose the “Sort Z to A” to sort the field data in descending order.

4. You can also select the “More Sort Options…” command in order to show the “Sort” dialog box. Here 

you can set any more advanced sorting options that you wish, and then click the “OK” button to apply 

them to your field data.

5. To manually select which field values to display, simply check or uncheck the values listed in the field’s 

drop-down listing.

6. You can also select either the “Label Filters” or “Value Filters” commands in order to display a side 

menu of comparison choices.

(cont.)
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ACTIONS-

PivotTables
SORTING AND FILTERING PIVOTTABLE DATA (CONT.):

7. You can then select the desired comparison operator from the side menu to display a “Value Filter” 

dialog box. Here you can enter the value or values needed in order to filter the field’s data.

8. After applying a filter, if you want to show all of the field’s values again, you can click the field’s drop-

down arrow button and then select either the “(Select All)” checkbox or select the “Clear Filter” 

command from the drop-down menu.
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EXERCISES-

PivotTables
Purpose:

1. There are no exercises for this chapter.

Exercises:

1. None.
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Excel Keyboard Shortcuts

Category: Using Windows

Command Key

Switch to the next window Alt + Tab

Switch to previous window Alt + Shift + Tab

Close window Ctrl + W or Ctrl + F4

Restore window after maximizing it Alt + F5

Move clockwise to task pane F6

Move counterclockwise to next task pane Shift + F6

Switching windows when multiple windows 

are open

Ctrl + F6

Switch to previous window Ctrl + Shift + F6

Maximize/Restore window Ctrl + F10

Copy screen to clipboard Print Screen

Copy window to clipboard Alt + Print Screen

Category: Using Dialog Boxes

Command Key

Switch between screen and dialog box (if 

possible)

Alt + F6

Move to next option Tab

Move to previous option Alt + Tab

Move to next tab Ctrl + Tab

Move to previous tab Ctrl + Shift + Tab

Move between options in a drop-down 

menu or option group

Arrow keys

Perform button action or select/clear a 

checkbox

Spacebar

Select an option or select/clear a checkbox Alt + underlined letter 

in option

Open a drop-down menu Alt + Down Arrow

Select drop-down option First letter of option

Close list/ Cancel Esc

Run command Enter

Category: Text

Command Key

Move to start of text Home

Move to end of text End

Move left one character Left Arrow

Move right one character Right Arrow

Move one word to left Ctrl + Left Arrow

Move right one word Ctrl + Right Arrow

Select/Deselect to left Shift + Left Arrow

Select/Deselect to right Shift + Right Arrow

Select/Deselect word left Ctrl + Shift + Left Arrow

Select/Deselect word right Ctrl + Shift + Right Arrow

Select to beginning Shift + Home

Select to end Shift + End

Category: Using the “Open” and “Save As” Dialog Boxes

Command Key

Show “Open” dialog box Ctrl + O or Ctrl + F12

Show “Save As” dialog box F12

Move to previous folder Alt + 1

Move up one level Alt + 2

Delete selected folder/file Del or Delete

Create new folder Alt + 4

Switch folder view Alt + 5

Show shortcut menu Shift + F10

Move between options Tab

Open the “Look in” list F4 or Alt + I

Category: Undoing and Redoing Actions

Command Key

Cancel action Esc

Undo Action Ctrl + Z

Redo/Repeat Action Ctrl + Y
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Excel Keyboard Shortcuts

Category: Moving and Scrolling in Worksheets/Workbooks

Command Key

Move one cell up, down, left or right Arrow Keys

Move to the edge of the current data region CTRL+ arrow key

Move to the beginning of the row HOME

Move to the beginning of the worksheet CTRL + HOME

Move to the last cell on the worksheet CTRL + END

Move down one screen PAGE DOWN

Move up one screen PAGE UP

Move one screen to the right ALT + PAGE DOWN

Move one screen to the left ALT + PAGE UP

Move to the next sheet in the workbook CTRL + PAGE DOWN

Move to the previous sheet in the workbook CTRL + PAGE UP

Category: Entering Data

Command Key

Complete a cell entry and move down in 

the selection

ENTER

Start a new line in the same cell ALT + ENTER

Fill the selected cell range with the current 

entry

CTRL + ENTER

Complete a cell entry and move up in the 

selection

SHIFT + ENTER

Complete a cell entry and move to the right 

in the selection

TAB

Complete a cell entry and move to the left 

in the selection

SHIFT + TAB

Cancel a cell entry ESC

Delete the character to the left of the 

insertion point, or delete the selection

DELETE

Delete text to the end of the line CTRL + DELETE

Move one character up, down, left or right Arrow Keys

Move to the beginning of the line HOME

Repeat the last action F4 or CTRL + Y

Category: Selecting Cells, Columns, or Rows

Command Key

Extend the selection by one cell SHIFT + arrow key

Extend the selection to the last 

nonblank cell in the same column or 

row as the active cell

CTRL + SHIFT + 

arrow key

Extend the selection to the beginning 

of the row

SHIFT + HOME

Extend the selection to the beginning 

of the worksheet

CTRL+ SHIFT + 

HOME

Extend the selection to the last used 

cell on the worksheet (lower-right 

corner)

CTRL + SHIFT + 

END

Select the entire column CTRL + SPACEBAR

Select the entire row SHIFT + SPACEBAR

Select the entire worksheet CTRL + A

Select only the active cell when 

multiple cells are selected

SHIFT + 

BACKSPACE

Extend the selection down one screen SHIFT + PAGE 

DOWN

Extend the selection up one screen SHIFT + PAGE UP

Select whole data area around active 

cell

CTRL + SHIFT + *

Category: Other Functions

Command Key

Display the “Print” dialog box CTRL + P

Insert a new worksheet SHIFT + F11

Category: Inserting, deleting and copying a selection

Command Key

Copy the selection CTRL + C

Cut the selection CTRL + X

Paste the selection CTRL + V

Clear the contents of the selection DELETE

Delete the selection CTRL + HYPHEN

Copy the selection CTRL + C
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Excel Keyboard Shortcuts

Category: Outlining Data

Command Key

Group rows or columns ALT + SHIFT + RIGHT 

ARROW

Ungroup rows or columns ALT + SHIFT + LEFT 

ARROW

Display or hide outline symbols CTRL + 8

Hide selected rows CTRL + 9

Unhide selected rows CTRL + SHIFT + ( 

(opening parenthesis)

Hide selected columns CTRL + 0 (zero)

Unhide selected columns CTRL + SHIFT + ) 

(closing parenthesis)

Category: Working in Cells or the Formula Bar

Command Key

Edit the active cell and then clear it, or 

delete the preceding character in the active 

cell as you edit cell contents

BACKSPACE

Complete a cell entry ENTER

Enter a formula as an array formula CTRL + SHIFT + 

ENTER

Cancel an entry in the cell or formula bar ESC

Display the Formula Palette after you type 

a function name in a formula

CTRL + A

Insert the argument names and 

parentheses for a function after you type a 

function name in a formula

CTRL + SHIFT + A

Insert a hyperlink CTRL + K

Activate a hyperlink ENTER (in a cell with 

a hyperlink)

Edit the active cell and position the 

insertion point at the end of the line

F2

Paste a defined name into a formula F3

Paste a function into a formula SHIFT + F3

Calculate all sheets in all open workbooks F9

Calculate all sheets in the active workbook CTRL + ALT + F9

Category: Working in Cells or the Formula Bar (cont.)

Command Key

Calculate the active worksheet SHIFT + F9

Start a formula = (equal sign)

Insert the AutoSum formula ALT + = (equal sign)

Enter the date CTRL + ; (semicolon)

Enter the time CTRL + SHIFT + : 

(colon)

Copy the value from the cell above 

the active cell into the cell or the 

formula bar

CTRL + SHIFT + “ 

(quotation mark)

Alternate between displaying cell 

values and displaying cell formulas

CTRL + „ (single left 

quotation mark)

Copy a formula from the cell above 

the active cell into the cell or the 

formula bar

CTRL + „ 

(apostrophe)

Display the AutoComplete list ALT + DOWN 

ARROW

Category: Formatting Data

Command Key

Display the “Insert” cells dialog box CTRL + SHIFT + + 

(plus sign)

Display the “Delete” cells dialog box CTRL + SHIFT + -

(minus sign)

Display the Style dialog box Alt + „ (apostrophe)

Display the Format Cells dialog box CTRL + 1

Apply the General number format CTRL + SHIFT + ~

Apply the Currency format with two 

decimal places (negative numbers 

appear in parentheses)

CTRL + SHIFT + $

Apply the Percentage format with no 

decimal places

CTRL + SHIFT + %

Apply the Exponential number format 

with two decimal places

CTRL + SHIFT + ^

Apply the Date format with the day, 

month and year

CTRL + SHIFT + #

Sam
ple

- fo
r e

va
lua

tio
n p

urp
os

es
 on

ly.



92Intermediate Excel©TeachUcomp, Inc.

Excel Keyboard Shortcuts

Category: Formatting Data (cont.)

Command Key

Apply the Time format with the hour and 

minute, and indicate A.M. or P.M.

CTRL + SHIFT + @

Apply the Number format with two decimal 

places, thousands separator, and minus 

sign (-) for negative values

CTRL + SHIFT + !

Apply the outline border CTRL + SHIFT + &

Remove outline border CTRL + SHIFT + _

Apply or remove bold formatting CTRL + B or CTRL + 2

Apply or remove italic formatting CTRL + I or CTRL + 3

Apply or remove an underline CTRL + U or CTRL + 4

Apply or remove strikethrough formatting CTRL + 5 or CTRL + 5

Hide rows CTRL + 9

Unhide rows CTRL + SHIFT + ( 

(opening parenthesis)

Toggle between hiding, showing, and 

showing placeholder for objects

CTRL + 6

Hide columns CTRL + 0 (zero)

Unhide columns CTRL + SHIFT + ) 

(closing parenthesis)
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