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Welcome to TeachUcomp, Inc.’s Advanced Access

course. This class caps the Microsoft Access classes. This

class is designed to complete the user skill set for the

student who is already familiar with this program and its

use of tables, forms, and queries.

Access is an excellent program to learn, as the skills

that you learn within Access can save valuable time and

money for organizations by automating, organizing and

structuring their data processing capabilities.

This class will focus giving the student who possesses

the basic working foundation of the Access program’s

tables, forms, and queries knowledge of the reports,

macros, and advanced features required to complete the

creation of a functioning desktop database file.

Introduction and Overview
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CHAPTER 14-

Reports

14.1- Using the Report Wizard

14.2- Using Basic Reports

14.3- Creating a Report in Design View

14.4- Sorting and Grouping Data in Reports

14.5- Creating Calculated Fields

Sa
mple

- f
or

 ev
alu

ati
on

 pu
rp

os
es

 on
ly!



6Advanced Access©TeachUcomp, Inc.

Reports

14.1- Using the Report Wizard:

You use reports to further calculate and then display the results from a query. You can also use

them to calculate statistical results on tables or queries for summary reports. They are simply a more

concise and certainly more “printer-friendly” way of presenting the data that you have calculated in your

queries to anyone who needs to view this information. They use fields like forms do, and the report design

view shares much in common with the form design view. However reports typically have a query as their

data source, versus a table.

A simple way to create a basic report is to use the Report Wizard. You can start the Report Wizard

by clicking “Report Wizard” button in the “Reports” group on the “Create” tab in the Ribbon. That will launch

the “Report Wizard.” Once the Report Wizard is launched, it will lead you through a step-by-step program

that prompts you to respond to the questions that it poses. You simply enter the answers and make your

desired selections in each screen, and click the “Next >” button to proceed to the next screen. When you

are done answering all of the questions on each screen in the wizard, click the “Finish” to create a basic

report.

14.2- Creating Basic Reports:

You can create a very basic report that simply shows the results from a table or query by first

selecting the table or query that you want to use as the basis for the report from the listing shown in the

Navigation Pane. Next, click the click “Report” button in the “Reports” group on the “Create” tab in the

Ribbon. Access will automatically create a simple report that you can use to display the selected

information. While it lacks style, its ease of use and simplicity of creation compensate for it. You can also

modify the report’s content and layout in design view after it has been created, if needed.

14.3- Creating a Report in Design View:

Once you have created a report, it will appear in the Navigation Pane. Here you can select it and

then press “Ctrl” + “Enter” on your keyboard to open the report in design view. In design view you can edit

the report to change the field placement, add or remove fields, or format the report objects.

In design view, you can change many of the same aspects of reports that you changed in your forms

when using design view. You can also create a report from scratch in design view in much the same way

that you created forms. To do this, click the “Report Design” button in the “Reports” group on the “Create”

tab in the Ribbon. That will create a new, blank report and display it in design view.

One of the first things that you will notice about report design view that is different than the form

design view is the number of “bands,” or sections, within the report. By default, the report design view

shows a “Page Header,” a “Detail” section, and a “Page Footer.” What is important to note about reports is

that in a report, the particular section that you place the fields into can impact what data displays in the field.

Just as with form design view, you can start by clicking and dragging the fields from the “Field List” at the

right side of the design view, and then dropping them into the desired section of the report design window.

However, since reports often use queries as their basis versus using a table, you may want to know how

you can select a query to use as the report’s data source, since queries are not shown by default in the

“Field List.” In this case, which happens frequently when designing reports, you should set the “Data

Source” property of the report. To do this, click the “Property Sheet” button in the “Tools” group on the

“Design” tab of the “Report Design Tools” contextual tab in the Ribbon. Use the drop-down at the top of the

“Property Sheet” window to select “Report,” if needed. Then click the “Data” tab. Use the drop-down in theSa
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Reports

14.3- Creating a Report in Design View (cont.):

“Record Source” property field to select the name of the query to use as the data source for the report. Then

click the “Add Existing Fields” button in the “Tools” group to show the available fields in the selected query

within the “Field List” pane.

Fields that are placed into the “Detail” section display their field information once for each record in

the associated data source. Items placed into the “Page Header” or “Page Footer” areas repeat once per

page. That makes those areas suitable for report labels and date/time stamps, but not calculations.

You can also add two more useful sections to the report: the “Report Header” and “Report Footer.”

In Access 2013 and 2010 you can right-click on the header of any displayed section in the report design

view and then select the “Report Header/Footer” button from the pop-up menu that appears to enable their

display. In Access 2007, you can enable both these sections by clicking the “Report Header/Footer” button

in the “Show/Hide” group on the “Arrange” tab of the “Report Design Tools” contextual tab in the Ribbon.

Fields placed into either the “Report Header” or the “Report Footer” sections will display their field

information once at the very top and once at the very bottom of a report. Oftentimes you will find report titles

placed into the “Report Header” section. The “Report Footer” section is often where you will place fields that

calculate the “Grand Total” of other report fields. You can also create many additional header/footer

combinations for the various groupings in your report, which you will examine in a later lesson.

In addition to the “Field List,” you also have many of the same controls that you used in forms

available for use in report design view, as well. They are shown in the “Controls” group on the “Design” tab

of the “Report Design Tools” contextual tab within the Ribbon. You can use the buttons in this group to add

labels, images, or custom calculated fields.

Once you have designed the report, you can view the report results in “Print Preview” to view how

the report would look if you actually printed it. When you are viewing a report in “Print Preview,” you can

view multiple or single pages of the report and also print the report using the buttons that are available to

you on the “Print Preview” tab. When you are finished previewing your report, you can click the “Close Print

Preview” button to close the preview and return to report design view.

14.4- Sorting and Grouping Data in Reports:

You can create data groupings in reports to group selected fields by the unique values that they

contain. You can then calculate the value of another field for each unique grouping created by the values

within the grouped field. This is how you create summary totals, by group, within a report.

For example, assume you created a sales report that displayed detailed data of product sales by

employee. You could create a data grouping on the “EmployeeID” field to create a group for each unique

value found in the “EmployeeID” field. When you create a data grouping, you can create a “group header”

and a “group footer” as additional sections within the report. Data fields placed into a group header or a

group footer will display once for each unique group within the field. You could then add a calculated field

for the group that would total the value of all of the sales values in the “Amount” field for each unique

grouping in the “EmployeeID” field, and display the subtotals for each employee in the group footer. So as

you can see, this can be an extremely useful feature!

To create a grouping in your report, click the “Group & Sort” button in the “Grouping & Totals” group

on the “Design” tab of the “Report Design Tools” contextual tab within the Ribbon. Doing that will show the

“Group, Sort, and Total” pane at the bottom of the report design view. In this section are two boxes: “Add a

group” and “Add a sort.”

To add a report grouping, click the “Add a group” button and then select name of the field by which

you wish to group the data from the pop-up menu that appears. That will add the primary grouping (of whichSa
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Reports

14.4- Sorting and Grouping Data in Reports (cont.):

you can have several) into the “Group, Sort, and Total” pane. To then view all of the available options that

you have for the group, click the “More >” button to expand the group options shown. You will click each

drop-down, from left to right, and set the value for each until you have specified all of your settings.

You can click the next drop-down arrow after the field name to select the sorting method used to sort

the values in the grouped field.

Moving to the right, you can then select the next drop-down arrow to select how you wish to create

the groups within the selected field. Normally, you will group “by entire value.” This means that the values in

the grouped field must match entirely in order to be included as part of the same group. However, you can

also create groups based on field values that share the first few initial characters or values. For text fields,

you can select either the “by first character” or “by first two characters” option to create groups based on

these criteria. To create groupings based on more than two initial characters, select the “Custom:” option

and enter the number of initial characters by which to create grouped values within the grouped field. For

date/time and number field, select a group option or enter a custom group value.

Starting in Access 2007, you can also create totals for the groups as you create the groupings. You

can click the next drop-down to choose what totals to display for the groupings created. If you do not want

to calculate any field values for each group, leave the selection at the default value of “with no totals.” To

add totals, click the drop-down arrow and select the field to total from the “Total On” drop-down within the

drop-down menu. Next, use the “Type” drop-down to select the function to perform on the field selected in

the “Total On” drop-down. Below that, check any of the four checkboxes shown to enable or disable each

setting. If you want a grand total for the field, select the “Show Grand Total” checkbox. To show each

group’s value as a percentage of the grand total, check the “Show group subtotal as % of Grand Total”

checkbox. To show the group subtotals in the group header, check the “Show subtotal in group header”

checkbox. To show the group subtotals in the group footer, check the “Show subtotal in group footer”

checkbox. You can set many totals on several fields, if needed, by selecting another field from the “Total

On” drop-down and then repeating the process. Once you have set your totals, click the drop-down arrow in

the group again to set your totals in the report.

To add a title to the groups, click the “click to add” hyperlink to open the “Zoom” dialog box where

you can enter the title to apply to the group and then press the “OK” button. This adds the title as a “Label”

control into the header of the group.

Next, you can click the next drop-down to select “with a header section” or “without a header

section.” If you added a group title, then you must have a group header section. You may only chose the

“without a header section” option if you do not have any controls of any kind in the group header shown in

the design view. Choosing this option with controls in the section will delete the section and the related

controls. Likewise, you can set the next drop-down to “with a footer section,” or “without a footer section.”

Once again, you may only remove the group footer as long as you do not have any controls in that section.

If you add totals to the group in the group footer, then you will not want to remove the group footer, as that

would delete the calculated fields that Access adds to that section when you request field totals.

The last drop-down arrow lets you choose how the data records shown within each group should

appear when printed. You can select the default of “do not keep group together on one page” to ignore

grouping and where the page breaks occur when you run out of printable area on a page. You can select

the “keep whole group together on one page” option to try to print all of the records in each group on one

page. You could also select “keep header and first record together on one page,” to start printing the

grouped data on a report page only if Access can fit both the group header and at least one detail record on

the same page.

Note that you can then create additional groupings, if desired, by clicking the next “Add a group”

button that is below your current group and then repeating this entire process. Note, however, that theSa
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Reports

14.5- Creating Calculated Fields:

When you want to modify reports in Access, you simply open them in design view. Once you are in

design view, you can add controls to the report in the same way that you add controls to a form. However,

the controls in a report are typically read-only and aren’t used to change data, but to display data. One of

the most useful types of controls is the calculated text box control. These are the types of fields that are

created when you specify that a group in a report show a total. While you can create many of the calculated

fields that you need while creating your data groupings, you can also create them yourself. A calculated

field is a text box control that will display the result of a calculation you create, instead of a field value.

To create a calculated field, simply open the report in design view and insert a regular text box

control into the report. Next, select the control that you inserted and view its properties in the Property

Sheet. You can click the “Property Sheet” button in the “Tools” group on the “Design” tab of the “Report

Design Tools” contextual tab in the Ribbon to display the Property Sheet, if needed.

In the Property Sheet, select the “Data” tab, click into the “Control Source” property field and then

click the “Expression Builder” button […] which appears at the right end of the “Control Source” text box.

This will then launch the “Expression Builder” dialog box. This dialog box is used to create functions and

formulas. Either type the expression (formula) to calculate into the box at the top of the “Expression Builder”

dialog box or select individual elements provided in the three sections at the bottom of the dialog box to

create the formula. When you are done creating your formula, click “OK” to set the field’s formula.

Another important consideration when creating a calculated field that performs a calculation on the

field data in the report is where it will be placed in the report. A calculated field may display different results

depending upon which section of the report you insert it into. For example, if you had a calculated field that

took the sum of a “Sales” field, the formula in the calculated field would be: =SUM([Sales]). However, if you

place this field into the “Report Footer,” it would show the total value of that field for all records displayed,

as a grand total. If you placed it into a “group” footer, it would show the total of that field for all of the records

in the group. Placing it into the “Page Footer” would cause an error, as calculated fields cannot be

14.4- Sorting and Grouping Data in Reports (cont.):

secondary groups should logically be secondary groupings within the larger, primary group. If using multiple

groups, note that you can also change the order in which the grouping is applied by selecting the group

whose order you want to change, and then clicking the small “Move up” and “Move down” arrows buttons

that appear at the right end of the grouping. To delete a group that you have created, you can click the “X”

at the right end of the group listing. Note that if you have controls in the group header or group footer, these

controls will be deleted along with the header or footer. Access will warn you if this is the case before

allowing you to delete the group.

Also note that this is the same process used for sorting your report data. As you have just seen,

when creating a group, you can choose how to sort the values within the group. However, for some detailed

reports, you may not have any groupings. In either case, you can still apply sorting to the report by using

any available field. You simply start the process of adding a sorting order by clicking the “Add a sort” button

in the “Group, Sort, and Total” pane. You can set any additional options for a sorted field that you can with a

grouped field. However, you will most commonly only need to set the two options that are initially shown

when the sort is created. That will allow you to select the field by which to sort and the method used to sort

the field’s values. As with groups, you can re-order the sorting that is applied or delete the sorting applied

by using the “Move up,” “Move down,” and “Delete” buttons that are available at the right end of the sort.

When you are finished creating groups and sorting, click the “X” button in the upper-right corner of the

“Group, Sort, and Total” pane to close it.
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Reports

14.5- Creating Calculated Fields (cont.):

evaluated on a per page basis. Also, if you placed the calculated field in a “group” footer, you then have the

ability to set the function as a “running sum.” To do this, select the field and then select the “Data” tab in the

Property Sheet. Click into the “Running Sum” property to set the value of this property to not calculate

(which is the default), to calculate per grouping, or to calculate over all the records. This is a great way of

displaying a running totals over groups.

Sa
mple

- f
or

 ev
alu

ati
on

 pu
rp

os
es

 on
ly!



11Advanced Access©TeachUcomp, Inc.

ACTIONS-

Reports
USING THE REPORT WIZARD:

1. Click the “Report Wizard” button in the “Reports” group on the “Create” tab in the Ribbon.

2. Use the “Queries/Tables:” drop-down menu to select the query or table that you want use as the basis of 

the report.

3. Next, select which fields from the selected query or table you want to display in the report by selecting 

them from the “Available Fields:” list and then clicking the “>” button to move them to the “Selected 

Fields:” list. You could also move all fields into the “Selected Fields:” list by clicking the “>>” button.

4. Click “Next >” when you have added all the fields that you want to display to the “Selected Fields:” list.

5. In the next screen, you may need to select by which field or table you wish to view the report results. 

Make your selection and click “Next >” to continue. If you did not base your report on multiple tables or a 

query, then move to the next step.

6. Select any fields by which you want to group the data in your report, and click the “>” button to add the 

selected groups to the report. If you do add grouping, you can click the “Grouping Options…” button to 

open another screen where you can select a “Grouping Interval” for any fields by which you grouped the 

report. Then click “OK” to close this screen.

7. Click “Next>” to continue.

8. In the next screen, select by which fields you wish to sort the report data by using the drop-down menus 

available. Then click the button to the right of each field to toggle it to display the desired sorting order: 

“Ascending” (A-Z, 1-10) or “Descending (Z-A, 10-1). If you have a “number” or “currency” field available 

in your report, you can click the “Summary Options…” button in this screen to launch the “Summary 

Options” dialog box. In this dialog box you can set any summary options for the available fields by 

checking the checkbox under the function that you want performed on each field. To the right of that, 

check either the “Detail and Summary” or “Summary Only” option button to select the type of report to 

create. You can also check the checkbox for “Calculate percent of total for sums,” if you want that option 

for your report summary. When you are done, click “OK” to close the “Summary Options” dialog box.

9. Click “Next>” to continue.

10. Next, select the desired report layout by selecting the option button that corresponds to the type of 

layout that you want in the “Layout” section. In the “Orientation” section, click the option button that 

corresponds to the page orientation that you want. You can also check the checkbox to “Adjust the field 

width so all fields fit on a page,” if you desire.

11. Click “Next>” to continue.

12. Next, select the style of your report by selecting the option button that corresponds to the type of style 

that you prefer.

13. Click “Next>” to continue.

14. In the final screen, type a title for your report in the text box at the top of the screen. Then select either to 

“Preview the report,” or “Modify the report’s design.” To view the report data, select the first option and 

click “Finish” to create your new report.
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ACTIONS-

Reports

CREATING AND MODIFYING REPORTS IN DESIGN VIEW:

1. To open a pre-existing report in Design View, select the name of the report from the listing shown in the 

Navigation Pane and then press “Ctrl” + “Enter” on your keyboard.

2. You can also create a report from scratch in design view by clicking the “Report Design” button in the 

“Reports” group on the “Create” tab in the Ribbon to create a new, blank report in design view.

3. By default, the report design view shows a “Page Header,” a “Detail” section, and a “Page Footer.”

4. To set a data source for a blank report in design view, click the “Property Sheet” button in the “Tools” 

group on the “Design” tab of the “Report Design Tools” contextual tab in the Ribbon. Use the drop-down 

at the top of the “Property Sheet” window to select “Report,” if needed. Then click the “Data” tab. Use 

the drop-down in the “Record Source” property field to select the name of the query to use as the data 

source for the report.

5. You can click the “Add Existing Fields” button in the “Tools” group to show the available fields in the 

selected data source in the report. You can click and drag fields from the “Field List” at the right side of 

the design view, and then drop them into the desired section of the report design window. 

6. Fields that are placed into the “Detail” section display their field information once for each record in the 

associated data source.

7. Fields placed into the “Page Header” or “Page Footer” areas repeat once per page.

8. In Access 2013 and 2010 you can right-click on the header of any displayed section in the report design 

view and then select the “Report Header/Footer” button from the pop-up menu that appears to enable 

their display. In Access 2007, you can enable the “Report Header” and the “Report Footer” by clicking 

the “Report Header/Footer” button in the “Show/Hide” group on the “Arrange” tab of the “Report Design 

Tools” contextual tab within the Ribbon.

9. Fields placed into either the “Report Header” or the “Report Footer” sections will display their field 

information once at the very top and once at the very bottom of a report.

10. You also can add many of the same controls used in form design view in report design view, as well. 

They are shown in the “Controls” group on the “Design” tab of the “Report Design Tools” contextual tab 

within the Ribbon. Use the buttons in this group to add labels, images, or custom calculated fields.

11. When you are done making modifications to your report, click the “Save” button in the Quick Access 

toolbar to save your changes.

CREATING BASIC REPORTS:

1. Select the table or query that you want to use as the basis for the report from the listing shown in the 

Navigation Pane.

2. Click the click “Report” button in the “Reports” group on the “Create” tab in the Ribbon.

3. Access will automatically create a simple report that you can use to display the selected information. 

You can modify the report’s content and layout in design view after it has been created, if needed.
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ACTIONS-

Reports
SORTING AND GROUPING DATA IN A REPORT:

1. Open the report to which you want to add sorting or data grouping in design view by selecting the name 

of the report from the Navigation Pane and then pressing “Ctrl” + “Enter” on your keyboard.

2. To create a grouping in your report, click the “Group & Sort” button in the “Grouping & Totals” group on 

the “Design” tab of the “Report Design Tools” contextual tab within the Ribbon. Doing that will show the 

“Group, Sort, and Total” pane at the bottom of the report design view. In this section are two boxes: 

“Add a group” and “Add a sort.”

3. To add a report grouping, click the “Add a group” button and then select name of the field by which you 

wish to group the data from the pop-up menu that appears. That will add the primary grouping (of which 

you can have several) into the “Group, Sort, and Total” pane.

4. To then view all of the available options that you have for the group, click the “More >” button to expand 

the group options shown. You will click each drop-down, from left to right, and set the value for each 

until you have specified all of your settings.

5. You can click the next drop-down arrow after the field name to select the sorting method used to sort the 

values in the grouped field.

6. Moving to the right, click the next drop-down arrow to select how to create the groups within the 

selected field.

7. Select the “by entire value” option to group the values in the grouped field by their entire value.

8. To create groups based on field values that share the first few initial characters or values, select a group 

option or enter a custom group value. This changes based on the data type of the selected field. For text 

fields, select either the “by first character,” “by first two characters,” or “Custom:” option. If needed, enter 

the number of initial characters by which to create grouped values within the grouped field. For 

date/time and number field, select a group option or enter a custom grouping value.

9. Starting in Access 2007, you can create totals for the groups as you create the groupings. To do this, 

click the next drop-down to choose what totals to display for the groupings created.

10. If you do not want to calculate any field values for each group, leave the selection at the default value of 

“with no totals.”

11. To add totals, click the drop-down arrow and select the field to total from the “Total On” drop-down 

within the drop-down menu.

12. Then use the “Type” drop-down to select the function to perform on the field selected in the “Total On” 

drop-down.

13. If you want a grand total for the field, select the “Show Grand Total” checkbox.

14. To show each group’s value as a percentage of the grand total, check the “Show group subtotal as % of 

Grand Total” checkbox.

15. To show the group subtotals in the group header, check the “Show subtotal in group header” checkbox.

16. To show the group subtotals in the group footer, check the “Show subtotal in group footer” checkbox.

17. You can set many totals on several fields, if needed, by selecting another field from the “Total On” drop-

down and then repeating the process.

18. Once you have set your totals, click the drop-down arrow in the group again to set totals in the report.

19. To add a group title, click the “click to add” hyperlink to open the “Zoom” dialog box and enter the group 

title to apply. Then click the “OK” button to add the title as a “Label” control into the group header.

20. Next, click the next drop-down to select “with a header section” or “without a header section.” If you 

added a group title, you must have a group header section. You may only chose the “without a header 

section” option if you do not have any controls in the group header. Choosing this option with controls in 

the section will delete the section and the related controls.
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ACTIONS-

Reports

SORTING AND GROUPING DATA IN A REPORT (CONT.):

21. Likewise, you can set the next drop-down to “with a footer section,” or “without a footer section.” Once 

again, you may only remove the group footer as long as you do not have any controls in that section. If 

you add totals to the group in the group footer, then you will not want to remove the group footer, as that 

would delete the calculated fields that Access adds to that section when you request field totals.

22. The last drop-down arrow lets you choose how the data records shown within each group should 

appear when printed. You can select the default of “do not keep group together on one page” to ignore 

grouping and where the page breaks occur when you run out of printable area on a page. You can 

select the “keep whole group together on one page” option to try to print all of the records in each group 

on one page. You could also select “keep header and first record together on one page,” to start printing 

the grouped data on a report page only if Access can fit both the group header and at least one detail 

record on the same page.

23. Note that you can then create additional groupings, if desired, by clicking the next “Add a group” button 

that is below your current group and then repeating this entire process. Note, however, that the 

secondary groups should logically be secondary groupings within the larger, primary group.

24. If using multiple groups, note that you can also change the order in which the grouping is applied by 

selecting the group whose order you want to change, and then clicking the small “Move up” and “Move 

down” arrows buttons that appear at the right end of the grouping.

25. To delete a group that you have created, you can click the “X” at the right end of the group listing. Note 

that if you have controls in the group header or group footer, these controls will be deleted along with 

the header or footer. Access will warn you if this is the case before allowing you to delete the group.

26. You can add sorting to a report by clicking the “Add a sort” button in the “Group, Sort, and Total” pane. 

You can set any additional options for a sorted field that you can with a grouped field. However, you will 

most commonly only need to set the two options that are initially shown when the sort is created. That 

will allow you to select the field by which to sort and the method used to sort the field’s values.

27. As with groups, you can re-order the sorting that is applied or delete the sorting applied by using the 

“Move up,” “Move down,” and “Delete” buttons that are available at the right end of the sort.

28. When you are finished creating groups and sorting, click the “X” button in the upper-right corner of the 

“Group, Sort, and Total” pane to close it.
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ACTIONS-

Reports

CREATING CALCULATED FIELDS:

1. Open the report to which you want to add a calculated field in design view by selecting the name of the 

report from the Navigation Pane and then pressing “Ctrl” + “Enter” on your keyboard.

2. Start by inserting a regular text box control into the report.

3. Select the control that you inserted and view its properties in the Property Sheet. You can click the 

“Property Sheet” button in the “Tools” group on the “Design” tab of the “Report Design Tools” contextual 

tab in the Ribbon to display the Property Sheet, if needed.

4. In the Property Sheet, select the “Data” tab, click into the “Control Source” property field and then click 

the “Expression Builder” button […] which appears at the right end of the “Control Source” text box. This 

will then launch the “Expression Builder” dialog box. This dialog box is used to create functions and 

formulas.

5. Either type the expression (formula) to calculate into the box at the top of the “Expression Builder” dialog 

box or select individual elements provided in the three sections at the bottom of the dialog box to create 

the formula. When you are done creating your formula, click “OK” to set the field’s formula.

6. Another important consideration when creating a calculated field that performs a calculation on the field 

data in the report is where it will be placed in the report. A calculated field may display different results 

depending upon which section of the report you insert it into. For example, if you had a calculated field 

that took the sum of a “Sales” field, the formula in the calculated field would be: =SUM([Sales]). 

However, if you place this field into the “Report Footer,” it would show the total value of that field for all 

records displayed, as a grand total. If you placed it into a “group” footer, it would show the total of that 

field for all of the records in the group. Placing it into the “Page Footer” would cause an error, as 

calculated fields cannot be evaluated on a per page basis.

7. If you placed the calculated field in a “group” footer, you then have the ability to set the function as a 

“running sum.” To do this, select the field and then select the “Data” tab in the Property Sheet. Click into 

the “Running Sum” property to set the value of this property to not calculate (which is the default), to 

calculate per grouping, or to calculate over all the records. This is a great way of displaying a running 

totals over groups.
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EXERCISES-

Reports
Purpose:

1. To be able to create basic reports on your data.

Exercises:

1. Open your Access application.

2. Open the “test” database you completed from the Exercise at the end of the last chapter in the

“Intermediate” manual.

3. Click the “Create” tab in the Ribbon.

4. Click the “Query Design” button in the “Queries” group (“Other” group in 2007).

5. In the “Show Table” dialog box, select all of the tables shown and then click the “Add” button.

6. Click “Close” in the “Show Table” dialog box.

7. Create the following query and save it as “qrySalesByEmployee.” Then close the query.

8. Click the “Report Wizard” button in the “Reports” group on the “Create” tab in the Ribbon.

9. Use the “Tables/Queries” drop-down to select “qrySalesByEmployee.”

10. Click the “>>” button to move all of the “Available Fields:” into the “Selected Fields:” list.

11. Click the “Next >” button to continue.

15. Select “FirstName,” and click the “>” button to group by the FirstName field.

16. Select “CompanyName” and click the “>” button to group by the CompanyName field.

17. Click “Next >.”

18. Use the “1.” drop-down to sort by “LastName.”
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EXERCISES-

Reports
Exercises (cont.):

19. Click the “Summary Options…” button.

20. Click the check box for “Sum,” and click “OK.”

21. Click “Next >.”

22. Select “Outline,” and click the “Landscape” option.

23. Click “Next >.”

24. If using Access 2007, select “Office,” and click “Next >.”

25. Rename the report “Sales By Employee.”

26. Click “Finish.”

27. Click the “Close Print Preview” button in the “Close Preview” group on the “Print Preview” tab in the

Ribbon.

28. In the design view, in the “FirstName Header” section, replace the “FirstName” label with

“Employee:.”

29. Change the field’s value to “[FirstName] & " " & [LastName].”

30. In the “Detail” section, delete the “LastName” field. If using Access 2013:2010, also delete the

“LastName” label that appears in the “Company Name Header” section.

31. Select the “=SUM([Sale Amount])” fields in the “CompanyName Footer,” “FirstName Footer,” and the

“Report Footer” and select the “Format” tab in the “Property Sheet.”

32. Click into the “Format” property box, and then select “Currency” from the drop-down menu that

appears.

33. Click “Save” in the Quick Access toolbar to save the report.

34. Preview the report in print preview to see your changes applied, then close the report and the

database.
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15.1- Creating Subreports

CHAPTER 15-

Subreports
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Subreports

15.1- Creating Subreports:

With subreports, you can view the data from one main report with related data from a separate, but

related report, as an embedded subreport within the original. This allows you to view related information

from two reports at once. It can also make the relationship between data in two related reports seem more

clear. Subreports are often used to show summary data from one main report with detail data from a related

subreport.

When you create subreports, you may want to begin by creating two separate reports first. However,

this isn’t required. You can create a subreport within a report from almost any database object that you have

already created, including tables, forms, and queries.

To create a subreport, first open the main report into which you wish to insert the

“Subform/Subreport” control in design view. Ensure that you have the related subreport that you want to

insert and display within the main report already created, if needed. Also make sure that the “Use Control

Wizards” button is activated in the “Controls” group on the “Design” tab of the “Report Design Tools”

contextual tab within the Ribbon. Note that in Access 2013:2010, this button appears in a separate section

when you click the “More” drop-down button in the lower right corner of the control group.

Next, click the “Subform/Subreport” button in the “Controls” group on the “Design” tab of the “Report

Design Tools” contextual tab within the Ribbon. Then click and drag over the area in the main report where

you wish to insert a subreport. Access will then automatically launch the “SubReport Wizard” to assist you

in placing and connecting your two reports.

In the first screen of the “SubReport Wizard,” you can select which object in your database contains

the data that you want to use in the subreport. You can select to either “Use existing Tables and Queries” or

“Use an existing report or form” by selecting the desired option button. If you select the latter option, then

you must select which report or form you wish to insert from the list shown. Click “Next >” when you are

ready to continue.

If you selected to “Use existing Tables and Queries” in the last step, then the next screen will

present you with a drop-down list of the tables and queries in the database from which you can select. For

whichever table or query you select, you can then choose which fields to display in the report by clicking on

their names in the “Available Fields:” list and then clicking the “>” button to move them into the “Selected

Fields:” list. Then click “Next >” to continue.

In the next screen, you must select how the data in the main report is linked to the data in the

subreport. If you select the “Choose from a list” option button, then you must select one of the listed

possible ways from the list box shown below the option button. When you select one of the ways that you

could link the data in the reports together from the list, you will see text describing the relationship below the

list. This is helpful in viewing the relationship when the description of the relationship selected in the list

extends beyond the edge of the list box. Once you have selected the desired relationship, click the “Next >”

button to continue.

The other option you have is to select the “Define my own” option button, which changes the section

below it to show two columns of drop-down menus: “Form/report fields:” and “Subform/subreport fields:.”

Use the drop-downs to select which field in the main report is correlated to which other field in the

subreport. You may connect multiple fields, if necessary. The text description of the link that you have

created will appear below the drop-down menus. When you have created the necessary links between the

reports, click “Next >” to continue.

In the last screen, you can type a name for your subreport, if needed. Then just click the “Finish”

button to complete the insertion of the subreport into the main report.
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ACTIONS-

Subreports
INSERTING SUBREPORTS:

1. To create a subreport, first open the main report into which you wish to insert the “Subform/Subreport” 

control in design view. Ensure that you have the related subreport that you want to insert and display 

within the main report already created, if needed. Also make sure that the “Use Control Wizards” button 

is activated in the “Controls” group on the “Design” tab of the “Report Design Tools” contextual tab 

within the Ribbon. Note that in Access 2013 and 2010, this button appears in a separate section when 

you click the “More” drop-down button in the lower right corner of the control group. 

2. Next, click the “Subform/Subreport” button in the “Controls” group on the “Design” tab of the “Report 

Design Tools” contextual tab within the Ribbon.

3. Click and drag over the area in the main report where you wish to insert a subreport. Access will then 

automatically launch the “SubReport Wizard” to assist you in placing and connecting your two reports.

4. In the first screen of the “SubReport Wizard,” select which object in your database contains the data that 

you want to use in the subreport. You can select either the “Use existing Tables and Queries” or the 

“Use an existing report or form” option button. If you select the latter option, then you must select which 

report or form you wish to insert from the list shown. Click “Next >” when you are ready to continue.

5. If you selected to “Use existing Tables and Queries” in the last step, then the next screen will present 

you with a drop-down list of the tables and queries in the database from which you can select. For 

whichever table or query you select, you can then choose which fields to display in the report by clicking 

on their names in the “Available Fields:” list and then clicking the “>” button to move them into the 

“Selected Fields:” list. Then click “Next >” to continue.

6. In the next screen, you must select how the data in the main report is linked to the data in the subreport. 

If you select the “Choose from a list” option button, then you must select one of the listed possible ways 

from the list box shown below the option button. Once you have selected the desired relationship, click 

the “Next >” button to continue.

7. The other option you have is to select the “Define my own” option button, which changes the section 

below it to show two columns of drop-down menus: “Form/report fields:” and “Subform/subreport fields:.” 

Use the drop-downs to select which field in the main report is correlated to which other field in the 

subreport. You may connect multiple fields, if necessary. When you have created the necessary links 

between the reports, click “Next >” to continue.

8. In the last screen, you can type a name for your subreport, if needed. Then just click the “Finish” button 

to complete the insertion of the subreport into the main report.
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EXERCISES-

Subreports
Purpose:

1. There are no exercises for this chapter.

Exercises:

1. None.
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16.1- Using Charts

CHAPTER 16-

Charting Data
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16.1- Using Charts:

In Access, you can use the “Chart Wizard” to quickly and easily create charts that can represent

data drawn from your underlying queries or tables. There are many different types of charts that are

available by default. Charts are inserted as another control into the reports in your database. You can insert

a chart into a report by first clicking the “Blank Report” button in the “Reports” group on the “Create” tab in

the Ribbon. Unlike other report controls, the chart that is inserted into a report will use its own data source

for its information display. Therefore, you can simply insert it into a blank, unassociated report if desired.

Next, click the “Insert Chart” button in the “Controls” group on the “Design” tab of the “Report Design

Tools” contextual tab within the Ribbon when the report is in “Design View.” You can then click and drag

over the area within the report where you wish to display the chart in order to create a frame for the

embedded chart control. When you release your mouse pointer, the “Chart Wizard” will then launch,

assuming that you have the “Use Control Wizards” button selected in the “Controls” group on the “Design”

tab of the “Report Design Tools” contextual tab within the Ribbon. Note that in Access 2013:2010, this

button appears in a separate section when you click the “More” drop-down button in the lower right corner of

the control group.

In the first screen of the “Chart Wizard” you select the data source for the chart. You can select

either the “Tables,” “Queries,” or “Both” option button to then display those selected type of objects in the

large list. Then select the name of the table or query that you want to use as the data source for the chart

from the listing of tables and/or queries shown. Then click the “Next >” button to continue.

In the next screen, choose the fields to display in the chart by selecting them from the “Available

Fields:” list box and then clicking the “>” button to move the selected fields into the “Fields for Chart:” list.

Then click the “Next >” button to continue. In the next screen, click on the type of chart that you want to

create from the listing of chart types shown. Then click the “Next >” button to continue.

In the next screen drag and drop any fields from the area at the right side of the window into the

desired chart locations shown at the left side of the window. Note that you can double-click on any summary

field shown in order to change the function performed on the data in a separate dialog box, if needed. You

can also click the “Preview Chart” button to show a preview of your chart in a separate window. Once you

are satisfied with the appearance of your chart, click the “Next >” button to continue.

In the last screen of the “Chart Wizard,” you can type a title for your chart into the box provided, and

then select whether or not to add a legend to the chart. Then click the “Finish” button to add the chart

control to your report. Don’t be alarmed if the chart doesn’t display your data in the design view, it won’t.

You will need to switch to “Layout View” in order to see the data within the chart object and also have the

ability to resize the chart control until it appears the way that you want it to within your report.

Charts are independent objects that contains many smaller objects that have their own properties

which can be independently formatted to suit your tastes. When in design view, you may select the chart

control and then view its properties in the “Property Sheet.” The “Row Source” property, which is located on

the “Data” tab, displays the SQL code of the query upon which the chart is based. If you click into the “Row

Source” property box, you can then click the “Builder” button […] that appears at the right end of the box to

view the SQL query in the visual query design view, which you can then edit, if needed.

To edit the chart in “Design View,” double-click the chart control. This will activate the “Microsoft

Graph” program. Note that the toolbars change to reflect that fact. The new toolbar which appears allows

you to edit the chart object’s formatting. You can select any object in the chart and click the available

buttons in the new toolbar to format it to your taste. Note that the data that is displayed in the “Datasheet”

when you edit the chart simply displays the most recent data. You do not need to change the datasheet

info. When you have made any formatting changes that you wish to keep, click once more back into the

report into which the chart is embedded to switch back to Access.

Charting Data
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ACTIONS-

Charting Data
CREATING CHARTS:

1. You can insert a chart into a report by first clicking the “Blank Report” button in the “Reports” group on 

the “Create” tab in the Ribbon to create a new blank, unassociated report in design view, if desired.

2. Click the “Insert Chart” button in the “Controls” group on the “Design” tab of the “Report Design Tools” 

contextual tab within the Ribbon when the report is in “Design View.” You can then click and drag over 

the area within the report where you wish to display the chart in order to create a frame for the 

embedded chart control. When you release your mouse pointer, the “Chart Wizard” will then launch, 

assuming that you have the “Use Control Wizards” button selected in the “Controls” group on the 

“Design” tab of the “Report Design Tools” contextual tab within the Ribbon. Note that in Access 

2013:2010, this button appears in a separate section when you click the “More” drop-down button in the 

lower right corner of the control group. 

3. In the first screen of the “Chart Wizard” you select the data source for the chart. You can select either 

the “Tables,” “Queries,” or “Both” option button to then display those selected type of objects in the large 

list. Then select the name of the table or query that you want to use as the data source for the chart from 

the listing of tables and/or queries shown. Then click the “Next >” button to continue.

4. In the next screen, choose the fields to display in the chart by selecting them from the “Available Fields:” 

list box and then clicking the “>” button to move the selected fields into the “Fields for Chart:” list. Then 

click the “Next >” button to continue.

5. In the next screen, click on the type of chart that you want to create from the listing of chart types shown. 

Then click the “Next >” button to continue.

6. In the next screen drag and drop any fields from the area at the right side of the window into the desired 

chart locations shown at the left side of the window. Note that you can double-click on any summary 

field shown in order to change the function performed on the data in a separate dialog box, if needed. 

You can also click the “Preview Chart” button to show a preview of your chart in a separate window. 

Once you are satisfied with the appearance of your chart, click the “Next >” button to continue.

7. In the last screen of the “Chart Wizard,” you can type a title for your chart into the box provided, and 

then select whether or not to add a legend to the chart. Then click the “Finish” button to add the chart 

control to your report.

VIEWING CHART PROPERTIES

1. Open the report which contains the chart object whose properties you wish to set in Design View.

2. Select the embedded chart control by clicking it.

3. Change any associated properties, as needed, in the “Property Sheet.”

EDITING CHARTS:

1. Open the report which contains the chart that you wish to edit in report design view.

2. Double-click the embedded chart control to edit in with Microsoft Graph.

3. Select the chart element that you wish to edit.

4. Use the buttons in the new toolbar that has appeared to change the appearance of the selected chart 

element.

5. Click once into the report area to return to Microsoft Access.
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EXERCISES-

Charting Data
Purpose:

1. To be able to create charts on your data.

Exercises:

1. Open your Access application.

2. Open the “test” database you completed from the Exercise at the end of Chapter 14.

3. Click the “Blank Report” button in the “Reports” group on the “Create” tab in the Ribbon to create a

new blank report in design view.

4. Click the “Insert Chart” button in the “Controls” group on the “Design” tab of the “Report Design

Tools” contextual tab within the Ribbon. Ensure that the “Use Control Wizards” button in the

“Controls” group is selected. Note that in Access 2013:2010, this button appears in a separate

section when you click the “More” drop-down button in the lower right corner of the control group.

5. Click and drag over the area within the report where you want to display the chart. When you

release your mouse pointer, Access will launch the “Chart Wizard.”

6. In the first screen of the “Chart Wizard,” select the “Queries” option button. Then select “Query:

qryJanuaryTotalSalesByEmployee” from the listing shown.

7. Click the “Next >” button to continue.

8. Click the “LastName” field, and then click the “>” button.

9. Click the “SaleAmount” field, and then click the “>” button.

10. Click the “Next >” button to continue.

11. Click the “Pie Chart” button, and then click “Next >” to continue.

12. Click “Next >.”

13. Enter “January Total Sales by Employee” into the chart title box provided.

14. Click “Finish.”

15. Select the “Layout View” from the “Views” group at the left end of the “Design” tab in the “Report

Design Tools” contextual tab in the Ribbon.

16. Click and drag the chart object into the horizontal center of the report layout view. Then resize it, as

needed, in order to display the data.

17. Click the “Save” button in the Quick Access toolbar.

18. Name the report “January Sales By Employee” and then click the “OK” button.

19. Close the report.

20. Close the database.
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CHAPTER 17-

Macros in Access 2007

17.1- Creating and Using Macros

17.2- Macro Actions

17.3- Assigning Macros to a Command Button

17.4- Conditional Macros and Option Groups

17.5- Using Group Names in Macros

17.6- Creating Autoexec Macros
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Macros in Access 2007

17.1- Creating and Using Macros:

A macro is a little program that you create in a visual environment that runs a series or set of

operations in a specified order. For example, an Access macro could check the value of a form field and

then open a corresponding report based on the value of the field. When you write macros you will need to

know both the “Actions:,” what to do for each step in the macro; and the “Arguments:,” which are additional

settings that specify more exactly what you want the “Actions” to do.

To make macro creation easier, Access comes with a macro design window. The window consists

of two panes. The upper pane is called the action pane, and contains a design grid similar to the QBE grid

used in creating queries. This design grid can contain up to five columns. The “Action,” “Arguments,” and

“Comment” columns are displayed by default. In the “Actions” column, you click and select one of the many

actions available that you want the macro to perform.

In the lower section, called the “action arguments” pane, you will enter any additional settings that

the selected action needs in order to function into the appropriate fields in the “action arguments” section.

Depending on the type of macro that you are writing, the arguments will vary considerably. Some actions

simply require that you define more arguments than others do. Many have default arguments that you can

change, if you wish. Some arguments have no default value, but instead allow you to enter in your own

expression. Also, some arguments are required for an action to work. For example, if you select the

“OpenReport” action, then you must specify the name of the report to open. As you enter the arguments

into the boxes available in the “Action Arguments” panel, the values will be displayed in the “Arguments”

column.

Access displays help about the currently selected argument at the right of the “Action Arguments”

pane when you have an argument selected. If you click into an argument text box in the pane, and then

press “F1” on your keyboard, a help window will appear to lend you even more assistance in specifying the

arguments needed for the selected action. This can be very helpful when programming macro behavior.

Next, move to the next line and continue selecting the next action to perform, and what arguments it

needs. When you have finished setting all of the actions and arguments that you wish, you will have your

macro completed. It’s just that easy.

The other column that is always displayed is the “Comment” column, into which you can type a brief

description of the action that is being performed. You can optionally display the “Macro Name” column into

which you can type a name for a section of actions within a macro. You can also display the “Condition”

column, which allows you to specify conditions under which a macro may run a specified action.

Once you have created a macro, you should save it so that you can run it in the future when needed.

When you are creating programs, they are usually designed to be run multiple times. So, give it a name that

will help you remember its function within the database.

Running a macro is easy. You can right-click on the name of any macro from the list displayed in the

Navigation Pane, and then click the “Run” command in the pop-up menu to run the program. You can also

simply double-click on the name of a macro shown in the Navigation Pane to run it, as well. Usually after

testing them, you will have to edit the macros to “tweak” little problems that you notice. Another way to run

macros in Access is to open them in design view, and then click the “Run” button in the “Tools” group on the

“Design” tab of the “Macro Tools” contextual tab within the Ribbon.

Editing a macro is easy, as well. Simply right-click the name of the macro to edit in the Navigation

Pane, and then select the “Design View” command in the pop-up menu that appears to display the design

view of the macro. Here you can change the macro actions and arguments as needed and then save it

again to run it. Once it is operating appropriately, you may want to consider adding the macro to a

command button’s “On Click” event.Sa
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Macros in Access 2007

17.2- Macro Actions:

When you are creating or editing a macro in design view, you may be a bit intimidated by the array

of actions that macros can perform. Many are very simple, once you get used to using them. A typical action

is “Open Query,” which opens a query in either “Design” or “Datasheet” view, depending on how you set the

action’s arguments. More complex command actions may only be used in programming modules.

A macro can use up to 999 actions. You place the actions in the separate rows of the macro design

grid, from the top line down. You can read the help file that is associated with any action that you select

from the “Actions” column by pressing the “F1” key on your keyboard with the action selected.

Also note that you can click the “Show All Actions” button in the “Show/Hide” group on the “Design”

tab of the “Macro Tools” tab within the Ribbon to toggle the display of all of the actions available on or off

within the “Actions” column in the macro design view. When this button is disabled, only macro actions that

can be run regardless of the trust status of the database will be shown in the “Actions” drop-down. This

ensures that even if the VBA is disabled in the database, the macro will still be allowed to function.

17.3- Assigning Macros to a Command Button:

When you assign a macro to a command button’s events, whenever the specified event to which

you attach the macro occurs, the specified macro will run. If you wish a user to click a command button

control in a form to launch a macro, then open the form in design view. Then make sure that the “Use

Control Wizards” button is selected in the “Controls” group. Next, click the “Button” control in the “Controls”

group on the “Design” tab of the “Form Design Tools” contextual tab within the Ribbon. Then click and drag

over the area in the form where you wish to place the command button. The “Command Button Wizard” will

then launch, allowing you to pick what text or picture to include on the button and also what macro to attach

to the button’s “Click” event. This is a very quick and easy way to assign a macro to a button.

You can also assign a macro to an object’s event through the “Property Sheet.” To do this, select the

object in the form to which you want to attach the macro, and then click the “Property Sheet” button to

display the “Property Sheet” pane. In the “Property Sheet” pane, click the “Event” tab to view all of the

available events for that particular type of object selected. Typically, macros are assigned to the “On Click”

event of a command button, which runs the macro when someone clicks the button. However, there are

other types of objects and events to which you may find it useful to attach macros. For example, you might

want a macro that runs when a user rolls the mouse pointer over a selected object. In this case, you would

program the macro to launch on the selected control’s “On Mouse Move” event. Once you have determined

the appropriate event to associate with a macro, click into the event property field in the “Event” tab in the

“Property Sheet,” and select the name of the macro that you want to run from the drop-down list that

appears.

Also, when in form design view, you can now embed macros directly into the form. Macros that are

embedded within a form do not appear as separate objects within the Navigation Pane. They can only be

edited from within the form. To do this, first select the object in the form within which you want to embed a

macro. Then click the “Events” tab in the “Property Sheet.” Find the event to which you want to attach an

embedded macro, and then click into the event shown in the tab. Next, click the builder button […] that

appears at the right end of the property field. In the “Choose Builder” dialog box that appears, select “Macro

Builder” and then click the “OK” button. This will open the new macro design window, where you build the

macro as normal. However, when you are finished, just click the “Close” button in the “Close” group on the

“Design” tab of the “Macro Tools” contextual tab. Then click the “Yes” button to save the embedded macro

into the form.Sa
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Macros in Access 2007

17.4- Conditional Macros and Option Groups:

Sometimes you only want a macro action to run based on whether or not some other value has been

set in the program. A conditional macro can accomplish this: the macro will only run when the specified

condition is met. Often, conditional macros are used to evaluate the specific option selected within an option

group control in a form. Option group controls are special logical controls used in forms to return a number

value when a specific selection is made within the option group. You can add an option group control into a

form by clicking the “Option group” button in the “Controls” group on the “Design” tab of the “Form Design

Tools” contextual tab within the Ribbon. Next, click and drag over the area of the form where you want the

option group to be placed. If you have the “Use Control Wizards” button selected, then the “Option Group

Wizard” will appear. You use this wizard to set the options from which the user can choose in the option

group. Whatever choice is made returns a number value, which is the value of the option group. You can

then easily use the “Expression Builder” when creating a conditional macro to evaluate which option has

been selected from within the option group, and then set the actions of the macro accordingly.

You can add conditions to macro actions by clicking the “Conditions” button in the “Show/Hide”

group on the “Design” tab of the “Macro Tools” contextual tab in the Ribbon when in the macro design view.

Doing that will insert a new column into your macro design view pane. This is the “Conditions” column

where you can insert a condition that, if evaluated to “True” when the macro is run, will cause your macro to

perform the associated action. You can either type your own expression into the “Condition” column, or you

can click the “Builder” button in the “Tools” group on the “Design” tab of the “Macro Tools” contextual tab

within the Ribbon to open the “Expression Builder” dialog box. You can use the “Expression Builder” dialog

box to assist you in creating your condition, if necessary. Ensure that the condition that you create is placed

next to the desired action in the design view. Then when the macro is activated, it will only perform the

action if the condition specified is true.

17.5- Using Group Names in Macros:

You can create a single macro that contains multiple, separate sections of actions that you can then

name and reference individually. This can have many advantages in simplifying the number of macros

contained in your database and how you reference them.

To use this feature, click the “Macro Names” button in the “Show/Hide” group on the “Design” tab of

the “Macro Tools” contextual tab in the Ribbon to display the “Macro Name” column. Here you can type a

name for the macro actions that you want to list in this grouping. You can list several names, with the

actions in the rows that appear immediately to the right and below it, as constituting the actions performed

by that named macro. Later, when making a reference to the specific group of actions to run within the

macro, you can refer to it by using this format: macroname.groupname.

17.6- Creating Autoexec Macros:

These are special macros. They run immediately upon opening a database file and serve “start-up”

functions like connecting to an ODBC data source. If you have a database to which you want to assign a

macro that will automatically run upon opening the database; you should make it an “Autoexec” macro. To

do this, simply create the macro that you want to use as the autoexec macro and then save it with that

name: “autoexec.” Any macro with this name is immediately run whenever the database file is opened.

NOTE: You can bypass “Autoexec” macros by holding down the “Shift” key as you open a database.Sa
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ACTIONS-

Macros in Access 2007
CREATING MACROS:

1. Click the “Macro” button in the “Other” group on the “Create” tab in the Ribbon, or click the “Macro” 

button’s drop-down button and then select “Macro” from the drop-down menu.

2. Click into the first empty field in the “Action” column and select an action from the drop-down “Action” 

list.

3. Click into the “Action Arguments” section at the bottom of the design view and set any additional 

arguments for the selected action, as needed.

4. Repeat steps 2 and 3 down the rows in the macro design view, until you have set all of the actions that 

you want the macro to perform.

5. Click “Save” in the Quick Access toolbar.

6. Type a name for the macro into the dialog box that appears, and click “OK” to save the macro.

EDITING MACROS:

1. Right-click on the name of the macro that you want to edit from the list displayed in the Navigation Pane.

2. Select the “Design View” command from the pop-up menu that appears.

3. Edit the macro as necessary, and then click the “Save” button in the Quick Access toolbar to save your 

changes.

RUNNING MACROS:

1. Double-click on the name of the macro that you want to run from the list displayed in the Navigation 

Pane.

2. Alternately, you could click the “Run” button in the “Tools” group on the “Design” tab in the “Macro 

Tools” contextual tab within the Ribbon.

MANUALLY ASSIGNING MACROS TO A COMMAND BUTTON:

1. Open the form into which you want to insert a command button that will run a specified macro in form 

design view.

2. Ensure that the “Use Control Wizards” button in the “Controls” group on the “Design” tab in the “Form 

Design Tools” contextual tab within the Ribbon.

3. Click the “Button” button in the “Controls” group on the “Design” tab in the “Form Design Tools” 

contextual tab within the Ribbon.

4. Click and drag over the area into which you wish to insert the command button, and release the mouse.

5. Cancel the “Command Button Wizard,” if it launches.

6. Make sure the command button control in the form is selected, and click the “Property Sheet” button in 

the “Tools” group on the “Design” tab in the “Form Design Tools” contextual tab within the Ribbon to 

display the “Property Sheet” panel, if needed.

7. Click the “Event” tab in the “Property Sheet.”

8. Click into the property box of the event which you would like to set as the triggering event for the macro.

9. Select the name of the macro to run from the drop-down list that appears when you click into the 

property box.Sa
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ACTIONS-

Macros in Access 2007
AUTOMATICALLY ASSIGNING MACROS TO A COMMAND BUTTON:

1. Open the form into which you want to insert a command button that will run a specified macro in form 

design view.

2. Ensure that the “Use Control Wizards” button in the “Controls” group on the “Design” tab in the “Form 

Design Tools” contextual tab within the Ribbon.

3. Click the “Button” button in the “Controls” group on the “Design” tab in the “Form Design Tools” 

contextual tab within the Ribbon.

4. Click and drag over the area into which you wish to insert the command button, and release the mouse.

5. In the “Command Button Wizard,” select “Miscellaneous” from the “Categories:” list box at the left and 

then select “Run Macro” from the “Actions:” list at the right.

6. Click “Next >” to continue.

7. Select the name of the macro to run from the list of macros that you have created, which is shown in this 

screen.

8. Click “Next >” to continue.

9. Select whether you want to display text or a picture on the command button by selecting the desired 

option button. Then enter the text to display or select the desired picture to display.

10. Click “Next >” to continue.

11. Type a name for the new command button, and click “Finish.”

CREATING CONDITIONAL MACROS:

1. Click the “Macro” button in the “Other” group on the “Create” tab in the Ribbon, or click the “Macro” 

button’s drop-down button and then select “Macro” from the drop-down menu.

2. If needed, click the “Conditions” button in the “Show/Hide” group on the “Design” tab in the “Macro 

Tools” contextual tab within the Ribbon to enable the “Condition” column.

3. Click into the field in the “Condition” column which is located next to the action that will be run if the 

condition evaluates to a true value.

4. Type the condition into the “Condition” column, or click into the “Condition” column and then click the 

“Builder” button in the “Tools” group on the “Design” tab in the “Macro Tools” contextual tab in the 

Ribbon to create the expression used in the column in the “Expression Builder” dialog box. If you create 

the expression in this dialog box, then click “OK” when you are finished to close the “Expression Builder” 

dialog box and insert the expression that you created into the “Conditions” column.

5. Click into the “Action” column to the right of the condition that you just created and then select the action 

to run if the condition is true.

6. Click into the “Action Arguments” section of the macro design view and set any additional arguments 

that your action needs in order to properly function.

7. Repeat steps 3 through 6 until all of the conditional actions for the macro have been assigned.

8. Click “Save” in the Quick Access toolbar.

9. Type a name for the macro into the dialog box that appears, and click “OK” to save the macro.
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ACTIONS-

Macros in Access 2007

CREATING GROUP MACROS:

1. Click the “Macro” button in the “Other” group on the “Create” tab in the Ribbon, or click the “Macro” 

button’s drop-down button and then select “Macro” from the drop-down menu.

2. If needed, click the “Macro Names” button in the “Show/Hide” group on the “Design” tab in the “Macro 

Tools” contextual tab within the Ribbon to enable the “Macro Name” column.

3. Type a group name for the group of actions into the first available row of the “Macro Names” column.

4. In the “Action” column to the right, select the first action to perform in the group from the drop-down list.

5. Set any required arguments for the selected action in the “Action Arguments” section.

6. Repeat steps 4 and 5 to list all of the following actions to be contained within that group.

7. Repeat steps 3 through 6 for any other groups that you want to add to the macro.

8. Click “Save” in the Quick Access toolbar.

9. Type a name for the macro into the dialog box that appears, and click “OK” to save the macro.

CREATING AUTOEXEC MACROS:

1. Click the “Macro” button in the “Other” group on the “Create” tab in the Ribbon, or click the “Macro” 

button’s drop-down button and then select “Macro” from the drop-down menu.

2. Create the macro that you wish to set as the macro that will be run each time the database is opened.

3. Click “Save” in the Quick Access toolbar.

4. Type “autoexec” into the “Macro Name:” text box and then click “OK” to save the macro.

ADDING AN OPTION GROUP CONTROL TO A FORM:

1. Open the form into which you want to insert an option group in form design view.

2. Ensure that the “Use Control Wizards” button in the “Controls” group on the “Design” tab in the “Form 

Design Tools” contextual tab within the Ribbon.

3. Click the “Option group” button in the “Controls” group on the “Design” tab in the “Form Design Tools” 

contextual tab within the Ribbon.

4. Click and drag over the area into which you wish to insert the option group, and release the mouse.

5. In the “Option Group Wizard,” type the labels of the choices from which you want the user to select.

6. Click “Next >” to continue.

7. In the next screen, select if you want the option group to have a default choice or not. If you do select to 

have a default choice, use the drop-down available to select which choice to set as the default.

8. Click “Next >” to continue.

9. In the next screen, type the number values that you wish to return as the value of the entire option group 

when a user make a selection. Option groups always return number values.

10. Click “Next >” to continue.

11. In the next screen, select the option button that corresponds to the desired style of controls to use with 

in the option group: “Option buttons,” “Check boxes,” or “Toggle buttons.” Next, select the option button 

that corresponds to the desired style that you wish to apply to the option group: “Etched,” “Flat,” 

“Raised,” “Shadowed,” or “Sunken.”

12. Click “Next >” to continue.

13. Type a name for the label used in the option group, and then click “Finish” to finish creating the option 

group control.
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EXERCISES-

Macros in Access 2007
Purpose:

1. To be able to create macros for your database and to be able to use them in forms in Access 2007.

Exercises:

1. Open your Access application.

2. Open the “test” database you completed from the Exercise at the end of Chapter 16.

3. Click the “Macro” button in the “Other” group on the “Create” tab in the Ribbon, or click the “Macro”

button’s drop-down button and then select “Macro” from the drop-down menu.

4. Create the macro shown below. Save it as “OpenJanuarySalesReport.”

5. Close the macro.

6. Select the “frmCustomers” form in the Navigation Pane and then press “Ctrl”+“Enter” to open it in

form design view.

7. Make sure the “Use Control Wizards” button is selected in the “Controls” group on the “Design” tab

of the “Form Design Tools” contextual tab within the Ribbon.

8. Click the “Button” control in the “Controls” group on the “Design” tab of the “Form Design Tools”

contextual tab within the Ribbon.

9. Click and drag over an area within the form into which you want to place a command button.

10. When you release the mouse button, the “Command Button” wizard will appear.

11. Under “Categories,” click “Miscellaneous.”

12. Under “Actions,” select “Run Macro.”

13. Click “Next >.”

14. Select the “OpenJanuarySalesReport” macro, and click “Next >.”

15. Select the “Text” option, and type “January Sales” into the text box to the right of the option button.

16. Click “Next >.”

17. Click “Finish.”

18. Click “Save.”

19. Click the “Form View” button in the “Views” group on the “Design” tab in the “Form Design Tools”

contextual tab in the Ribbon, and then click the button to view the report.

20. Close all objects in the database and click the “Yes” button to save your changes to “frmCustomers.”
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CHAPTER 18-

Macros in Access 2013:2010

18.1- Creating a Standalone Macro

18.2- Assigning Macros to a Command Button

18.3- Using Program Flow with Macros

18.4- Creating Autoexec Macros

18.5- Creating Data Macros
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Macros in Access 2013:2010

18.1- Creating a Standalone Macro:

A standalone macro is a program that you create in a visual environment that runs a series or set of

operations in a specified order. These objects will appear under the “Macros” category within the Navigation

Pane in your database. For example, a standalone Access macro could check the value of a form field and

then open a corresponding report based on the value of the field. When you write macros you will need to

know both the “Actions:,” what to do for each step in the macro; and the “Arguments:,” which are additional

settings that specify more exactly what you want the “Actions” to do.

To make macro creation easier, Access comes with a macro design window. To view this window,

first click the “Create” tab in the Ribbon. Next, click the “Macro” button in the “Macros & Code” group on this

tab. This will open the macro design window and also display the “Design” tab of the “Macro Tools”

contextual tab within the Ribbon.

Next you will need to select the actions that the macro will perform when it is run in the future. You

can select the desired action from the drop-down that appears within the macro design window.

Once you have selected a desired action, you will then need to enter the action’s arguments. These

action arguments are simply the additional settings that the selected action needs in order to function. You

enter these into the appropriate fields shown. Depending on the type of macro that you are writing, the

arguments will vary considerably. Some actions simply require that you define more arguments than others

do. Many have default arguments that you can change, if you wish. Some arguments have no default value,

but instead allow you to enter in your own expression. Also, some arguments are required for an action to

work. For example, if you select the “OpenForm” action, then you must specify the name of the form to

open.

If you hold your mouse pointer over one of the fields shown in the action arguments, Access

displays help about the currently selected argument in a pop-up window.

If you selected an action that you do not wish to include in your macro, you can remove the action

from the macro by simply clicking the delete button that looks like a small “x” in the upper-right corner of the

selected action.

To complete your macro, you simply continue selecting actions to perform from the “Add New

Action” drop-down below your current action and then specify what arguments the selected action needs.

When you have finished setting all of the actions and arguments that you wish, you will have completed

your macro. It’s just that easy.

Once you have created a macro, you should save it so that you can run it in the future when needed.

You can do this by clicking the “Save” button in the QuickAccess toolbar. Give it a name that will help you

remember its function within the database.

Running a macro is easy. You can right-click on the name of any macro from the list displayed in the

Navigation Pane, and then click the “Run” command in the pop-up menu to run the program. You can also

simply double-click on the name of a macro shown in the Navigation Pane to run it as well. Another way to

run macros in Access is to open them in design view, and then click the “Run” button in the “Tools” group on

the “Design” tab of the “Macro Tools” contextual tab within the Ribbon.

Editing a macro is easy, as well. Simply right-click the name of the macro to edit in the Navigation

Pane, and then select the “Design View” command in the pop-up menu that appears to display the design

view of the macro. Here you can change the macro actions and arguments as needed and then save it

again to run it. Once it is operating appropriately, you may want to consider adding the macro to a

command button’s “On Click” event.
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Macros in Access 2013:2010

18.2- Assigning Macros to a Command Button:

When you assign a macro to a command button’s events, whenever the specified event occurs the

specified macro will run. Most often, you will associate a macro with the “click” event of a command button.

If you wish a user to click a command button control in a form to launch a macro, then open the form in

design view. Then make sure that the “Use Control Wizards” button is selected in the “Controls” group

within the Ribbon. Next, click the “Button” control in the “Controls” group on the “Design” tab of the “Form

Design Tools” contextual tab within the Ribbon. Then click and drag over the area in the form where you

wish to place the command button. The “Command Button Wizard” will then launch, allowing you to pick

what text or picture to include on the button and also what macro to attach to the button’s “Click” event. This

is a very quick and easy way to assign a macro to a button.

You can also assign a macro to an object’s event through the “Property Sheet.” To do this, select the

object in the form to which you want to attach the macro, and then click the “Property Sheet” button to

display the “Property Sheet” pane. In the “Property Sheet” pane, click the “Event” tab to view all of the

available events for that particular type of object selected. Typically, macros are assigned to the “On Click”

event of a command button, which runs the macro when someone clicks the button. However, there are

other types of objects and events to which you may find it useful to attach macros. For example, you might

want a macro that runs when a user rolls the mouse pointer over a selected object. In this case, you would

program the macro to launch on the selected control’s “On Mouse Move” event. Once you have determined

the appropriate event to associate with a macro, click into the event property field in the “Event” tab in the

“Property Sheet,” and select the name of the macro that you want to run from the drop-down list that

appears.

Also, when in form design view, you can embed macros directly into the form. Macros that are

embedded within a form do not appear as separate objects within the Navigation Pane. They can only be

edited from within the form. To do this, first select the object in the form within which you want to embed a

macro. Then click the “Events” tab in the “Property Sheet.” Find the event to which you want to attach an

embedded macro, and then click into the event shown in the tab. Next, click the builder button […] that

appears at the right end of the property field. In the “Choose Builder” dialog box that appears, select “Macro

Builder” and then click the “OK” button. This will open the new macro design window, where you build the

macro as normal. However, when you are finished, just click the “Close” button in the “Close” group on the

“Design” tab of the “Macro Tools” contextual tab. Then click the “Yes” button to save the embedded macro

into the form.
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Macros in Access 2013:2010

18.3- Using Program Flow with Macros:

You can use the program flow functionality in Access to create macros that are run only when

specified conditions have been met or perform other, more advanced types of macro functions. The

program flow functions replace many of the older features of macros found in versions of Access before

2010, such as the “Conditions” column, macro names, and comments. In this section we will examine how

you can use the program flow functions to create advanced macros.

You can use the “Group” function to create collapsible and expandable groupings of named macro

actions within a larger macro. This allows you to create a larger macro with different named sections within

it. To do this, click and drag the “Group” function into your macro design window from the “Action Catalog”

and then type a name for the group into the “Group:” field. You then add the actions to the named group as

you normally would. Note that you can have several groups within a single macro. Note that, unlike previous

versions of Access, the groups within a macro cannot be called or run individually. They are simply used to

organize actions within longer macros.

You can use the “If” function to create conditional macros that will only execute if a given scenario

evaluates to a logical true value. To do this, click and drag the “If” function into your macro design window

from the “Action Catalog” and then enter the expression to evaluate into the “If” field. If you want assistance

in correctly entering the expression, be sure to click the “Expression Builder” button that appears at the right

end of the “If” field. This will open a separate “Expression Builder” window where you can add references to

database objects and also enter values that should be evaluated. When you are finished creating the

expression, click the “OK” button to add it to your “If” function. You can then use the “Add New Action” drop-

down to choose the action to take if the specified expression returns a “True” value. Next, if you wish to add

an “else” condition to the “if” statement, you can click either the “Add Else” or “Add Else If” hyperlinks within

the “If statement. Clicking the “Add Else” hyperlink will add an “Else” statement to your “If” statement that

will allow you to specify an action to take if your expression returns a logical false value. Clicking the “Add

Else If” hyperlink will allow you to evaluate yet another expression if the first expression evaluates to a false

value. This allows you to evaluate many expressions and return a unique action based on multiple possible

values.

To use the “Comment” function, click and drag the “Comment” from the “Action Catalog” and drop it

into the desired line within a macro to add a non-executable line of text to your macro. Simply type the text

that you want to have appear within the text box. When you exit the text box, Access will convert the text

into a non-executing comment within your macro. Note that if you add the comment into the wrong place,

you can click the “Move Up” or “Move Down” arrows that appear at the right end of the comment line when

you hold your mouse pointer over it to move the comment up or down through the lines of actions. You can

also delete a comment by clicking the small delete button, which looks like a small “x,” in the same area.

You can use the “Submacro” function to add a submacro within your macro that can only be called

by either the “OnError” or “RunMacro” macro actions. Submacros must always be the last actions within a

macro, if used. To do this, click and drag the “Submacro” function into your macro design window from the

“Action Catalog” and then type a name for the submacro into the “Submacro:” field. You then add the

actions to the submacro as you normally would. You can set the reference to the submacro using the

“Property Event” sheet, or by using the “RunMacro” or “OnError” actions within a macro.
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18.4- Creating Autoexec Macros:

These are special macros. They run immediately upon opening a database file and serve “start-up”

functions like connecting to an ODBC data source. If you have a database to which you want to assign a

macro that will automatically run upon opening the database; you should make it an “Autoexec” macro. To

do this, simply create the macro that you want to use as the autoexec macro and then save it with that

name: “autoexec.” Any macro with this name is immediately run whenever the database file is opened.

NOTE: You can bypass “Autoexec” macros by holding down the “Shift” key as you open a database.

18.5- Creating Data Macros:

Starting in Access 2013:2010, you can create data macros which will allow you to evaluate data as it

is entered into the database tables. These macros perform the same function that “stored procedures”

would within larger relational database applications, such as Microsoft SQL Server for example. You can

also created named data macros that can be called as a standalone macro would be.

To create a data macro, first display the table for which you want to create the data macro in the

datasheet view. Next, click the “Table” tab within the “Table Tools” contextual tab within the Ribbon.

You can then select with which data event you want to associate the macro by clicking the desired

event from the listing shown in the “Before Events” and “After Events” groups. Your choice will determine

when this macro is run in the future. If macros have already been set for any of these events, they will

appear as highlighted already in the Ribbon.

Next the macro design window will appear, and you can then select the actions that you want to

have occur when this macro is triggered in the future. When you have finished, you can click the “Save”

button in design window to save the data macro.

Also note that you can create a “Named Macro” that is associated with the selected table, but not

with any particular action that occurs within the table. These macros can be run by other data or standalone

macros. To create a named data macro, on the “Table” tab in the “Named Macros” group, click the “Named

Macro” button and then click the “Create Named Macro” button in the drop-down menu that appears.

You can then create the macro as normal using the actions available in the “Add New Action” drop-

down. You can also add parameters, if needed, into your data macro. Parameters allow you to pass values

to a named data macro so that they can be evaluated. You can also use them to pass object references

from a standalone macro to a data macro.

To add a parameter to a data macro, click the “Create Parameter” hyperlink at the top of the macro.

Next, in the “Name” box, type a unique name for the parameter. This will be the name that you use to refer

to the parameter in your expressions. You can also optionally type a description for the parameter into the

“Description” text box. This is recommended because in the future when you use the parameter, the

description text that you enter here will be displayed as a tooltip. This helps you remember the purpose of

the parameter.

In the future, you can run a named data macro from another macro by using the “RunDataMacro”

action provided. The action provides a box for each parameter created within the data macro, so that you

can give it the necessary values.
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CREATING A STANDALONE MACRO:

1. Click the “Create” tab in the Ribbon. Next, click the “Macro” button in the “Macros & Code” group on this 

tab. This will open the macro design window and also display the “Design” tab of the “Macro Tools” 

contextual tab within the Ribbon.

2. Next you will need to select the actions that the macro will perform when it is run in the future. You can 

select the desired action from the drop-down that appears within the macro design window.

3. Once you have selected a desired action, you will then need to enter the action’s arguments. These 

action arguments are simply the additional settings that the selected action needs in order to function. 

You enter these into the appropriate fields shown. Depending on the type of macro that you are writing, 

the arguments will vary considerably.

4. If you hold your mouse pointer over one of the fields shown in the action arguments, Access displays 

help about the currently selected argument in a pop-up window.

5. If you selected an action that you do not wish to include in your macro, you can remove the action from 

the macro by simply clicking the delete button that looks like a small “x” in the upper-right corner of the 

selected action.

6. To complete your macro, you simply continue selecting actions to perform from the “Add New Action” 

drop-down below your current action and then specify what arguments the selected action needs.

7. When you have finished setting all of the actions and arguments that you wish, click the “Save” button in 

the QuickAccess toolbar. Give it a name that will help you remember its function within the database.

RUNNING A MACRO:

1. To run a macro, right-click on the name of any macro from the list displayed in the Navigation Pane and 

then click the “Run” command in the pop-up menu to run the program. You can also simply double-click 

on the name of a macro shown in the Navigation Pane to run it as well. Another way to run macros in 

Access is to open them in design view, and then click the “Run” button in the “Tools” group on the 

“Design” tab of the “Macro Tools” contextual tab within the Ribbon.

EDITING A MACRO:

1. To edit a macro, right-click the name of the macro to edit in the Navigation Pane, and then select the 

“Design View” command in the pop-up menu that appears to display the design view of the macro. Here 

you can change the macro actions and arguments as needed and then save it again to run it.
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ACTIONS-
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ASSIGNING A MACRO TO A COMMAND BUTTON WITHIN A FORM:

1. Open the form in design view.

2. Make sure that the “Use Control Wizards” button is selected in the “Controls” group within the Ribbon.

3. Click the “Button” control in the “Controls” group on the “Design” tab of the “Form Design Tools” 

contextual tab within the Ribbon.

4. Click and drag over the area in the form where you wish to place the command button. The “Command 

Button Wizard” will then launch, allowing you to pick what text or picture to include on the button and 

also what macro to attach to the button’s “Click” event.

5. You can also assign a macro to an object’s event through the “Property Sheet.” To do this, select the 

object in the form to which you want to attach the macro, and then click the “Property Sheet” button to 

display the “Property Sheet” pane.

6. In the “Property Sheet” pane, click the “Event” tab to view all of the available events for that particular 

type of object selected. Typically, macros are assigned to the “On Click” event of a command button.

7. Once you have determined the appropriate event to associate with a macro, click into the event property 

field in the “Event” tab in the “Property Sheet,” and select the name of the macro that you want to run 

from the drop-down list that appears.

EMBEDDING A MACRO WITHIN A FORM:

1. Select the object in the form within which you want to embed a macro.

2. Click the “Events” tab in the “Property Sheet.”

3. Find the event to which you want to attach an embedded macro, and then click into the event shown in 

the tab.

4. Next, click the builder button […] that appears at the right end of the property field.

5. In the “Choose Builder” dialog box that appears, select “Macro Builder” and then click the “OK” button.

6. This will open the new macro design window, where you build the macro as normal.

7. When you are finished, just click the “Close” button in the “Close” group on the “Design” tab of the 

“Macro Tools” contextual tab.

8. Click the “Yes” button to save the embedded macro into the form.

USING THE “COMMENT” PROGRAM FLOW FUNCTION WITHIN A MACRO:

1. Click and drag the “Comment” from the “Action Catalog” and drop it into the desired line within a macro 

to add a non-executable line of text to your macro.

2. Type the text that you want to have appear within the text box.

3. When you exit the text box, Access will convert the text into a non-executing comment within your 

macro.

4. Note that if you add the comment into the wrong place, you can click the “Move Up” or “Move Down” 

arrows that appear at the right end of the comment line when you hold your mouse pointer over it to 

move the comment up or down through the lines of actions.

5. You can also delete a comment by clicking the small delete button, which looks like a small “x,” in the 

same area.
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ACTIONS-

Macros in Access 2013:2010

USING THE “GROUP” PROGRAM FLOW FUNCTION WITHIN A MACRO:

1. Click and drag the “Group” function into your macro design window from the “Action Catalog” and then 

type a name for the group into the “Group:” field.

2. You then add the actions to the named group as you normally would. Note that you can have several 

groups within a single macro.

USING THE “IF” PROGRAM FLOW FUNCTION WITHIN A MACRO:

1. Click and drag the “If” function into your macro design window from the “Action Catalog” and then enter 

the expression to evaluate into the “If” field.

2. If you want assistance in correctly entering the expression, be sure to click the “Expression Builder” 

button that appears at the right end of the “If” field. This will open a separate “Expression Builder” 

window where you can add references to database objects and also enter values that should be 

evaluated. When you are finished creating the expression, click the “OK” button to add it to your “If” 

function.

3. You can then use the “Add New Action” drop-down to choose the action to take if the specified 

expression returns a “True” value.

4. If you wish to add an “else” condition to the “if” statement, you can click either the “Add Else” or “Add 

Else If” hyperlinks within the “If statement.

5. Clicking the “Add Else” hyperlink will add an “Else” statement to your “If” statement that will allow you to 

specify an action to take if your expression returns a logical false value.

6. Clicking the “Add Else If” hyperlink will allow you to evaluate yet another expression if the first 

expression evaluates to a false value. This allows you to evaluate many expressions and return a 

unique action based on multiple possible values.

USING THE “SUBMACRO” PROGRAM FLOW FUNCTION WITHIN A MACRO:

1. Click and drag the “Submacro” function into your macro design window from the “Action Catalog” and 

then type a name for the submacro into the “Submacro:” field.

2. You then add the actions to the submacro as you normally would.

3. You can set the reference to the submacro using the “Property Event” sheet, or by using the 

“RunMacro” or “OnError” actions within a macro.
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ACTIONS-

Macros in Access 2013:2010

CREATING AN “AUTOEXEC” MACRO:

1. Create the macro that you want to use as the autoexec macro as you normally would, and then save it 

with that name: “autoexec.” Any macro with this name is immediately run whenever the database file is 

opened.

NOTE: You can bypass “Autoexec” macros by holding down the “Shift” key as you open a database.

CREATING A DATA MACRO:

1. To create a data macro, first display the table for which you want to create the data macro in the 

datasheet view.

2. Click the “Table” tab within the “Table Tools” contextual tab within the Ribbon.

3. You can then select with which data event you want to associate the macro by clicking the desired event 

from the listing shown in the “Before Events” and “After Events” groups. Your choice will determine 

when this macro is run in the future. If macros have already been set for any of these events, they will 

appear as highlighted already in the Ribbon.

4. Next the macro design window will appear, and you can then select the actions that you want to have 

occur when this macro is triggered in the future.

5. When you have finished, you can click the “Save” button in design window to save the data macro.

CREATING A NAMED DATA MACRO:

1. To create a named data macro, on the “Table” tab in the “Named Macros” group, click the “Named 

Macro” button and then click the “Create Named Macro” button in the drop-down menu that appears.

2. You can then create the macro as normal using the actions available in the “Add New Action” drop-

down.

3. To add a parameter to a data macro, click the “Create Parameter” hyperlink at the top of the macro.

4. Next, in the “Name” box, type a unique name for the parameter. This will be the name that you use to 

refer to the parameter in your expressions.

5. You can also optionally type a description for the parameter into the “Description” text box. This is 

recommended because in the future when you use the parameter, the description text that you enter 

here will be displayed as a tooltip. This helps you remember the purpose of the parameter.

6. In the future, you can run a named data macro from another macro by using the “RunDataMacro” action 

provided. The action provides a box for each parameter created within the data macro, so that you can 

give it the necessary values.
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EXERCISES-

Macros in Access 2013:2010
Purpose:

1. To be able to create macros for your database and to be able to use them in forms in Access.

Exercises:

1. Open your Access application.

2. Open the “test” database you completed from the Exercise at the end of Chapter 16.

3. Click the “Create” tab in the Ribbon and then click the “Macro” button in the “Macros & Code” group

on this tab. This will open the macro design window and also display the “Design” tab of the “Macro

Tools” contextual tab within the Ribbon.

4. Create the macro shown below. Save it as “OpenJanuarySalesReport.”

5. Close the macro.

6. Select the “frmCustomers” form in the Navigation Pane and then press “Ctrl”+“Enter” to open it in

form design view.

7. Make sure the “Use Control Wizards” button is selected in the “Controls” group on the “Design” tab

of the “Form Design Tools” contextual tab within the Ribbon.

8. Click the “Button” control in the “Controls” group on the “Design” tab of the “Form Design Tools”

contextual tab within the Ribbon.

9. Click and drag over an area within the form into which you want to place a command button.

10. When you release the mouse button, the “Command Button” wizard will appear.

11. Under “Categories,” click “Miscellaneous.”

12. Under “Actions,” select “Run Macro.”

13. Click “Next >.”

14. Select the “OpenJanuarySalesReport” macro, and click “Next >.”

15. Select the “Text” option, and type “January Sales” into the text box to the right of the option button.

16. Click “Next >.”

17. Click “Finish.”

18. Click “Save.”

19. Click the “Form View” button in the “Views” group on the “Design” tab in the “Form Design Tools”

contextual tab in the Ribbon, and then click the button to view the report.

20. Close all objects in the database and click the “Yes” button to save your changes to “frmCustomers.”Sa
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CHAPTER 19-

Switchboard and Navigation Forms

19.1- Creating a Switchboard Form

19.2- Creating a Navigation Form- 2013:2010 Only

19.3- Controlling Startup Behavior- 2007 Only

19.4- Controlling Startup Behavior- 2013:2010 Only
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Switchboard and Navigation Forms

19.1- Creating a Switchboard Form:

When you create a “switchboard” form, all you are doing is changing the form’s function or purpose

within the database. Instead of allowing users to perform data entry, switchboard forms allow users to click

buttons or make choices in option groups that then launch macros which grant access to other forms and

reports or automate other database tasks. Switchboard forms are used to control the flow of the database

application’s screens. Starting in Access 2010, this functionality has been incorporated into the new

“Navigation” form types, which allow you to create switchboard forms and add buttons for navigation more

easily than before. While you can still create a switchboard form using this method in Access 2010 and

later, you may find that using the “Navigation” form type is simply faster and easier.

To create a switchboard form, click the “Blank Form” button in the “Forms” group on the “Create” tab

in the Ribbon. Do not associate any data source with the form. If needed, switch to the form’s design view.

Next, in the form design view, click the form selector in the upper left corner of the form. It is the

square gray button that is located at the intersection of the horizontal and vertical rulers. This will place a

small black square into the box. That means that you have the whole form selected, versus selecting a

specific section within the form. Next, ensure that you can see the “Property Sheet.” If not, you can click the

“Property Sheet” button in the “Tools” group on the “Design” tab of the “Form Design Tools” contextual tab

within the Ribbon.

In the “Property Sheet,” you are now going to change some default settings to get rid of some of the

aspects of the form which you commonly associate with data entry. This will clear the way for you to then

add images, command buttons or other types of navigational controls into the form. To start, click the

“Format” tab. In this tab, click into the “Default View” property and set the value to “Single Form” from the

drop-down menu that appears. Next, click into the “Allow Form View” property and select “Yes” from the

drop-down menu available. Then you will set the “Allow Datasheet View,” “Allow PivotTable View,” “Allow

PivotChart View,” and “Allow Layout View” properties to “No.” This will prevent the user from changing the

view of your switchboard form.

Next, click into the “Record Selectors” property and set that to “No.” Click into the “Navigation

Buttons” property and set that to “No.” This will remove the distracting record navigation features which you

will not use in a switchboard form, as you do not perform data entry in these types of forms. Once you have

made these basic changes, plus any additional ones that you would like, save the changes to the form.

Then you can begin adding your desired navigational controls, command buttons, and onscreen instructions

to the switchboard form.

19.2- Creating a Navigation Form- 2013:2010 Only:

If you are using Access 2013 or 2010, then you have the ability to quickly and easily create a

“Navigation” form that will allow you to perform the same function as a switchboard form within your

database. A navigation form simply contains buttons that you can click in order to open other database

objects, such as reports and other, related forms.

To create a navigation form, click the “Navigation” button in the “Forms” group on the “Create” tab

within the Ribbon. Then select the desired style of navigation form that you would like to create from the

drop-down listing that appears.

Next, you can click and drag the desired database objects for which you want to create buttons from

the Navigation Pane into the “Add New” section of the Navigation Form. As you drop the items into this

section, Access will automatically create button links to the objects and also display the objects within the

designated section within the Navigation Form. When you are finished, simply click the “Save” button in the

QuickAccess toolbar to save your Navigation Form.Sa
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Switchboard and Navigation Forms

19.3- Controlling Startup Behavior- 2007 Only:

Depending on the size and complexity of the database that you are creating, you may have multiple

switchboard forms in the database. Simple databases usually don’t require more than one. If you have a

main switchboard that you would like to appear at the startup of the database you can specify which one

you want to run by changing the database startup options.

To do this, close all open database objects and then click the “Microsoft Office Button.” In the

command panel that appears, click the “Access Options” button. That will open the “Access Options” dialog

box. Select the “Current Database” option at the left side of this window to set properties for the currently

opened database in the screen at right. To set a form to display when a user starts the database, select the

name of the switchboard form to open from the “Display Form:” drop-down. You can even type a new title

for your database application into the “Application Title:” text box.

In the “Navigation” section, you can uncheck the “Display Navigation Pane” checkbox to hide the

Navigation Pane at startup. Set any additional database startup options, as you desire, in this dialog box.

Then click “OK.” The next time that you open the database file, it will open the form you selected and will

also apply any other startup settings specified.

19.4- Controlling Startup Behavior- 2013:2010 Only:

Depending on the size and complexity of the database that you are creating, you may have multiple

navigation forms in the database. Simple databases usually don’t require more than one. If you have a main

navigation form that you would like to have appear when the users initially open the database you can

specify which form you want to display by changing the database startup options.

To do this, close all open database objects and then click the “File” tab in the Ribbon. In the

command panel that appears at the left side of the window, click the “Options” button. That will open the

“Access Options” dialog box.

Select the “Current Database” option at the left side of this window to set properties for the currently

opened database in the screen at right. To set a form to display when a user starts the database, select the

name of the switchboard form to open from the “Display Form:” drop-down. You can even type a title for

your database application into the “Application Title:” text box.

In the “Navigation” section, you can uncheck the “Display Navigation Pane” checkbox to hide the

Navigation Pane from your users at startup. Set any additional database startup options, as you desire, in

this dialog box. Then click “OK.” The next time that you open the database file, it will open the form you

selected and will also apply any other startup settings specified.
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ACTIONS-

Switchboard and Navigation Forms

CREATING A SWITCHBOARD FORM:

1. Click the “Blank Form” button in the “Forms” group on the “Create” tab in the Ribbon.

2. Ensure that you can see the “Property Sheet.” If not, you can click the “Property Sheet” button in the 

“Tools” group on the “Design” tab of the “Form Design Tools” contextual tab within the Ribbon.

3. Click the “Format” tab in the “Property Sheet.”

4. Click into the “Default View” property and select “Single Form” from the drop-down menu that appears.

5. Click into the “Allow Form View” property and select “Yes” from the drop-down.

6. Click into the “Allow Datasheet View” property and select “No.”

7. Click into the “Allow PivotTable View” property and select “No.”

8. Click into the “Allow PivotChart View” property and select “No.”

9. Click into the “Allow Layout View” property and select “No.”

10. Click into the “Record Selectors” property and select “No.”

11. Click into the “Navigation Buttons” property and select “No.”

12. Click “Save” in the Quick Access toolbar.

13. In the dialog box that appears, enter a name for your new switchboard form and then click “OK.”

CREATING A NAVIGATION FORM- (ACCESS 2013:2010 ONLY):

1. To create a navigation form, click the “Navigation” button in the “Forms” group on the “Create” tab within 

the Ribbon. Then select the desired style of navigation form that you would like to create from the drop-

down listing that appears.

2. Next, you can click and drag the desired database objects for which you want to create buttons from the 

Navigation Pane into the “Add New” section of the Navigation Form.

3. As you drop the items into this section, Access will automatically create button links to the objects and 

also display the objects within the designated section within the Navigation Form.

4. When you are finished, simply click the “Save” button in the QuickAccess toolbar to save your 

Navigation Form.

CONTROLLING STARTUP BEHAVIOR- (ACCESS 2007 ONLY):

1. Open the database and close all database objects.

2. Click the “Microsoft Office Button.”

3. In the command panel that appears, click the “Access Options” button. That will open the “Access 

Options” dialog box.

4. Select the “Current Database” option at the left side of this window to set properties for the currently 

opened database in the screen at right.

5. To set a form to display when a user starts the database, select the name of the switchboard form to 

open from the “Display Form:” drop-down.

6. You can type a new title for your database application into the “Application Title:” text box.

7. In the “Navigation” section, you can uncheck the “Display Navigation Pane” checkbox to hide the 

Navigation Pane at startup.

8. Set any additional database startup options, as you desire, in this dialog box.

9. Click “OK.”

10. The next time that you open the database file, it will open the form you selected and will also apply any 

other startup settings specified.Sa
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ACTIONS-

Switchboard and Navigation Forms
CONTROLLING STARTUP BEHAVIOR- (ACCESS 2013:2010 ONLY):

1. Open the database and close all database objects.

2. Click the “File” tab in the Ribbon.

3. In the command panel that appears at the left side of the window, click the “Options” button. That will 

open the “Access Options” dialog box.

4. Select the “Current Database” option at the left side of this window to set properties for the currently 

opened database in the screen at right.

5. To set a form to display when a user starts the database, select the name of the switchboard form to 

open from the “Display Form:” drop-down.

6. You can type a new title for your database application into the “Application Title:” text box.

7. In the “Navigation” section, you can uncheck the “Display Navigation Pane” checkbox to hide the 

Navigation Pane at startup.

8. Set any additional database startup options, as you desire, in this dialog box.

9. Click “OK.”

10. The next time that you open the database file, it will open the form you selected and will also apply any 

other startup settings specified.
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EXERCISES-

Switchboard and Navigation Forms

Purpose:

1. To be able to create a switchboard form and to assign it to display at startup in Access 2007.

Exercises:

1. Open your Access application.

2. Click the Microsoft Office button and select the “Open” command.

3. Open the “test” database you completed from the Exercise at the end of Chapter 17.

4. Click the “Blank Form” button in the “Forms” group on the “Create” tab in the Ribbon.

5. Ensure that you can see the “Property Sheet.” If not, you can click the “Property Sheet” button in the

“Tools” group on the “Design” tab of the “Form Design Tools” contextual tab within the Ribbon.

6. Click the “Format” tab in the “Property Sheet.”

7. Click into the “Default View” property and select “Single Form” from the drop-down menu.

8. Click into the “Allow Form View” property and select “Yes” from the drop-down.

9. Click into the “Allow Datasheet View” property and select “No.”

10. Click into the “Allow PivotTable View” property and select “No.”

11. Click into the “Allow PivotChart View” property and select “No.”

12. Click into the “Allow Layout View” property and select “No.”

13. Click into the “Record Selectors” property and select “No.”

14. Click into the “Navigation Buttons” property and select “No.”

15. Set the “AutoCenter” property to “Yes.”

16. Set the “Dividing Lines” property to “No.”

17. Click “Save” in the Quick Access toolbar. In the dialog box that appears, name the form “frmSwitch,”

and then click the “OK” button.

18. Click the “Button” control in the “Controls” group on the “Design” tab of the “Form Design Tools”

contextual tab in the Ribbon, and then click and drag over an area for the button within the form.

19. In the “Command Button Wizard,” under “Categories,” select “Form Operations” and select “Open

Form” under “Actions.”

20. Click “Next >.”

21. Select “frmCustomers” and click “Next >.”

22. Select the “Open the form and show all the records” option.

23. Click “Next >.”

24. Select to “Open the form and show all the records.”

25. Click “Next >”

26. Select the “Text” option, and then type “Open Customer Form” as the text.

27. Click “Next >.”

28. Click “Finish.”

29. Click “Save” in the Quick Access toolbar.

30. Click the Microsoft Office Button and then click the “Access Options” button to open the “Access

Options” dialog box. Click the “Current Database” category at the left side of the dialog box.

31. At the right side of the window, use the “Display Form:” drop-down to select “frmSwitch.”

32. Click “OK.”

33. Close the database and the reopen the database to see the “Switch” form appear at startup. Test it

for functionality, and then close the database.Sa
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EXERCISES-

Switchboard and Navigation Forms

Purpose:

1. To be able to create a switchboard form and to assign it to display at startup in Access 2013 & 2010.

Exercises:

1. Open your Access application.

2. Click the Microsoft Office button and select the “Open” command.

3. Open the “test” database you completed from the Exercise at the end of Chapter 18.

4. Click the “Navigation” button in the “Forms” group on the “Create” tab in the Ribbon.

5. Click the “Vertical Tabs, Left” button to create a navigation form and display it in form layout view.

6. Click and drag the “frmCustomers” form from the “Forms” section of the Navigation Pane and drop it

into the “[Add New]” panel at the left side of the navigation form.

7. Click and drag the “Sales By Employee” report from the “Reports” section of the Navigation Pane

and drop it into the “[Add New]” panel at the left side of the navigation form.

8. Click “Save” in the Quick Access toolbar.

9. Close the “frmSwitch” navigation form that you just created.

10. Click the “File” tab in the Ribbon.

11. Click the “Options” button in the command button listing at the left side of the backstage view to

open the “Access Options” dialog box.

12. Click the “Current Database” category at the left side of the “Access Options” dialog box.

13. At the right side of the window, use the “Display Form:” drop-down to select “frmSwitch.”

14. Click “OK.”

15. Click “OK” in the message box that appears.

16. Close the database and the reopen the database to see the “Switch” form appear at startup. Test it

for functionality, and then close the database.
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CHAPTER 20-

Advanced Features

20.1- Getting External Data

20.2- Exporting Data

20.3- Setting a Database Password- 2007 Only

20.4- Setting a Database Password- 2013:2010 Only

20.5- Using Help
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Advanced Features

20.1- Getting External Data:

Access has a feature that allows it to connect to many different types of external data sources. You

have a choice as to how you want to connect to the external data in Access. You can either import the

external data into a native Access table that you create, or you can try to create a link to the source data.

Depending upon the type of link that you create to the external data, you may be allowed to query, add, edit,

and otherwise modify the external data as if it were a native Access table but without actually importing the

data into the database.

When you import external data into an Access database, it is stored in an actual Access table. You

are then free to use it just as you would any other Access table. Changes made to the table are not

reflected in the original data source, such as the text file or spreadsheet from which you imported the data.

When you create a link to an external data source, such as an SQL Server database, Access does

not import the table, nor does it change the type of data to which it is linked. A linked table in Access is

represented by a right-pointing arrow which points at an icon. The icon shown changes depending on the

“source” data type. Linked tables are useful because the link will automatically update the data in the copy

in Access with changes from the original data source, so that you can work with the most current data within

the linked table. Also, when you delete a “linked” table from your Access database, it is important to

remember that you are only deleting the “link” or “reference” to the data source, not the actual linked data

source itself.

To either import or link external data to your database, you start by clicking the “External Data” tab in

the Ribbon. To then make a connection to the external data source, click on the button in the “Import & Link”

group (“Import” group in Access 2007) that shows the name of the type of external data to which you are

trying to connect. Clicking any one of these buttons will then open the “Get External Data” wizard. This

wizard will then lead you on a step-by-step process that will allow you to decide whether or not to import the

data or link to the data, select the data source, and also save the connection if needed. Note that the

specific steps involved in the “Get External Data” wizard will vary slightly, depending upon the type of data

which you are trying to import or link to your current database.

20.2- Exporting Data:

You can easily export table data from your database into a wide variety of formats that are available.

You can also export other database objects, like forms and reports, however you will find that you have

more limitations on the formats in which these type of objects can be exported.

To export database information, first select the database object that you wish to export from the

listing shown in the Navigation Pane. Next, click the “External Data” tab in the Ribbon. In the “Export” group,

click the button that shows the file format to which you want to export the selected database object.

This will open the “Export” wizard for the type of export that you want to perform. The specific steps

shown in each wizard will vary slightly depending upon the file type to which you are exporting the selected

database object. However, most of the time, you will still need to select a name and file location for the

exported object. You will also often need to set additional parameters for the export routine. Just as when

you import data, you will also be prompted to save your export routine, if desired.
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Advanced Features

20.3- Setting a Database Password- 2007 Only:

Once you have your database up and running, you may want to consider adding a bit of security to it

so that no one will be able to destroy what you’ve created. You can set a database password to prevent

unauthorized access to the database file. In order to set a database password, you must open the database

as “exclusive.” To do this, simply open Access and then click the Microsoft Office Button. Select the “Open”

command from the drop-down command panel. Use the “Open” dialog box to navigate to the folder which

contains the database that you want to open. Then click the database file to select it. Next, instead of

clicking the “Open” button to open it, click the small drop-down arrow next to the “Open” button in the lower

right corner of the “Open” dialog box. From this drop-down menu, select “Open exclusive.” That will open

the selected database for your exclusive use, and now you can set the database password.

Once the database is opened exclusively, click the “Encrypt with Password” button in the “Database

Tools” group on the “Database Tools” tab in the Ribbon. This will launch the “Set Database Password”

dialog box. Enter your database password into the “Password:” text box and then retype it into the “Verify:”

text box. Then click “OK.” Then write down the password and store in a safe place for later retrieval, if

necessary. You cannot open the database without the password. If you lose the password, you’ll need to

start all over again! We cannot overemphasize the importance of securing your password in a safe place.

20.4- Setting a Database Password- 2013:2010 Only:

You can set a database password to prevent unauthorized access to the database file, if desired. In

order to set a database password, you must first open the database as “exclusive.” To do this, simply open

Access 2013 or 2010 and then click the “File” tab in the Ribbon. Click the “Open” command in the command

panel at the left side of the backstage view. Use the “Open” dialog box to navigate to the folder which

contains the database that you want to open. Then click the database file to select it. Next, instead of

clicking the “Open” button to open it, click the small drop-down arrow next to the “Open” button in the lower

right corner of the “Open” dialog box. From this drop-down menu, select “Open exclusive.” That will open

the selected database for your exclusive use, and now you can set the database password.

Once the database is opened exclusively, click “File” tab in the Ribbon once again. Then click the

“Info” command in the command panel at the left side of the backstage view. To the right, click the “Encrypt

with Password” button in the backstage view.

This will launch the “Set Database Password” dialog box. Enter your database password into the

“Password:” text box and then retype it into the “Verify:” text box. Then click “OK.”

Then write down the password and store in a safe place for later retrieval, if necessary. You cannot

open the database without the password. If you lose the password, you’ll need to start all over again! We

also cannot overemphasize the importance of securing your password in a safe place.
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Advanced Features

20.5- Using Help:

Access has built-in help functionality which can greatly reduce the time and cost of technical

support. The help functionality is quite extensive. It contains a searchable database of help files for you to

read.

You can access the help in Access by clicking the “Microsoft Access Help” button. This will open the

“Access Help” window. Notice that this window can be closed by simply clicking the “x” in the upper right

corner of the window when you are finished using the help files.

If you wish to search through the help files for a topic, you can easily type the words for which you

wish to look into the long white text box in the toolbar at the top of this window. You can then decide where

you wish to search for the information by clicking the drop-down button next to the “Access Help” title in

Access 2013 or the “Search” button in Access 2010:2007, and then selecting a choice from the drop-down

menu. Once you have selected where to search, just click the “Search” button to let Access search for the

words or phrases that you entered.

Any matching help topics are then displayed in the “Access Help” window as a listing of hyperlinks.

You can click on the name of a help topic to view its content in the “Access Help” window. To go back to the

main listing of help topics, just click the “Back” button in the toolbar at the top of the window to return to the

list. You can then continue reading other topics, perform another search, or simply close the window if you

are finished.

Should you want to print any topic that is displayed in the “Access Help” window, you can do so by

just clicking the “Print” button in the toolbar at the top of the “Access Help” window.

Sa
mple

- f
or

 ev
alu

ati
on

 pu
rp

os
es

 on
ly!



55Advanced Access©TeachUcomp, Inc.

ACTIONS-

Advanced Features
GETTING EXTERNAL DATA:

1. To either import or link external data to your database, you start by clicking the “External Data” tab in the 

Ribbon.

2. To then make a connection to the external data source, click on the button in the “Import & Link” group 

(“Import” group in Access 2007) that shows the name of the type of external data to which you are trying 

to connect. Clicking any one of these buttons will then open the “Get External Data” wizard.

3. This wizard will then lead you on a step-by-step process that will allow you to decide whether or not to 

import the data or link to the data, select the data source, and also save the connection if needed. Note 

that the specific steps involved in the “Get External Data” wizard will vary slightly, depending up on the 

type of data which you are trying to import or link to your current database.

EXPORTING DATA:

1. To export database information, first select the database object that you wish to export from the listing 

shown in the Navigation Pane.

2. Next, click the “External Data” tab in the Ribbon.

3. In the “Export” group, click the button that shows the file format to which you want to export the selected 

database object. This will open the “Export” wizard for the type of export that you want to perform.

4. The specific steps shown in each wizard will vary slightly depending upon the file type to which you are 

exporting the selected database object. However, most of the time, you will still need to select a name 

and file location for the exported object. You will also often need to set additional parameters for the 

export routine.

5. Just as when you import data, you will also be prompted to save your export routine, if desired.

SETTING A DATABASE PASSWORD- (ACCESS 2007 ONLY):

1. Open Access and then click the Microsoft Office Button.

2. Select the “Open” command from the drop-down command panel.

3. Use the “Open” dialog box to navigate to the folder which contains the database that you want to open.

4. Then click the database file to select it.

5. Next, instead of clicking the “Open” button to open it, click the small drop-down arrow next to the “Open” 

button in the lower right corner of the “Open” dialog box.

6. From this drop-down menu, select “Open exclusive.” That will open the selected database for your 

exclusive use, and now you can set the database password.

7. Once the database is opened exclusively, click the “Encrypt with Password” button in the “Database 

Tools” group on the “Database Tools” tab in the Ribbon. This will launch the “Set Database Password” 

dialog box.

8. Enter your database password into the “Password:” text box and then retype it into the “Verify:” text box.

9. Then click “OK.”

10. Then write down the password and store in a safe place for later retrieval, if necessary. You cannot 

open the database without the password. If you lose the password, you’ll need to start all over again! 

We cannot overemphasize the importance of securing your password in a safe place.
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ACTIONS-

Advanced Features

USING HELP:

1. You can access the help in Access by clicking the “Microsoft Access Help” button. This will open the 

“Access Help” window.

2. Notice that this window can be closed by simply clicking the “x” in the upper right corner of the window 

when you are finished using the help files.

3. If you wish to search through the help files for a topic, you can easily type the words for which you wish 

to look into the long white text box in the toolbar at the top of this window.

4. You can then decide where you wish to search for the information by clicking the drop-down button next 

to the “Access Help” title in Access 2013 or the “Search” button in Access 2010:2007, and then 

selecting a choice from the drop-down menu.

5. Once you have selected where to search, just click the “Search” button to let Access search for the 

words or phrases that you entered.

6. Any matching help topics are then displayed in the “Access Help” window as a listing of hyperlinks. You 

can click on the name of a help topic to view its content in the “Access Help” window.

7. To go back to the main listing of help topics, just click the “Back” button in the toolbar at the top of the 

window to return to the list.

8. You can then continue reading other topics, perform another search, or simply close the window if you 

are finished.

9. Should you want to print any topic that is displayed in the “Access Help” window, you can do so by just 

clicking the “Print” button in the toolbar at the top of the “Access Help” window.

SETTING A DATABASE PASSWORD- (ACCESS 2013:2010 ONLY):

1. Open Access 2013:2010 and then click the “File” tab in the Ribbon.

2. Click the “Open” command in the command panel at the left side of the backstage view.

3. Use the “Open” dialog box to navigate to the folder which contains the database that you want to open. 

Then click the database file to select it.

4. Next, instead of clicking the “Open” button to open it, click the small drop-down arrow next to the “Open” 

button in the lower right corner of the “Open” dialog box. From this drop-down menu, select “Open 

exclusive.” That will open the selected database for your exclusive use, and now you can set the 

database password.

5. Once the database is opened exclusively, click “File” tab in the Ribbon once again.

6. Then click the “Info” command in the command panel at the left side of the backstage view. To the right, 

click the “Encrypt with Password” button in the backstage view.

7. This will launch the “Set Database Password” dialog box. Enter your database password into the 

“Password:” text box and then retype it into the “Verify:” text box. Then click “OK.”

8. Then write down the password and store in a safe place for later retrieval, if necessary. You cannot 

open the database without the password. If you lose the password, you’ll need to start all over again! 

We cannot overemphasize the importance of securing your password in a safe place.
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EXERCISES-

Advanced Features
Purpose:

1. There are no exercises for this chapter.
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Access Keyboard Shortcuts

Category: General Shortcuts

Command Key

Open a database Ctrl + O

Create a new database Ctrl + N

Exit Access Alt + F4

Print Ctrl + P

Open “Page Setup” from “Print Preview” S

Cancel “Print Preview” or “Layout Preview” C or Esc

Save Ctrl + S or Shift + F12

Open “Save As” dialog box F12

Open a combo box (drop-down box) Alt + Down Arrow or 

F4

Refresh a lookup field F9

Move down one line in combo or list box Down Arrow

Move down one page in combo or list box Page Down

Move up one line in combo or list box Up Arrow

Move up one page in combo or list box Page Up

Exit the combo or list box Tab

Open “Find” from Datasheet or Form View Ctrl + F

Open “Replace” from Datasheet or Form 

View

Ctrl + H

Switch between Edit Mode and Navigation 

Mode in a datasheet

F2

Exit Navigation Mode in a form or report Esc

Show/Hide Property Sheet in Design View Alt + Enter or F4

Cycle between panes in Design View F6

Open “Choose Builder” or Visual Basic 

Editor in Form and Report Design View

F7

Switch between Visual Basic Editor and 

Form or Report Design View windows

Shift + F7 or Alt + F11

Copy Ctrl + C

Cut Ctrl + X

Paste Ctrl + V

Move selected form or report 

control right

Right Arrow or Ctrl + 

Right Arrow

Move selected form or report 

control left

Left Arrow or Ctrl + Left 

Arrow

Move selected form or report 

control up

Up Arrow or Ctrl + Up 

Arrow

Move selected form or report 

control down

Down Arrow or Ctrl + 

Down Arrow

Increase height of control Shift + Down Arrow

Reduce height of control Shift + Up Arrow

Increase width of control Shift + Right Arrow

Decrease width of control Shift + Left Arrow

Show/Hide Navigation Pane F11

Cycle between open windows Ctrl + F6

Close the active window Ctrl + W

Switch focus of controls Tab

“Next” button in wizards Alt + N

“Back” button in wizards Alt + B

“Finish” button in wizards Alt + F

Display hyperlink address F2

Check Spelling F7

Open “Zoom” when performing 

data entry in small fields

Shift + F2

Switch forward to next object 

view, if available

Ctrl + , (comma)

Switch back to previous object 

view, if available

Ctrl + . (period)

Category: Using the Navigation Pane

Command Key

Rename selected Navigation 

Pane object

F2

Open (Run) selected Navigation 

Pane object

Enter

Design selected Navigation Pane 

object

Ctrl + Enter
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Access Keyboard Shortcuts

Category: Using Menus

Command Key

Show pop-up menu Shift + F10

Show access keys in Ribbon Alt or F10

Show application menu Alt + Spacebar

Close menus Alt

Category: Using Windows and Dialog Boxes

Command Key

Switch to next open application Alt + Tab

Switch to previous application Alt + Shift + Tab

Shown Windows “Start” Menu Ctrl + Esc

Close active window in database Ctrl + W

Switch to next open database window Ctrl + F6

Switch to previous open database window Ctrl + Shift + F6

Switch to next tab in dialog box Ctrl + Tab

Switch to previous tab in dialog box Ctrl + Shift + Tab

Move to next option or option group Tab

Move to previous option or option group Shift + Tab

Perform selected button action or toggle 

status of selected checkbox

Spacebar

Close dialog box Alt + F4

Show/Hide the Field List Pane Alt + F8

Send selected Navigation Pane object as 

an email message

Alt + F + E

Category: Working with Text and Data

Command Key

Extend text selection one character right Shift + Right Arrow

Extend text selection one word right Ctrl + Shift + Right 

Arrow

Extend text selection one character left Shift + Left Arrow

Extend text selection one word left Ctrl + Shift + Left 

Arrow

Undo typing Ctrl +Z or Alt + 

Backspace

Undo changes to field, then undo 

changes to record

Esc once to undo field, 

Esc twice to undo record

Insert current date Ctrl + ; (semicolon)

Insert current time Ctrl + : (colon)

Insert default field value Ctrl + Alt + Spacebar

Insert previous record’s field 

value

Ctrl + ‘ (apostrophe)

Add new record Ctrl + + (plus sign)

Delete current record Ctrl + - (minus sign)

Save changes to current record Shift + Enter

Switch between options in a 

checkbox or option box

Spacebar

Insert a new line Ctrl + Enter

Recalculate fields F9

Requery underlying data Shift + F9
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