A Presentation of TeachUcomp Incorporated.
Copyright © TeachUcomp, Inc. 2011

Introductory
Dreamweaver
v. CS5 through CS3

TeachUcomp, Inc.
...it's all about you
Copyright:

TeachUcomp, Inc. provides this product “as is”, makes no representations or warranties with respect to its contents or use, and specifically disclaims any expressed or implied warranties of merchantability or fitness for any particular purpose. To the maximum extent permitted by applicable law, in no event shall TeachUcomp, Inc. or its suppliers be liable for special, incidental, indirect, or consequential damages whatsoever (including, without limitation, damages for loss of business information, or any other pecuniary loss) arising out of the use of this product or contents, or the inability to use the software product, even if TeachUcomp, Inc. has been advised of the possibility of such damages. Because some states and jurisdictions do not allow the exclusion or limitation of liability for consequential or incidental damages, the limitation may not apply to you. TeachUcomp, Inc. reserves the right to make changes to this product at any time, without obligation to notify any person or entity of such changes.

No part of this product may be reproduced or transmitted in any form or by any means, electronic or mechanical, including photocopying, recording, or information storage and retrieval systems, for any purpose, without the express written consent of TeachUcomp, Inc.

TeachUcomp, Inc. is a registered trademark of TeachUcomp, Inc. All other registered trademarks are the property of their respective companies and do not imply any association with TeachUcomp, Inc. All rights reserved.

Copyright © TeachUcomp, Inc. All rights reserved. Printed in the United States of America. All rights reserved.

Trademark Acknowledgements:

Adobe Dreamweaver, Adobe Bridge, Adobe Photoshop, Adobe Photoshop Elements, Adobe Illustrator, Adobe ImageReady and Adobe Acrobat are registered trademarks of Adobe Systems Incorporated. Other brand names and product names are trademarks or registered trademarks of their respective holders.

Disclaimer:

While every precaution has been made in the production of this book, TeachUcomp, Inc. assumes no responsibility for errors or omissions. Nor is any liability assumed for damages resulting from the use of the information contained herein. These training materials are provided without any warranty whatsoever, including, but not limited to, the implied warranties of merchantability or fitness for a particular purpose. All names of persons or companies in this manual are fictional, unless otherwise noted.
Welcome to TeachUcomp Incorporated’s Introductory Dreamweaver course. This class introduces the student to Adobe Dreamweaver, the most popular web designing software application available. This class is designed to take a user with little to no knowledge of Dreamweaver through the skills necessary to master the use of the Dreamweaver application. To that end, it is also an excellent tutorial for those users who are already familiar with Dreamweaver, but want to “fill-in” the gaps in their knowledge of the program.

Adobe Dreamweaver is an excellent program to learn, as the skill, terms, and techniques that we learn and master in this application can also be used throughout the rest of the Adobe applications. For example, after learning this application, you will find it easier to learn an application like Adobe Illustrator or Adobe Photoshop.

This class will start by introducing the student to the Dreamweaver environment. We will then introduce how to open and create web pages. After that, we will look at the different types of tools available in Dreamweaver, why they are there, and what we can do to control them. We will then look at using more dynamic content in web pages and what we can do to control their settings. We will also cover the basics of obtaining a domain name, web hosting, and publishing a web page to the Internet.
# Table Of Contents

<table>
<thead>
<tr>
<th>Topic:</th>
<th>Page(s):</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction and Overview</td>
<td>3</td>
</tr>
<tr>
<td>Table of Contents</td>
<td>4</td>
</tr>
<tr>
<td>Getting Acquainted with Dreamweaver</td>
<td>5</td>
</tr>
<tr>
<td>The Dreamweaver Environment</td>
<td>6</td>
</tr>
<tr>
<td>The Designer View Workspace: Menu Bar Basics</td>
<td>7</td>
</tr>
<tr>
<td>The Menu Bar: Drop-Down Menus</td>
<td>8</td>
</tr>
<tr>
<td>The Designer View Menu Bar Icons</td>
<td>9</td>
</tr>
<tr>
<td>The Designer View Workspace: The Toolbar</td>
<td>10</td>
</tr>
<tr>
<td>Working With Panels</td>
<td>11</td>
</tr>
<tr>
<td>The Properties Inspector</td>
<td>12</td>
</tr>
<tr>
<td>The Insert Panel</td>
<td>12</td>
</tr>
<tr>
<td>Other Common Panels</td>
<td>13</td>
</tr>
<tr>
<td>Getting Acquainted with Dreamweaver- Actions</td>
<td>14</td>
</tr>
<tr>
<td>Creating a Web Site</td>
<td>16</td>
</tr>
<tr>
<td>About New Websites</td>
<td>17</td>
</tr>
<tr>
<td>The Root Folder</td>
<td>17</td>
</tr>
<tr>
<td>Defining a New Website</td>
<td>18</td>
</tr>
<tr>
<td>Creating a New Web Page</td>
<td>19</td>
</tr>
<tr>
<td>Saving and Closing Web Pages</td>
<td>20</td>
</tr>
<tr>
<td>Opening Saved Web Pages</td>
<td>20</td>
</tr>
<tr>
<td>Previewing Web Pages</td>
<td>21</td>
</tr>
<tr>
<td>Multi-Browser Previews</td>
<td>22</td>
</tr>
<tr>
<td>Creating a Web Site- Actions</td>
<td>23-24</td>
</tr>
<tr>
<td>Creating a Web Site- Exercises</td>
<td>25</td>
</tr>
<tr>
<td>All About Text</td>
<td>26</td>
</tr>
<tr>
<td>Working With Text</td>
<td>27</td>
</tr>
<tr>
<td>Exploring Heading Levels</td>
<td>28</td>
</tr>
<tr>
<td>Formatting Text Color</td>
<td>29</td>
</tr>
<tr>
<td>Changing a Web Page’s Background Color</td>
<td>30</td>
</tr>
<tr>
<td>Aligning Text</td>
<td>31</td>
</tr>
<tr>
<td>Creating Paragraphs</td>
<td>32</td>
</tr>
<tr>
<td>Working With Fonts</td>
<td>33</td>
</tr>
<tr>
<td>Using Custom Fonts</td>
<td>34</td>
</tr>
<tr>
<td>Using Bold and Italics With Text</td>
<td>34</td>
</tr>
<tr>
<td>Creating Lists</td>
<td>35</td>
</tr>
<tr>
<td>Special Characters</td>
<td>36</td>
</tr>
<tr>
<td>Creating Block Quotes</td>
<td>36</td>
</tr>
<tr>
<td>All About Text- Actions</td>
<td>37-39</td>
</tr>
<tr>
<td>All About Text- Exercises</td>
<td>40</td>
</tr>
<tr>
<td>All About Images</td>
<td>41</td>
</tr>
<tr>
<td>Using Images In a Web Page</td>
<td>42</td>
</tr>
<tr>
<td>Image File Types</td>
<td>42</td>
</tr>
<tr>
<td>Commonly Used Web Images</td>
<td>43</td>
</tr>
<tr>
<td>Inserting Images Into a Web Page</td>
<td>44</td>
</tr>
<tr>
<td>Image Properties</td>
<td>45</td>
</tr>
<tr>
<td>Borders and Spacing Around Images</td>
<td>45</td>
</tr>
<tr>
<td>Using Background Images</td>
<td>46</td>
</tr>
<tr>
<td>Resizing Images</td>
<td>47</td>
</tr>
<tr>
<td>Cropping Images</td>
<td>48</td>
</tr>
<tr>
<td>Using Images and Text Together</td>
<td>49</td>
</tr>
<tr>
<td>When to Use Outside Imaging Programs</td>
<td>50</td>
</tr>
<tr>
<td>Opening an Image in Adobe Photoshop</td>
<td>51</td>
</tr>
<tr>
<td>Cropping an Image Using Photoshop</td>
<td>52</td>
</tr>
<tr>
<td>Saving an Image Using Photoshop</td>
<td>53</td>
</tr>
<tr>
<td>Resizing an Image Using Photoshop</td>
<td>54</td>
</tr>
<tr>
<td>Working with Custom Fonts in Photoshop</td>
<td>55</td>
</tr>
<tr>
<td>All About Images- Actions</td>
<td>56-59</td>
</tr>
<tr>
<td>All About Images- Exercises</td>
<td>60</td>
</tr>
<tr>
<td>All About Hyperlinks</td>
<td>61</td>
</tr>
<tr>
<td>Inserting a Hyperlink Into a Web Page</td>
<td>62</td>
</tr>
<tr>
<td>Turning Images Into Hyperlinks</td>
<td>63</td>
</tr>
<tr>
<td>Creating Image Maps</td>
<td>63-64</td>
</tr>
<tr>
<td>Named Anchor Links</td>
<td>65</td>
</tr>
<tr>
<td>Adding an Email Link to a Web Page</td>
<td>65</td>
</tr>
<tr>
<td>Changing the Appearance of Hyperlinks</td>
<td>66</td>
</tr>
<tr>
<td>All About Hyperlinks- Actions</td>
<td>67-68</td>
</tr>
<tr>
<td>All About Hyperlinks- Exercises</td>
<td>69</td>
</tr>
<tr>
<td>Using Frames</td>
<td>70</td>
</tr>
<tr>
<td>Using Frames</td>
<td>71</td>
</tr>
<tr>
<td>Adding Content to Frames</td>
<td>72</td>
</tr>
<tr>
<td>Naming Frames</td>
<td>72</td>
</tr>
<tr>
<td>Deleting Frames</td>
<td>73</td>
</tr>
<tr>
<td>Linking to Frames</td>
<td>74</td>
</tr>
<tr>
<td>Using Frames- Actions</td>
<td>75-76</td>
</tr>
<tr>
<td>Using Frames- Exercises</td>
<td>77-79</td>
</tr>
<tr>
<td>Dreamweaver Keyboard Shortcuts</td>
<td>80-82</td>
</tr>
</tbody>
</table>

©TeachUcomp, Inc.  Introductory Dreamweaver  
Sample- for evaluation purposes only!
CHAPTER 1-
GETTING ACQUAINTED WITH DREAMWEAVER

1.1- THE DREAMWEAVER ENVIRONMENT-DIFFERENT VIEWS
1.2- THE DESIGNER VIEW WORKSPACE: MENU BAR BASICS
1.3- THE MENU BAR: DROP-DOWN MENUS
1.4- THE MENU BAR: ICONS
1.5- THE DESIGNER VIEW WORKSPACE: THE TOOLBAR
1.6- WORKING WITH PANELS
1.7- THE PROPERTIES INSPECTOR
1.8- THE "INSERT" PANEL
1.9- OTHER COMMON PANELS
1.1- The Dreamweaver Environment: Different Views:

When you initially open Dreamweaver, you will notice that the workspace area looks very complex. One of the fundamental concepts that it is essential to understand about Dreamweaver is that Adobe designed the program for several types of users: those who are new to the concept of web design and publishing, those who have been familiar with web publishing for so long that they are most comfortable working directly with XHTML code, and everyone “in-between.” For this reason, the Dreamweaver interface allows for high levels of workspace customization. In fact, Adobe has included eight different basic “views” of the workspace that you can start with, and each of these can be customized in a multitude of ways. The eight basic views are: App Developer, App Developer Plus, Classic, Coder, Coder Plus, Designer, Designer Compact, and Dual Screen. You can switch from one view to another while working on the same project, or stick with the same view all the time. Let’s take a look at the basic layout differences between the different views. To switch views, use the drop-down menu toward the far right of the menu bar. In App Developer View, the document window is on the right, and various panels are on the left. In the App Developer Plus view, the panels remain on the left, but the Properties Inspector panel is visible at the bottom of the screen. In the Classic view, the main document window is to the left of the screen while common panels are on the right of the screen, with the Properties Inspector at the bottom. The Classic view also makes use of icons and buttons that may be more familiar to you if you have worked with older versions of Dreamweaver. In the Coder view, the document is displayed only as XHTML code, with panels on the left of the screen. The Coder Plus view is much like the Coder view, except that it adds a panel on the right of the screen to allow for easy access to the Adobe Browser Lab, as well as several other features. The Designer view, which we will be using for the majority of this tutorial, seems to have the features which most users find helpful and necessary. The document window is to the left, the Properties Inspector is at the bottom of the screen, and several panels are on the right of the screen. The Designer Compact view offers a slightly larger document window with a split screen that shows both design and code views of the current document. The Designer Compact view has collapsed versions of the same panels that are found in the Designer view. These panels can be easily expanded to their full size by clicking the “expand panels” double arrows at the top right corner of the panel. Finally, you can work in Dual Screen view, which puts a large amount of information and many features, including the code inspector, on the screen. Dual Screen view is probably only appropriate for advanced users of Dreamweaver, as the complexity of that view would most likely overwhelm newer users of the program. Once you have had time to look at the different views that Dreamweaver offers, please set the view to Designer. Although you may decide later that another workspace view suits your needs better, it will be important to remain in Design view as you complete this tutorial, so that you will be able to follow along with the lessons.
1.2-The Designer View Workspace: Menu Bar Basics:

The Dreamweaver Menu Bar allows easy access to the features and commands you will need when designing and creating web pages. You can click the name of a command category to view the subcommands within that category displayed in a drop-down menu. You can then click on the subcommand in the selected category which you would like to perform.

If a subcommand appears in gray, it cannot be selected at that time. Subcommands which are followed by an ellipsis mark (…) will launch a dialog box into which you will have to make additional choices or provide the program with additional information before the subcommand can be executed. Subcommands followed by a right-pointing arrow will display another side menu of choices from which you will need to select when you roll over them in the drop-down menu of subcommand choices.

To the right of some subcommands you will see keyboard shortcuts listed. For example, if you select the “Edit” command, you can see that the keyboard shortcut for the “Undo” command is “Ctrl + Z.” This means that rather than using the drop-down “Edit” menu and then selecting the “Undo” command, you could simply press the “Ctrl” and “Z” keys on your keyboard simultaneously to execute the same command. Some people like to memorize keyboard shortcuts as soon as possible when they are learning a new computer program, because keyboard shortcuts can be performed somewhat more quickly. Other users prefer to stick to the drop-down menus to execute commands. Many people find that, as they become more comfortable and proficient with Dreamweaver, it is most convenient to use a combination of keyboard shortcuts and drop-down menu commands.
1.3- THE MENU BAR: DROP-DOWN MENUS:

Let’s take a brief look at the various commands found on the menu bar. We’ll go into more detail about their various functions later—this lesson is just to help you familiarize yourself with the layout of the workspace. Keep in mind that many commands can be executed using the other panels and windows within Dreamweaver. First is the “File” drop-down menu. It contains many of the primary commands used in Dreamweaver. Using the “File” drop-down menu, you can create a new file, open an existing file, and save your work. The “File” drop-down menu also contains commands to browse files in Adobe Bridge, import and export files, and preview the open page in a browser.

Next is the “Edit” drop-down menu. It contains several common commands that allow you to cut, copy, and paste using Dreamweaver. There are also “select” and “find” commands. You can also use the “Edit” drop-down to locate keyboard shortcuts, tag libraries, and Dreamweaver’s preferences.

Next is the “View” drop-down menu. Using this menu, you can access zoom features, switch between code and design views, and use “live view.” The “View” drop-down menu also gives access to rulers, grids, guides, and visual aids.

Next is the “Insert” drop-down menu. As the name suggests, it gives you quick access to buttons that you can use to insert common web design elements into the open file, such as tags, images, and links.

Next is the “Modify” drop-down menu. You can use it to adjust page properties, selection properties, and CSS styles. The “Modify” drop-down menu also contains commands for editing tags and making links. Additionally, you can use this drop-down menu to modify tables, images, framesets, your Dreamweaver library, and templates.

Next is the “Format” drop-down menu. The commands in this menu allow you to adjust the properties of the text, fonts, and color on your web pages, as well as CSS styles, among other things.

Next is the “Commands” drop-down menu. Among other things, you can use this menu to “record” your Dreamweaver actions and then “play” them back again and again on future pages in order to save steps. The “Commands” drop-down menu is also where you will find tools for checking spelling and cleaning up XHTML code.

Next is the “Site” drop-down menu. It contains the command for starting a new web site. The “Site” menu is also where you’ll find “Get” and “Put” commands, as well as the “Manage Sites” command. Various site reports can also be found in the “Site” drop-down menu.

Next is the “Window” drop-down menu. It contains a long list of Dreamweaver’s many windows. By checking and un-checking the ones you want visible, you can customize the Dreamweaver workspace in countless ways. It is a good idea to experiment with the “Window” drop-down menu a little until you find the workspace that suits you best.

Next is the “Help” drop-down menu. As the name suggests, this drop-down menu gives you access to various help features. The “Help” menu also has information on product registration, updates, and ways to contact Adobe.
1.4- THE DESIGNER VIEW MENU BAR ICONS:

In this lesson, we will explore the various icons found on Dreamweaver’s Designer workspace. Above the Menu bar, you will find the “Layout” icon. Using this icon, you can quickly switch between Code, Split-Code, and Design View. You can also adjust how the Split-Code screen is split—vertically or horizontally.

To the right of the “Layout” icon is the “Extend Dreamweaver” icon. In addition to giving you access to the Extension Manager and the Widget Browser, the “Browse for Other Dreamweaver Extensions” command will open up the Adobe Dreamweaver Exchange in your computer’s default web browser. The Exchange gives you access to thousands of Widgets created by other Dreamweaver users.

To the right of the “Extend Dreamweaver” icon is the “Site” icon. This icon gives you quick access to the “New Site” and “Manage Sites” commands.

To the right of the “Site” icon is another drop-down menu that gives you quick access to Dreamweaver’s eight main workspace views. Because we have chosen the “Designer” view, the drop-down menu says “Designer.” It will change to reflect whichever view you choose.

Just to the right of that, you will see a white search field with a magnifying glass icon. Typing a search term into this field will open up Adobe Community Help, where you can often find answers to common questions using the site’s forums.

To the right of the search field is a button that will launch CS Live Services. This is a subscription service offered by Adobe. Once you sign up, you may be offered complimentary access to services for several months, after which you will have to pay a monthly or yearly fee to continue using CS Live Services.

To the right of the CS Live Services button are common icons for minimizing, restoring, and closing the Dreamweaver program. If you close the program without saving your work, a pop-up box will ask if you would like to save before closing.
1.5- THE DESIGNER VIEW WORKSPACE: THE TOOLBAR:

Under the Menu Bar, you will see the Toolbar, a row of buttons that allow you to access various views within Dreamweaver. Again, keep in mind that many commands within the program can be executed in a number of different ways, so there is some repetition in the explanation.

On the far left of the toolbar, there are three buttons that let you choose between Code, Split, and Design views. To the right of those, the “Live Code” button shows the Live View source in Code View. To the right of that is the “Check Browser Compatibility” button, which does what its name suggests. The “Check Browser Compatibility” button also gives access to the spell-checker, as well as several other tools. To the right of that is the “Live View” button, which shows you, within the Dreamweaver program, how the currently opened page will behave when it’s published to the internet. “Live View” is a wonderful feature, because it allows you to see the dynamics of your site before you publish it or even preview it in a browser window. Next to the “Live View” button is the “Inspect” button. This button, when clicked, will turn on Dreamweaver’s “Inspect Mode.” This is another great feature from Adobe, because it allows you to simply move the mouse over different elements of your page in order to get information about them.

To the right of the “Inspect” button is a button with a small globe icon; this is the “Preview in Browser” button. This handy tool allows you to open up your page in various browser windows before ever publishing your site, so that you can find and resolve issues before your site is live and visible to others. To the right of the “Preview in Browser” button is the “Multiscreen” button. This tool opens up a new window that displays the current webpage at several sizes. This allows you to see how the page you’re working on will look on typical phone, tablet, and desktop screens.

To the right of the “Multiscreen” button is the “Visual Aids” button. When you click it, you will see a list of common visual aids within Dreamweaver. Checking these aids will make them visible; un-checking them will make them invisible. [Note: If you use a lot of visual aids, you may want to use the “Live View” button often—it removes all of the selected visual aids to show what your page will look like without them, “live.”] To the right of the “Visual Aids” button is the “Refresh” button, which refreshes the default view. To the right of the “Refresh” button is the Title text field, which displays the title of the file you are working on. To the right of the Title text field is the “File Management” button, it contains commands like “Get” and “Put,” as well as several other organizational tools.
1.6- WORKING WITH PANELS:

Many of the features that you will need to use in Dreamweaver are contained within panels. In the Design View, there is a large panel group at the right side of the screen, and there is also the “Properties Inspector” panel at the bottom left of the screen. There are many features shared by all panels. You can collapse and expand the content of any panel by double-clicking on the name of the panel shown in the panel’s title bar at the top of the panel, or by clicking the double-arrow “collapse/expand” icons at the top right of the panel. Each panel also has a panel options button at the right end of the panel’s title bar. You can click on this button to view any available related menu commands which you can use in that panel. Panels can also be moved around within the Dreamweaver workspace. You can drag a panel into another place within the panel grouping, or you can take it outside of the panel grouping to make it a “floating” panel. To do this, simply click and drag the name of panel found in the panel’s title bar. Panel groups and floating panels all have small “Xs” at the top right of the panel; clicking this “X” will close the panel or panel grouping. To make the panel visible again, simply go to the “Window” drop-down menu and check the window to re-open it. To place a floating panel back within the panel grouping, simply click and drag the panel by its name back to the panel group area. When you move the panel correctly to reposition it within the panel group, the panel grouping will display a thin blue border. Releasing the panel once the panel group displays the blue border will dock the floating panel back into the panel group. If you would like to see more or less of any panel, you can click and drag it from its edges or corners. You can also completely hide all onscreen panels by selecting “Hide Panels” from the “Window” drop-down menu in the Menu Bar.
1.7- THE PROPERTIES INSPECTOR:

The Properties Inspector is a panel found at the bottom left of the Design View workspace. When you are designing web pages, you will often need to edit the settings of the text, images, and objects. You can use the Properties Inspector to make those changes quickly and easily. When you select an image, text, or another element on your web page, the Properties Inspector displays the various properties of that element. For example, you can click on an image to select it, and the Properties Inspector instantly changes to reflect the properties of that image. You can see the pixel dimensions, source and link information, borders and alignment, as well as other settings. You can also make changes to these settings very easily within the Properties Inspector. By clicking on text within your web page, you can view properties of the text such as font family, size, and color. While text is selected, the Properties Inspector also displays a “Page Properties” button. Clicking it will open a new window that allows you to adjust the settings for the font family, size, color, and even the background color of the page, very quickly. You can minimize the Properties Inspector in order to have more usable workspace, but many people find that they use it so often that it is more convenient to leave it open on the screen.

1.8- THE INSERT PANEL:

In Dreamweaver’s Design View, the “Insert” panel is located at the very top of the panel grouping on the right of the screen. The “Insert” panel is one of the most heavily-used features of Dreamweaver. You can use this panel to insert various common elements into your web pages. To use this panel, simply click the button that corresponds to the type of content you want to add to your page. The default setting of the “Insert” panel displays a list of common elements like images, hyperlinks, and tables. Clicking on any of these will open a new dialog box into which you enter specific information about that element of your page. You can also adjust the “Insert” panel to suit your needs. Under the “Insert” tab at the top of the panel, you will see the word “Common” in bold type, with a black arrow pointing downward to the right. By clicking this button, you can change the “Insert” panel to include layout items, forms, Spry data, and text formatting. You can even customize the “Insert” panel by choosing the “Favorites” selection, which lets you choose exactly which elements appear in the “Insert” panel.
1.9 – OTHER COMMON PANELS:

Dreamweaver allows you to access most of its features through various panels that can be docked within the main panel grouping on the right side of the workspace. Commonly-used panels include the “Assets” panel, which allows you to see and manage the content of the site you are working on. The “Files” panel allows you to see, within a split-panel, all of the local and remote files associated with the current site. The “CSS Styles” panel allows you to see, also within a split-panel, the CSS settings of the current site. In “Current” mode, you see the CSS properties of the currently selected element of your page. By switching to the “All” mode, you can see all of the CSS rules and properties for the entire page that is open. The “Frames” panel allows you to see the frames within a currently-opened frameset. Within the “Frames” panel, the frameset itself is surrounded by a thicker border; individual frames within the frameset have a thin grey line. Other panels include the “AP Elements” panel, the “Adobe Browserlab” panel, and the “Tag Inspector” panel, among others. To access a panel that is not visible on your workspace, simply select it using the “Window” drop-down menu in the Menu Bar.

![Panels in Dreamweaver](image_url)
**ACTIONS-**

**Getting Acquainted with Dreamweaver**

**CHANGING THE LOOK OF THE WORKSPACE:**
1. To change the workspace view click on the drop-down triangle to the right of the menu bar.
2. Choose from the eight view choices based on your preference.

**OPENING PANELS WITHIN THE WORKSPACE:**
1. Open panels like “Insert” and "CSS Styles" by clicking “Window” from the Menu bar.
2. Select the panel(s) you want to see in the workspace by clicking their name.
3. A checkmark will appear next to panels which are visible.

**EXPANDING AND CONTRACTING THE SIZE OF PANELS:**
1. Expand panels and contract them according to the amount of information you need to see as you design.
2. Click and drag, up or down, the solid border lines between groups of panel windows to increase or decrease their size.
3. Click and drag, left or right, the solid border line to the left or right of the panel edge to increase or decrease their width.
4. Click the small double triangle in the top right of the panel window to expand or collapse the panels within it.

**DETACHING PANELS TO FLOAT THEM INTO THE WORKSPACE:**
1. Click on the name of the panel and drag it away from its neighbors when you need to expand that panel fully.
2. Move the floating panel back into its original position by clicking and dragging its name. When you have it nested with its neighbors the borders of the panel grouping turn blue.
3. Release the panel back into the group.
Exercises-
Getting Acquainted with Dreamweaver

Purpose:
1. To be able to find the basic tools in the Dreamweaver interface.

Exercises:
1. Open your Dreamweaver application.
2. Change the workspace to “Design” using the “Layout” drop-down.
3. Open the “Insert” panel by selecting “Window| Insert” from the Menu Bar.
4. Increase and decrease the size of the “Insert” panel by clicking and dragging the solid border line around the panel to expand and contract it.
5. Click and drag on the “Insert” panel’s title bar to move the panel to a new location in the Dreamweaver window.
6. Close the panel by clicking the “X” in the upper-right corner.
7. Show and hide the “Properties Inspector” by selecting “Window| Properties” from the Menu Bar to check (show) or uncheck (hide) it.
CHAPTER 2-
CREATING A WEBSITE

2.1 - About New Websites
2.2 - The Root Folder
2.3 - Defining a New Website
2.4 - Creating a New Web Page
2.5 - Saving and Closing Web Pages
2.6 - Opening Saved Web Pages
2.7 - Previewing Web Pages
2.8 - Multi-Browser Previews
2.1 – ABOUT NEW WEBSITES:

If this is your first attempt at creating a web site, you may have the urge to begin by immediately creating web pages with the content that you want. However, before you begin creating a hodgepodge of web pages, you will want to pause and think about the overall design of your site, as well as its layout and content. This type of preplanning is essential to creating a unified website that will be both comprehensive and easy-to-navigate.

A website is simply a collection of individual web pages that are linked together. At this point, the most important thing you can do is to ensure that you have an idea what web pages you need to create, and how those web pages will link to each other. Dreamweaver will not lay your site out for you, but it does include terrific site management tools that will help you to create, manage, and organize all of the pages on your site. Before beginning with the Dreamweaver software, many people like to start with a pen and paper. You may find it easier to execute your site within the Dreamweaver program if you have previously planned out the site on paper.

2.2 – THE ROOT FOLDER:

The first step when you start a new website is to create a folder that will serve as the local copy of the web site on your computer. This is known as the “root folder.” You will store all of the content, like web pages and their associated images, into the root folder. Later, you will upload all of the contents of this folder to the Internet. This process is known as publishing your website.

Defining a root folder first is crucial because when it is time to upload your website, the individual web pages and other elements like pictures within your site must stay in the same relative location to each other in order for the site to work. The site management tools included with Dreamweaver help to insure that hyperlinks will still function and images will be displayed properly once the site is online.

Once you have created a local root folder, you should then define a new website within Dreamweaver. Even if you are editing a website which has already been created, you should always define that website within Dreamweaver. This allows you to use Dreamweaver’s site management tools to assist in tracking changes to the website and updating web page content. It is critical to do this, especially if you are managing more than one website. If you are working on an existing website, you do not need to create a new root folder, but you will still need to define the site in Dreamweaver.
Creating a New Website

2.3 – DEFINING A NEW WEBSITE:

To define a new website, follow these steps: First, choose “New Site” from the “Site” dropdown menu in the Menu Bar. When you do this, the Site Setup dialog box opens. Click within the “Site Name” text field, and type the name of your website. After you have named your site, click the folder icon next to the “Local Site Folder” text field. This will open up the “Choose Root Folder” dialog box. Within this dialog box, you’ll see the “Select” text field. By clicking the downward-pointing triangle at the right of that text field, you can search for the root folder you created for your website. When you locate it on your computer, click the root folder and then click the “Select” button at the bottom right of the dialog box. The “Choose Root Folder” dialog box will close, and you will be returned to the “Site Setup” dialog box. Click the “Save” button at the bottom right of the dialog box. If you are defining an existing site that has been previously created, a dialog box may appear that says “The cache will not be re-created.” If this box appears, click “OK.” Your new website is now defined.
2.4 – CREATING A NEW WEB PAGE:

As we've discussed in previous lessons, there are often several different ways to accomplish the same task in Dreamweaver. In this lesson, we will look at one way to create a new web page for your website. As you become more proficient with the program, you may find that another method is more comfortable for you. For now, follow these simple steps to create a new page for your website.

First, choose “New” from the “File” drop-down menu in the Menu Bar. This will open the “New Document” dialog box. As you can see from this dialog box, there are many different ways to begin a new web page in Dreamweaver. This vast number of choices can be overwhelming to new users, but you don’t have to understand the entire program to start building simple web pages. Click the “Blank Page” selection at the top left of the screen. Under “Page Type,” click “HTML.” Under “Layout,” click “<none>.” Then click the “Create” button at the bottom right of the dialog box. A new document window will appear. This is your first web page.

To give your web page a name, click in the Title text field in the Toolbar, and type in your web page name. Let’s name this page “My First Webpage.” When you’re done typing, hit the “Enter” key on your keyboard. Once your page is uploaded to the Internet, users will see “My First Webpage” in the title bar of their web browsers, and those who save your site to their favorites will see “My First Webpage” listed in their favorites.

You will see that your page opens as a new, blank document window in the main workspace. Depending on your preference, this window can be docked under the Dreamweaver Toolbar, or it can exist as a floating window. To detach it from the Toolbar, you may have to collapse the main panel grouping on the right of the screen. Once you have gotten the panel grouping out of the way, click the “Restore Down” icon on the far right of the Toolbar. This will display the document as a floating window which you can move and resize by clicking and dragging. To re-dock the window into the Toolbar, click the “Maximize” icon at the top right of the document window. Once you have the document window the way you want it, remember to re-expand the panel grouping on the right of the screen.

Sample - for evaluation purposes only!

©TeachUcomp, Inc. Introductory Dreamweaver
Creating a New Website

2.5 – SAVING AND CLOSING WEB PAGES:

When creating web pages, it is a good idea to save them often, so that things like software problems and power outages don’t cause you to lose work. After you name your file, choose “Save” from the “File” drop-down menu. When you save for the first time, this will open the “Save As” dialog box. Click the downward-pointing triangle to the right of the “Save in” text field, and find the root folder that you set up earlier. Click on the root folder so that its name appears in the “Save in” text field.

Next, click in the “File name” text field and name your web page. Even though you typed “My First Webpage” into the title bar of the page, that is not the best name for your file. If this is going to be the main page of your website, the best idea is to name it “index” because most Web servers will try to load that page first when someone types your domain name into their Web browser. In the “Save as type” text field, make sure you’ve chosen “All Documents,” and then click the “Save” button at the bottom right of the dialog box. You will notice that the filename and path are now reflected in the title bar of the document window.

Once you’ve saved your document, you can safely close the page. You can do this by clicking the X-shaped “Close” icon that is at the top right of the document window. To exit Dreamweaver entirely, you can choose “Exit” from the “File” drop-down menu in the Menu Bar, or simply click the X-shaped “Close” icon at the top right of the workspace.

2.6 – OPENING SAVED WEB PAGES:

You can open a saved web page in Dreamweaver using several methods. If you have worked on a page recently, you can choose “Open Recent” from the “File” drop-down menu. This will show you a list of the ten most recent pages opened in Dreamweaver. Highlight and click the page you want to open.

If you haven’t worked on the page recently, choose “Open” from the “File” drop-down menu. This will bring up the “Open” dialog box. Just like the “Save As” dialog box, the “Open” dialog box will default to the root folder of the currently selected website. By clicking the downward-pointing arrow to the right of the “Look in” text field, you can browse your computer to find the page you’re looking for. Once you locate the page, click it to highlight it, and click the “Open” button at the bottom right of the dialog box.

Another way to open a page is by using the “Files” panel to the right of the workspace. By clicking the plus and minus icons to the left of the file icons in the panel, you can search for the page you want to open. Once you locate it, simply double-click to open the page.
One of the best features of Dreamweaver is that it allows you to see what your web pages will look like in various browsers before you publish your site to the Internet. This is helpful because it lets you locate and fix problems with pages before your site is viewable to the public.

To preview a page in a browser before publishing, follow these steps. First, open the page that you want to preview in a browser. Then click the globe-shaped “Preview in Browser” icon located in the Toolbar. When you click the icon, Dreamweaver will open a drop-down list of the browsers found on your computer. The first option on the list will be your computer’s default web browser. If you have several browsers installed on your computer, they will be listed. You can also preview your page in Adobe Device Central, or using the Adobe Browser Lab.

Let’s preview this page using Internet Explorer, a very common web browser. Choose “Preview in IExplore” from the drop-down menu. This will open a new window, and your current web page will open in Internet Explorer. It is important to remember that your web page is NOT on the Internet right now—Dreamweaver is simply using your computer’s web browsing program to simulate what the page will look like if you published it in its current state. You can change the size of the Internet Explorer page to see how your page responds. If your page has links, you can click on them within the browser preview to see how they function. When you are done previewing your page, simply close Internet Explorer by clicking the X-shaped icon at the top right of the Explorer window.
As you probably know, web pages look very different when they are viewed on different devices or using different Internet browsers. Choosing “Preview in Device Central” from the “Preview in Browser” icon in the Toolbar will open Adobe Device Central, a separate program from Dreamweaver. Device Central allows you to see what your web page will look like on different “smart phones” and other handheld devices which connect to the Internet.

As we discussed in the last lesson, Dreamweaver also allows you to preview your web pages in your computer’s Internet browser. However, it may not be enough to simply preview your page in the browser that you commonly use to view web pages. There are many different Internet browsers out there, and different browsers can sometimes display pages differently. For this reason, it is a good idea to preview your web page in at least two different web browsing programs before publishing it to the Internet.

If you only have one program on your computer that will display web pages, for example Internet Explorer, you’ll want to download a secondary program from the Internet. If you open your existing web browser and search for “Free internet browser download,” you will find several sites that offer free browsing software. A good suggestion is Mozilla Firefox.

Once you have downloaded and installed your secondary browser, you will need to add it to the list of browsers in Dreamweaver. To do this, select “Edit Browser List” from the “Preview in Browser” icon in the Toolbar. This will open a Preferences dialog box. By clicking the plus-sign icon at the top of the dialog box, you can open the “Add Browser” dialog box. Type the name of the browser into the “Name” text field. Then click the “Browse” button to the right of the “Application” text field. This will open your computer’s “Program Files” folder, the most likely location of most software. In this case, we are going to add Mozilla Firefox as Dreamweaver’s secondary preview browser. Double-click on the “Mozilla Firefox” folder in the Program Files, and click on the program’s icon to highlight it. Then click the “Open” button. Click to place a checkmark in the “Secondary Browser” box, and click “OK.” You have now assigned Mozilla Firefox as Dreamweaver’s secondary Internet browser.

Now, when we click the “Preview in Browser” icon, you can see that we have the option to preview using Firefox in addition to being able to preview using Internet Explorer. Previewing in more than one web browser will help to ensure that your website looks the way you want it to, regardless of which browser your viewer may be using.
OPENING A NEW WEBSITE:
1. Click on “Site” from the Menu bar.
2. Choose “New Site.”
3. In the “Site Setup” dialog box input your site name and then click “Local Site Folder” icon.
4. Choose a root folder.
5. Click “Save.”

CREATING A NEW WEB PAGE:
1. Click “New” from the “File” menu in the Menu bar.
2. Choose from the selection on the left side of the “New Document” dialog box which opens.
3. Choose from the “Page Type” menu.
4. Click on a layout preference from the “Layout” menu.
5. Click on the “Create” button.

SAVING AND CLOSING WEB PAGES:
1. Click on “Save” from the “File” menu in the Menu bar.
2. Click on the downward pointing triangle next to the “Save in” text field to find the root folder.
3. Type in a file name for your page in the “File name” text field.
4. Click the “Save” button.
5. Close your saved web page by choosing from the following options:
6. Click “Exit” from the “File” menu found in the Menu bar.
   -or-
7. Click the small “x” in the top right of the page frame.
OPENING A SAVED WEB PAGE:
1. Click on either “Open” or “Open recent” from the “File” menu in the Menu bar.
2. Click on the folder icon to browse folders on your computer where the page is stored.
3. Alternatively, open the page using the “Files” panel by browsing through folders using the “+” and “-” icons.

PREVIEWING WEB PAGES:
1. Click on the small black triangle on the globe icon immediately below the Menu bar.
2. Choose a web browser in which to preview your web page.
3. Use the keyboard shortcut shown next to the browser name if you prefer.

ENABLING MULTI-BROWSER PREVIEWS:
1. Click on “Edit Browser List” from the “Preview in browser” button with the small globe icon.
2. Click on “Preview in Browser” from the “Category” menu on the left of the “Preferences” dialog box which opens.
3. Click the “+” icon to open the “Add Browser” dialog box.
4. Click the “Browse” button to search for additional browsers saved on your computer.
5. Name this additional browser in the “Name” text field of this dialog box.
6. Click the appropriate checkbox for “Defaults.”
Excercises- Creating a Website

Purpose:
1. To be able to create a basic website in Dreamweaver.

Exercises:
1. Open your Dreamweaver application.
2. Select “Site| New Site” from the Menu Bar.
3. Type “Dreamweaver Test Site” into the “Site name:" text box.
4. Click the small folder button at the right end of the “Local root folder:" text box to launch the “Choose local root folder” dialog box.
5. Use the “Select:" drop-down to choose the “My Documents” folder.
6. Click the “Create New Folder” button to the right of the “Select:" drop-down and name your new folder "root.”
7. Double-click the “root” folder. It should now appear in the “Select:" box at the top of the dialog box.
8. Click the “Select” button in the lower right corner of this dialog box.
9. Click “Advanced Settings” at the left of the dialog box.
10. Click the small folder button at the right end of the “Default images folder:" text box to launch the “Choose local images folder” dialog box.
11. If needed, use the “Select:" drop-down at the top of this dialog box to select the “My Documents” folder and double-click the “root” folder displayed in the list of files and folders to open that, as well.
12. Click the “Create New Folder” button to the right of the “Select:" drop-down and name the new folder “images.”
13. Double-click on the new “images” folder to open it. It should now display in the “Select:" drop-down at the top of the dialog box.
14. Click the “Select” button in the lower right corner of the dialog box.
15. Click “Save” in the “Site Setup” dialog box to create the basic web site.
17. Select “Blank page” from the “Category:" list at the left side of this dialog box.
18. Select “HTML” in the “Page Type:" list in the middle of the dialog box.
19. Click the “Create” button in the lower right corner of the “New Document” dialog box.
20. Select “File| Save As...” from the Menu Bar.
21. Ensure that you have the "root" folder selected in the “Save in:" drop-down.
22. Type “index” into the “File name:" text box.
23. Click the “Save” button in the lower right corner of the “Save As” dialog box.
24. Select “File| Close” from the Menu Bar to close the web page.
25. View the contents of the web site in the “Files” panel.
26. Double-click on the icon for the “index.htm” file in the “Files” panel to open that page for editing.
27. Close the web page again by clicking the small “x” in the upper right corner of the web page.
28. Select “File| Exit” from the Menu Bar to close and exit the Dreamweaver application.
CHAPTER 3-
All About Text

3.1 - Working With Text

3.2 - Exploring Heading Levels

3.3 - Formatting Text Color

3.4 - Changing a Web Page Background Color

3.5 - Aligning Text

3.6 - Creating Paragraphs

3.7 - Working With Fonts

3.8 - Using Custom Fonts

3.9 - Using Bold and Italics With Text

3.10 - Creating Lists

3.11 - Special Characters

3.12 - Creating Blockquotes
3.1- WORKING WITH TEXT:

Let’s examine how to create text in your web pages using Dreamweaver. In many ways, entering text into a web page is much like entering text into a document using standard word processing software. However, there are important differences.

You can easily type text into a web page by simply clicking into the page and typing your text. The text will then appear next to the thin, blinking insertion marker within the web page, just as if you were typing text into a word processing application. You can use the “Backspace” and “Delete” keys on your keyboard to edit and remove text, just as you would expect. However, some keyboard keys will not function within Dreamweaver. Note that when you press the “Tab” key on your keyboard, which normally indents the first line of a paragraph, nothing happens to your text. So, while there may be a great deal of similarity in the way that you enter text, there are also some differences in what you can and cannot do to the text within the web page.

For example, let’s look at how to format the size of text in Dreamweaver. When using word processing applications, we get used to thinking in terms of point-sizes when we think of fonts. In Dreamweaver, however, your thinking must shift. People who view your website will be doing so from different types of devices, like laptops, smart-phones, and even televisions. Those devices will be using a variety of web-browsing programs which have different settings. So you cannot, for example, ensure that the headline of your page is the size of a 16-point font. The best you can do is to ensure that the headline will be proportionately larger than the text below it using “Heading” levels. That way, even though your heading text might appear larger on a laptop than it will on a hand-held device, your heading will be proportionately larger than the rest of the text on the page on both screens.

Sample- for evaluation purposes only!
3.2 – EXPLORING HEADING LEVELS:

Let’s create a heading for a new web page. When you open a new, blank page in Dreamweaver, the cursor will be blinking in the upper left corner of the new document. Type the title, or heading, of your page. Let’s type “My Home Page Title” into the page. You’ll see that the text doesn’t look much like a title. If we click the “Live View” button in the Toolbar, you’ll notice that the text is unformatted. You’ll also notice that the Properties Inspector panel at the bottom of the workspace is “grayed-out” and unusable. This is an indicator that you’re in “Live View” mode and cannot edit your page. “Live View” is a great tool because it lets you preview the functionality and formatting of your web page before you even save the page. In order to preview using a browser, we must save this file. But we can preview using the “Live View” button on any document.

Let’s format the text to make it look more like a heading on a web page. Using your mouse, click and drag to highlight the text. Again, there are several ways to format the text using Dreamweaver. We’re going to format using the Properties Inspector. You’ll notice that, as soon as you highlighted the text, the Properties Inspector displayed the properties of the text. For the time being, make sure that the Properties Inspector is set to display HTML properties rather than CSS properties. You can do this by clicking the “HTML” button at the left of the Properties Inspector panel.

In addition to examining the various properties of your text, you can also edit the text using the Properties Inspector. Making sure that your text is highlighted, use the “Format” drop-down menu in the Properties Inspector to choose “Heading 1.” You’ll notice that your text gets bigger. “Heading 1” is the largest formatting option that you have for text. Try changing the text to “Heading 2.” You’ll see that your text is now slightly smaller. “Heading 3” is smaller still, and you’ll notice that “Heading 4” is the same size as your original unformatted text, but the text is still boldface. “Heading 5” and “Heading 6” make the text smaller still. These two very small heading levels are mostly used for things like copyright information, disclaimers, and other “fine print.” So the higher the heading number, the smaller the text will appear on the web page.
3.3 – FORMATTING TEXT COLOR:

In this lesson you’ll learn how to change the color of text on your web page. Using the same process as in the last lesson, open a new, blank page, and type “My Home Page Title” into the document. Make sure you have sized it to “Heading 1” using the Properties Inspector.

First, click the “Page Properties…” button at the bottom of the Properties Inspector. This will open the “Page Properties” dialog box. Click the small downward-facing triangle in to the box to the right of “Text Color.” You will notice that your mouse cursor turns into an eyedropper, and a box of “color cubes” opens. When you hover over individual colors, notice how Dreamweaver displays the exact color number for you. When you choose a color for your text and click on it, the box with the color swatches closes, and you will see both the color you chose and its exact number reflected in the “Page Properties” dialog box. Click “OK.” You will notice that the dialog box closes. You will see that the color of your text has changed to reflect your choice.

You can also customize the way that you choose colors in Dreamweaver. Click the “Page Properties” button in the Properties Inspector. This will open the “Page Properties” dialog box again. You will notice that your last text color choice is still displayed, with its exact number in the text field to its right. Click on the small down-ward facing triangle on the color cube to open up the box of “color cubes” again. On the top right-hand corner of the dialog box, click the right-pointing black triangle. This will display a drop-down menu which allows you to change the way the swatches of color are displayed. Change “Color Cubes” to “Continuous Tone.” Now try changing it to “Windows OS,” “Mac OS,” and “Grayscale.” Notice how the color swatches change with each choice. Choose a setting you like and choose a new color for your heading text. Now click “OK.”

Let’s look at another way to choose color for your text. With the “Page Properties” dialog box open, click the small downward-facing triangle next to your text color. This time, click the round “System Color Picker” icon at the top of the color cubes. The classic Windows “Color” dialog box opens up. Now you can use this alternate method of choosing your text color, or even defining custom colors for your page.

To remove the color from your heading text, click the “Page Properties” button in the Properties Inspector. Then click the small downward-facing arrow next to your text color, which will open up that color-cubes box. Click on the “Default Color” icon—it’s the white square one with the red diagonal stripe. Click “OK.” The dialog box will close. You’ll see that your text has returned to its default color—most likely black, unless Dreamweaver’s Preferences have been changed.
3.4 – CHANGING A WEB PAGE’S BACKGROUND COLOR:

In this lesson you will learn how to change the background color of your web pages. If you do not choose a background color for your site, your text and colors will be displayed on a white background—or whatever the default background color is on the device used to view your page.

Let’s add a background color to a web page. Click the “Page Properties” button found at the bottom of the Properties Inspector panel. This will open the “Page Properties” dialog box. Click on the square icon found next to the “Background Color” text field. This will open up the same palette of colors that you used to define your text color, and your mouse icon will change into an eyedropper, indicating that you are able to click and choose a color for the background of your page. When you find one that you like, click “OK.” The page changes to reflect your choice and the dialog box closes.

Keep in mind that your background color should compliment the content of your page, not compete with it. If your page contains a lot of text, choose a background color that is in sharp contrast from your text color. If your background color and your text color are too similar, your text will be difficult to read.
3.5 – ALIGNING TEXT:

In this quick lesson, we’ll look at how to center your page heading. Using the same process as in the last lesson, open a new, blank page, and type “My Home Page Title” into the document. Make sure you have sized it to “Heading 1” using the Properties Inspector, and choose a color for your heading text.

Choose “Align” from the “Format” drop-down menu in the Menu Bar. Notice that the checkmark is on “Left,” indicating that your heading will be aligned to the left of the screen when your page is viewed in a browser. Click on “Center.” You will notice that the heading text becomes centered in the document window. As you can see from the drop-down menu, you also have the option of aligning your text to the right of the page.
3.6 – CREATING PARAGRAPHS:

In this lesson, you will learn how to add paragraphs of text to your web pages. Make sure you have a new, blank document open in the Dreamweaver workspace.

As we’ve seen in previous lessons, Dreamweaver allows you to simply start typing your text within the document window. Many times, however, you will want to use text from somewhere else, such as text that has been prepared using word editing software, or text that someone has emailed you. In this case, simply click and drag to highlight the text in whatever other program you are working with, and copy the text. You can copy by choosing “Copy” from the “Edit” drop-down menu of most programs. You can also press the “Control” and “C” buttons on your keyboard at the same time to copy highlighted text.

Once you’ve highlighted and copied your text from another program, return to Dreamweaver. Choose “Paste” from the “Edit” drop-down menu in the Menu Bar. The text that you copied will appear in the document window.

If you have a large body of text that you want to break up into separate paragraphs, simply click in the text to place the blinking cursor at the spot where you want to end the first paragraph, and hit the “Enter” key on your keyboard. Dreamweaver will put a space called a “paragraph break” between your paragraphs. You can do this as many times as you like to separate your ideas and text.

If you have text that you want to separate without creating a new paragraph, you can use Dreamweaver to create a “line break.” Simply click in the text to place your cursor at the spot where you want to divide the text, and hold down the “Shift” key while you hit the “Enter” key on your keyboard. This will create a line break in your text, which keeps the text in the same paragraph but moves it to a new line.

You may sometimes notice that when you create a paragraph break or a line break, there is an extra space at the beginning of your new paragraph or line. This is because Dreamweaver is still displaying the space that you typed to separate two words or sentences before creating your line break or paragraph break. To remove this unwanted space, simply click to the far left of it and hit your keyboard’s “Delete” key once or twice. This will remove the extra space, and your paragraph will be perfectly aligned.
3.7 – WORKING WITH FONTS:

As we’ve discussed in previous lessons, you can never completely control the way your web page will look on a viewer’s browser, because you do not know which device, software, or settings the viewer will be using. This is important to keep in mind as you learn about using different fonts. Fonts are simply different typefaces used to display your text. Their use is mainly decorative, since they don’t change the content of your text; fonts simply make your text more attractive to read. The primary problem you face when choosing fonts is this: Your font choice will only be displayed on the viewer’s screen if that viewer has your same font installed on his or her device. In other words, if you used a really neat, obscure font on your web page and the person viewing the page didn’t have that same font installed on his or her computer, your page wouldn’t be displayed the way you intended.

To help to prevent this, Dreamweaver requires you to select fonts in groups of three. Let’s look at how this works. Beginning with a new, blank page, type some text. Let’s type “The moon was full and bright.” Now click the “Page Properties” button found in the Properties Inspector panel. This will open the “Page Properties” dialog box. In the “Page font” text field, you should see “Default Font.” This means that your text is being displayed using your computer’s default typeface, in this case Times New Roman. If you click on the downward-pointing arrow to the right of the text field, the font list will open.

You’ll notice that each choice in the font list is actually three font types. Click on the first choice: “Verdana, Geneva, sans-serif, and click “OK.” This will close the “Page Properties” dialog box, and you’ll notice that your font has changed.

The reason that Dreamweaver forces you to choose groups of three fonts is to give as much design control as possible. In this case, your web text will appear as the “Verdana” typeface. If the viewer’s computer doesn’t have the “Verdana” font installed, the web page will display “Geneva.” If the viewer’s computer doesn’t have either Verdana or Geneva, the web page will display any sans-serif font installed on that computer as a last resort. So, as you choose your font groups for your pages, Dreamweaver will display the first font on the list. Hopefully, people viewing your web pages will have most of the fonts that Dreamweaver allows you to choose from. If they don’t, you can at least control what type of font the page will display.
3.8 – USING CUSTOM FONTS:

If you really want to use a specific font on your web page that isn’t on Dreamweaver’s list, you have two choices. First, you can use the “Edit Font List” choice at the bottom of the Font List drop-down menu to add specific fonts from your computer to Dreamweaver’s list. Keep in mind, however, that Dreamweaver has included the fonts that most people have. Any font you add to that list will be available to design with, but your page won’t display the custom font unless your viewer also has that font installed on his or her hard drive.

Your other option, if you want to display text using a custom font, would be to use an image-editing program such as Adobe Photoshop. Using Photoshop, you can type your text using your custom font, and save it as a jpeg or gif image. You won’t be able to edit the content of your text after you do this, but it is a handy trick if you have a company logo or a few words that really depend on a specific typeface. It’s a good idea to use the same background color in your created image as you plan to use on your web page; doing so will make your text appear to be its own element on the finished page.

3.9 – USING BOLD AND ITALICS WITH TEXT:

In this short lesson we’ll look at how to display text using bold face and italics. Make sure you have a blank page opened, and type some text. Let’s use “The moon was full and bright” again. Click and drag to highlight the text, and then click the “Bold” icon with the capital “B” found in the Properties Inspector. You’ll notice that your text is now displayed in bold type. Incidentally, default text with bold applied, such as you see here, is displayed exactly the same way as if you chose “Heading 4” from the “Format” drop-down menu in the Properties Inspector panel. This is another example of how Dreamweaver gives you a lot of different ways to achieve the same end result.

After making sure that the text is highlighted, click the “Bold” icon again. This returns your text to its original state. With the text still highlighted, click the “Italic” icon that is just to the right of the “Bold” icon. Note that your text is now italicized. If you click the “Bold” icon again, you’ll see that your text is now both italicized and boldfaced. You can click on these icons again to remove these attributes. Now click on the text once to remove the highlight. Your text should look exactly the way it did when you first typed it.

You can also highlight part of your text and apply bold or italics to just the selection. Click and drag to highlight the word “full” and then click the “Bold” icon in the Properties Inspector. Now click and drag to highlight the word “bright” and then click the “Italic” icon in the Properties Inspector. Click on the highlighted word to remove the highlight. You can see that the text reflects your changes.

Don’t forget that you can click on the “Live View” button at any time, and Dreamweaver will simulate how your formatting will look once it’s published to the web and viewable by others.
In this lesson, you’ll learn how to turn text into ordered and unordered lists. First, make sure that you have a new blank page opened, and type in some text that you want to turn into a bulleted list. A bulleted list is known as an “unordered list” because the items in it are separated by bullet-points rather than numbers or letters, and are therefore in no particular order.

We’ll type “Apples Strawberries Blueberries Plums” into our blank page. If this were going to be a sentence, we would probably put commas between the words, but because this is going to become a bulleted list, I’m going to leave out the commas. In fact, I’m even going to eliminate the spaces between my bulleted items, so that I have one long mash of words.

Next, click into your text so that the blinking cursor is just to the left of your first bulleted item. Then click the “Unordered List” icon found just to the right of the “Italics” icon in the Properties Inspector panel. You’ll see that Dreamweaver adds a bullet just to the left of where the blinking cursor was. You’ll notice, as you use Dreamweaver, that many of the program’s tasks work using this same method: You click to put the blinking cursor at a spot on the page, then click another button to add something at the spot where you placed the cursor.

To continue creating your bulleted list, click to place the blinking cursor just to the left of the next item of text—in this case, I’m going to click just to the left of the capital “S” in “Strawberries”—and click the “Enter” key on your keyboard. You will see that Dreamweaver moves the text beginning with the capital “S” to a new line and adds a bullet point to the left. Next, I’m going to click to place the cursor just to the left of the capital “B” in “Blueberries” and hit the “Enter” key again. Finally, I click to place the cursor just to the left of the capital “P” in “Plums” and hit the “Enter” key one more time. My long mash-up of words is now a nicely-formatted, bulleted list. It’s probably more obvious at this point why I left out the spaces between the words, as well: Once Dreamweaver adds the bullet-points and separates the words into different lines, the spaces become unnecessary.

Creating ordered lists using Dreamweaver is much the same as creating unordered lists, except that your items are separated by letters or numbers rather than bullet-points. Starting with the same long mash of “ApplesStrawberriesBlueberriesPlums,” click to place the blinking cursor just to the left of the capital “A” in “Apples” and then click the “Ordered List” icon found just to the right of the “Unordered List” icon in the Properties Inspector panel. You’ll notice that a number ‘one’ appears to the left of the capital “A.” Next, click to place the cursor just to the left of the capital “S” in “Strawberries” and hit the “Enter” key on your keyboard. Everything from the capital “S” on is now part of a new line, with the number ‘two’ just to the left of where you had placed the cursor. Continue clicking between words and hitting the “Enter” key to finish creating your numbered list.

- Apples
- Strawberries
- Blueberries
- Plums
3.11 – SPECIAL CHARACTERS:

From time to time, you may need to insert special characters into your web page text that do not appear on your computer’s keyboard. This lesson will teach you how to access and insert special characters into your web page text.

First, start with a new, blank page and type or paste some text into it. I’m going to type “Tiffco Turtles are great!” Now let’s put a trademark symbol after the word “Turtles.”

Click to place the blinking cursor just to the right of the letter “s” in “Turtles.” Then click to open the “Insert” drop-down menu in the Menu Bar. Hover over “HTML” to open another menu, and hover over “Special Characters” to open the menu which contains the special characters. Click on “Trademark.” This will close all of the menus, and you will see that a small “TM” symbol has been placed where you put the cursor.

You can now click and drag to highlight the text with the trademark symbol, and use the Properties Inspector panel to edit it just as you would edit other text, and the trademark symbol will take on the same properties that you assign to the rest of the text. If you have formatted your text prior to adding the trademark symbol, the symbol will take on the properties of the text surrounding it.

If you do not see the special character that you want to insert in the drop-down menu, choose the “Other…” option at the bottom of the menu. This will open up a new dialog box that has dozens of additional characters to choose from.

3.12 – CREATING BLOCKQUOTES:

In this lesson, you will learn to create “block quotes” using Dreamweaver. A block quote is simply an area of indented text. Traditionally, this formatting was used to separate long quotations from surrounding text. However, block quotes can be a handy way of breaking up the text areas on your web page.

Start with a new, blank web page and type or copy three paragraphs of text into the document window. In this case, I’m going to use some random text.

To create a block quote on the second paragraph, I’m going to click to place the blinking cursor anywhere within that paragraph. Next, I’m going to click the “Blockquote” icon in the Properties Inspector panel. Notice that the entire paragraph becomes indented. To remove the Blockquote, simply click the “Remove Blockquote” icon in the Properties Inspector panel.
WORKING WITH HEADING LEVELS:
1. Click and drag on some text on your page to highlight it.
2. Click on the “HTML” button in the Properties Inspector.
3. Click either the downward facing arrow to its right or within the “Format” text field itself.
4. Choose the appropriate heading size: h1 is the largest, h6 is the smallest.

FORMATTING TEXT COLOR:
1. Click the “Page Properties” button in the Properties Inspector.
2. Click the “Text color” color picker square.
3. Choose a new color from the palette of color cubes which appears.
4. Click the right-pointing arrow in the top right of this color cubes menu to choose from more color options (continuous tone, color cubes etc).
5. Click on the round “System Color Picker” icon to make custom color selections.

CHANGING YOUR WEB PAGE’S BACKGROUND COLOR:
1. Click the “Page Properties” button in the Properties Inspector.
2. Click on the “Background color” square color picker.
3. Choose a new background color from the color cubes palette which opens.
4. Click the “OK” button to confirm your choices.

ALIGNING TEXT:
1. Click on “Align” from the “Format” menu in the Menu bar.
2. Choose an alignment option from the side menu which appears: Left, Center, Right or Justify.
CREATING PARAGRAPHS:
1. To create a break between paragraphs of text, place your cursor at the end of the first paragraph.
2. Hit the “Enter” key.
3. To create a link break within the same paragraph, place your cursor where you want the line break.
4. Hold the “Shift” key and hit the “Enter” key.

CHOOSING THE APPEARANCE OF FONTS:
1. Click on the “Page Properties” button in the Properties Inspector.
2. Click the downward facing triangle next to the “Page font” text field.
3. Choose your preferred trio of font selections from the drop-down list.
4. Click “OK” to confirm your choices.

USING CUSTOM FONTS:
1. To use a specific, custom font not shown in the “Page Font” list, click “Edit Font List” at the bottom.
2. From the “Edit Font List” dialog box and select from the “Available fonts” list there to add fonts you have on your computer to the list in Dreamweaver.

USING BOLDFACE AND ITALICS:
1. Click and drag to highlight the text you want to modify.
2. Click the bold icon (“B”) in the Properties Inspector to apply boldface to your selection.
3. Click the italics icon (“i”) in the Properties Inspector to italicize highlighted text.
CREATING LISTS:
1. Type in all the items on your proposed list as one sentence without spaces or punctuation.
2. Place your cursor to the left of the first bulleted list item.
3. Click the “Unordered List” icon in the Properties Inspector.
4. Repeat step 2 for the next bulleted list item and hit the “Enter” key.
5. Repeat for all list items until your bulleted list is complete.

INSERTING A SPECIAL CHARACTER INTO A PAGE:
1. Click into the web page at the spot where you want to place the special character.
2. Select “HTML” and then “Special Characters” from the “Insert” drop-down menu.
3. Click to select the special character you want to insert.

CREATING A BLOCKQUOTE:
1. Click within the web page within the paragraph that you want to turn into a blockquote.
2. Click the “Blockquote” icon in the Properties Inspector panel.
3. To remove a blockquote, use the “Remove Blockquote” icon.
**Exercises- All About Text**

**Purpose:**
1. To be able to create the basic text in our web pages.

**Exercises:**

1. Open your Dreamweaver application.
2. Ensure that you have the “Dreamweaver Test Site” open.
3. Select “File| Open…” from the Menu Bar, and ensure that you are viewing the “root” folder in the “look in:” drop-down.
4. Select the “index.htm” file from the large white box of files and folders.
5. Click the “Open” button in the lower right corner of the “Open” dialog box.
6. Click into the “index.htm” web page and type the following: “Welcome to the Dreamweaver Home Page.”
7. Press “Enter” on your keyboard to begin a new paragraph.
8. Type “In this lesson we will examine how to:” on the next line.
9. Press “Enter” on your keyboard.
10. Type “Enter text into the web page.”
11. Press “Enter” on your keyboard.
12. Type “Select and format text.”
13. Press “Enter” on your keyboard.
14. Type “And make bulleted lists.”
15. Select all of the text from “Enter text into the web page” through “And make bulleted lists” by clicking and dragging over the text with your mouse.
16. Click the “Unordered List” button in the “Properties” panel to make a bulleted list of the three lines.
17. Click and drag over the “Welcome to the Dreamweaver Home Page” text to select it.
18. Use the “Format:” drop-down in the “Properties” panel to select the “Heading 1” style.
19. Click the color box button in the “Properties” panel and select the color of “#003333” from the palette, or simply type it into the text box provided.
20. Select “File| Save” from the Menu Bar.
21. Select “File| Close” from the Menu Bar to close the web page.
22. Select “File| Exit” from the Menu Bar to close and exit the Dreamweaver application.
CHAPTER 4-
All About Images

4.1 - Using Images in a Web Page
4.2 - Image File Types
4.3 - Commonly Used Web Images
4.4 - Inserting Images into a Web Page
4.5 - Image Properties
4.6 - Borders and Spacing Around Images
4.7 - Using Background Images
4.8 - Resizing Images
4.9 - Cropping Images
4.10 - Using Images and Text Together
4.11 - When to Use Outside Imaging Programs
4.12 - Opening an Image in Adobe Photoshop
4.13 - Cropping an Image Using Photoshop
4.14 - Saving an Image Using Photoshop
4.15 - Resizing an Image Using Photoshop
4.16 - Working with Custom Fonts in Photoshop
4.1 – USING IMAGES IN A WEB PAGE:

Whatever type of website you are planning, images will undoubtedly play a big role in helping to get your ideas across. In this chapter, you will learn how to use visual images effectively as a way to give your web pages greater impact.

It is important to remember that Dreamweaver isn’t an image editing program. This means that you will have to prepare some of your images beforehand, using another program like Adobe Photoshop, so that they can be inserted into your web pages. Making sure that your images are of the correct file type and size will help to ensure that your website functions correctly, that you stay within bandwidth requirements, and that your images look as good as possible.

It’s a very good idea to sit down with pen and paper beforehand, and make a list of all of the images that your website will need. As you start to consider banners, buttons, and other visual elements, you may realize that you will need to prepare more images than you originally thought. You can save yourself a lot of frustration by carefully planning and preparing your images. That way, when it comes time to build your site, you won’t have to stop again and again to create the image files that you will need. Planning your images beforehand also allows you to size them exactly to your needs, which helps to give your finished website a professional, polished look.

4.2 – IMAGE FILE TYPES:

Although there are several different image file types that you can upload to your web pages, the two most common are GIF and jpeg images. GIF images were developed by CompuServe, and GIF stands for Graphics Interchange Format. GIF images contain a compression algorithm that reduces the size of a GIF file. GIF files, however, do not contain any dpi information for printers, and they can only display 256 colors. GIF images are best used for non-photo-based graphics, buttons, and rollover images.

Jpeg images are much better suited for displaying photos, as they can display millions of colors. Jpeg files tend to be somewhat larger than GIF files, but the size versus quality ratio is adjustable when you save a jpeg using image editing software like Adobe Photoshop. This means that, if you are trying to stay within a certain file size, you can save the image as a jpeg and adjust the quality of the image to suit your needs. Jpeg images also contain dpi information for printers.

One thing to keep in mind, especially if you use image-editing software a lot, is that “TIFF” files will not be displayed on most browsers. It is best to avoid the “TIFF” file format when designing your web page.
4.3 – COMMONLY USED WEB IMAGES:

In addition to the images that you plan to insert into your web pages as featured content, there are several other common images that you may have to prepare in order to build a functioning website with Dreamweaver. Here are a few of them:

Web Banners: Although web banners are usually associated with advertising, many people like to develop a banner design that appears on every page of a website. This technique of putting the same banner on every page gives website continuity, and the banner can also be used as a “Home Page” button.

Background Images: When designing your web pages, you have the option of having a solid-colored background, or you can use a background image. Certain image-editing software, such as Adobe Photoshop, can help you create seamless background images that will repeat endlessly.

Button Images: Buttons are small images that viewers use to navigate the different pages of your web site. They are often used in conjunction with rollover images to create “rollover effects.” There are a variety of free buttons available for download on the Internet, or you can use image editing software to create your own.

Rollover Images: Rollover images are the images that appear when your viewer moves the mouse above an image that has a rollover effect. In this case, you can see that when I hover the mouse over the different page buttons in Dreamweaver’s “Live View,” the mouse arrow changes into a pointing hand and the image of the button changes color. When designing rollover images, it is a good idea to keep them similar to the image that they replace.

Thumbnail Images: If you plan to include an image gallery in your website, you'll need to prepare thumbnail images. Thumbnail images are the smaller images that a user clicks on to see a bigger version of the same image. Although it is possible to resize images within Dreamweaver, it is very easy to lose your original image by doing this. It is a much better idea to prepare your thumbnails as separate image files that you size and save using image-editing software before starting to build your website in Dreamweaver.
4.4 – INSERTING IMAGES INTO A WEB PAGE:

As you’ve heard several times now, Dreamweaver often gives you many different options for accomplishing the same task. This is also true when it comes to inserting images into a web page. For the next few lessons, we’re going to focus on using the “Insert” panel and the “Properties Inspector” panel to accomplish most of what we need to do with images.

Let’s insert an image into a web page. Start with a new, blank page. Dreamweaver will insert the photo wherever you place the blinking cursor. In this case, the photo is the first element of the page, so you don’t have to position the cursor.

Click on “Image” in the “Insert” panel. This will open up the “Select Image Source” dialog box. Use the downward-pointing arrow found to the right of the “Look In” text field and locate the image you want. Click on the image to highlight it, and then click “OK.” Depending on Dreamweaver’s preferences, a pop-up box may alert you about document-relevant paths. If you see this box, click “OK.”

The next thing you will see is the “Image Tag Accessibility Attributes” dialog box. You will see an “Alternate Text” text field. You don’t have to put any information in here, but it’s a good idea to use a few words to describe your photo. This description will be displayed if your image cannot be displayed by a web browser. The description is also read aloud when visually-impaired people use special software to “read” web pages. I’m going to just type “small carved turtle” here, and click “OK.” The dialog box will close, and the image is now on the web page.
4.5 – IMAGE PROPERTIES:

Now that you know how to insert an image into a web page, let's look at the Properties Inspector to find out more about the image. As you remember, the Properties Inspector will display information about whatever element of your page you click on. Because the photo is the only element on this page, the Properties Inspector is displaying information about the photo.

At the far left of the Properties Inspector, you can see a very small thumbnail version of your image. In the case where you have more than one photo inserted into a web page, this thumbnail image is a handy way to see which image properties you are looking at. Just next to the thumbnail, you see the word “Image” with the size of the image file. In this case, the file is 140KB. Just to the right of the image file size, you can see the pixel height and width of the image. These are known as the image dimensions.

Once you edit your image, the Properties Inspector panel will also give you information about the formatting of your image, such as whether or not it has a border, how the image is aligned on the page, and how much blank space there will be around the image. So, in addition to being a powerful editing tool, the Properties Inspector is a good first place to check when you are looking for information about your image.

4.6 – BORDERS AND SPACING AROUND IMAGES:

In this lesson, you'll learn how to add a border to an image, and how to add space around an image. Starting with a new page, use the techniques from the previous lesson to insert an image into a web page. It doesn’t matter which type or size of image you use.

To add a border to the image, first make sure that your image is selected by checking for the thumbnail of your image in the Properties Inspector. Then use your mouse to click into the “Border” text field within the Properties Inspector. With the cursor blinking within the text field, use your keyboard to type the width in pixels that you want your border to be. Let's put a five-pixel border around this image. Once you type in the numeric value for your border, simply press the “Enter” key on your keyboard. You will see that Dreamweaver adds a five-pixel border around your image.

To put “blank space” around an image, use your mouse to click into the “V Space” text field in the Properties Inspector. Once the cursor is blinking within that text field, use your keyboard to type the width in pixels of the vertical space you want surrounding your image. If I type in “10” and hit the “Enter” key on my keyboard, Dreamweaver will add ten pixels of blank space both above and below my image. You can see that the image shifts down slightly when I do this; that’s how I know that Dreamweaver has added space above and below my image.

Now use your mouse to click into the “H Space” text field found immediately below the “V Space” text field in the Properties Inspector. This is where you type in the amount of blank space that you want on either side of your image. Type “10” and hit the “Enter” key on your keyboard. The image shifts slightly to the right as Dreamweaver adds the space to the left and right of the image.

As you may have guessed, “V Space” stands for “Vertical Space” and “H Space” stands for “Horizontal Space.” Adding space around an image doesn’t make much sense if the image is the only element on your web page. If the image appears next to text, however, adding space around the image is a good way to make sure that your text doesn’t “crowd” your image.
4.7 – USING BACKGROUND IMAGES:

In this lesson, you will learn how to insert a background image into a web page. First, start with a new, blank page and type or paste some text into the page. I’m going to paste in some random text to this blank page.

Next, click the “Page Properties” button found at the bottom of the Properties Inspector panel. This will open the “Page Properties” dialog box. Click the “Browse” button found to the right of the “Background image” text field. This will open the “Select Image Source” text field. Click on the downward-pointing arrow to the right of the “Look In” text field to find the image you want to use for your background. When you’ve found it, click it once to highlight the image, and click “OK.” If you get a pop-up message about creating a document-relevant path, click “OK.” This will bring you back to the “Page Properties” dialog box. You will notice that your file’s path is now visible in the “Background Image” text field.

To determine how your background image will be displayed, click the downward-facing arrow found to the right of the “Repeat” text field. Choosing “no-repeat” will center your image on the page, and your image will never repeat, regardless of the size of your viewer’s browser. Choosing “repeat” will repeat your image in the case where the viewer’s browser is bigger than your image. If you choose the “repeat-x” or “repeat y” choices, your image will repeat either vertically on the viewer’s page, or horizontally. Choosing to repeat images usually works best with small pattern images that are designed to be “seamless.” Many image-editing programs like Adobe Photoshop have features that will help you create your own seamless tiles and images.

I’m going to choose “no-repeat” for this background image, and click “OK.” You can see that the image appears under my text. Just like when you are selecting background colors, it’s very important to think of the impact that a background image will have on your site. If your image is too complicated or “busy,” it may make your text hard to read. Large, subtle images with not too much color make great background images.
4.8 – RESIZING IMAGES:

In this lesson, you will learn how to resize an image within Dreamweaver. Using techniques from previous lessons, open a new, blank document in Dreamweaver, and insert an image into the page.

There are two easy ways to resize an image within Dreamweaver. First, you can use the Properties Inspector. By clicking into the dimensions of the image, you can use your backspace key to remove the old value, and type in a new value instead. In this case, the original image was 480 pixels wide by 360 pixels tall. I’m going to click into the width text field and change 480 to 400, and then I’m going to press the “Enter” key on my keyboard. You can see that my image stretches to accommodate the changed width. Notice also that the height of the image does not change.

You’ll also see that, when I changed the size of my image, a new icon appeared just to the right of the image’s dimensions. This is the “Reset Size” icon, and if I click it, the image will revert to its original size.

Another easy way to resize an image is to simply click and drag one of the black boxes that appear around the border of an image when it is selected. You can see that, when you hover your mouse over one of these boxes, the box changes to a double-pointing arrow. If I choose the box on the right side of my image, I can click and drag to make my image wider. If I click and drag the box on the bottom of the image, it will make the image taller. Each change I make is reflected in the Properties Inspector, and I can see the new width and height of my image after I click and drag. If I want to enlarge or shrink the image proportionately, so that there is no distortion to the image, I click and drag using the box on the bottom right corner of the image. When I’m done, I can either save my page, or click the “Reset Size” icon in the Properties Inspector to restore the image’s original size.

Although it is easy to resize images within Dreamweaver, there are several reasons that it is a better idea to resize your images using an image-editing program like Adobe Photoshop. First, when you resize images using Dreamweaver, you are not really changing the size of your image—you’re just adjusting the way your image is displayed within a web page. If you use Dreamweaver to reduce the size of the image, the web page will still have to load the original, larger image, which wastes bandwidth and takes longer for pages to load. If you use Dreamweaver to enlarge the size of an image, you can face distortion and quality issues that are avoidable when you use a program like Photoshop. For these and other reasons, it’s always a good idea to prepare and save the images for your website in an image-editing program before beginning to build your site with Dreamweaver.
4.9 – CROPPING IMAGES:

In this lesson, you will learn to crop an image using Dreamweaver. “Crop” is a synonym for “trim,” and so when you’re cropping an image, that’s the same as saying, you’re trimming the image. Cropping is mostly done to remove the outside parts of a photo that are unnecessary or distracting, in order to draw more attention to the photo’s main subject matter. Cropping is also done as an alternative to shrinking an image.

Let’s crop an image using Dreamweaver. First, open a new, blank page, and insert an image into the document window. Then click the “Crop Tool” icon found in the Properties Inspector panel. When you click it, a dialog box appears, warning you that when you crop the image and save the page, your original image will be permanently changed. This is really an important thing to keep in mind, especially if you intend to use your image at some other time when you might want the bigger version of it. Once you crop your image and save the page, the image is cropped for good, and you cannot retrieve the original, larger image.

Click “OK” to close the warning dialog box. You will notice that the outside of your image now has a darkened frame shape on it. You will also notice a white border on your image that has boxes on it. Click and drag these boxes to define the size of your image. The boxes on either side of the border allow you to control the width of your image. The boxes on the top and bottom of the white border allow you to control the height of your image. The boxes on the corners of the white border allow you to crop your image proportionately, so that you trim the same amount from each side of your image. When you are done clicking and dragging, what you see on the inside of the white border is the part of your image that will be saved. Double-click on the inside of the image to execute the crop. Dreamweaver crops the image, and the Properties Inspector reflects the new width and height of your image. To undo this action, choose “Undo Crop” from the “Edit” drop-down menu in the Menu Bar. If you are happy with the crop and want your image to be permanently changed, you should now save your page.

Cropping images is another task that is best left to outside imaging software such as Photoshop. Although cropping in Dreamweaver is quick and easy, it is always a good idea to save your cropped image as a new, smaller image, and keep your original image as well. Dreamweaver will not let you do this, and so you are better off cropping your photos and saving them using another program before starting to build your site with Dreamweaver.
4.10 – USING IMAGES AND TEXT TOGETHER:

As you have learned in previous lessons, there is no way to make sure that your web pages look exactly the same to every viewer. In this lesson, you will learn how to use text and images together on a web page. First, start with a new, blank page, and insert an image into the document window. Then click just to the right of your image. This will place a blinking cursor, the same height as your image, immediately to the right of your image on the page.

Next, either type or copy/paste some text into the document window. I’m going to paste some random text. You will see text appears underneath the image. Next, click on the image to select it, and click the downward-pointing arrow found at the right of the “Align” text field. This will open up a menu that lets you designate where on the page your photo will load. Choose “Left.” You’ll see that the menu closes, and the text now moves to the right of the image. Now click on the downward-facing arrow next to the “Align” text field again, and align the image at the right of the page. Note how the text reverts to the left of the page.

If your text is too big to fit next to your image, it will continue at the bottom of the page. Watch what happens when I format the text to be a bigger size—the text fills up the area to the left of the image and continues on below the image. This is known as “wrapping text around an image.” You can experiment by aligning your images in different ways to get your page to look the way you like—but remember, device and browser settings will also influence the way your page looks when viewed by others.
4.11 – WHEN TO USE OUTSIDE IMAGING PROGRAMS:

Because it lets you design pages visually, it's tempting to treat Dreamweaver like an imaging program. However, Dreamweaver's main function is to convert your visually-designed pages into HTML code. Therefore, using Dreamweaver to modify images isn't always the best idea.

As you've heard in previous lessons, it's always a good idea to open an outside image editing program if you're resizing or cropping an image. Imaging programs like Adobe Photoshop are also very helpful if you want to display a rare typeface on your site—you can convert text to an image using these types of programs.

Image editing programs, like Photoshop, will also offer you better “save” options for your images. Saving within Photoshop gives you control of your file sizes in a way that Dreamweaver does not.

Preparing your images ahead of time using another program will also help you to organize your site before you even start building it. This will undoubtedly spare you some headaches in the long run. Additionally, you may know more about your image-editing software than you currently know about Dreamweaver. It may be easier to prepare images using a program that you're more familiar with, and then use Dreamweaver to build your site. Most professional web designers prepare both the text and the images for a website before they ever open Dreamweaver.

Because it is so beneficial to prepare your images in an outside imaging program, TeachUcomp, Inc. has included several bonus Photoshop lessons with this title. They will teach you how to crop, resize, and save files using Photoshop. To learn more about Adobe Photoshop, please use TeachUcomp, Inc's “Mastering Photoshop Made Easy” title.
4.12 – OPENING AN IMAGE IN ADOBE PHOTOSHOP:

In the next several lessons, you will learn how to prepare and edit images using Adobe Photoshop. This lesson will teach you how to launch Photoshop using Dreamweaver, and we will take a quick look at the Photoshop interface and workspace. Make sure you start with an open document that contains at least one image.

To launch Photoshop using Dreamweaver, first click on an image to select it. Check the image thumbnail in the Properties Inspector to ensure that you have selected the image you want to edit using Photoshop, and then click the blue “Edit” icon with the “PS” on it, located in the Properties Inspector. This will launch Adobe Photoshop, provided that you have Photoshop installed on your computer.

If you are launching Photoshop for the first time, it may take several minutes for the program to open. If you’ve used the program before, it should only take a few seconds. Once Photoshop opens, you will see your image from Dreamweaver has been opened as well, and is ready to be edited.

Let’s take a brief look at the Photoshop workspace. You will probably notice that it looks somewhat similar to Dreamweaver. This is because Adobe is the creator of both programs, and so Dreamweaver and Photoshop share many features. First, I’m going to click-and-drag over the name of my open document, so that I can detach it from the main document window. This allows me to move this image around in the Photoshop workspace, which can be very helpful when working with more than one image at the same time. I can also click-and-drag panels just like I can with Dreamweaver.

Like Dreamweaver, Adobe Photoshop is a powerful, complex program. There are many different panels on the right of the workspace that allow you to view and edit many features of an image, and new users of Photoshop can be a bit overwhelmed by these. Luckily, you do not have to learn the entire Photoshop program in order to learn simple operations like cropping, copying, and saving images—which is what we will be focusing on for the next few lessons.

If you would like to learn more about Photoshop, please see TeachUcomp, Inc.’s title, “Mastering Photoshop Made Easy.”
In this lesson, you will learn how to crop an image using Adobe Photoshop. As you learned in a previous lesson, cropping an image using Dreamweaver will permanently alter the image. Many times, however, you will want to save your original, larger image as well as the cropped version. Since Dreamweaver won’t let you do this, you have to use an image-editing program like Adobe Photoshop.

Let’s crop an image with Photoshop. Using the techniques from the previous lesson, launch Photoshop and then click-and-drag to display your open image in its own floating document window. Next, we’re going to click on the Rectangular Marquee Tool found in Photoshop’s main Tool Panel. Now, click and drag within your image to select the area you want to keep as your new image. When you’re done clicking and dragging, you’ll see that Photoshop puts a blinking border around your selection. This blinking border is sometimes known as “marching ants.” Anything inside the borders of the marching ants will be your selection. You can click and drag to move the selection area around, too. When you have the parameters of your new image selected, choose “Copy” from the “Edit” drop-down menu found in the Menu Bar.

Next, click “New” from the “File” drop-down menu. This will open the “New file” dialog box. You can see that Photoshop has already filled in the pixel dimensions of the new image. Anytime you copy something in Photoshop and then immediately open a new document, Photoshop will do this for you. Click “OK.” A new, blank document will open. I’m going to click-and-drag to detach it from the other document, so that I can see both of them in the workspace. Now, choose “Paste” from the “Edit” drop-down menu found in the Menu Bar.

You will see that Photoshop pastes in your selection from the previous image. Choose “Flatten Image” from the “Layer” drop-down menu found in the Menu Bar. Your new image is now ready to be saved.
In this lesson, you will learn how to save an image using Adobe Photoshop. Using techniques from the previous lessons, launch Photoshop, and copy a selection from an existing image into a new document. Remember to choose “ Flatten Image” from the “Layer” drop-down menu before attempting to save the new image.

To save your new image, choose “Save As” from the “File” drop-down menu found in the Menu Bar. This will open the “Save As” dialog box. You will see that your file is currently named “Untitled.” Type a new name for your file. I’m going to call this one “Turtle Cropped.” Next, click to open the “Format” drop-down menu. If you’re not sure what image file type to choose, jpeg is probably your best bet. It is the most common image type found on the Internet, and you can control your file size when you save as a jpeg. Finally, using the “Save In” field, navigate to find the most appropriate folder for this image. Now click “Save.” This will open the “Jpeg options” dialog box. You can accept the default quality and file size, or you can move the slider to create the size and quality of file that you need. As the quality goes down, the file size also decreases, and vice-versa. When you have your file the way you want it, click “OK.” Photoshop will save your new image, and you can now insert the new, cropped version into a Dreamweaver page without having to sacrifice the original file.

Please note that if you choose to save your file as a GIF image, Photoshop will open several dialog boxes as part of the saving process. Choosing “OK” or accepting the default settings of these dialog boxes is your best bet when saving GIF files.
4.15 – RESIZING AN IMAGE USING PHOTOSHOP:

In this lesson, you will learn to resize an image using Adobe Photoshop. Start by launching Photoshop and opening an image to resize. I’m going to use this image of three turtles. You may have noticed that Photoshop doesn’t really have the equivalent of a “Properties Inspector” panel. So, in order to get information about the size of this file, I’m going to choose “Image Size” from the “Image” drop-down menu. This will open the “Image Size” dialog box, and I can use this dialog box just like the Properties Inspector—not only can I get information about the image from this box, I can also click within the various text fields to edit my image. For now, I’m going to take note that this image is 600 pixels wide by 400 pixels tall, and then close the dialog box.

Let’s resize this image using Photoshop. First, we’re going to make a copy of this entire image, and then resize the copy. It’s not technically necessary to do this, since we could just use the “Save As” feature later to give the resized image a new name. But, if you want to make absolutely sure that you don’t somehow lose your original image, the best idea is to just copy the entire image, and then do whatever editing you like on the copy. This will prevent your original image from being resized. Choose “All” from the “Select” drop-down menu found in the Menu Bar. You will notice that Photoshop displays marching ants around the entire image. Now choose “Copy” from the “Edit” drop-down menu. Next, choose “New” from the “File” drop-down menu. This will open the “New file” dialog box. You’ll see that Photoshop has already filled in pixel dimensions for this image—these are the exact dimensions of the image we just copied. Click “OK.” Photoshop opens a new document. I’m going to click-and-drag to detach this new document from the one I just copied, so that I can see both images on my screen.

Next, choose “Paste” from the “Edit” drop-down menu. Photoshop pastes the copied image into the new document window. Choose “Flatten Image” from the “Layer” drop-down menu in the Menu Bar.

In order to tell which image is which, look at the titles of both images. Your new image will say “untitled” until you give it a name and save it. Let’s now resize this image. Open up the “Image Size” dialog box again, by choosing “Image Size” from the “Image” drop-down menu. This time, I’m going to click into the width text field and change the 600 to 500. Photoshop will resize the image proportionately; so you can see that the height automatically resizes to 333 in order to adjust to the new width. Click “OK.” You can see that the image changes size to reflect my choices. Now I can choose “Save As” from the “File” drop-down menu, and give this image a new name before saving it to my computer’s hard drive. When I go back to Dreamweaver, I will now have the option of inserting the smaller image into my web page, while the larger image will still be available at its original size.
4.16 – WORKING WITH CUSTOM FONTS IN PHOTOSHOP:

In this lesson, you will learn a little bit about working with custom fonts in Photoshop. Make sure you have launched Photoshop. Now, choose “New” from the “File” drop-down menu found in the Menu Bar. When the “New file” dialog box opens, type “600” into the “Width” text field, and “200” into the “Height” text field. Leave everything else at its default setting, and click “OK.” Photoshop will open a new, blank document that is 600 pixels wide by 200 pixels tall.

You’ve learned in previous lessons that Dreamweaver offers font choices in groups of three, so that you can make educated guesses about how your web pages will look when displayed on a variety of different devices. The fonts that Dreamweaver offers are the very common typefaces that almost every device can display. Sometimes, however, you may want to use a specific font on your web page that Dreamweaver doesn’t offer in a font grouping. Here is a handy way to use Photoshop to get around this problem.

First, choose the “Horizontal Type Tool” icon found in Photoshop’s main Tool panel. Then, click into blank document. A blinking cursor will appear. Type some text. I’m going to type, “carvedturtles.com.” Now, click-and-drag to highlight your text, and then use the taskbar below the main Menu Bar to adjust your text. I’m going to change the font size to 60, and then I’m going to click the downward-pointing triangle to the right of the “Font type” text field. This will open a drop-down menu which contains all of the fonts installed on my hard drive. I’m going to choose “AJ1.” You’ll notice that, when I move my cursor around my text, it turns into a sort of cross icon. This means that I can click-and-drag to move the text around within the document, and then I just un-click when I have it positioned exactly the way I want. When you’re happy with the size, font choice, and positioning of your text, click the “Checkmark” icon on the far right of the taskbar. This will apply your settings, and Photoshop removes the highlight from your text.

By clicking into the “Styles” panel, you can experiment with different effects for your type. To remove all effects, click the white icon with the red diagonal stripe at the top left of the “Styles” panel. You can also experiment with changing the color of your font, or even try the “Text Warp” features…you will be truly amazed at what Photoshop can do. When you’re happy with the way your text looks, choose “Flatten Image” from the “Layer” drop-down menu. You are now ready to save your image. Later, when you return to Dreamweaver, you can insert this image into a web page, and your custom font can be displayed, regardless of which device the page is viewed on.
INSERTING AN IMAGE INTO A WEB PAGE:
1. Click within the web page at the spot where you want to insert an image.
2. Click the “Image” icon within the “Insert” panel.
3. Navigate within the “Look In” text field within the “Select Image Source” dialog box to find the image you want.
4. Click to highlight the image.
5. Click “OK.”
6. Type a brief description into the “Alternate text” field of the “Image Tag Accessibility Attributes” dialog box.
7. Click “OK.”

ADD A BORDER TO AN IMAGE:
1. Click to select the image to which you want to add a border.
2. Click within the “Border” text field in the Properties Inspector.
3. Type in a border width in pixels, and hit the “Enter” key on your keyboard.

INSERTING A BACKGROUND IMAGE INTO A WEB PAGE:
1. Click the “Page Properties” button in the Properties Inspector.
2. Click the “Browse” button to the right of the “Background Image” text field in the “Page Properties” dialog box.
3. Navigate using the “Look In” text field within the “Select Image Source” dialog box to locate the image you want, and click to highlight it.
4. Click “OK.”
ACTIONS - ALL ABOUT IMAGES

RESIZING AN IMAGE:
1. Click to select the image that you want to resize.
2. Using the border which appears around the image, click-and-drag to resize the image.
   OR
2. Click within the “Width” and “Height” text fields within the Properties Inspector, and manually type in exact dimensions for your image.

CROPPING AN IMAGE:
1. NOTE: Cropping an image using Dreamweaver will permanently alter the image.
2. Click to select the image that you want to crop.
3. Click the “Crop Tool” icon in the Properties Inspector.
4. Click “OK” to close the warning box.
5. Click-and-drag the boxes on the white image border to select your image outline.
6. Double-click within the image border to execute the crop.

FORMATTING TEXT NEXT TO AN IMAGE:
1. Click to select the element that you want to format (text or image).
2. Choose “Align” from the “Format” drop-down menu in the Menu Bar.
3. Choose your justification (left, right, center, justify).

OPENING AN IMAGE IN ADOBE PHOTOSHOP:
1. Click to select the image that you want to open in Photoshop.
2. Click the “PS” icon in the Properties Inspector.
ACTIONS-
All About Images

CROPPING AN IMAGE USING ADOBE PHOTOSHOP:
1. Launch Photoshop and open an image to crop.
2. Click on the Rectangular Marquee Tool found in Photoshop’s main Tool Panel.
3. Click-and-drag within the image to select the borders of your new image—make sure you see the “marching ants” blinking selection border.
4. Choose “Copy” from the “Edit” drop-down menu in the Menu Bar.
5. Choose “New” from the “File” drop-down menu in the Menu Bar.
6. Click “OK” in the “New file” dialog box.
7. Choose “Paste” from the “Edit” drop-down menu in the Menu Bar.
8. Choose “Flatten Image” from the “Layer” drop-down menu in the Menu Bar.
9. Choose “Save” from the “File” drop-down menu, and save your new image.

SAVING AN IMAGE USING ADOBE PHOTOSHOP:
1. Choose “Save As” from the “File” drop-down menu in the Menu Bar.
2. Type a name for your file.
3. Choose a format for your file using the “Format” drop-down menu.
4. Choose a location for your saved file using the “Save In” field.
5. Click “OK.”
6. If you choose to save as a jpeg, use the “Jpeg options” dialog box to create the size and quality you need.
RESIZING AN IMAGE USING ADOBE PHOTOSHOP:
1. Open the image in Photoshop.
2. Choose “All” from the “Select” drop-down menu in the Menu Bar.
3. Choose “Copy” from the “Edit” drop-down menu in the Menu Bar.
5. Click “OK” in the “New File” dialog box.
6. When the new document opens, choose “Paste” from the “Edit” drop-down menu in the Menu Bar.
7. Choose “Flatten Image” from the “Layer” drop-down menu in the Menu Bar.
9. Click into the “Width” or “Height” text field and type in the new size in pixels.
10. Choose “Save As” from the “File” drop-down menu in the Menu Bar.
11. Save your newly resized image using a different name than the original image.

WORKING WITH CUSTOM FONTS IN PHOTOSHOP:
1. Choose “New” from the “File” drop-down menu in the Menu Bar.
2. Choose dimensions for your new image in the “New file” dialog box, and click “OK.”
3. Choose the “Horizontal Type Tool” icon in the main Tool panel.
4. Click into the blank document, and type your text.
5. Click-and-drag to highlight the text.
6. Choose your specialty font from the “Font type” text field in the task bar.
7. Format your highlighted text using the task bar.
8. Click the “Checkmark” icon on the right side of the task bar.
10. Save your image.
EXERCISES-
All About Images

Purpose:
1. To be able to insert and modify graphics in web pages.

Exercises:
1. Open your Dreamweaver application.
2. Ensure that you have the “Dreamweaver Test Site” open.
4. Select “Blank page” from the “Category:” list at the left side of this dialog box.
5. Select “HTML” in the “Page Type:” list in the middle of the dialog box.
6. Click the “Create” button in the lower right corner of the “New Document” dialog box.
7. Select “File| Save As...” from the Menu Bar.
8. Ensure that you have the “root” folder selected in the “Save in:” drop-down.
9. Type “graphics” into the “File name:” text box.
10. Click the “Save” button in the lower right corner of the “Save As” dialog box.
11. Click into the “graphics.htm” document.
12. Select “Insert| Image” from the Menu Bar.
13. Use the “Look in:” drop-down to navigate to the folder which contains the image which you want to insert into the web page. Ideally, the image you insert should already be placed into the “root” folder or one of its subfolders. If not, Dreamweaver will offer to copy the image into the root folder the next time you save the web page.
14. Select the desired image to use from the “Select Image Source” dialog box.
15. Click the “OK” button.
16. Click the “Cancel” button in the “Image Tag Accessibility Attributes” dialog box, as we will enter that information using the Properties panel momentarily.
17. Ensure that you have the image in the web page selected.
18. Type “3” into the “Border” text box in the “Properties” panel.
19. Click into the web page next to the image and type “This is a sample image.”
20. Click on the graphic again to select it.
21. Use the “Align” drop-down in the “Properties” panel to select “Top.”
22. Click into the “Alt” text box in the “Properties” panel and type a description of your graphic.
23. Click the small folder button at the right of the “Link” text box in the “Properties” panel to launch the “Select File” dialog box.
24. Choose the “index.htm” file and then click “OK” in the “Select File” dialog box.
25. Select “File| Save” from the Menu Bar to save your changes. If you selected an image that was outside of the “root” folder, then choose to save a copy of the image into your “root” folder.
26. Press the “F12” key on your keyboard to preview the web page in your default web browser.
27. Click on the image displayed in the web browser to display the “index” page in the web browser.
28. Close the web browser when you are finished.
29. Select “File| Close” from the Menu Bar in Dreamweaver to close the web page.
30. Select “File| Exit” from the Menu Bar in Dreamweaver to close the entire application.
CHAPTER 5-
ALL ABOUT HYPERLINKS

5.1 - INSERTING AN IMAGE INTO A WEB PAGE

5.2 - TURNING IMAGES INTO HYPERLINKS

5.3 - CREATING IMAGE MAPS

5.4 - NAMED ANCHOR LINKS

5.5 - ADDING AN EMAIL LINK TO A WEB PAGE

5.6 - CHANGING THE APPEARANCE OF HYPERLINKS
5.1 – INSERTING A HYPERLINK INTO A WEB PAGE:

In this lesson you will learn how to insert hyperlinks—sometimes just called “links”—into your web pages. Hyperlinks serve as a shortcut between different pages—either within the same website, or from one website to another site elsewhere on the Internet. By clicking a link—which can be text, an image, or even part of an image—you can navigate to different pages. Let’s turn some text into a hyperlink. Start with an open web page that contains some text.

To convert text to a hyperlink, first click and drag to select the text that you want to turn into a link. Click “hyperlink” in the Insert panel. This will open the “Hyperlink” dialog box. You will see that Dreamweaver has already filled in “Text” field with your highlighted text. Next, click the small folder icon to the right of the “Link” text field to choose the HTML file which you want to associate with that link. Click “OK”. You will notice the link you have created now appears underlined and in color. Note also that the Properties Inspector panel reflects the filename and path of the hyperlink when it is chosen.

If you want your text to link to somebody else’s website, just click-and-drag to select text as you did before; but when the “Hyperlink” dialog box opens, insert the URL address of the page (including the http:// part at the start) of the outside website. Click the small drop down triangle to the right of the “Target” text field and select “_blank”—this will display the linked page in its own new browser window or tab when clicked. Click “OK” to confirm your selection. Again, the link now appears underlined and in color.
5.2 – TURNING IMAGES INTO HYPERLINKS:

In this lesson, you will learn how to turn an image into a hyperlink. This is a great way to turn the banner at the top of your page into a “Home” button that users can click on to return to the main page of your website. First, start with a page containing an image that you want to turn into a link. Click on the image to select it, and then click on the small folder icon to the right of the “Link” field in the Properties Inspector panel. This will open the “Select File” dialog box. Select the HTML file to which you want your image to link. Click “OK.” The image will now function as a link and Dreamweaver automatically inserts the path and filename to the linked page in the “Link” text field of the Properties Inspector panel. Visitors will know that the image functions as a link when their mouse cursors change from an arrow to a hand when they move their mouse over the image.

5.3 – CREATING IMAGE MAPS:

In this lesson, you will learn how to create image maps using Dreamweaver. Image maps are simply images that include one or more “hot spots.” Hot spots are areas of the image that function as hyperlinks. When a viewer moves the mouse over a hot spot in an image, the mouse arrow will change into a pointing hand, and the viewer can click on that part of the image to follow a link.

Let’s create three hotspots on an image. Start with a blank document, and insert a photo that is big enough to create three separate button-sized areas. I’m going to use this photo of three turtles. Watch as I demonstrate three different methods of creating hotspots on this image.

First, I’m going to check the thumbnail image in the Properties Inspector to make sure I’m editing the correct element of my page. Next, I’m going to type a name for my image map in the “Map” text field found in the Properties Inspector panel. I’m going to use “three turtles” as my Map name, but I have to type it in without any spaces, because you can’t use numbers, special characters, or spaces when you name your map. Then I’m going to click on one of the three drawing tools just below my Map name.
5.3 – CREATING IMAGE MAPS (cont.):

Let’s start with the square drawing icon on the left. I’m going to click it, then click and drag to highlight a rectangular area around the first turtle. This is going to be my first hotspot. When I’m done clicking and dragging, two things happen: The area I’ve chosen is covered with a blue highlight—this shows me where my hotspot will be. A dialog box also appears, asking me to describe the image map for visually impaired people. I’m going to click “OK,” and then I’m going to type “turtle hotspot” into the “Alt” text field. Now I’m going to click on the folder icon found to the right of the “Link” text field, and I’m going to find the page that I want to link this hotspot to. I’m going to attach it to the amber turtle. Keep in mind that the highlight you see on the page when you’re working won’t be there once your site is on the Internet. That highlight is just a tool to help you design your page.

Now I’m going to repeat the process using the middle, circular drawing tool. First I click on it, then click and drag on my image to define my second hotspot. Let’s put the hotspot right on the middle turtle. Click “OK” to get rid of the dialog box, then type “turtle hotspot” into the “Alt” text field. I’m going to have this hotspot link to the bertrandite turtle.

For my third hotspot, I’m going to use the “Polygon Hotspot Tool” icon found just to the right of the “Circle Hotspot Tool” icon in the Properties Inspector. This is a neat little tool that allows me to click repeatedly along the outside of my image to make really specific hotspots. I’m going to connect this one to the coral turtle.

Let’s preview this file in a browser to see how the hotspots work. When I use the “Preview in Browser” icon and choose Internet Explorer, I am prompted to save my page first. You can’t preview in a browser until you save your file. I’m going to call this file “Hotspots page” and then preview it using Internet Explorer.

Once the Explorer window opens, you can see that the hotspots are working perfectly. When I move my mouse over the turtles, the arrow turns into a pointing hand. And when I click on the hotspots, they act as links to the pages I assigned.
5.4 – NAMED ANCHOR LINKS:

In this lesson, you will learn how to insert “Named Anchor” links into web pages. Using Named Anchor hyperlinks at the top of a long web page is a useful feature. It allows visitors to quickly and easily navigate their way up and down your page without having to use the scroll bar. Named Anchor links are usually found in a Frequently Asked Questions (“FAQ”) web page, where visitors may wish to jump from the index at the top of the page to a particular area of text and then easily return back up to the index. Let’s create a named anchor link.

Start with a blank web page, and paste a lot of text into it. Now, click the spot in the text further down in your page where you want the visitor to be able to jump. This spot is called the Named Anchor point. Then click the small anchor-shaped “Named Anchor” icon in the “Insert” panel. This will open the “Named Anchor” Dialog box. Create a name for the anchor point. Click “OK.” You will see a small anchor icon in the Document window on the part of the screen to which you have told the link to jump.

Go up to the top of your page. Now, click and drag to select the text you want visitors to click in order to easily jump further down the page. Click the “Hyperlink” icon in the “Insert” panel. The “Hyperlink Dialog” box will open. Select the appropriate corresponding link name from the Link field’s drop down menu. Once you have selected the link click “OK.” You will see that the text is colored and underlined like other links, and the anchor name appears in the Link field in the Properties Inspector panel, preceded by a pound (“#”) sign.

5.5 – ADDING AN EMAIL LINK TO A WEB PAGE:

In this quick lesson, you will learn how to insert email Links into your web pages. Having an email link on your web page will let visitors to your site conveniently contact you by email after clicking this link.

Let’s add an email link to a web page. Start with a blank page and then click or paste in some text. I’m going to type, “Click here to contact me by email.” Now, click and drag the text which will launch the email link—I’m going to click and drag to highlight the word “here.” Next, click the envelope “Email Link” icon found in the “Insert” panel. This will open the “Email link” dialog box. You can see that the text I highlighted earlier is already filled in for me, and so all I have to do is fill in my email address and click “OK”. The text I selected now looks like a link. When a visitor to the site clicks on this link, their default email program will open in another window, with the email address from the link already filled in.
5.6 – CHANGING THE APPEARANCE OF HYPERLINKS:

In this lesson you will learn how to change the appearance of links on your web page. It is not necessary to customize the look of your hyperlinks, but if you want to remove the underline or change the color of the link to compliment the other colors on your web page, you can. Make sure you have a page open that includes a text hyperlink.

First, click “Page Properties” in the Properties Inspector panel. Next, click “Links” from the “Category” menu on the left. Then click the “Link Color” icon and you will notice that the arrow changes to a dropper. Choose your preferred color from the grid.

You can repeat the last two steps to specify new colors for links, visited links and rollover links. If you do not modify the appearance of your links, the default settings are as follows: links appear blue, visited links appear purple and rollover links are red. To remove underlining from your links, click the “Underline Style” drop down menu and select “Never Underline” and confirm by clicking “OK.” Your links will now appear according to your selection choices.
CHANGING TEXT TO A HYPERLINK:
1. Click-and-drag to highlight the text.
2. Click the “Hyperlink” icon found in the Insert panel.
3. When the “Hyperlink” dialog box opens, click the folder icon to the right of the “Link” text field to locate the HTML file that you want to associate with the highlighted text.
4. Click “OK.”

OR
3. When the “Hyperlink” dialog box opens, type in the URL address of the outside web page into the “Link” text field.
4. Click “OK.”

TURNING AN IMAGE INTO A HYPERLINK:
1. Click to select the image.
2. Click the small folder icon to the right of the “Link” text field in the Properties Inspector.
3. Navigate using the “Select file” dialog box to locate the HTML file that you want to link to this image.
4. Click “OK.”

CREATING AN IMAGE MAP:
1. Click to select the image which will become an image map.
2. Type a one-word name for the map in the “Map” text field in the Properties Inspector.
3. Click on one of the three drawing tools (rectangular, circular, or polygon) below the map name.
4. Click-and-drag (rectangular hotspot or circular hotspot) or click repeatedly (polygon hotspot) on the image to define the hotspot area.
5. Describe the image map for visually impaired people by typing into the “Alt” text field of the dialog box which appears.
6. Click the folder icon to the right of the “Link” text field, and navigate to find the page that will attach to the hotspot.
INTERNET DREAMWEAVER ©TeachUcomp, Inc.

ACTIONS-
ALL ABOUT HYPERLINKS

INSERTING A “NAMED ANCHOR” LINK INTO A WEB PAGE:
1. Open a page that contains a lot of text.
2. Click the spot in your text that will become the Named Anchor point.
3. Click the “Named Anchor” icon in the “Insert” panel.
4. Create a name for the named anchor point in the “Named Anchor” dialog box, and click “OK.”
5. Click-and-drag to highlight the text at the top of your page which will serve as a link to the named anchor point.
6. Click the “Hyperlink” icon in the “Insert” panel.
7. Select the appropriate corresponding link from the “Link” field’s drop-down menu in the “Hyperlink” dialog box.
8. Click “OK.”

ADDING AN EMAIL LINK TO A WEB PAGE:
1. Click-and-drag to select text on a page that will become an email link.
2. Click the “Email link” icon in the “Insert” panel.
3. Fill in your email address in the “Email link” dialog box.
4. Click “OK.”

CHANGING THE APPEARANCE OF A HYPERLINK:
1. Click the “Page Properties” button in the Properties Inspector.
2. Click “Links” from the left Category menu.
3. Edit the appearance of links using the “Page Properties” dialog box.
4. Click “OK.”
EXERCISES-
ALL ABOUT HYPERLINKS

Purpose:

1. To be able to create basic hyperlinks in our web pages.

Exercises:

1. Open your Dreamweaver application.
2. Ensure that you have the “Dreamweaver Test Site” open.
4. Select “Blank page” from the “Category:” list at the left side of this dialog box.
5. Select “HTML” in the “Page Type:” list in the middle of the dialog box.
6. Click the “Create” button in the lower right corner of the “New Document” dialog box.
7. Select “File| Save As…” from the Menu Bar.
8. Ensure that you have the “root” folder selected in the “Save in:” drop-down.
9. Type “links” into the “File name:” text box.
10. Click the “Save” button in the lower right corner of the “Save As” dialog box.
11. Click into the “links.htm” document.
12. Type “Click here to return to the main page of our web site.”
13. Select the text which you just typed.
14. Select the small folder button at the right end of the “Links” text box in the “Properties” panel.
15. In the “Select File” dialog box, select the “index.htm” file as the file to which you would like to create a hyperlink.
16. Click “OK” to set the hyperlink.
17. Select “File| Save” from the Menu Bar.
18. Select “File| Close” from the Menu Bar to close the “links.htm” page.
20. Select the “index.htm” file and click the “Open” button within the “Open” dialog box.
21. Click into the page after the “And make bulleted lists” line.
22. Press “Enter” on your keyboard.
23. Press “Enter” on your keyboard again.
24. Type “Click here to see our page of links.”
25. Select just the word “here” in the sentence which you just typed.
26. Select “Insert| Hyperlink” from the Menu Bar.
27. Click the small folder button at the right end of the “Link:” text box.
28. Select the “links.htm” file as the web page to which you would like to create a hyperlink.
29. Click “OK” to set the hyperlink.
30. Click “OK” in the “Hyperlink” dialog box.
31. Select “File| Save” from the Menu Bar to save your changes.
32. Select “File| Preview in Browser” from the Menu Bar and select your desired web browser with which to preview the web page.
33. Test the hyperlinks which you created to ensure that they function properly.
34. Close your web browser when you are finished.
35. Select “File| Close” to close the web page in Dreamweaver.
36. Select “File| Exit” to close Dreamweaver.
CHAPTER 6-
Using Frames

6.1 - Using Frames

6.2 - Adding Content to Frames

6.3 - Naming Frames

6.4 - Deleting Frames

6.5 - Linking to a Frame
6.1 USING FRAMES:

In this lesson you will learn the purpose of frames and how to use them within Dreamweaver. Using frames in your website allows you to divide up a web page and place different content in different areas of it. The frames function independently of one another—this allows visitors to click on an image or link in one part of the page and the linked content will appear inside a different frame on the same page.

When you work with frames it is vital to remember that each frame acts like its own web page. Therefore, you must save each frame’s content as a separate file. However, all the frames on the page go together as one “frameset” which itself must be saved as a separate HTML web page.

Dreamweaver provides several predefined framesets from which you can choose as a starting option. To access them first choose “New” from the “File” drop-down menu. You will see that the “New Document” dialog box opens. Click on “Page from Sample” and then click on “Frameset.” Next, select a frameset configuration. A preview appears to the right of the dialog box for each choice. Once you have found the appropriate frameset for your site, click “Create”. The “Frame Tag Accessibility Attributes” dialog box will open, and you can name the individual frames accordingly—either type the title you want or accept the frame title which Dreamweaver has assigned. Click “OK.” Repeat this process for the other frames on your page. Note that your frameset’s properties are now displayed in the Properties Inspector panel.

Remember that you must save each frame as its own web page by clicking inside of each individual frame, then clicking “File”, and finally clicking on “Save Frame As.” Once you have done this, you should then save the entire frameset as its own web page by choosing “Save All” from the “File” drop down menu located in the Menu bar.
6.2 – ADDING CONTENT TO FRAMES:

In this lesson, you will learn how to add content to the Frames on your web page. To open an existing file within an individual frame, choose “Open in Frame” from the “File” drop-down menu. This will open the “Select HTML File” dialog box. Using the drop down menu arrow, navigate to locate the HTML file that you wish to appear in the frame and then click “OK.”

The web page you selected now appears in the appropriate frame. If the content is too large to fit within the frame’s borders you will need to include a scroll bar. To do this, first click on the frame in the “Frames” panel. Then, using the Properties Inspector, set the “Scroll” drop down menu to “Auto.” After you do this scroll bars will automatically appear when you need them so that visitors can scroll around and see the entire frame’s content. To add text to a frame, click inside the frame where you want the text to appear, and then copy-paste or type your text as usual.

6.3 – NAMING FRAMES:

In this lesson you will learn how to name your frames. Begin by opening a page that includes frames. Before it is possible to link from one frame to another you must name each of your frames to identify them within Dreamweaver.

First, ensure that the “Frames” panel is visible on the right hand side of your workspace. If it is not, open it by choosing “Frames” from the “Window” drop-down menu located in the Menu Bar. Next, click on the frame you wish to name within the “Frames” panel and then type the name in the text field below “Frame Name” in the Properties Inspector panel. Note that you can rename a frame by deleting the name within the Properties Inspector and then typing a new name. Press “Enter” to save your choice.
6.4 – DELETING FRAMES:

In this lesson you will learn how to delete one or more frames from your web page. Make sure you open a page that contains frames. Click on the frame that you want to delete within the “Frames” panel. Then position your cursor in the document window right at the dotted border of the frame until the cursor arrow turns into a double-pointed arrow. Next, click and drag the border of the frame until you have reduced it to nothing. A dialog box will open asking if you want to save changes. Let’s click “No” for now to make sure we like the changes. If we like them we can always save later. You will see that Dreamweaver removes the frame. If you don’t like the way the page looks with the frame removed simply choose “Undo” from the “Edit” drop down menu.

Keep in mind that if you have saved a frame, manually deleting it will not delete the corresponding HTML file from your hard drive. Even though the deleted frame will not appear on the current web page the data remains on your computer as a saved file.
6.5 – LINKING TO FRAMES:

In this lesson you will learn how to link to a frame within your web page. Linking from either text or an image allows you to open content in a separate, self-contained frame on your page. This will allow you to display lots of different types of content within the same web page.

First, click on the text or image which will serve as the link. I'm going to use this thumbnail image. Once you have done this click in the Properties Inspector panel on the small folder icon to the right of the “Link” text field. This will open the “Select File” dialog box. Click on the drop down menu triangle to access the folder and file within that folder to which you wish to link. Next, select the appropriate file and then confirm your choice by clicking “OK.”

Next, click the drop down triangle to the right of the “Target” text field in the Properties Inspector. You will now select the frame in which you want the linked content to appear. Remember, each frame has its own individual name, so you must carefully choose the correct frame where you want the linked content to appear. The names of frames are displayed in the “Frames” panel.

If you would like the linked content to appear within a new browser window (rather than within a predefined frame on the same page) choose “_blank” from the drop down menu to the right of the “Target” text field. This is a good idea if the link you create is to someone else’s website—opening sites that don’t belong to you in a new window will avoid confusing visitors about which content is yours and which is not.
OPENING A NEW FRAMESET:
1. Choose “New” from the “File” drop-down menu in the Menu Bar.
2. Choose “Page from Sample” and then “Frameset” from the “New Document” dialog box.
3. Select a frameset configuration.
4. Click “Create.”
5. Name the frames, or accept Dreamweaver’s default names.
6. Remember to save each frame individually, as well as saving the entire frameset.

OPENING A WEB PAGE IN A FRAME:
1. Choose “Open in Frame” from the “File” drop-down menu in the Menu Bar.
2. Find the file you want to open using the “Select HTML File” dialog box.
3. Click “OK.”

NAMING A FRAME:
1. Open the “Frames” panel by checking “Frames” in the “Window” drop-down menu in the Menu Bar.
2. Click on the frame you wish to name within the “Frames” panel.
3. Type the name in the text field below “Frame Name” in the Properties Inspector.
4. Press “Enter” on your keyboard to save your choice.
DELETING A FRAME:
1. Using the “Frames” panel, click on the frame you want to delete.
2. Click-and-drag the border of the frame until it is reduced to nothing.
3. Click “No” when asked if you want to save the changes, until you are sure that you like them.
4. If you are satisfied with the removed frame, save the frameset.

OR

4. To restore the frame, choose “Undo” from the “Edit” drop-down menu in the Menu Bar.

LINKING TO A FRAME:
1. Select the text or image that will serve as the link.
2. Click the folder icon to the right of the “Link” text field in the Properties Inspector.
3. Navigate using the “Select File” dialog box to find the file that you want to attach to the link.
4. Click “OK.”
5. Click the drop-down triangle to the right of the “Target” text field in the Properties Inspector.
6. Select the frame in which you want the linked content to appear.
Purpose:
1. To be able to create a basic framed site layout.

Exercises:
1. Open your Dreamweaver application.
2. Select “Site| New Site...” from the Menu Bar.
3. Click the “Local Info” category at the left side of the “Site Setup” dialog box.
4. Type “Advanced Test Site” into the “Site name:” text box.
5. Click the small folder button at the right end of the “Local root folder:” text box to launch the “Choose local root folder” dialog box.
6. Use the “Select:” drop-down to choose the “My Documents” folder.
7. Click the “Create New Folder” button to the right of the “Select:” drop-down and name your new folder “AdvancedRoot.”
8. Double-click the “AdvancedRoot” folder. It should now appear in the “Select:” box at the top of the dialog box.
9. Click the “Select” button in the lower right corner of this dialog box.
10. In the “Site Setup” dialog box, click on “Advanced Settings.”
11. Click the small folder button at the right end of the “Default images folder:” text box to launch the “Choose local images folder” dialog box.
12. Use the “Select:” drop-down at the top of this dialog box to select the “My Documents” folder.
13. Double-click the “AdvancedRoot” folder displayed in the list of files and folders to open that, as well.
14. Click the “Create New Folder” button to the right of the “Select:” drop-down and name the new folder “images.”
15. Double-click on the new “images” folder to open it. It should now display in the “Select:” drop-down at the top of the dialog box.
16. Click the “Select” button in the lower right corner of the dialog box.
17. Click “OK” in the “Site Definition” dialog box to create the basic web site.
19. Select “Page from Sample” from the “Category:” list at the left side of this dialog box.
20. Select “Frameset” in the “Sample Folder:” list in the middle of the dialog box.
21. Select “Fixed Left, Nested Top” from the “Sample Page” list.
22. Click the “Create” button in the lower right corner of the “New Document” dialog box.
23. Click the “Cancel” button in the “Frame Tag Accessibility Attributes” dialog box that appears.
24. Select “File| Save All” from the Menu Bar.
25. In the “Save As” dialog box which appears, type “index” into the “File name:” text box.
26. Make sure that the “AdvancedRoot” folder is selected in the “Save in:” box.

(cont.)
Exercises:

27. Click the “Save” button.
28. Click into the main frame and select “File|Save Frame As” from the Menu Bar.
29. In the “Save As” dialog box, type “main” into the “File name:” text box.
30. Click the “Save” button.
31. Click into the top frame and select “File|Save Frame As” from the Menu Bar.
32. In the “Save As” dialog box, type “top” into the “File name:” text box.
33. Click the “Save” button.
34. Click into the left frame and select “File|Save Frame As” from the Menu Bar.
35. In the “Save As” dialog box, type “left” into the “File name:” text box.
36. Click the “Save” button.
37. Type “Advanced Dreamweaver Test Site” into the page.
38. Select the text and choose “Heading 1” from the “Format” drop-down in the “Properties” panel.
39. Select “Window|Frames” from the Menu Bar to view the “Frames” panel.
40. Click the “top” in the “Frames” panel to select it.
41. Set the “Borders” drop-down to “No” in the “Properties” panel.
42. Click the “left” frame in the “Frames” panel to select it.
43. Set the “Borders” drop-down to “No” in the “Properties” panel.
44. Click the “main” frame in the “Frames” panel to select it.
45. Set the “ Borders” drop-down to “No” in the “Properties” panel.
46. Select “File|Save All” from the Menu Bar.
47. Select “File|Close All” from the Menu Bar.
49. Select “Blank Page” from the “Category” list at the left side of this dialog box.
50. Select HTML in the “Page Type:” list in the middle of the dialog box.
51. Click the “Create” button in the lower right corner of the “New Document” dialog box.
52. Click into the new web page and type “This is the linked content.”
53. Select “File|Save As…” from the Menu Bar.
54. Ensure that the “AdvancedRoot” folder is selected in the “Save in” drop-down of the “Save As” dialog box. Then type “linkedpage” into the “File name:” text box.
55. Click the “Save” button.
56. Select “File|Close” from the Menu Bar.
57. Double-click on the “index.htm” file in the “Files” panel to open the frameset for editing in Dreamweaver.
58. If needed, select “View|Visual Aids|Frame Borders” to enable the display of the frame borders in the design window.
59. Click into the left frame and type the word “Home.”
60. Select the word “Home,” and click the small folder button at the right end of the “Link” text box in the “Properties” panel to launch the “Select File” dialog box.
61. Select “main.htm” from the list of files available, and then click “OK.”
62. Use the “Target” drop-down in the “Properties” panel to select “main.”
63. Click after the word “Home” in the left frame and press “Enter” on your keyboard to create a new paragraph in the page.
64. Type “Test Link” into the second line and select the text.

(cont.)
Exercises:

63. Click the small folder button at the right end of the “Link” text box to launch the “Select File” dialog box.
64. Select the “linkedpage.htm” file and then click “OK.”
65. Use the “Target” drop-down in the “Properties” panel to select “main.”
66. Select “File| Save All” from the Menu Bar.
67. Press “F12” on your keyboard to preview the web page in your default browser.
68. In the browser, click the “Test Link” hyperlink to view the linked content in the frame to the right.
69. In the browser, click the “Home” hyperlink to return to the blank default page.
70. Close the browser window to return to Dreamweaver.
71. Select “Modify| Frameset| Edit NoFrames Content” from the Menu Bar.
72. In the “NoFrames Content” window, type “You must have a frames-capable browser in order to view this web site.”
73. Select “Modify| Frameset| Edit NoFrames Content” from the Menu Bar.
74. Select “File| Save All” from the Menu Bar.
75. Select “File| Close All” from the Menu Bar.
76. Select “File| Exit” from the Menu Bar to close the application.
### Dreamweaver Keyboard Shortcuts

#### “File” Shortcuts

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + N</td>
<td>New Document</td>
</tr>
<tr>
<td>Ctrl + O</td>
<td>Open…</td>
</tr>
<tr>
<td>Ctrl + Shift + O</td>
<td>Open in Frame…</td>
</tr>
<tr>
<td>Ctrl + W</td>
<td>Close</td>
</tr>
<tr>
<td>Ctrl + Shift + W</td>
<td>Close All</td>
</tr>
<tr>
<td>Ctrl + S</td>
<td>Save</td>
</tr>
<tr>
<td>Ctrl + Shift + S</td>
<td>Save All</td>
</tr>
<tr>
<td>Ctrl + P</td>
<td>Print Code</td>
</tr>
<tr>
<td>Shift + F8</td>
<td>Check Links</td>
</tr>
<tr>
<td>Shift + F6</td>
<td>Validate Markup</td>
</tr>
</tbody>
</table>

#### “Edit” Shortcuts

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + Z</td>
<td>Undo</td>
</tr>
<tr>
<td>Ctrl + Y</td>
<td>Redo</td>
</tr>
<tr>
<td>Ctrl + X</td>
<td>Cut</td>
</tr>
<tr>
<td>Ctrl + C</td>
<td>Copy</td>
</tr>
<tr>
<td>Ctrl + V</td>
<td>Paste</td>
</tr>
<tr>
<td>Ctrl + Shift + C</td>
<td>Copy HTML</td>
</tr>
<tr>
<td>Ctrl + Shift + V</td>
<td>Paste HTML</td>
</tr>
<tr>
<td>Ctrl + A</td>
<td>Select All</td>
</tr>
<tr>
<td>Ctrl + [</td>
<td>Select Parent Tag</td>
</tr>
<tr>
<td>Ctrl + ]</td>
<td>Select Child Tag</td>
</tr>
<tr>
<td>Shift + F3</td>
<td>Find and Replace…</td>
</tr>
<tr>
<td>F3</td>
<td>Find Selection</td>
</tr>
<tr>
<td>F3</td>
<td>Find Next</td>
</tr>
<tr>
<td>Ctrl + G</td>
<td>Go to Line</td>
</tr>
<tr>
<td>Ctrl + Spacebar</td>
<td>Show Code Hints</td>
</tr>
<tr>
<td>Ctrl + Shift + &gt;</td>
<td>Indent Code</td>
</tr>
<tr>
<td>Ctrl + Shift + &lt;</td>
<td>Outdent Code</td>
</tr>
<tr>
<td>Ctrl + ’</td>
<td>Balance Braces</td>
</tr>
<tr>
<td>Ctrl + U</td>
<td>Preferences</td>
</tr>
</tbody>
</table>

#### “View” Shortcuts

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + `</td>
<td>Switch Views</td>
</tr>
<tr>
<td>F5</td>
<td>Refresh Design View</td>
</tr>
<tr>
<td>Ctrl + Shift + G</td>
<td>Server Debug</td>
</tr>
<tr>
<td>Ctrl + Shift + H</td>
<td>Head Content</td>
</tr>
<tr>
<td>F6</td>
<td>Expanded Tables Mode (2004)</td>
</tr>
<tr>
<td>Ctrl + F6</td>
<td>Layout Mode</td>
</tr>
<tr>
<td>Ctrl + Shift + I</td>
<td>Hide All (Visual Aids)</td>
</tr>
<tr>
<td>Ctrl + Alt + R</td>
<td>Show Rulers</td>
</tr>
<tr>
<td>Ctrl + Alt + G</td>
<td>Show Grid</td>
</tr>
<tr>
<td>Ctrl + Alt + Shift + G</td>
<td>Snap to Grid</td>
</tr>
<tr>
<td>Ctrl + Alt + P</td>
<td>Play Plugin</td>
</tr>
<tr>
<td>Ctrl + Alt + X</td>
<td>Stop Playing Plugin</td>
</tr>
<tr>
<td>Ctrl + Alt + Shift + P</td>
<td>Play All</td>
</tr>
<tr>
<td>Ctrl + Alt + Shift + X</td>
<td>Stop All</td>
</tr>
<tr>
<td>F4</td>
<td>Show Panels</td>
</tr>
</tbody>
</table>

#### “Insert” Shortcuts

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + E</td>
<td>Insert Tag</td>
</tr>
<tr>
<td>Ctrl + Alt + I</td>
<td>Insert Image</td>
</tr>
<tr>
<td>Ctrl + Alt + F</td>
<td>Insert Flash</td>
</tr>
<tr>
<td>Ctrl + Alt + D</td>
<td>Insert Shockwave</td>
</tr>
<tr>
<td>Ctrl + Alt + T</td>
<td>Insert Table</td>
</tr>
<tr>
<td>Ctrl + Alt + A</td>
<td>Insert Named Anchor</td>
</tr>
<tr>
<td>Shift + Return</td>
<td>Insert Line Break</td>
</tr>
<tr>
<td>Ctrl + Shift + Space</td>
<td>Non-Breaking Space</td>
</tr>
<tr>
<td>Ctrl + Alt + V</td>
<td>Insert Editable Region</td>
</tr>
</tbody>
</table>

©TeachUcomp, Inc.
<table>
<thead>
<tr>
<th><strong>Modify</strong> Shortcuts</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Properties</td>
<td>Ctrl + J</td>
</tr>
<tr>
<td>Quick Tag Editor</td>
<td>Ctrl + T</td>
</tr>
<tr>
<td>Make Link…</td>
<td>Ctrl + L</td>
</tr>
<tr>
<td>Remove Link</td>
<td>Ctrl + Shift + L</td>
</tr>
<tr>
<td>Select Table</td>
<td>Ctrl + A</td>
</tr>
<tr>
<td>Merge Cells</td>
<td>Ctrl + Alt + M</td>
</tr>
<tr>
<td>Split Cell…</td>
<td>Ctrl + Alt + S</td>
</tr>
<tr>
<td>Insert Row</td>
<td>Ctrl + M</td>
</tr>
<tr>
<td>Insert Column</td>
<td>Ctrl + Shift + A</td>
</tr>
<tr>
<td>Delete Row</td>
<td>Ctrl + Shift + M</td>
</tr>
<tr>
<td>Delete Column</td>
<td>Ctrl + Shift + -</td>
</tr>
<tr>
<td>Increase Column Span</td>
<td>Ctrl + Shift + ]</td>
</tr>
<tr>
<td>Decrease Column Span</td>
<td>Ctrl + Shift + [</td>
</tr>
<tr>
<td>Left Align Cell</td>
<td>Ctrl + Shift + 1</td>
</tr>
<tr>
<td>Right Align Cell</td>
<td>Ctrl + Shift + 3</td>
</tr>
<tr>
<td>Top Align Cell</td>
<td>Ctrl + Shift + 4</td>
</tr>
<tr>
<td>Bottom Align Cell</td>
<td>Ctrl + Shift + 6</td>
</tr>
<tr>
<td>Make Columns Same Width</td>
<td>Ctrl + Shift + 7</td>
</tr>
<tr>
<td>Make Rows Same Height</td>
<td>Ctrl + Shift + 8</td>
</tr>
<tr>
<td>Add Object to Timeline</td>
<td>Ctrl + Alt + Shift + T</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Text</strong> Shortcuts</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Indent</td>
<td>Ctrl + Alt + ]</td>
</tr>
<tr>
<td>Outdent</td>
<td>Ctrl + Alt + [</td>
</tr>
<tr>
<td>No paragraph format</td>
<td>Ctrl + 0</td>
</tr>
<tr>
<td>Paragraph Format</td>
<td>Ctrl + Shift + P</td>
</tr>
<tr>
<td>Heading 1</td>
<td>Ctrl + 1</td>
</tr>
<tr>
<td>Heading 2</td>
<td>Ctrl + 2</td>
</tr>
<tr>
<td>Heading 3</td>
<td>Ctrl + 3</td>
</tr>
<tr>
<td>Heading 4</td>
<td>Ctrl + 4</td>
</tr>
<tr>
<td>Heading 5</td>
<td>Ctrl + 5</td>
</tr>
<tr>
<td>Heading 6</td>
<td>Ctrl + 6</td>
</tr>
<tr>
<td>Left Align Text</td>
<td>Ctrl + Alt + Shift + L</td>
</tr>
<tr>
<td>Center Align Text</td>
<td>Ctrl + Alt + Shift + C</td>
</tr>
<tr>
<td>Right Align Text</td>
<td>Ctrl + Alt + Shift + R</td>
</tr>
<tr>
<td>Justify Text</td>
<td>Ctrl + Alt + Shift + J</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Style</strong> Shortcuts</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bold</td>
<td>Ctrl + B</td>
</tr>
<tr>
<td>Italic</td>
<td>Ctrl + I</td>
</tr>
<tr>
<td>Check Spelling</td>
<td>Shift + F7</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Commands</strong> Shortcuts</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start Recording</td>
<td>Ctrl + Shift + X</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Site</strong> Shortcuts</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Get</td>
<td>Ctrl + Shift + D</td>
</tr>
<tr>
<td>Check Out</td>
<td>Ctrl + Alt + Shift + D</td>
</tr>
<tr>
<td>Put</td>
<td>Ctrl + Shift + U</td>
</tr>
<tr>
<td>Check In</td>
<td>Ctrl + Alt + Shift + U</td>
</tr>
<tr>
<td>Check Links Sitewide</td>
<td>Ctrl + F8</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Window</strong> Shortcuts</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert</td>
<td>Ctrl + F2</td>
</tr>
<tr>
<td>Properties</td>
<td>Ctrl + F3</td>
</tr>
<tr>
<td>CSS Styles</td>
<td>Shift + F11</td>
</tr>
<tr>
<td>Layers</td>
<td>F2</td>
</tr>
<tr>
<td>Behaviors</td>
<td>Shift + F4</td>
</tr>
<tr>
<td>Snippets</td>
<td>Shift + F9</td>
</tr>
<tr>
<td>Reference</td>
<td>Shift + F1</td>
</tr>
<tr>
<td>Databases</td>
<td>Ctrl + Shift + F10</td>
</tr>
<tr>
<td>Bindings</td>
<td>Ctrl + F10</td>
</tr>
<tr>
<td>Server Behaviors</td>
<td>Ctrl + F9</td>
</tr>
<tr>
<td>Components</td>
<td>Ctrl + F7</td>
</tr>
<tr>
<td>Files</td>
<td>F8</td>
</tr>
<tr>
<td>Assets</td>
<td>F11</td>
</tr>
<tr>
<td>Tag Inspector</td>
<td>F9</td>
</tr>
<tr>
<td>Results</td>
<td>F7</td>
</tr>
<tr>
<td>History</td>
<td>Shift + F10</td>
</tr>
<tr>
<td>Frames</td>
<td>Shift + F2</td>
</tr>
<tr>
<td>Code Inspector</td>
<td>F10</td>
</tr>
<tr>
<td>Timelines</td>
<td>Alt + F9</td>
</tr>
<tr>
<td>Show Panels</td>
<td>F4</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Help</strong> Shortcuts</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using Dreamweaver</td>
<td>F1</td>
</tr>
<tr>
<td>Using Cold Fusion</td>
<td>Ctrl + F1</td>
</tr>
<tr>
<td>Reference</td>
<td>Shift + F1</td>
</tr>
</tbody>
</table>
### “Site Panel” Shortcuts

<table>
<thead>
<tr>
<th>Action</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>New File</td>
<td>Ctrl + Shift + N</td>
</tr>
<tr>
<td>New Folder</td>
<td>Ctrl + Alt + Shift + N</td>
</tr>
<tr>
<td>Rename</td>
<td>F2</td>
</tr>
<tr>
<td>Delete</td>
<td>Del</td>
</tr>
<tr>
<td>Check Links</td>
<td>Shift + F8</td>
</tr>
<tr>
<td>Duplicate</td>
<td>Ctrl + D</td>
</tr>
<tr>
<td>Refresh View</td>
<td>F5</td>
</tr>
<tr>
<td>Show/Hide Link</td>
<td>Ctrl + Shift + Y</td>
</tr>
<tr>
<td>View as Root</td>
<td>Ctrl + Shift + R</td>
</tr>
<tr>
<td>Show Page Titles</td>
<td>Ctrl + Shift + T</td>
</tr>
<tr>
<td>Site Files</td>
<td>F8</td>
</tr>
<tr>
<td>Site Map</td>
<td>Alt + F8</td>
</tr>
<tr>
<td>Link to New File...</td>
<td>Ctrl + Shift + N</td>
</tr>
<tr>
<td>Link to Existing File...</td>
<td>Ctrl + Shift + K</td>
</tr>
<tr>
<td>Change Link...</td>
<td>Ctrl + L</td>
</tr>
<tr>
<td>Remove Link</td>
<td>Ctrl + Shift + L</td>
</tr>
<tr>
<td>Close Window</td>
<td>Ctrl + F4</td>
</tr>
<tr>
<td>Quit Application</td>
<td>Alt + F4</td>
</tr>
<tr>
<td>Open</td>
<td>Enter</td>
</tr>
<tr>
<td>Preview in Primary Browser</td>
<td>F12</td>
</tr>
<tr>
<td>Preview in Secondary Browser</td>
<td>Ctrl + F12</td>
</tr>
<tr>
<td>Cancel FTP</td>
<td>Esc</td>
</tr>
</tbody>
</table>

### “Code Editing” Shortcuts

<table>
<thead>
<tr>
<th>Operation</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select Parent Tag</td>
<td>Ctrl + [</td>
</tr>
<tr>
<td>Balance Braces</td>
<td>Ctrl + '</td>
</tr>
<tr>
<td>Delete word to left</td>
<td>Ctrl + BkSp</td>
</tr>
<tr>
<td>Delete word to right</td>
<td>Ctrl + Del</td>
</tr>
<tr>
<td>Select line up</td>
<td>Shift + Up Arrow</td>
</tr>
<tr>
<td>Select line down</td>
<td>Shift + Down Arrow</td>
</tr>
<tr>
<td>Character select to left</td>
<td>Shift + Left Arrow</td>
</tr>
<tr>
<td>Character select to right</td>
<td>Shift + Right Arrow</td>
</tr>
<tr>
<td>Select to page up</td>
<td>Shift + PgUp</td>
</tr>
<tr>
<td>Select to page down</td>
<td>Shift + PgDn</td>
</tr>
<tr>
<td>Move word left</td>
<td>Ctrl + Left Arrow</td>
</tr>
<tr>
<td>Move word right</td>
<td>Ctrl + Right Arrow</td>
</tr>
<tr>
<td>Select word to left</td>
<td>Ctrl + Shift + Left</td>
</tr>
<tr>
<td>Select word to right</td>
<td>Ctrl + Shift + Right</td>
</tr>
</tbody>
</table>

### “Code Editing” Shortcuts (cont.)

<table>
<thead>
<tr>
<th>Operation</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select word to the right</td>
<td>Ctrl + Shift + Right</td>
</tr>
<tr>
<td>Move to start of line</td>
<td>Home</td>
</tr>
<tr>
<td>Move to end of line</td>
<td>End</td>
</tr>
<tr>
<td>Select to start of line</td>
<td>Shift + Home</td>
</tr>
<tr>
<td>Select to end of line</td>
<td>Shift + End</td>
</tr>
<tr>
<td>Move to top of file</td>
<td>Ctrl + Home</td>
</tr>
<tr>
<td>Move to end of file</td>
<td>Ctrl + End</td>
</tr>
<tr>
<td>Select to start of file</td>
<td>Ctrl + Shift + Home</td>
</tr>
<tr>
<td>Select to end of file</td>
<td>Ctrl + Shift + End</td>
</tr>
</tbody>
</table>

### “Document Editing” Shortcuts

<table>
<thead>
<tr>
<th>Operation</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Quit Application</td>
<td>Alt + F4</td>
</tr>
<tr>
<td>Go to Next Word</td>
<td>Ctrl + Right Arrow</td>
</tr>
<tr>
<td>Go to Previous Word</td>
<td>Ctrl + Left Arrow</td>
</tr>
<tr>
<td>Go to Previous Paragraph</td>
<td>Ctrl + Up Arrow</td>
</tr>
<tr>
<td>Go to Next Paragraph</td>
<td>Ctrl + Down Arrow</td>
</tr>
<tr>
<td>Select Until Next Word</td>
<td>Ctrl + Shift + Right</td>
</tr>
<tr>
<td>Select from Previous Word</td>
<td>Ctrl + Shift + Left</td>
</tr>
<tr>
<td>Select from Previous Paragraph</td>
<td>Ctrl + Shift + Up</td>
</tr>
<tr>
<td>Select until Next Paragraph</td>
<td>Ctrl + Shift + Down</td>
</tr>
<tr>
<td>Close Window</td>
<td>Ctrl + F4</td>
</tr>
<tr>
<td>Edit Tag</td>
<td>Ctrl + F5</td>
</tr>
<tr>
<td>New in Same Window</td>
<td>Ctrl + Shift + N</td>
</tr>
<tr>
<td>Preview in Primary Browser</td>
<td>F12</td>
</tr>
<tr>
<td>Preview in Secondary Browser</td>
<td>Shift + F12</td>
</tr>
<tr>
<td>Exit Paragraph</td>
<td>Ctrl + Enter</td>
</tr>
<tr>
<td>Live Data Mode</td>
<td>Ctrl + R</td>
</tr>
<tr>
<td>Print Code</td>
<td>Ctrl + P</td>
</tr>
<tr>
<td>Next Document</td>
<td>Ctrl + Tab</td>
</tr>
<tr>
<td>Previous Document</td>
<td>Ctrl + Shift + Tab</td>
</tr>
</tbody>
</table>