Welcome to TeachUcomp, Inc.’s Advanced Excel course. This class caps the student’s knowledge of Microsoft Excel, one of the most popular spreadsheet programs available today. This class is designed to give the student a firm grasp of the advanced concepts in Excel.

Excel is an excellent program to learn, as the skills that we learn in Excel apply to many other programs as well, especially Access. It is the recommended starting point for learning database programs as it contains some basic database functionality and features.

Excel is a multi-featured spreadsheet program in which you can create powerful spreadsheets that can manipulate numbers and store data for you. It is a very powerful program, and has many advanced features that can automate and simplify your work. Whether you want it to create charts, spreadsheets, or data sources, Excel can assist you in accomplishing your tasks quickly and easily.

This class will focus on the advanced concepts of the Excel program. You will learn how to create and manage data models, use PivotTables and PivotCharts, create visualizations, use Power Pivot, use slicers, apply security, and set up macros.
# Table of Contents

## Chapters/Lessons: Data Models
- **CHAPTER 28- Data Models**
  - 28.1- Creating a Data Model from External Relational Data  
    Page(s): 5  
  - 28.2- Creating a Data Model from Excel Tables  
    Page(s): 6  
  - 28.3- Relating Tables in a Data Model  
    Page(s): 7  
  - 28.4- Managing a Data Model  
    Page(s): 8  
  - **Data Models- Exercises**  
    Page(s): 9-12

## Chapters/Lessons: PivotTables and PivotCharts
- **CHAPTER 29- PivotTables and PivotCharts**
  - 29.1- Creating Recommended PivotTables  
    Page(s): 10-12  
  - 29.2- Manually Creating a PivotTable  
    Page(s): 13-15  
  - 29.3- Creating a PivotChart  
    Page(s): 16  
  - 29.4- Manipulating a PivotTable or PivotChart  
    Page(s): 17-18  
  - 29.5- Changing Calculated Value Fields  
    Page(s): 19  
  - 29.6- Formatting PivotTables  
    Page(s): 20  
  - 29.7- Formatting PivotCharts  
    Page(s): 21  
  - 29.8- Setting PivotTable Options  
    Page(s): 22  
  - 29.9- Sorting and Filtering Using Field Headers  
    Page(s): 23  
  - **PivotTables and PivotCharts- Actions**  
    Page(s): 24-25  
  - **PivotTables and PivotCharts- Exercises**  
    Page(s): 26

## Chapters/Lessons: Power Pivot
- **CHAPTER 30- Power Pivot**
  - 30.1- Starting Power Pivot  
    Page(s): 27-28  
  - 30.2- Managing the Data Model  
    Page(s): 29  
  - 30.3- Calculated Columns  
    Page(s): 30  
  - 30.4- Measures  
    Page(s): 31  
  - 30.5- Creating KPIs  
    Page(s): 32  
  - 30.6- Creating and Managing Perspectives  
    Page(s): 33  
  - 30.7- Power Pivot PivotTables and PivotCharts  
    Page(s): 34  
  - **PowerPivot- Actions**  
    Page(s): 35-36  
  - **PowerPivot- Exercises**  
    Page(s): 37

## Chapters/Lessons: Power View
- **CHAPTER 31- Power View**
  - 31.1- Starting Power View  
    Page(s): 38-39  
  - 31.2- Adding Report Visualizations  
    Page(s): 40  
  - 31.3- Changing the Layout of Report Visualizations  
    Page(s): 41  
  - 31.4- Using Undo and Redo in Power View  
    Page(s): 42  
  - 31.5- Formatting the Power View Sheet  
    Page(s): 43  
  - 31.6- Creating Multiples in a Chart  
    Page(s): 44  
  - 31.7- Filtering Power View Using the Filter Area  
    Page(s): 45  
  - 31.8- Cross-Filtering Visualizations  
    Page(s): 46  
  - **Power View- Actions**  
    Page(s): 47-48  
  - **Power View- Exercises**  
    Page(s): 49

## Chapters/Lessons: Slicers and Timelines
- **CHAPTER 32- Slicers and Timelines**
  - 32.1- Inserting and Deleting Slicers  
    Page(s): 50-51  
  - 32.2- Modifying Slicers  
    Page(s): 52  
  - 32.3- Inserting and Deleting Timelines  
    Page(s): 53  
  - 32.4- Modifying Timelines  
    Page(s): 54  
  - **Slicers and Timelines- Actions**  
    Page(s): 55-56  
  - **Slicers and Timelines- Exercises**  
    Page(s): 57

## Chapters/Lessons: Security Features
- **CHAPTER 33- Security Features**
  - 33.1- Unlocking Cells  
    Page(s): 58  
  - 33.2- Worksheet Protection  
    Page(s): 59  
  - 33.3- Workbook Protection  
    Page(s): 60  
  - 33.4- Password Protecting Excel Files  
    Page(s): 61  
  - **Security Features- Actions**  
    Page(s): 62-63  
  - **Security Features- Exercises**  
    Page(s): 64

## Chapters/Lessons: Making Macros
- **CHAPTER 34- Making Macros**
  - 34.1- Recording Macros  
    Page(s): 65  
  - 34.2- Running and Deleting Recorded Macros  
    Page(s): 66  
  - 34.3- The Personal Macro Workbook  
    Page(s): 67  
  - **Making Macros- Actions**  
    Page(s): 68-69  
  - **Making Macros- Exercises**  
    Page(s): 70

## Glossary of Functions
- **Glossary of Functions Index**  
  Page(s): 71

## Keyboard Shortcuts
- **Keyboard Shortcuts**  
  Page(s): 72-74

©TeachUcomp, Inc.  Advanced Excel  4
CHAPTER 28-
Data Models

28.1- Creating a Data Model from External Relational Data
28.2- Creating a Data Model from Excel Tables
28.3- Relating Tables in a Data Model
28.4- Managing a Data Model
28.1- Creating a Data Model from External Relational Data:

You can use a data model in Excel to store multiple tables of information that can then be used as a data source for PivotTables and PivotCharts, as well as Power View reports. Note that the choice to add a selected table to a data model is given when manually creating a PivotTable in Excel. This effectively allows you to use a relational data source within Excel. Starting in Excel 2016, Excel automatically creates relationships between tables in the data model when your analysis requires two or more tables to be linked together. However, you can also manually create relationships between the data within the table fields in Excel, relating them as needed for your reports. The tables saved into the data model within an Excel workbook can be tables within Excel worksheets or external data tables.

In this lesson you will learn how to create a data model within Excel from external relational data, such as a Microsoft Access database file. If you choose to import multiple tables from an existing relational data source, the data model will be created automatically.

To import multiple tables from an external relational data source, click the “Data” tab within the Ribbon and then click the desired button within the “Get External Data” button group. For example, if you wanted to add tables from an Access database to the data model in Excel, click the “From Access” button within the “Get External Data” button group on the “Data” tab within the Ribbon. In this case, the “Select Data Source” dialog box will appear. You can then use this dialog box to navigate to and then select the desired Access database file to open. Then click the “Open” button to continue.

Next, you will see the “Select Table” dialog box appear. To enable the selection of multiple tables from the database file, be sure to check the “Enable selection of multiple tables” checkbox at the top of this dialog box. Then check the checkboxes next to the tables that you wish to add to the data model in the Excel workbook. Then click the “OK” button to continue.

You will then see the “Import Data” dialog box appear within Excel. You can then choose the option that you prefer within the “Select how you want to view this data in your workbook” section. You can then choose where to place the imported data by selecting an option within the “Where do you want to put the data?” section. Note that depending upon the choice made in the first section, not every option will necessarily be available within the latter section. Once you have decided where to place the type of data that you want to import, click the “OK” button to finish.

At that point, Excel will create the data connection and then import the necessary data into the data model within Excel. It will also create any visual representation of the data that you chose to import and place it into the selected location.
28.2- Creating a Data Model from Excel Tables:

You can also manually add multiple Excel tables to manually create a data model within a workbook which you can then use as the data source for PivotTables, PivotCharts and Power View reports. Before you can do this, however, you must first create the necessary tables within Excel and ensure that the information is formatted as a table within the worksheets. Only table data that has been formatted as a table with a “Table Name” value that can be referenced can be added as a data source when adding tables to the data model. Also note, however, that the tables can be available within any opened workbook in Excel and do not necessarily need to be included within the workbook into which they will be added to the data model.

Once you have the tables opened and available in Excel, simply open the workbook where you want to include the tables within the data model. Then click the “Data” tab within the Ribbon. Then click the “Connections” button within the “Connections” button group on the “Data” tab to open the “Workbook Connections” dialog box. This dialog box normally displays workbook connections that are available to a workbook and where those connections are used within the workbook.

To add Excel tables to the data model within this dialog box, click the drop-down arrow button that appears to the right of the “Add…” button within the “Workbook Connections” dialog box. From the drop-down menu that appears, select the “Add to the Data Model…” command. When you do this, the “Existing Connections” dialog box will appear. Click the “Tables” tab within the “Existing Connections” dialog box to view a list of the available Excel tables within any opened workbooks. Select the desired table that you want to add to the data model, and then click the “Open” button to add that table as the initial table to the data model within the workbook. You can then see the table reference shown within the “Workbook Connections” dialog box. You can then repeat this process, starting by clicking the “Add…” button’s drop-down menu again, to repeat the same steps to continue adding any other Excel tables that you would like to the data model. Once you have finished adding the necessary tables to the data model, click the “Close” button within the “Workbook Connections” dialog box to close it.

At that point, you can then select the data model as the desired data source when creating PivotTables and PivotCharts. Within the “Create PivotTable” or “Create PivotChart” dialog boxes, you can select the “Use an external data source” option button and then click the “Choose Connection…” button to open the “Existing Connections” dialog box. Here you can select the “Tables” tab and then click on the “Tables in Workbook Data Model” choice within the “This Workbook Data Model” shown. Then click the “Open” button to return to the “Create PivotTable” or “Create PivotChart” dialog boxes, where you can finish creating the desired objects.
28.3- Relating Tables in a Data Model:

When you add fields from multiple tables into a PivotTable or PivotChart, the data within the tables must be related for the resultant data within the PivotTable to make sense and be of any use. Note that if you create a data model from data tables in a relational database file, Excel can often create the needed relationships “behind the scenes” when it imports the data. Excel 2016 will attempt to create necessary relationships between tables when they are used. For all other cases, the tables must be manually related.

If you add data fields from multiple tables within a data model to a PivotChart or PivotTable without first relating the tables, you will see a warning message appear within the task pane at the right side of the window informing you that “Relationships between tables may be needed.” You can click the “Create…” button that appears next to this message to open the “Create Relationship” dialog box where you can create the needed relationship between the two tables.

You can also create relationships between tables within a data model prior to adding any fields to the PivotTable or PivotChart. You can create multiple relationships between data tables, if needed, so as to avoid any warning message prompts when adding fields to PivotTables or PivotCharts within the workbook. To create a relationship, simply click the “Relationships” button within the “Data Tools” button group on the “Data” tab in the Ribbon. In the “Manage Relationships” window that appears, click the “New…” button to open the “Create Relationship” dialog box.

In the “Create Relationship” dialog box, you must select the names of the two tables that you wish to relate and also select the fields within each that share the common data. Within one of the tables, the field with the shared, or common, data must contain only unique values. This is the “Primary” field. Within the other table with the field that contains the shared data, the values within the field may or may not be unique. This is the “Foreign” field. Start by selecting the name of the table with the “Foreign” field values from the “Table” drop-down menu. Then select the name of the “Foreign” field within that table from the “Column (Foreign)” drop-down menu. Then select the name of the table with the “Primary” field values from the “Related Table” drop-down. Then select the name of the “Primary” field within that table that contains the common data with unique values from the “Related Column (Primary)” drop-down. Then click the “OK” button to create the relationship between the two tables.

When you create relationships within this window, the relationship created needs to be either a “one to one” relationship or a “one to many” relationship between the fields. Excel will not allow you to create any other type of relationship between table fields. For users who are familiar with the concepts of relating tables within a relational database, this should come as no surprise. However, if you are unfamiliar with relational database table design, this may seem perplexing. While a full discussion of relational database table design is not within the scope of this particular tutorial, it is discussed at length in the “Mastering Access Made Easy” tutorial by TeachUcomp, Inc. In essence, you can only create a relationship between fields within tables where the values contained within one field in one of the tables are unique. This field can then be joined to associated data within another table where the values may or may not be unique.

After creating the relationship it will appear within the “Manage Relationships” window. Note that you can continue creating additional relationships between tables if needed in this window by simply clicking the “New…” button and repeating the process. Also note that you can only have one active table relationship between tables that are used within a PivotTable or PivotChart. If you have multiple relationships between two tables that are available, only one of the relationships can be active at a time. The active relationship is shown within the “Manage Relationships” window. You can select an active relationship shown in this window and then click the “Deactivate” button to deactivate it. You can also select an inactive relationship and then click the “Activate” button to enable it again. You can also select a relationship in this window and click the “Delete” button to delete a relationship or click the “Edit…” button to edit the relationship.
28.4- Managing a Data Model:

After you have created a data model, you may need to return to it at some later point in time to remove tables or external data connections from the data model if you no longer need them. You can also set the properties of the data connections within a workbook’s data model. In this lesson we will examine some of the tasks that can be involved with managing a workbook’s data model.

You can manage the tasks related to your workbook’s data model by using the buttons within the “Connections” button group on the “Data” tab in the Ribbon. If your workbook uses external data connections, you can click the “Refresh All” button to refresh all of the external data connections and access the most recent data available.

You can click the “Connections” button to open the “Workbook Connections” dialog box to manage the data connections within your workbook’s data model. You can then select a specific connection shown in the listing at the top of this dialog box to manage it. You can click the “Remove” button at the right side of this dialog box to remove a selected connection from the workbook. You will then need to click the “OK” button in the warning message box that appears to remove the selected connection.

You can click the “Properties” button for a selected connection to open the “Connection Properties” dialog box. You can set the properties of the data connections on the “Usage” tab within this dialog box. Under the “Refresh control” section, you can set the refresh rate for the selected data connection. This can save time in that it can allow the selected connection’s data to be automatically refreshed within the workbook. Below that section, you can use the “OLAP Server Formatting” and “OLAP Drill Through” sections to set any additional parameters for OLAP data sources. When you are finished setting any properties you want in this dialog box, click the “OK” button to apply them.

You can also manually refresh a selected data connection by clicking the “Refresh” button at the right side of the “Workbook Connections” dialog box to manually refresh the data connection.

You can also view the area within a workbook where a selected data connection is used. To do this, first select the connection whose usage you want to inspect. Then click the “Click here to see where the selected connections are used” hyperlink in the section at the bottom of the dialog box. The cells within the selected worksheet that make use of the data connection will then be displayed in a list within the area at the bottom of the dialog box. You can then click one of the listings shown to select those cells within the workbook.

When you are finished using the “Workbook Connections” dialog box to manage your workbook connections, click the “Close” button to close it.
CREATING A DATA MODEL FROM EXTERNAL RELATIONAL DATA:

1. **To import multiple tables from an external relational data source**, click the “Data” tab in the Ribbon.
2. Click the button associated with the data type to import within the “Get External Data” button group.
3. The “Select Data Source” dialog box will appear.
4. Use this dialog box to navigate to and then select the desired database file to open.
5. Click the “Open” button to continue.
6. **To enable the selection of multiple tables from the database file**, check the “Enable selection of multiple tables” checkbox at the top of the “Select Table” dialog box that appears.
7. Check the checkboxes next to the tables that you wish to add to the data model.
8. Click the “OK” button to continue.
9. You will then see the “Import Data” dialog box appear within Excel.
10. Choose the preferred option within the “Select how you want to view this data in your workbook” section.
11. You can then choose where to place the imported data by selecting an option within the “Where do you want to put the data?” section. Note that depending upon the choice made in the first section, not every option will necessarily be available within the latter section.
12. Click the “OK” button to finish.
13. At that point, Excel will create the data connection and import the data into the data model. It will also create any visual representation of the imported data and place it into the selected location.

CREATING A DATA MODEL FROM EXCEL TABLES:

1. Once you have the Excel tables to add to the data model opened and available in Excel, open the workbook within which you want to add those tables to the data model.
2. Click the “Connections” button within the “Connections” button group on the “Data” tab in the Ribbon to open the “Workbook Connections” dialog box.
3. **To add Excel tables to the data model within this dialog box**, click the drop-down arrow button that appears to the right of the “Add…” button within the “Workbook Connections” dialog box.
4. From the drop-down menu that appears, select the “Add to the Data Model…” command.
5. In the “Existing Connections” dialog box that appears, click the “Tables” tab within the “Existing Connections” dialog box to view a list of the available Excel tables within any opened workbooks.
6. Select the desired table that you want to add to the data model, and then click the “Open” button to add that table as the initial table to the data model within the workbook. You can then see the table reference shown within the “Workbook Connections” dialog box.
7. Repeat steps 3 through 6 above to continue adding any other Excel tables that you would like to the data model.
8. Once you have finished adding the necessary tables to the data model, click the “Close” button within the “Workbook Connections” dialog box to close it.
9. You can then select the data model as the data source when creating PivotTables and PivotCharts.
10. Within the “Create PivotTable” or “Create PivotChart” dialog boxes, select the “Use an external data source” option button and then click the “Choose Connection…” button to open the “Existing Connections” dialog box.
11. Select the “Tables” tab and then click the “Tables in Workbook Data Model” choice within the “This Workbook Data Model” shown.
12. Click the “Open” button to return to the “Create PivotTable” or “Create PivotChart” dialog boxes, where you can finish creating the desired objects.
RELATING TABLES IN A DATA MODEL:

1. Note that if you create a data model from data tables in a relational database file, Excel can often create the needed relationships “behind the scenes” when it imports the data. For all other cases, the tables must be manually related.

2. If you add data fields from multiple tables within a data model to a PivotChart or PivotTable without first relating the tables, you will see a warning message appear within the task pane at the right side of the window informing you that “Relationships between tables may be needed.” You can click the “Create…” button that appears next to this message to open the “Create Relationship” dialog box where you can create the needed relationship between the two tables.

3. You can also create relationships between tables within a data model prior to adding any fields to the PivotTable or PivotChart. You can create multiple relationships between data tables, if needed, so as to avoid any warning message prompts when adding fields to PivotTables or PivotCharts within the workbook.

4. **To create a relationship**, simply click the “Relationships” button within the “Data Tools” button group on the “Data” tab in the Ribbon.

5. In the “Manage Relationships” window that appears, click the “New…” button to open the “Create Relationship” dialog box.

6. In the “Create Relationship” dialog box, you must select the names of the two tables that you wish to relate and also select the fields within each that share the common data.

7. Within one of the tables, the field with the shared, or common, data must contain only unique values. This is the “Primary” field. Within the other table with the field that contains the shared data, the values within the field may or may not be unique. This is the “Foreign” field.

8. Select the name of the table with the “Foreign” field values from the “Table” drop-down menu.

9. Select the name of the “Foreign” field within that table from the “Column (Foreign)” drop-down menu.

10. Select the name of the table with the “Primary” field values from the “Related Table” drop-down.

11. Select the name of the “Primary” field within that table that contains the common data with unique values from the “Related Column (Primary)” drop-down.

12. Click the “OK” button to create the relationship between the two tables.

13. After creating the relationship it will appear within the “Manage Relationships” window.

14. Note that you can continue creating additional relationships between tables if needed in this window by simply clicking the “New…” button and repeating the process in steps 5 through 12.

15. You can only have one active table relationship between tables that are used within a PivotTable or PivotChart. If you have multiple relationships between two tables that are available, only one of the relationships can be active at a time. The active relationship is shown within the “Manage Relationships” window.

16. **To deactivate an active relationship shown in this window**, select the relationship to deactivate and then click the “Deactivate” button to deactivate it.

17. **To reactivate an inactive relationship shown in this window to enable it again**, select an inactive relationship and then click the “Activate” button.

18. **To delete a relationship**, select a relationship in this window and click the “Delete” button.

19. **To edit a relationship**, select a relationship in this window and click the “Edit…” button.
MANAGING A DATA MODEL:

1. You can manage the tasks related to your workbook’s data model by using the buttons within the “Connections” button group on the “Data” tab in the Ribbon.

2. To refresh all of the external data connections and access the most recent data available if your workbook uses external data connections, click the “Refresh All” button.

3. To manage the data connections within your workbook’s data model, click the “Connections” button to open the “Workbook Connections” dialog box.

4. Then select a specific connection shown in the listing at the top of this dialog box to manage it.

5. To remove a selected connection from the workbook, click the “Remove” button at the right side of this dialog box.

6. Then need to click the “OK” button in the warning message box that appears to remove the selected connection.

7. You can click the “Properties” button for a selected connection to open the “Connection Properties” dialog box.

8. You can set the properties of the data connections on the “Usage” tab within this dialog box.

9. Under the “Refresh control” section, you can set the refresh rate for the selected data connection. This can save time in that it can allow the selected connection’s data to be automatically refreshed within the workbook.

10. Below that section, you can use the “OLAP Server Formatting” and “OLAP Drill Through” sections to set any additional parameters for OLAP data sources.

11. When you are finished setting any properties you want in this dialog box, click the “OK” button to apply them.

12. To manually refresh a selected data connection, click the “Refresh” button at the right side of the “Workbook Connections” dialog box to manually refresh the data connection.

13. To view the area within a workbook where a selected data connection is used, select the connection whose usage you want to inspect.

14. Click the “Click here to see where the selected connections are used” hyperlink in the section at the bottom of the dialog box.

15. The cells within the selected worksheet that make use of the data connection will then be displayed in a list within the area at the bottom of the dialog box.

16. You can then click one of the listings shown to select those cells within the workbook.

17. To close the “Workbook Connections” dialog box when you are finished using it to manage your workbook connections, click the “Close” button.
**EXERCISES - Data Models**

**Purpose:**

1. To be able to create and manage a data model in Excel.

**Exercises:**

1. Open up the Excel application.
2. Create a new blank workbook.
3. Enter the data into “Sheet1” of the new workbook as shown in the picture below.

5. Click the “Format as Table” button in the “Styles” button group on the “Home” tab within the Ribbon.
6. Select the “Table Style Light 1” choice from the drop-down menu that appears.
7. Ensure that there is a checkmark in the “My table has headers” checkbox in the “Format As Table” dialog box that appears, and then click the “OK” button within this dialog box to create the first table.
8. Type “Salespeople” into the “TableName” field in the “Properties” button group of the “Design” tab in the “Table Tools” contextual tab within the Ribbon and press “Enter” on your keyboard to name the table.
9. Select the cell range of F1:H20.
10. Click the “Format as Table” button in the “Styles” button group on the “Home” tab within the Ribbon.
11. Select the “Table Style Light 2” choice from the drop-down menu that appears.
12. Ensure that there is a checkmark in the “My table has headers” checkbox in the “Format As Table” dialog box that appears, and then click the “OK” button within this dialog box to create the first table.
13. Type “Sales” into the “Table Name” field in the “Properties” button group of the “Design” tab in the “Table Tools” contextual tab within the Ribbon and press “Enter” on your keyboard to name the table.
14. Select the cell range of J1:K5.
15. Click the “Format as Table” button in the “Styles” button group on the “Home” tab within the Ribbon.
16. Select the “Table Style Light 3” choice from the drop-down menu that appears.
17. Ensure that there is a checkmark in the “My table has headers” checkbox in the “Format As Table” dialog box that appears, and then click the “OK” button within this dialog box to create the first table.
18. Type “Regions” into the “Table Name” field in the “Properties” button group of the “Design” tab in the “Table Tools” contextual tab within the Ribbon and press “Enter” on your keyboard to name the table.

(cont’d.)
Exercises- (cont’d.):

20. Click the “Format as Table” button in the “Styles” button group on the “Home” tab within the Ribbon.
21. Select the “Table Style Light 4” choice from the drop-down menu that appears.
22. Ensure that there is a checkmark in the “My table has headers” checkbox in the “Format As Table” dialog box that appears, and then click the “OK” button within this dialog box to create the first table.
23. Type “Budgets” into the “Table Name” field in the “Properties” button group of the “Design” tab in the “Table Tools” contextual tab within the Ribbon and press “Enter” on your keyboard to name the table.
25. Click the “Accounting Number Format” button within the “Number” button group on the “Home” tab within the Ribbon to format the selection as currency.
26. Select cell A7 to break your current cell selections.
27. Click the “Save” button within the Quick Access Toolbar to open the “Save As” backstage view.
28. Save the workbook to your computer’s “Documents” folder with the file name of “Advanced Excel.”
29. Click the “Connections” button in the “Connections” button group on the “Data” tab within the Ribbon to open the “Workbook Connections” dialog box.
30. Within the “Workbook Connections” dialog box, click the drop-down arrow to the right of the “Add…” button and then select the “Add to the Data Model…” command to open the “Existing Connections” dialog box.
31. Click the “Tables” tab within the “Existing Connections” dialog box.
32. Select the “Salespeople” table and then click the “Open” button.
33. Within the “Workbook Connections” dialog box, click the drop-down arrow to the right of the “Add…” button and then select the “Add to the Data Model…” command to open the “Existing Connections” dialog box.
34. Click the “Tables” tab within the “Existing Connections” dialog box.
35. Select the “Sales” table and then click the “Open” button.
36. Within the “Workbook Connections” dialog box, click the drop-down arrow to the right of the “Add…” button and then select the “Add to the Data Model…” command to open the “Existing Connections” dialog box.
37. Click the “Tables” tab within the “Existing Connections” dialog box.
38. Select the “Regions” table and then click the “Open” button.
39. Within the “Workbook Connections” dialog box, click the drop-down arrow to the right of the “Add…” button and then select the “Add to the Data Model…” command to open the “Existing Connections” dialog box.
40. Click the “Tables” tab within the “Existing Connections” dialog box.
41. Select the “Budgets” table and then click the “Open” button.
42. Click the “Close” button within the “Workbook Connections” dialog box to close it.
43. Click the “Relationships” button within the “Data Tools” button group on the “Data” tab within the Ribbon to open the “Manage Relationships” dialog box.
44. Click the “New…” button at the right side of the “Manage Relationships” dialog box to open the “Create Relationship” dialog box.
45. Select “Sales” from the “Table” drop-down field.
46. Select “Salesperson ID” from the “Column (Foreign)” drop-down field.
47. Select “Salespeople” from the “Related Table” drop-down field.
48. Select “Salesperson ID” from the “Related Column (Primary)” drop-down field.

(cont’d.)
**EXERCISES - Data Models**

**Exercises- (cont’d.):**

49. Click the “OK” button within the “Create Relationship” dialog box to return to the “Manage Relationships” dialog box where the new relationship should now be shown within the listing of relationships.

50. Click the “New…” button at the right side of the “Manage Relationships” dialog box to open the “Create Relationship” dialog box.

51. Select “Salespeople” from the “Table” drop-down field.

52. Select “Region” from the “Column (Foreign)” drop-down field.

53. Select “Regions” from the “Related Table” drop-down field.

54. Select “Region” from the “Related Column (Primary)” drop-down field.

55. Click the “OK” button within the “Create Relationship” dialog box to return to the “Manage Relationships” dialog box where the new relationship should now be shown within the listing of relationships.

56. Click the “New…” button at the right side of the “Manage Relationships” dialog box to open the “Create Relationship” dialog box.

57. Select “Budgets” from the “Table” drop-down field.

58. Select “Region” from the “Column (Foreign)” drop-down field.

59. Select “Regions” from the “Related Table” drop-down field.

60. Select “Region” from the “Related Column (Primary)” drop-down field.

61. Click the “OK” button within the “Create Relationship” dialog box to return to the “Manage Relationships” dialog box where the new relationship should now be shown within the listing of relationships.

62. Click the “Close” button within the “Manage Relationships” dialog box.

63. Click the “Save” button within the Quick Access toolbar to save your changes.

64. You may close the workbook, if you would like to.

65. **Keep this workbook, as you will need the information within it to perform the Exercises at the end of the following chapters within this manual! The Exercises should be completed in sequential order.**
CHAPTER 29-
PivotTables and PivotCharts

29.1- Creating Recommended PivotTables
29.2- Manually Creating a PivotTable
29.3- Creating a PivotChart
29.4- Manipulating a PivotTable or PivotChart
29.5- Changing Calculated Value Fields
29.6- Formatting PivotTables
29.7- Formatting PivotCharts
29.8- Setting PivotTable Options
29.9- Sorting and Filtering Using Field Headers
29.1- Creating Recommended Pivot Tables:

You can use the PivotTable feature of Excel to access some of the most powerful data analysis that Excel can provide. PivotTables allow you to organize massive amounts of data in more coherent and meaningful ways to extract exactly what you want to know from the data. One of the most helpful features of PivotTables is the ability to be reorganized quickly and easily to change the information they are displaying and calculating. When you create a PivotTable, you are comparing information in your worksheet and then calculating intersecting values of your choosing. In addition to PivotTables, you can also create PivotCharts, which use the data from PivotTables but display it in a graphic format.

The best way to learn how to use a PivotTable is to actually create one with which you can experiment and practice. Excel makes it easy to create a PivotTable from your data. Starting in Excel 2013, Excel makes creating PivotTables even easier by offering suggestions as to what types of data you may want to view within a selected data set or table. These are called “Recommended PivotTables.” When you create a recommended PivotTable, Excel offers suggestions as to what type of data you may want to initially view within the PivotTable based on the data selected. You can then choose a recommendation and Excel will automatically create a PivotTable that shows the selected type of data within a new worksheet.

To create a recommended PivotTable, click the “Insert” tab in the Ribbon. Then click the “Recommended PivotTables” button in the “Tables” button group.

Then select the source of data for the PivotTable in the “Choose Data Source” dialog box that appears. Your choices are: “Select a table or range,” which pulls the data from your Excel workbook; or “Use an external data source,” which allows you to use data from an existing data connection in your workbook or on your computer. Select the option button for the choice that you prefer.

If you select the “Select a table or range” option button, click the “Collapse/Expand Dialog Box” button at the right end of the “Table/Range” field to collapse the dialog box down to a single line. Then click and drag over the cell range or table you want to use as the data source for your PivotTable. Then click the same “Collapse/Expand Dialog Box” button again to expand the dialog box when you have finished selecting the data cells within your workbook. Alternately, if you want to use a named table as your data source, type the name of the table into the “Table/Range” field instead of manually selecting the cell range reference. You could also type an absolute cell range reference into the “Table/Range” field, if desired, instead of manually selecting the cell range.

If you select the “Use an external data source” option button, then click the “Choose Connection...” button to open the “Existing Connections” dialog box. Within the “Existing Connections” dialog box you will see any connections available. You can use the “Show” drop-down at the top of the dialog box to select the “All Connections” choice, if needed. That will then display all data connections within your workbook, computer, and network within three separate sections within this dialog box. Select the data connection that you would like to use for your PivotTable from the connections shown within this dialog box and then click the “Open” button to return to the “Choose Data Source” dialog box. Note that while you can select data tables from existing data connections to external data sources, such as an Access database, you cannot select Excel tables that you have added to the workbook’s data model when creating a “Recommended PivotTable.” To use Excel tables that have been saved to the workbook’s data model as your data source, you must manually create the PivotTable using the “PivotTable” button. We will cover doing this in the next lesson.

When you are finished selecting a data source, click the “OK” button to continue. Excel will then display the “Recommended PivotCharts” dialog box. The left side of this dialog box will display several
29.1- Creating Recommended Pivot Tables- (cont’d.):

different types of data analysis that you can view within a PivotTable. Select the type of PivotTable that you wish to create from this listing. You can then see a large preview of the selected PivotTable in the area to the right. You can then click the “OK” button at the bottom of this dialog box to create the selected PivotTable. Note that if your data selection did not include enough data fields, or contained too many blank or repetitive cell entries, you may not be able to create a recommended PivotTable. If this is the case, then Excel will inform you of that fact within this dialog box. However, you can still click the ‘OK’ button to continue and insert a blank PivotTable into a new workbook. You will simply need to manually create the data that you want to show within the PivotTable by using the “PivotTable Fields” task pane.

After you have created a PivotTable, you will see the “PivotTable Fields” task pane appear at the side of your workbook window. In the “PivotTable Fields” pane, you will see the information from your data source. Note the fields that have been added to your PivotTable, and into which quadrant at the bottom of the pane those field have been placed. These settings determine the values displayed within your PivotTable.

You can change the values displayed within the PivotTable by using the “PivotTable Fields” task pane. You can check the checkbox next to each field in the “Choose fields to add to report:” section that you want to add to the PivotTable. If you check a field, Excel will add that field into one of the four quadrants shown in the “Drag fields between areas below:” section at the bottom of the task pane. For PivotTables, these quadrants are “Filters,” “Columns,” “Rows,” and “Values.” At that point, you can click and drag the fields shown from one quadrant to another, based on what function or layout you want the PivotTable to show. Note that fields that are placed into the “Values” section are calculated using the SUM function, by default.
29.2- Manually Creating a PivotTable:

You can also manually create a blank PivotTable that you can then customize as desired. To do this, click the “Insert” tab in the Ribbon and then click the “PivotTable” button in the “Tables” button group.

You will then see the “Create PivotTable” dialog box appear. Within this dialog box you must first select the source of data for the PivotTable within the “Choose the data that you want to analyze” section. If you select the “Select a table or range” option button, then click the “Collapse/Expand Dialog Box” button at the right end of the “Table/Range” field to collapse the dialog box down to a single line. Then click and drag over the cell range or table you want to use as the data source for your PivotTable. Then click the same “Collapse/Expand Dialog Box” button again to expand the dialog box when you have finished selecting the data cells within your workbook. Alternately, to use a named table as your data source, type the name of the table into the “Table/Range” field instead of manually selecting the cell range reference. You could also type an absolute cell range reference into the “Table/Range” field, if desired, instead of manually selecting the cell range.

If you select the “Use an external data source” option button, click the “Choose Connection...” button to open the “ExistingConnections” dialog box. Within the “ExistingConnections” dialog box you will see any connections available. You can use the “Show” drop-down at the top of the dialog box to select the “All Connections” choice, if needed. That will display all data connections within your workbook, computer, and network within three separate sections. Select the data connection you would like to use for your PivotTable from the connections shown within this dialog box. Then click the “Open” button to return to the “Create PivotTable” dialog box. To use Excel tables from your workbook’s data model as your PivotTable’s data source, click the “Tables” tab at the top of the “Existing Connections” dialog box. Then select either an individual table or select the “Tables in Workbook Data Model” choice to select all the tables within the data model. Then click the “Open” button to return to the “Create PivotTable” dialog box.

Next, choose the location where you want to place the PivotTable from the options shown within the “Choose where you want the PivotTable report to be placed” section. You can select the “New Worksheet” option button to place the PivotTable into a new worksheet. You can select the “Existing Worksheet” option button to select a location within an existing worksheet. If you select this option, then you can either enter an absolute cell address location into the “Location:" text box or use the “Collapse/Expand Dialog Box” button at the right end of the field to collapse the dialog box down to a single line so that you can click on the cell that you want to select within an existing worksheet. You can then click the same button again to expand the dialog box when you are finished. Note that the cell that you enter or select will become the upper left corner of the PivotTable.

Next, to add your selected data to an internal data model used by your Excel workbook, check the “Add this data to the Data Model” checkbox. This will add the selected data to the data model in your Excel workbook. In Excel, you can store and relate data from multiple tables in a data model which you can then manipulate and analyze using PivotTables. When finished, click the “OK” button to create your new PivotTable.

Then you will see the “PivotTable Fields” task pane appear at the side of your workbook window. In the “PivotTable Fields” pane, you will see the fields within your data source. You can change the values displayed within the PivotTable by using the “PivotTable Fields” task pane. You can check the checkbox next to each field in the “Choose fields to add to report:" section that you want to add to the PivotTable. If you check a field, Excel will add that field into one of the four quadrants shown in the “Drag fields between areas below:" section at the bottom of the task pane. For PivotTables, these quadrants are “Filters,” “Columns,” “Rows,” and “Values.” You can click and drag the fields shown from one quadrant to another, based on what function or layout you want the PivotTable to show. Note that fields that are placed into the “Values” section are calculated using the SUM function, by default.
29.3- Creating a PivotChart:

A PivotChart shows the data from an associated PivotTable in a graphic format. You can create a PivotChart along with an associated PivotTable in Excel. You can then manipulate the PivotChart data in the same way that you manipulate the PivotTable data. Starting in Excel 2013, you can also choose to decouple a PivotChart from its associated PivotTable, if needed. You can create a PivotChart as you create a PivotTable in Excel, or you can add a PivotChart to an existing PivotTable if you didn’t create one when you initially created the PivotTable.

One way to create a PivotChart is to click the “PivotChart” drop-down button within the “Charts” button group on the “Insert” tab within the Ribbon. You can then select “PivotChart” to insert only a PivotChart or select “PivotChart & PivotTable” to insert both objects. Excel will then launch the “Create PivotChart” dialog box. This dialog box is exactly the same as the “Create PivotTable” dialog box.

Once you have finished making your choices within the “Create PivotChart” dialog box and then click the “OK” button to continue, Excel will then insert a PivotChart, and possibly an accompanying PivotTable, into the location that you selected within the workbook.

You can then add fields from your data source to the various areas within the PivotChart or the PivotTable. If you inserted both objects, then note that data added or changed within one of the items will be reflected in the other. When you select the PivotChart, you can add data fields into the quadrants shown within the “PivotChart Fields” task pane. Note that this task pane functions in the same way as the “PivotTable Fields” task pane does. The quadrants are: “Filters,” “Legend (Series),” “Axis (Categories),” and “Values.”

You can also add a PivotChart to an existing PivotTable within Excel. To do this, simply click into any cell within the PivotTable to which you want to add an accompanying PivotChart. Then click the “PivotChart” button within the “Charts” button group on the “Insert” tab within the Ribbon.

Excel will then display the “Insert Chart” dialog box. Here you will select the chart type and specific subtype that you want to use for your PivotChart. Then click the “OK” button to insert the selected chart into the worksheet. You can then use the “PivotTable Field” task pane to manipulate the PivotChart and its associated PivotTable.

29.4- Manipulating a PivotTable or PivotChart:

Now you will see the ways that you can alter a PivotTable or PivotChart to change what data is displayed and calculated within them. You can check and uncheck the fields shown in the “Choose fields to add to report:” list within the “PivotTable Fields” or “PivotChart Fields” task panes to add or remove them. Once the fields have been added to any one of the four quadrants shown at the bottom of the task panes, you may click and drag the fields shown in these areas from one quadrant to another to rearrange the display of the data, if needed.

When working with the fields in your PivotTable, if you click into a worksheet cell outside of the PivotTable area, the PivotTable will become de-selected and the “PivotTable Fields” task pane will be hidden. You can click back into a cell within the PivotTable to reactivate the PivotTable and display the “PivotTable Fields” task pane again. This same principle of selection also applies to PivotCharts.

You can also use the buttons in the “Active Field” button group on the “Analyze” tab of the “PivotTable Tools” or “PivotChart Tools” contextual tabs within the Ribbon to change the appearance of your PivotTable and PivotChart data. When you click into a field cell within a PivotTable, the name of the active field will be displayed in the “Active Field” text box within this button group. The “Expand Field” and “Collapse Field” buttons in the “Active Field” button group on the “Analyze” tab can be used to collapse and...
29.4- Manipulating a PivotTable or PivotChart- (cont’d.):

expand the detail data for any actively selected field in an outlined group. In this same button group, you can click the “Field Settings” button to open a dialog box where you can change the settings of the active field within the PivotTable or PivotChart.

To enable or disable the display of the “PivotTable Fields” or “PivotChart Fields” task pane for any reason, click the “Field List” button in the “Show” button group on the “Analyze” tab within the “PivotTable Tools” contextual tab in the Ribbon to show and hide the “PivotTable Fields” task pane. This same button is located within the “Show/Hide” button group on the “Analyze” tab within the “PivotChart Tools” contextual tab within the Ribbon when you have a PivotChart selected, instead.

29.5- Changing Calculated Value Fields:

When you add a field into the “Values” section of either the “PivotTable Fields” or “PivotChart Fields” task pane, the data within the field is added together using the “Sum” function. You can change the function used to calculate the data, if you wish. There are also several other features of value fields that you can alter, if needed.

To change the properties of value fields, click the small drop-down arrow to the right of the field name displayed in the “Values” section of the “PivotTable Fields” or “PivotChart Fields” task pane. Select the “Value Field Settings…” command from the menu that appears to open the “Value Field Settings” dialog box.

The “Source Name” field shows the original field name from which the calculated field derives its values. You can type a name for the field to display into the “Custom Name” text box. On the “Summarize Values By” tab, click on the name of the function by which you wish to summarize the source field selected.

You can click the “Number Format” button in the lower left corner of this dialog box to open a simplified version of the “Format Cells” dialog box which you can use to set the appearance of the numeric formatting used by the numbers in the selected value field. Then you can click the “OK” button to return to the “Value Field Settings” dialog box.

You can click the “Show Values As” tab in the “Value Field Settings” dialog box to select how you want to show the data from the field. You can select another summarization option from the “Show values as:” drop-down. You can compare the values listed in the rows or columns as a percentage of the column, row, or field total. You can also choose to show the number as the difference of another field.

If you select a comparison option that requires another field against which to compare the value, you can select that field’s name from the “Base field:” list and then select the value against which to compare from that field from the “Base item:” list. Note that if you change settings on either the “Summarize Values By” or “Show Values As” tabs, then you may need to re-enter any changes made to the “Custom Name” field or formats applied in the “Format Cells” dialog box to apply them to the new calculated field’s values before you click the “OK” button. Once you have set the options that you want for your value field, click the “OK” button to set the appearance of the value field.
PivotTables and PivotCharts

29.6- Formatting PivotTables:

You can use PivotTable styles to apply preset formatting to your PivotTables in Excel. To do this, just click into any cell within your PivotTable. Then click the desired style you want to apply in the listing of PivotTable styles shown in the “PivotTable Styles” group on the “Design” tab of the “PivotTable Tools” contextual tab within the Ribbon.

You can modify the settings of the preset PivotTable styles by checking the desired checkboxes in the “PivotTable Style Options” group on the “Design” tab of the “PivotTable Tools” contextual tab within the Ribbon. Doing this will allow you to select the areas within the PivotTable to which special formatting is applied. You can select to apply special formatting to the “Row Headers” and “Column Headers” by checking those checkboxes. You can also apply banding to the row or columns within the PivotTable by checking the “Banded Rows” or “Banded Columns” checkboxes.

You can also easily change the summarization and layout of a PivotTable by using the buttons shown within the “Layout” button group on the “Design” tab of the “PivotTable Tools” contextual tab within the Ribbon. You can click the “Subtotals” button to choose a layout for subtotals within a selected PivotTable from the drop-down menu that appears. You can also click the “Grand Totals” button to choose the display of grand totals within a selected PivotTable from the drop-down menu that appears. You can click the “Report Layout” drop-down button to choose a desired layout for your selected PivotTable from the menu of choices shown. Finally, you can click the “Blank Rows” drop-down button to choose the display of blank rows within a selected PivotTable from the menu of choices that appears.

29.7- Formatting PivotCharts:

You can format PivotCharts in the same way that you can format any other chart that is available in Excel. To format a PivotChart, first select the PivotChart to format within the worksheet. You can then use the available formatting options that are found on the “Design” and “Format” tabs within the “PivotChart Tools” contextual tab within the Ribbon to apply formatting to the selected PivotChart. The options that are available are the same for PivotChart as for normal charts.

29.8- Setting PivotTable Options:

If you wish to view and edit the general options for a selected PivotTable, then click the “Options” button in the “PivotTable” group on the “Analyze” tab in the “PivotTable Tools” contextual tab within the Ribbon. Doing this will open the “PivotTable Options” dialog box where you can set several general options that control the appearance and behavior of the selected PivotTable.

At the top of this dialog box, you can type a name for the PivotTable into the “PivotTable Name: ” text box. Below that, there are several tabs that represent the various PivotTable option categories.

On the “Layout & Format” tab, you can check or uncheck the options shown to set the appearance of PivotTable data. You can click the “Totals & Filters” tab to change the display of totals and subtotals in the PivotTable and also set the general filtering and sorting behaviors that are available. On the “Display” tab, you can set options that determine the appearance of the PivotTable in the worksheet. On the “Printing” tab to set the appearance of the PivotTable when printed. On the “Data” tab, you can set options that control the relationship that is shared between the PivotTable and its source data. Finally, on the “Alt Text” tab, you can enter a text description of the PivotTable. After setting the options that you want your PivotTable to posses in these tabs, click the “OK” button to apply the options to the selected PivotTable.
29.9- Sorting and Filtering Using Field Headers:

You can sort and filter the data by using the “Field Headers” that you have added to your PivotTable fields. Note that you can show and hide the display of field headers within a selected PivotTable by clicking the “Field Headers” button within the “Show” group on the “Analyze” tab within the “PivotTable Tools” contextual tab within the Ribbon. When field headers are enabled, you will see the “Row Labels” and “Column Labels” text appear next to a drop-down arrow within a cell above the columns and rows. You can use the drop-down that appears within these cells to sort and filter the fields within the columns and rows in the PivotTable.

If you click the drop-down arrow, you will see a menu that shows you the sorting and filtering options available. If you have added multiple fields to either the columns or the rows, then you will see another drop-down menu called “Select field” appear at the top within the drop-down menu. You can then select the desired field to sort or filter from the field choices shown within this drop-down menu.

For the selected field, you can choose the “Sort A to Z” command to sort the field data in ascending order. You can choose the “Sort Z to A” to sort the field data in descending order. You can also select the “More Sort Options…” command to show the “Sort” dialog box where you can set any advanced sorting options that you wish. If you open the “Sort” dialog box, just click the “OK” button to apply any sorting options that you set when you are finished.

You can also apply filtering to a field to include or exclude data specific values from being displayed within the PivotTable. To manually select which field values to display, simply check or uncheck the values listed in the field’s drop-down listing. Then click the “OK” button at the bottom of the menu to apply the filters.

You can also select either the “Label Filters” or “Value Filters” commands to display a side menu of comparison choices. You can then select the desired comparison operator from the side menu to display a “Value Filter” dialog box. Here you can enter the value or values needed to filter the field’s data. Then click the “OK” button to apply the filter.

If, after applying a filter, you want to show all of the field’s values again, you can click the drop-down arrow button again and then select either the “(Select All)” checkbox or select the “Clear Filter” command from the drop-down menu. If you select the “(Select All)” checkbox, then click the “OK” button at the bottom of the menu to finish removing the filters.
CREATING A RECOMMENDED PIVOTTABLE:

1. To create a recommended PivotTable, click the “Insert” tab in the Ribbon.
2. Click the “Recommended PivotTables” button in the “Tables” button group.
3. Select the option button for the data source choice you want for the PivotTable in the “Choose Data Source” dialog box that appears: “Select a table or range” or “Use an external data source.”
4. If you select the “Select a table or range” option button, click the “Collapse/Expand Dialog Box” button at the right end of the “Table/Range” field to collapse the dialog box down to a single line.
5. Click and drag over the cell range or table you want to use as the data source for your PivotTable.
6. Click the same “Collapse/Expand Dialog Box” button again to expand the dialog box when you have finished selecting the data cells within your workbook.
7. Alternately, to use a named table as your data source, you can type the name of the table into the “Table/Range” field instead of manually selecting the cell range reference.
8. You could also type an absolute cell range reference into the “Table/Range” field, if desired, instead of manually selecting the cell range.
9. If you select the “Use an external data source” option button, click the “Choose Connection...” button to open the “Existing Connections” dialog box.
10. Within the “Existing Connections” dialog box you will see any connections available.
11. To display all data connections within your workbook, computer, and network within three separate sections within this dialog box, use the “Show” drop-down at the top of the dialog box to select the “All Connections” choice, if needed.
12. Select the data connection you would like to use for your PivotTable from the connections shown within this dialog box, and then click the “Open” button to return to the “Choose Data Source” dialog box.
13. When you are finished selecting a data source, click the “OK” button to continue.
14. Excel will then display the “Recommended PivotCharts” dialog box. The left side of this dialog box will display several different types of data analysis that you can view within a PivotTable.
15. Select the type of PivotTable that you wish to create from this listing. You can then see a large preview of the selected PivotTable in the area to the right.
16. To create the selected PivotTable, click the “OK” button at the bottom of this dialog box.
17. Note that if your data selection did not include enough data fields, or contained too many blank or repetitive cell entries, you may not be able to create a recommended PivotTable. If this is the case, Excel will inform you of that fact within this dialog box. However, you can still click the “OK” button to continue and insert a blank PivotTable into a new workbook. You will simply need to manually create the data that you want to show within the PivotTable by using the “PivotTable Fields” task pane.
18. After you have created a PivotTable, you will see the “PivotTable Fields” task pane appear at the side of your workbook window. Note the fields that have been added to your PivotTable, and into which quadrant at the bottom of the pane those field have been placed. These settings determine the values displayed within your PivotTable.
19. You can change the values displayed within the PivotTable by using the “PivotTable Fields” task pane.
20. You can check the checkbox next to each field in the “Choose fields to add to report:” section that you want to add to the PivotTable.
21. If you check a field, Excel will add that field into one of the four quadrants shown in the “Drag fields between areas below:” section at the bottom of the task pane. For PivotTables, these quadrants are “Filters,” “Columns,” “Rows,” and “Values.”
22. At that point, you can click and drag the fields shown from one quadrant to another, based on what function or layout you want the PivotTable to show.
MANUALLY CREATING A PIVOTTABLE:

1. Click the “Insert” tab in the Ribbon and then click the “PivotTable” button in the “Tables” button group.
2. In the “Create PivotTable” dialog box, select the option button that corresponds to the source of data for the PivotTable within the “Choose the data that you want to analyze” section.
3. **If you select the “Select a table or range” option button**, click the “Collapse/Expand Dialog Box” button at the right end of the “Table/Range” field to collapse the dialog box down to a single line.
4. Click and drag over the cell range or table that you want to use as the data source.
5. Click the same “Collapse/Expand Dialog Box” button again to expand the dialog box when you have finished selecting the data cells within your workbook.
6. **Alternately, if you want to use a named table as your data source**, type the name of the table into the “Table/Range” field instead of manually selecting the cell range reference.
7. You could also type an absolute cell range reference into the “Table/Range” field, if desired, instead of manually selecting the cell range.
8. **If you select the “Use an external data source” option button**, click the “Choose Connection...” button to open the “ExistingConnections” dialog box. Within the “ExistingConnections” dialog box you will see any connections available.
9. To display all data connections within your workbook, computer, and network within three separate sections within this dialog box, use the “Show” drop-down at the top of the dialog box to select the “All Connections” choice, if needed.
10. Select the data connection to use for your PivotTable from the connections shown within this dialog box, and then click the “Open” button to return to the “Create PivotTable” dialog box.
11. **To use Excel tables from your workbook’s data model as your PivotTable’s data source**, click the “Tables” tab at the top of the “ExistingConnections” dialog box.
12. Select either an individual table or select the “Tables in Workbook Data Model” choice to select all the tables within the data model.
13. Click the “Open” button to return to the “Create PivotTable” dialog box.
14. Choose the location to place the PivotTable from the options shown within the “Choose where you want the PivotTable report to be placed” section of the “Create PivotTable” dialog box.
15. **To place the PivotTable into a new worksheet**, select the “NewWorksheet” option button.
16. **To select a location within an existing worksheet**, select the “Existing Worksheet” option button.
17. If you select this option, either enter an absolute cell address location into the “Location:” text box or use the “Collapse/Expand Dialog Box” button at the right end of the field to collapse the dialog box down to a single line so that you can click on the cell that you want to select within an existing worksheet.
18. Then click the same button again to expand the dialog box when you are finished.
19. Note that the cell that you enter or select will become the upper left corner of the PivotTable.
20. **To add your selected data to an internal data model used by your Excel workbook**, check the “Add this data to the Data Model” checkbox.
21. **To create your new PivotTable when finished**, click the “OK” button.
22. You will see the “PivotTable Fields” task pane appear at the side of your workbook window.
23. You can check the checkbox next to each field in the “Choose fields to add to report:” section that you want to add to the PivotTable.
24. If you check a field, Excel will add that field into one of the four quadrants shown in the “Drag fields between areas below:” section at the bottom of the task pane. For PivotTables, these quadrants are “Filters,” “Columns,” “Rows,” and “Values.”
25. You can click and drag the fields shown from one quadrant to another, based on what function or layout you want the PivotTable to show.
CREATING A PIVOTCHART:

1. To create a PivotChart, click the “PivotChart” drop-down button within the “Charts” button group on the “Insert” tab within the Ribbon.
2. To insert only a PivotChart, select “PivotChart” from the drop-down menu.
3. To insert both a PivotChart and PivotTable, select “PivotChart & PivotTable” from the drop-down menu.
4. Excel will then launch the “Create PivotChart” dialog box, which is exactly the same as the “Create PivotTable” dialog box.
5. Once you have finished making your choices within the “Create PivotChart” dialog box and then click the “OK” button to continue, Excel will then insert a PivotChart, and possibly an accompanying PivotTable, into the location that you selected within the workbook.
6. You can add fields from your data source to the various areas within the PivotChart or the PivotTable. If you inserted both objects, data added or changed within one of the items will be reflected in the other.
7. When you select the PivotChart, you can add data fields into the quadrants shown within the “PivotChart Fields” task pane. Note that this task pane functions in the same way as the “PivotTable Fields” task pane does. The quadrants are: “Filters,” “Legend (Series),” “Axis (Categories),” and “Values.”
8. To add a PivotChart to an existing PivotTable within Excel, click into any cell within the PivotTable to which you want to add an accompanying PivotChart.
9. Click the “PivotChart” button within the “Charts” button group on the “Insert” tab within the Ribbon.
10. Select the chart type and specific subtype you want to use for your PivotChart in the “Insert Chart” dialog box and click the “OK” button.
11. Use the “PivotTable Field” task pane to manipulate the PivotChart and its associated PivotTable.

MANIPULATING A PIVOTTABLE OR PIVOTCHART:

1. To add or remove fields from a PivotTable or PivotChart, check or uncheck the fields in the “Choose fields to add to report:” list of the “PivotTable Fields” or “PivotChart Fields” task panes.
2. To rearrange the display of the data fields after they have been added to any one of the four quadrants shown at the bottom of the task panes, if needed, click and drag the fields shown in these areas from one quadrant to another.
3. If you click into a worksheet cell outside of the PivotTable or PivotChart area when working with the fields in a PivotTable or PivotChart, the PivotTable will become de-selected and the “PivotTable Fields” or “PivotChart Fields” task pane will be hidden.
4. You can click back into a cell within the PivotTable or PivotChart area to reactivate the PivotTable or PivotChart and display the “PivotTable Fields” or “PivotChart Fields” task pane again.
5. You can also make use of the buttons shown in the “Active Field” button group on the “Analyze” tab of the “PivotTable Tools” or “PivotChart Tools” contextual tabs within the Ribbon to change the appearance of your PivotTable and PivotChart data.
6. When you click into a field cell within a PivotTable, the name of the active field will be displayed in the “Active Field” text box within this button group.
7. To collapse and expand the detail data for any actively selected field in an outlined group, click the “Expand Field” and “Collapse Field” buttons in the “Active Field” button group on the “Analyze” tab.
8. To open a dialog box where you can change the settings of the active field within the PivotTable or PivotChart, click the “Field Settings” button in this same button group.

(cont'd.)
MANIPULATING A PIVOTTABLE OR PIVOTCHART- (CONT’D.):

9. To enable or disable the display of the “PivotTable Fields” or “PivotChart Fields” task pane, click the “Field List” button in the “Show” button group on the “Analyze” tab within the “PivotTable Tools” contextual tab in the Ribbon to show and hide the “PivotTable Fields” task pane.
10. This same button is located within the “Show/Hide” button group on the “Analyze” tab within the “PivotChart Tools” contextual tab within the Ribbon when you have a PivotChart selected, instead.

CHANGING CALCULATED VALUE FIELDS:

1. To change the properties of fields placed into the “Values” section of either the “PivotChart Fields” or “PivotTable Fields” task pane, click the small drop-down arrow to the right of the field name displayed in the “Values” section of the “PivotTable Fields” or “PivotChart Fields” task pane.
2. Select the “Value Field Settings…” command to open the “Value Field Settings” dialog box.
3. The “Source Name” field shows the original field name from which the calculated field derives its values.
4. You can type a name for the field to display into the “Custom Name” text box.
5. On the “Summarize Values By” tab, click the name of the function to use to summarize the source field.
6. To set the appearance of the numeric formatting used by the numbers in the selected value field, click the “Number Format” button in the lower left corner of this dialog box to open a simplified version of the “Format Cells” dialog box which you can use to select a number format.
7. Then click the “OK” button to return to the “Value Field Settings” dialog box.
8. To select how you want to show the data from the field, click the “Show Values As” tab in the “Value Field Settings” dialog box.
9. You can select another summarization option from the “Show values as:” drop-down.
10. You can compare the values listed in the rows or columns as a percentage of the column, row, or field total. You can also choose to show the number as the difference of another field.
11. If you select a comparison option that requires another field against which to compare the value, you can select that field’s name from the “Base field:” list and then select the value against which to compare from that field from the “Base item:” list.
12. If you change settings on either the “Summarize Values By” or “Show Values As” tabs, you may need to re-enter any changes made to the “Custom Name” field or formats applied in the “Format Cells” dialog box to apply them to the new field’s values before you click the “OK” button.
13. Once you have set the options that you want for your value field, click the “OK” button.

APPLYING PIVOTTABLE STYLES:

1. Click into any cell within your PivotTable.
2. Click the desired style you want to apply in the listing of PivotTable styles shown in the “PivotTable Styles” group on the “Design” tab of the “PivotTable Tools” contextual tab within the Ribbon.
3. To select the areas within the PivotTable to which special formatting is applied and modify the settings of the preset PivotTable styles, check the desired checkboxes in the “PivotTable Style Options” group on the “Design” tab of the “PivotTable Tools” contextual tab within the Ribbon.
4. To apply special formatting to the “Row Headers” and “Column Headers,” check those checkboxes.
   (cont’d.)
APPLYING PIVOTTABLE STYLES- (CONT’D.):

5. To apply banding to the row or columns within the PivotTable, check the “Banded Rows” or “Banded Columns” checkboxes.
6. To change the summarization and layout of a PivotTable, use the buttons shown within the “Layout” button group on the “Design” tab of the “PivotTable Tools” contextual tab within the Ribbon.
7. To choose a layout for subtotals within a selected PivotTable, click the “Subtotals” button and make a choice from the drop-down menu that appears.
8. To choose the display of grand totals within a selected PivotTable, click the “Grand Totals” button and make a choice from the drop-down menu that appears.
9. To choose a desired layout for your selected PivotTable, click the “Report Layout” drop-down button and make a choice from the menu of choices shown.
10. To choose the display of blank rows within a selected PivotTable, click the “Blank Rows” drop-down button and make a choice from the menu of choices that appears.

FORMATTING PIVOTCHARTS:

1. To format a PivotChart, select the PivotChart to format within the worksheet.
2. To apply formatting to the selected PivotChart, use the available formatting options found on the “Design” and “Format” tabs within the “PivotChart Tools” contextual tab within the Ribbon.
3. The options available are the same for PivotChart as for normal charts.

SETTING PIVOTTABLE OPTIONS:

1. To view and edit the general options for a selected PivotTable, click the “Options” button in the “PivotTable” group on the “Analyze” tab in the “PivotTable Tools” contextual tab within the Ribbon.
2. Doing this will open the “PivotTable Options” dialog box where you can set several general options that control the appearance and behavior of the selected PivotTable.
3. You can type a name for the PivotTable into the “PivotTable Name:” text box at the top of this dialog box.
4. There are several tabs that represent the various PivotTable option categories shown below that.
5. To set the appearance of PivotTable data, check or uncheck the options shown on the “Layout & Format” tab.
6. To change the display of totals and subtotals in the PivotTable and also set the general filtering and sorting behaviors that are available, check or uncheck the options shown on the “Totals & Filters” tab.
7. To set options that determine the appearance of the PivotTable in the worksheet, check or uncheck the options shown on the “Display” tab.
8. To set the appearance of the PivotTable when printed, check or uncheck the options shown on the “Printing” tab.
9. To set options that control the relationship that is shared between the PivotTable and its source data, check or uncheck the options shown on the “Data” tab.
10. To enter a text description of the PivotTable, click the “Alt Text” tab and enter a “Title” and “Description.”
11. To apply the options to the selected PivotTable, click the “OK” button.
SORTING AND FILTERING USING FIELD HEADERS:

1. You can sort and filter the data by using the “Field Headers” that you have added to your PivotTable fields.
2. To show or hide the display of field headers within a selected PivotTable, click the “Field Headers” button within the “Show” group on the “Analyze” tab within the “PivotTable Tools” contextual tab within the Ribbon.
3. When field headers are enabled, you will see the “Row Labels” and “Column Labels” text appear next to a drop-down arrow within a cell above the columns and rows.
4. You use the drop-down that appears within these cells to sort and filter the fields within the columns and rows in the PivotTable.
5. If you click the drop-down arrow, you will see a menu that shows you the sorting and filtering options available.
6. If you have added multiple fields to either the columns or the rows, then you will see another drop-down menu called “Select field” appear at the top within the drop-down menu.
7. You can then select the desired field to sort or filter from the field choices shown within this “Select field” drop-down menu.
8. For the selected field, to sort the field data in ascending order, choose the “Sort A to Z” command.
9. To sort the field data in descending order, choose the “Sort Z to A”.
10. To show the “Sort” dialog box where you can set any advanced sorting options that you wish, select the “More Sort Options…” command.
11. If you open the “Sort” dialog box, click the “OK” button to apply any sorting options that you set when you are finished.
12. You can also apply filtering to a field to include or exclude data specific values from being displayed within the PivotTable.
13. To manually select which field values to display, check or uncheck the values listed in the field’s drop-down listing.
14. Then click the “OK” button at the bottom of the menu to apply the filters.
15. You can also select either the “Label Filters” or “Value Filters” commands to display a side menu of comparison choices.
16. Then select the desired comparison operator from the side menu to display a “Value Filter” dialog box.
17. Enter the value or values needed to filter the field’s data.
18. Then click the “OK” button to apply the filter.
19. If, after applying a filter, you want to show all of the field’s values again, click the drop-down arrow button again and then select either the “(Select All)” checkbox or select the “Clear Filter” command from the drop-down menu.
20. If you select the “(Select All)” checkbox, click the “OK” button at the bottom of the menu to finish removing the filters.
Purpose:

1. To be able to create and manipulate a PivotTable in Excel.

Exercises:

1. Open the “Advanced Excel” workbook that has been completed through the Exercise at the end of the previous chapter.
2. Select cell M1 within the “Budgets” table.
3. Click the “Recommended PivotTables” button within the “Tables” button group on the “Insert” tab within the Ribbon to launch the “Recommended PivotTables” dialog box.
4. Select the “Sum of Actual Expenses by Region” PivotTable choice from the left side of the “Recommended PivotTables” dialog box, and then click the “OK” button.
5. The PivotTable will be inserted into a new worksheet within the workbook titled “Sheet2.”
6. In the “PivotTable Fields” pane at the right side of the worksheet, click the drop-down arrow that appears at the right end of the “Sum of Actual Expenses” field within the “Values” section.
7. Select the “Value Field Settings…” command from the drop-down menu of choices to open the “Value Field Settings” dialog box.
8. Click the “Number Format” button in the lower left corner of the “Value Field Settings” dialog box to open the “Format Cells” dialog box.
9. Select “Currency” from the “Category” list within the “Format Cells” dialog box and then click the “OK” button.
10. Click the “OK” button within the “Value Field Settings” dialog box to apply the currency format to the values shown within the PivotTable.
11. Now you will alter the PivotTable to display actual expenses per department within each region. You can do this by clicking and dragging the “Department” field from the “PivotTable Fields” list and then dropping it below the “Region” field within the “Rows” section at the bottom of the pane.
12. Now you will alter the PivotTable to display actual expenses per region as well as actual expenses per department for all regions. You can do this by clicking and dragging the “Department” field from the “Rows” section and then dropping it into the “Columns” section at the bottom of the “PivotTable Fields” pane.
13. Now you will display the sum of both the budgeted and actual expenses per department per region. You can do this by clicking and dragging the “Budgeted Expenses” field from the top of the “PivotTable Fields” pane and then dropping it at the top of the “Values” section at the bottom of the pane.
14. In the “PivotTable Fields” pane at the right side of the worksheet, click the drop-down arrow that appears at the right end of the “Sum of Budgeted Expenses” field within the “Values” section.
15. Select the “Value Field Settings…” command from the drop-down menu of choices to open the “Value Field Settings” dialog box.
16. Click the “Number Format” button in the lower left corner of the “Value Field Settings” dialog box to open the “Format Cells” dialog box.
17. Select “Currency” from the “Category” list within the “Format Cells” dialog box and then click the “OK” button.
18. Click the “OK” button within the “Value Field Settings” dialog box to apply the currency format to the values shown within the PivotTable.
19. Click the “Save” button within the Quick Access toolbar to save the changes.
20. You can close the workbook, but be sure to keep it, as you will need it to perform the Exercises at the end of the following chapters within this manual.